Subject: RE: [Capwap] Additional Requirement?

From: "Saravanan Govindan" <[email-masked]>
Date: Thu, 3 Mar 2005 10:19:29 +0800

Hi James,

Apologies for the late reply. 

It is a good point you raise that CAPWAP needs to be able to run independent of IP versions. 

The Interconnection objective (5.2.6) tries to capture this requirement. It suggests that the CAPWAP
protocol be independent of underlying transport technology. Maybe we can add IPv4 and IPv6
specifically as transport technologies that the protocol must be independent of.

Consider revising the paragraph 2 of the Description (5.2.6), last sentence:

Current text:

"As a result of realizing this objective, the protocol will be capable of operation over different
interconnect technologies including Ethernet, bus backplanes, ATM (cell) fabrics and also wireless
technologies such as IEEE 802.11."

Proposed text:

"As a result of realizing this objective, the protocol will be capable of operation over different
interconnect technologies including Ethernet, IPv4, IPv6, bus backplanes, ATM (cell) fabrics and
also wireless technologies such as IEEE 802.11."

Does this capture your suggestion for IP version independence?

Cheers,

Saravanan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of James Kempf
> Sent: Friday, February 25, 2005 2:26 AM
> To: subrata goswami; Saravanan Govindan
> Cc: [email-masked]
> Subject: [Capwap] Additional Requirement?
> 
> I don't recall seeing anything about independence of IP 
> version. I think CAPWAP needs to be defined such that it will 
> run on IPv4 or IPv6.
> 
>             jak
> 
> ----- Original Message -----
> From: "subrata goswami" <[email-masked]>
> To: "Saravanan Govindan" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Thursday, February 24, 2005 8:33 AM
> Subject: Re: [Capwap] Additions #12 - Future Wireless Technologies
> 
> 
> > Saravanan , seems okay to me.
> >
> > Subrata
> >
> >
> > Saravanan Govindan wrote:
> >
> > >Hi Subrata, James,
> > >
> > >Thank you for your comments and suggestions.
> > >
> > >In summary, the suggestion is to clearly specify what the 
> CAPWAP protocol
> needs in terms of
> > >applicability to 802.11 and non-802.11 technologies.
> > >
> > >Please consider the following text which combines the 
> proposals from
> James and Subrata.
> > >
> > >-------
> > >(Include the following in Description)
> > >
> > >"In all cases where the CAPWAP protocol messages contain 
> specific Layer 2
> information elements, the
> > >definition of the protocol needs to provide for 
> extensibility so that
> these elements can be defined
> > >for specific layer 2 wireless protocols. This may entail 
> assigning a
> layer 2 wireless protocol type
> > >and version field to the message PDU. Examples of other wireless
> protocols that might be supported
> > >include but are not limited to 802.16e, 802.15.x, etc."
> > >----XXXX----
> > >
> > >Cheers,
> > >
> > >Saravanan
> > >
> > >
> > >
> > >
> > >
> > >
> > >>-----Original Message-----
> > >>From: [email-masked]
> > >>[mailto:[email-masked]] On Behalf Of James Kempf
> > >>Sent: Thursday, February 24, 2005 1:57 AM
> > >>To: subrata goswami; [email-masked]
> > >>Subject: Re: [Capwap] Additions #12 - Future Wireless Technologies
> > >>
> > >>
> > >>
> > >>
> > >>>>"In all cases where the CAPWAP protocol messages 
> contain specific
> > >>>>Layer 2 information elements, the definition of the
> > >>>>
> > >>>>
> > >>protocol needs to
> > >>
> > >>
> > >>>>provide for extensibility so that these elements can be
> > >>>>
> > >>>>
> > >>defined for
> > >>
> > >>
> > >>>>wireless
> > >>>>
> > >>>>
> > >>protocols
> > >>
> > >>
> > >>>>other than 802.11."
> > >>>>
> > >>>>
> > >>>>
> > >>>>
> > >>>"In all cases where the CAPWAP protocol messages contain specific
> > >>>Layer 2 information elements, the definition of the
> > >>>
> > >>>
> > >>protocol needs to
> > >>
> > >>
> > >>>provide for extensibility so that these elements can be 
> defined for
> > >>>specific layer 2 wireless protocols (e.g. 802.11, 
> 802.16, 802.15.x
> > >>>etc). This may
> > >>>
> > >>>
> > >>The problem with mentioning these is it might be construed to
> > >>exclude others. If you want to include specific reference,
> > >>I'd suggest adding a sentence at the end of the paragraph
> > >>that says something like:
> > >>
> > >>"Examples of other wireless protocols that might be supported
> > >>include but are not limited to 802.16e, 802.15.x, etc.
> > >>
> > >>
> > >>
> > >>>entail assigning a layer 2 wireless protocol type and
> > >>>
> > >>>
> > >>version field to
> > >>
> > >>
> > >>>the message PDU. "
> > >>>
> > >>>
> > >>>
> > >>Hmm, well, that's a bit too specific for a requirement. But,
> > >>off the top of my head, I can't think of any other way one
> > >>could do this, so I suppose it's OK.
> > >>
> > >>            jak
> > >>
> > >>
> > >>
> > >>_______________________________________________
> > >>Capwap mailing list
> > >>[email-masked]
> > >>http://mail.frascone.com/mailman/listinfo/capwap
> > >>
> > >>
> > >>
> > >
> > >_______________________________________________
> > >Capwap mailing list
> > >[email-masked]
> > >http://mail.frascone.com/mailman/listinfo/capwap
> > >
> > >
> > >
> > >
> >
> >
> >
> 
> 
> _______________________________________________
> Capwap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/capwap
> 

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "James Kempf" <[email-masked]>
Date: Thu, 3 Mar 2005 09:29:21 -0800

This sounds OK, but I'm wondering if anything other than IP needs to be
mentioned. With a very few exceptions (PPP, MPLS, EAP), IETF typically
doesn't deal with standardizing anything other than IP. I assume CAPWAP
won't be proposing running over anything other than IP, or? And if something
runs over IP, it should run just fine over Ethernet, ATM, etc., so why even
mention them?

What I suspect might be the real concern here (and please correct me if I am
wrong) is to avoid desigining the protocol such that it only works over a
single hop Ethernet or within a closed administrative domain. So if the
protocol only ran over 802.3 Ethernet, it could only be used over a single
hop, between a router and the AC/WTPs on the link. It is possible to design
the protocol using IP and still have it constrained to a single hop, or make
it insecure to use on anything other than a single hop. To avoid this, the
paragraph should have something in it specifying that the protocol should
run over networks that are both tightly administered and public access.

I'd propose modifying the paragraph to say:

"As a result of realizing this objective, the protocol will be capable of
operation over both IPv4 and IPv6, and will be designed such that it can run
on single hop links, within tightly administered networks, such as
enterprise networks, or on open, public access networks."

            jak

----- Original Message ----- 
From: "Saravanan Govindan" <[email-masked]>
To: "'James Kempf'" <[email-masked]>; "'subrata goswami'"
<[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, March 02, 2005 6:19 PM
Subject: RE: [Capwap] Additional Requirement?