Subject: RE: [Capwap] CAPWAP Evaluation Team

From: <[email-masked]>
Date: Sat, 11 Jun 2005 23:57:25 -0700

Dear Dan-

Most recently Mani and I both responded to a email Paul Lambert sent to the list on 4/25/05, Subject:  RE: [Capwap] Selecting Protocols to evaluate, where he asks if we can "mix and match sections from each protocol".  Mani replied on 4/26, and I replied on 5/2. 

Also, during the IETF face to face meetings we have discussed this topic during milestone review.  That is why we have described the chosen protocol as a "base" protocol for CAPWAP.

As for the informational RFC, I'll discuss your concerns with the ADs.  However, the intent is to evaluate the proposals and make a recommendation for the CAPWAP protocol.  Work will progress along these lines.

Regards,
Dorothy    

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of ext Dan Harkins
Sent: Friday, June 10, 2005 9:29 PM
To: Gellert Dorothy (Nokia-ES/MtView)
Cc: [email-masked]; [email-masked]; [email-masked]; Kessens
David (Nokia-NET/MtView)
Subject: Re: [Capwap] CAPWAP Evaluation Team 

  Hi Dorothy,

  You're saying that there are 2 possibilities: one protocol, periodfullstop;
or, one protocol that needs to incorporate some features from other protocols.

  I don't recall ever seeing you (plural, or even singular) state that before.
Can you please point out when that was?

  I was under the impression that the result could be what you state and
also the possibility that no single protocol would be selected but that
some hybrid that combines features from several of the candidates could
result in an acceptable protocol. Or possibly (although doubtful) no protocol
would be satisfactory.

  I'm concerned that you are giving guidance to this new team that does
not originate from the working group.

  Also, you listed September 2005 as a date to submit a draft to the IESG
as an Informational RFC. Per RFC2026 and Informational RFC "is published for
the general information of the Internet community, and does not represent an
Internet community consensus or recommendation." Given that it won't 
represent any consensus or recommentation how can it be used to select
one or more of the candidate protocols?

  thanks,

  Dan.

On Fri, 10 Jun 2005 19:20:45 PDT you wrote
> Hi All-
> 
> Thanks to everyone who volunteered for editorship of the CAPWAP Evaluation dr
>aft.   The Chairs and ADs have selected a team of evaluators, based on partici
>pation on the list and the WG.    The team is as follows:
> 
> Darren Loher (Roving Planet), Lead Editor
> David Nelson (Enterasys), Lead for Evaluation Process 
> Behcet Sarikaya (UofBC)
> Oleg Volinsky (Colubris)
> 
> David Nelson has participated in a similar protocol evaluation process in the
> AAA WG, and we are lucky to have his experience on the team to benefit our ev
>olution.
> 
> The milestones for the CAPWAP evaluation draft are as follows:
> 
> July 2005:  		Issue first Internet-Draft of CAPWAP Evaluation Draft  
> (00 draft deadline to repository is July 8th)
> August 2005:     	WGLC for CAPWAP Evaluation Draft.
> September 2005:	Submit CAPWAP Evaluation Draft to IESG as Informational
> RFC.
> 
> The evaluation draft will be based on the WG consensus, self-evaluations and 
>the previous WG drafts.
> We expect the first draft will have a TBD as the recommended Protocol for CAP
>WAP.   
> 
> As we have stated before, the final evaluation may select one protocol for th
>e CAPWAP protocol, or the recommendation may be one protocol, with specific ob
>jectives met by other protocols.    
> 
> Congratulations to the Evaluation team!
> 
> Best Regards,
> Dorothy and Mani
> _______________________________________________
> Capwap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/capwap
> 
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: Dan Harkins <[email-masked]>
Date: Tue, 14 Jun 2005 09:09:39 -0700

Hi Dorothy,

  Paul asked if we could "mix and match" and Mani said, "Such considerations
are welcome...mix-n-match of quality features is always possible if the
WG feels so." Your response seemed more directed to the stage of the
process at that time-- selecting protocols to evaluate-- and not to the
process now-- evaluating the protocols selected. But you did say, "if
one protocol is not accepted for evaluation as a baseline protocol,
certainly portions of that protocol can be submitted to the WG to
better address the objectives." So assuming the "not accepted for 
evaluation" implies "not acceptable after evaluation" I still don't
see where you're coming up with only the two possible outcomes you
mentioned below.

  So let me ask Paul's question once more. Is it possible for the
evaluation team to mix-and-match and come up with some new baseline
protocol that is the result of mixing-and-matching? The thread you
directed me implies the answer is "yes". 

  But if that's the case then how come you're saying that the outcome
will be that the evaulation "may select one protocol" or it may select
"one protocol with specific objectives met by other protocols."? Where
are you coming up with this "one protocol" directive? Surely there is
another possibility: that no one protocol is selected but features from
more than one are combined to create a baseline protocol that does not
resemble _any_ of the candidates being evaluated.

  Dan.

On Sat, 11 Jun 2005 23:57:25 PDT you wrote
> Dear Dan-
> 
> Most recently Mani and I both responded to a email Paul Lambert sent to the l
>ist on 4/25/05, Subject:  RE: [Capwap] Selecting Protocols to evaluate, where 
>he asks if we can "mix and match sections from each protocol".  Mani replied o
>n 4/26, and I replied on 5/2. 
> 
> Also, during the IETF face to face meetings we have discussed this topic duri
>ng milestone review.  That is why we have described the chosen protocol as a "
>base" protocol for CAPWAP.
> 
> As for the informational RFC, I'll discuss your concerns with the ADs.  Howev
>er, the intent is to evaluate the proposals and make a recommendation for the 
>CAPWAP protocol.  Work will progress along these lines.
> 
> Regards,
> Dorothy    
> 
> 
>