Subject: [Capwap] IEEE Review 11 - Firmware Trigger

From: "Saravanan Govindan" <[email-masked]>
Date: Wed, 1 Jun 2005 17:40:43 +0800

Section 5.1.5 - Firmware Trigger (Requirement, Motivation, Relation)

Comment: 

Clarify use of firmware equivalence
--XX--

Protocol requirement:

Existing text:
The CAPWAP protocol must support a trigger for delivery of firmware
updates.  

Proposed change: "The CAPWAP protocol MUST support a trigger for
delivery of firmware."
--XX--
 
Motivation and Protocol Benefits:  

Existing text:
The CAPWAP protocol interfaces many WTPs to a centralized WLAN
controller.  Firmware distribution allows these interfaces to be
appropriately equivalent.  This in turn results in consistent
configuration and simplified management.  So the protocol benefits by
including triggers for the distribution of firmware updates.

Proposed change:
"The CAPWAP protocol interfaces many WTPs to a centralized WLAN
controller.  Firmware distribution allows these interfaces to be
compatible.  This in turn results in consistent configuration and
simplified management.  So the protocol benefits by including triggers
for the distribution of firmware updates." 
--XX--

Relation to Problem Statement:  

Existing text:
Inconsistencies in the configuration of WTPs has been identified as a
major challenge for large-scale WTPs.  This objectives helps overcome
the challenge by providing for a way for the protocol to initiate
delivery of equivalent versions of firmware to all WTPs.

Proposed change:
"Inconsistencies in the configuration of WTPs has been identified as a
major challenge for large-scale WTPs.  This objectives helps overcome
the challenge by providing for a way for the CAPWAP protocol to initiate
delivery of firmware updates that are compatible among all WTPs."
--XX--
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Pat Calhoun" <[email-masked]>
Date: Wed, 1 Jun 2005 16:52:44 -0700

Ok with changes, with the exception that I'd like to see "This objectives"
changed to "These objectives"

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Saravanan Govindan
> Sent: Wednesday, June 01, 2005 2:41 AM
> To: [email-masked]
> Subject: [Capwap] IEEE Review 11 - Firmware Trigger
> 
> The CAPWAP protocol must support a trigger for delivery of 
> firmware updates.  
> 
> Proposed change: "The CAPWAP protocol MUST support a trigger 
> for delivery of firmware."
> --XX--
>  
> The CAPWAP protocol interfaces many WTPs to a centralized 
> WLAN controller.  Firmware distribution allows these 
> interfaces to be appropriately equivalent.  This in turn 
> results in consistent configuration and simplified 
> management.  So the protocol benefits by including triggers 
> for the distribution of firmware updates.
> 
> Proposed change:
> "The CAPWAP protocol interfaces many WTPs to a centralized 
> WLAN controller.  Firmware distribution allows these 
> interfaces to be compatible.  This in turn results in 
> consistent configuration and simplified management.  So the 
> protocol benefits by including triggers for the distribution 
> of firmware updates." 
> --XX--
> 
> Inconsistencies in the configuration of WTPs has been 
> identified as a major challenge for large-scale WTPs.  This 
> objectives helps overcome the challenge by providing for a 
> way for the protocol to initiate delivery of equivalent 
> versions of firmware to all WTPs.
> 
> Proposed change:
> "Inconsistencies in the configuration of WTPs has been 
> identified as a major challenge for large-scale WTPs.  This 
> objectives helps overcome the challenge by providing for a 
> way for the CAPWAP protocol to initiate delivery of firmware 
> updates that are compatible among all WTPs."
> --XX--