Subject: RE: [Capwap] NAT traversal

From: "Darren Loher" <[email-masked]>
Date: Thu, 9 Jun 2005 16:24:03 -0700

On the requirements side for NAT, should we specify if the WTP is behind
NAT, the AC behind NAT or both?  I can see two basic scenarios
realistically being implemented:

Assume:

- Hotspot provider uses whatever available broadband connection as an
Internet uplink

-This connection is limited to one, dynamically assigned IP address

-NAT is required to share the connection with multiple hosts

Scenario 1: The hotspot provider's AC is on the open Internet

Scenario 2: The hotspot provider's AC is behind a NAT firewall and the
hotspot provider has port forwarding and/or static NAT control of this
firewall

There could be several more, but these seem very common and
straightforward.

-Darren

________________________________

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Pat Calhoun
Sent: Thursday, June 09, 2005 7:19 AM
To: 'Cheng Hong'; 'Sadot, Emek (Emek)'; [email-masked]
Subject: RE: [Capwap] NAT traversal

Imagine a service provider connecting their AC to their customer's WTPs
across a NAT. Makes sense to me.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

________________________________

	From: [email-masked]
[mailto:[email-masked]] On Behalf Of Cheng Hong
	Sent: Thursday, June 09, 2005 12:52 AM
	To: Sadot, Emek (Emek); [email-masked]
	Subject: RE: [Capwap] NAT traversal

	Hi Emek,

	Would like to know a bit more about the deployment examples:

	>>say the WTP is located at branch office and the AC at the main
office separated by NAT device

	In this case, most likely the NAT traversal is not a problem for
the WTP or AC directly. For the branch office and main office case, most
likely there will be a VPN setup between them. To the WTP and AC, NAT
will be transparent. 

	 >>or within an Enterprise segregated by NAT devices.

	Does this mean AC and WTP are on different side of the NAT? It
sounds interesting, but is there any reason for deploy it in such a way
(A NAT inside the enterprise network to separate the AC and WTP)? 

	cheers

	Cheng Hong

		
________________________________

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Sadot, Emek (Emek)
		Sent: Wednesday, June 08, 2005 4:27 AM
		To: [email-masked]
		Subject: [Capwap] NAT traversal

		All,

		Would like to suggest adding a NAT traversal requirement
to the CAPWAP objective document, i.e. the ability of AC and WTP to
communicate across NAT device (UDP / TCP transport, refresh CAPWAP
session at the NAT device, WTP identification behind NAT device, etc.).
Deployment examples? say the WTP is located at branch office and the AC
at the main office separated by NAT device, or within an Enterprise
segregated by NAT devices.

		Regards,

		Emek

---

From: "David T. Perkins" <[email-masked]>
Date: Thu, 9 Jun 2005 17:19:45 -0700 (PDT)

HI Darren & Pat,

I'm still having a problem understanding what you are trying
to accomplish.

Here is a picture....

  /------------\   209.128.82.1   10.1.1.1 /---------------\
 |             |           ----------     |                 |
 | Internet    |-----------|NAT box |-----|Private Network  |
 |             |---        ----------     |(say 10.1.1.0/16)|
  \-----------/    \                       \---------------/
       |            \                        |
       AC            \                      WTP     STA-IP=?
   209.128.82.62      \                  10.1.2.1
                       \                   /---------------\ 
                        \  ----------     |                 |
                         --|NAT box |-----|Private Network  |
                           ----------     |(say 10.1.1.0/16)|
                   209.128.82.2  10.1.1.1  \---------------/
                                             | 
                                            WTP    STA-IP=?
                                         10.1.2.1

                           More NAT boxes

Is this what you are talking about? And If so, tell me again
what problem are you trying to solve, or service that you
are wanting to provide? 

Regards,
/david t. perkins

> There could be several more, but these seem very common and

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Pat Calhoun" <[email-masked]>
Date: Fri, 10 Jun 2005 05:43:33 -0700

Well, asking me what service or problem I'm trying to solve is not the right
question - I'm not in this business ;-)

That said, I was simply stating that one could envision a scenario such as
the one you have shown in your diagram. Call it Service Provider Managed
WLAN service. While service provider managed networks are fairly rare here
in the US, they are rather common in Europe, so I could envision the
small/medium business owner outsourcing their network to their service
provider. Local access (data), but centralized configuration and
provisioning.

That said, we're not here to dictate who can do what. I was simply stating
that a protocol should not disallow the diagram you provided below.

Pat Calhoun

> -----Original Message-----
> From: David T. Perkins [mailto:[email-masked]] 
> Sent: Thursday, June 09, 2005 5:20 PM
> To: Darren Loher
> Cc: Pat Calhoun; Cheng Hong; Sadot, Emek (Emek); [email-masked]
> what problem are you trying to solve, or service that you are 
> wanting to provide? 
> 
> Regards,
> /david t. perkins
> 
> > On the requirements side for NAT, should we specify if the WTP is 
> > behind NAT, the AC behind NAT or both?  I can see two basic 
> scenarios 
> [mailto:[email-masked]] On 
> > Behalf Of Pat Calhoun
> > Imagine a service provider connecting their AC to their customer's 
> > WTPs across a NAT. Makes sense to me.
> > 
> >  
> > 
> > Pat Calhoun
> > CTO, Wireless Networking Business Unit Cisco Systems
> > 
> >  
> > 
> > 	 
> > 
> > 	
> > 	In this case, most likely the NAT traversal is not a 
> problem for the 
> > WTP or AC directly. For the branch office and main office 
> case, most 
> > 	Does this mean AC and WTP are on different side of the 
> NAT? It sounds 
> > interesting, but is there any reason for deploy it in such a way (A 
> > NAT inside the enterprise network to separate the AC and WTP)?
> > 
> > 	 
> > 
> > 	cheers
> > 
> > 	 
> > 
> > 	Cheng Hong
> > 
> > 	 
> > 
> > 	 
> > 
> > 		 
> > 
> > 		
> > 		Would like to suggest adding a NAT traversal 
> requirement to the 
> > CAPWAP objective document, i.e. the ability of AC and WTP to 
> > Deployment examples? say the WTP is located at branch 
> office and the 
> > AC at the main office separated by NAT device, or within an 
> Enterprise