Subject: RE: [Capwap] NAT traversal

From: "Cheng Hong" <[email-masked]>
Date: Thu, 9 Jun 2005 15:52:18 +0800

Hi Emek,
 
Would like to know a bit more about the deployment examples:
 
>>say the WTP is located at branch office and the AC at the main office
separated by NAT device
 
In this case, most likely the NAT traversal is not a problem for the WTP
or AC directly. For the branch office and main office case, most likely
there will be a VPN setup between them. To the WTP and AC, NAT will be
transparent. 
 
 >>or within an Enterprise segregated by NAT devices.
 
Does this mean AC and WTP are on different side of the NAT? It sounds
interesting, but is there any reason for deploy it in such a way (A NAT
inside the enterprise network to separate the AC and WTP)? 
 
cheers
 
Cheng Hong

________________________________

	From: [email-masked]
[mailto:[email-masked]] On Behalf Of Sadot, Emek (Emek)
	Sent: Wednesday, June 08, 2005 4:27 AM
	To: [email-masked]
	Subject: [Capwap] NAT traversal

	All,
	 
	Would like to suggest adding a NAT traversal requirement to the
CAPWAP objective document, i.e. the ability of AC and WTP to communicate
across NAT device (UDP / TCP transport, refresh CAPWAP session at the
NAT device, WTP identification behind NAT device, etc.). Deployment
examples? say the WTP is located at branch office and the AC at the main
office separated by NAT device, or within an Enterprise segregated by
NAT devices.
	 
	Regards,
	Emek

---

From: "Pat Calhoun" <[email-masked]>
Date: Thu, 9 Jun 2005 06:18:33 -0700

Imagine a service provider connecting their AC to their customer's WTPs
across a NAT. Makes sense to me.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Cheng Hong
Sent: Thursday, June 09, 2005 12:52 AM
To: Sadot, Emek (Emek); [email-masked]
Subject: RE: [Capwap] NAT traversal

Hi Emek,

separated by NAT device
 
In this case, most likely the NAT traversal is not a problem for the WTP or
AC directly. For the branch office and main office case, most likely there
will be a VPN setup between them. To the WTP and AC, NAT will be
transparent. 

 
cheers
 
Cheng Hong

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Sadot, Emek (Emek)
Sent: Wednesday, June 08, 2005 4:27 AM
To: [email-masked]
Subject: [Capwap] NAT traversal

All,
 
Would like to suggest adding a NAT traversal requirement to the CAPWAP
objective document, i.e. the ability of AC and WTP to communicate across NAT
device (UDP / TCP transport, refresh CAPWAP session at the NAT device, WTP
identification behind NAT device, etc.). Deployment examples? say the WTP is
located at branch office and the AC at the main office separated by NAT
device, or within an Enterprise segregated by NAT devices.
 
Regards,
Emek

---

From: "David T. Perkins" <[email-masked]>
Date: Thu, 9 Jun 2005 13:43:43 -0700 (PDT)

HI,

While it is possible, I really don't understand the motivation
for an IP service provider to provide this service. Also,
which address space would the stations be put in? Would
you show a diagram with the IP address pools, and the
wired and wireless overlays.

Thanks,
/david t. perkins

> device, or within an Enterprise segregated by NAT devices.

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Pat Calhoun" <[email-masked]>
Date: Thu, 9 Jun 2005 16:22:19 -0700

Assuming that Local MAC means local bridging, then the station could get an
IP address from a local DHCP server. However, the WTP could be a managed
service by the service provider (could include cool firewall features, etc).

I'm not in this business, I'm simply stating a possibility for an
application that could include a NAT.

Pat Calhoun

> -----Original Message-----
> [mailto:[email-masked]] On Behalf Of David T. Perkins
> Sent: Thursday, June 09, 2005 1:44 PM
> To: Pat Calhoun
> Cc: 'Cheng Hong'; 'Sadot, Emek (Emek)'; [email-masked]
> While it is possible, I really don't understand the 
> motivation for an IP service provider to provide this 
> service. Also, which address space would the stations be put 
> in? Would you show a diagram with the IP address pools, and 
> the wired and wireless overlays.
> 
> Thanks,
> /david t. perkins
> 
> > Imagine a service provider connecting their AC to their customer's 
> > WTPs across a NAT. Makes sense to me.
> >  
> > 
> > Pat Calhoun
> > CTO, Wireless Networking Business Unit Cisco Systems
> > 
> >  
> > 
> > 
> >   _____
> > 
> [mailto:[email-masked]] On 
> > Behalf Of Cheng Hong
> > In this case, most likely the NAT traversal is not a 
> problem for the 
> > WTP or AC directly. For the branch office and main office 
> case, most 
> > likely there will be a VPN setup between them. To the WTP 
> and AC, NAT 
> > will be transparent.
> >  
> > interesting, but is there any reason for deploy it in such a way (A 
> > NAT inside the enterprise network to separate the AC and WTP)?
> >  
> > cheers
> >  
> > Cheng Hong
> >  
> >  
> > 
> > 
> >   _____
> > 
> > objective document, i.e. the ability of AC and WTP to communicate 
> > examples? say the WTP is located at branch office and the AC at the 
> > main office separated by NAT device, or within an 
> Enterprise segregated by NAT devices.
> >  
> > Regards,
> > Emek
> > 
> > 
>