Subject: Re: [Capwap] VLAN name in (section 4.4.8)Add Mobile Station

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 19 Jun 2006 18:43:23 -0700

Given we are sending a VLAN "name", the actual VLAN identifier (tag) may
differ across WTPs. I don't understand the issue.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: David T. Perkins [mailto:[email-masked]] 
> Sent: Wednesday, June 14, 2006 5:04 PM
> To: [email-masked]
> Subject: [Capwap] VLAN name in (section 4.4.8)Add Mobile Station
> 
> HI,
> 
> The message element (4.4.8)Add Modile Station has subfield 
> "VLAN name". However, there are no CAPWAP messages or message 
> elements for VLAN names on a WTP to be managed by the the AC. 
> (A value for a VLAN Name is only approapriate for a localMAC 
> WTP.) Managed means to find out the list of the VLAN names, 
> create VLANs and apply attributes, modify VLAN attributes, 
> and delete VLANs. The attributes include the VLAN name, and 
> ports:tag pairs in the VLAN. (By the way, this is sort of an 
> expansion of CAPWAP, but it is the price to pay to support localMAC.)
> 
> For example, consider a localMAC WTP with 4 802.3 ports.
> It could have the following configuration:
> 
> VLAN RED - members: port 1:untagged, port 2:tag 23,
>                     port 4:tag 56
> VLAN GREEN - members: port 1:tag 96, port 2:tag 103 VLAN 
> YELLOW - members: port 1:tag 200, port 4:untagged (Port 3 is 
> not a member of any VLAN)
> 
> This is not simple, esspecially since there may be 
> restrictions, such as 1) all ports in a VLAN must use the same tag, or
> 2) a port can be either a TRUNK port or a feeder port and 
> feeder ports are untagged, and the VLANs on the trunk port 
> must be all tagged. (I've seen many different sets of limitations.)
> 
> I'm not sure what to suggest, other than to drop support for 
> localMAC WTPs (only joking).
> 
> Regards,
> /david t. perkins
> 
> 
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
> 
> Archives: http://lists.frascone.com/pipermail/capwap
> 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Mon, 19 Jun 2006 19:19:59 -0700 (PDT)

HI,

How do you know the VLAN Names so you can specify an appropriate
one in an Add Mobile station message.

How do you configure VLANs on the WTP?

On a splitMAC WTP, this is not an issue, since you configure
the egress VLAN on the AC, and you configure the ports and
tags in each VLAN on the AC. Of course, how you set up VLANs
on the AC is a local matter, not part of the CAPWAP spec.
However, it seems to me that you have to be able to
configure the VLANs on a localMAC WTP via CAPWAP, since
that is the only standard protocol between an AC and WTP,
and you really need to configure the egress VLANs on
a localMAC WTP.

If you don't use CAPWAP to determine the VLAN names
on a localMAC WTP, or CAPWAP to configure VLANs on
a localMAC WTP, then what would you use?

Regards,
/david t. perkins