Subject: [Capwap] Proposed Resolution for Issue 78:- no result code for WLAN config command

From: "Dorothy Stanley" <[email-masked]>
Date: Wed, 14 Jun 2006 15:39:10 -0700

All,

Issue 78, copied in the e-mail below raises 2 questions.
Proposed resolutions to both questions are provided below.
Comments please.

Thanks,

Dorothy
---------------------------------------------------------------------------------------------------------------
Issue 78, Part 1:

 1.  I found that in the CAPWAP specification, the WLAN
> configuration
> request sent from the AC to the WTP is acked by the WLAN Configuration
> Response. This Message does not have any message elements.
> And I presume
> it is sent irrespective of success / failure of configuration.
>
>  Can we have the Radio Id , WLAN ID and Success Code Message Elements
> (tlvs) to be sent as part of WLAN Configure Response ? ?If
> not, is there
> any other means of finding out if my WLAN Configuration (Add
> / Update /
> Delete ) succeeded or not?

Proposed Resolution to Issue 78 Part 1:
Same as (part of)  Issue 74, include the Result Code message element
as a mandatory message element in the IEEE 802.11 WLAN
Configuration Response message.

Issue 78 Part 2:

>  2. The WTP Radio Information that lists the Radio type and Id is part
> of the Discovery Request. It is not sent as part of any Message after
> that.  But since the AC does not keep any state for a
> Discovery Request,
> the AC does not remember it. I assume that without knowing the Radio
> type, the AC would not be able to configure the WTP. I suggest we add
> Radio Type TLV to the Configure Request, to avoid this.

Proposed Resolution for Issue 78 Part 2:

Add "WTP Radio Information" to the list of message elements that
MUST be included in the Configuration Status Message (WTP->AC)

On 3/16/06, Michael Montemurro <[email-masked]> wrote:
>
> I've recorded this issue as a bug. The issue number is 78.
>
> Cheers,
>
>         Mike
>
> > -----Original Message-----
> > From: sujay [mailto:[email-masked]]
> > Sent: March 8, 2006 2:11 AM
> > To: [email-masked]; [email-masked]
> > Subject: RE: [Capwap] FW: 802.11 Specific - no result code
> > for WLAN config command
> >
> > Sujatha,
> > The first point you have mentioned could  be addressed thus;
> >
> > Send WLAN Configuration reponse only when the operation is
> > successful.Using the sequence number in the request packet
> > you should be able identify which WLAN configuration request
> > has failed and thus the Radio ID. WLAN Id etc.
> >
> >
> > Second point;
> >
> > (In the expired lwapp-03.txt this message was being sent in the Join
> > Request Message,
> > not so in the current.)
> >
> > It could be handled in two ways;
> > 1. the AC should not send the Discovery Response if it is unable to
> > configure the WTP
> > With its given WTP radio information, that automatically means the
> > ClientHello SHOULD
> > not be expected from the that non-supported WTP.
> >
> > 2. It could be added as a part of the 802.11 binding message, IEEE
> > 802.11 WTP WLAN Radio Configuration,
> > message another "Radio Type".
> >
> >
> > Any comments?
> >
> > Regards,
> > Sujay
> >
> > My Location;
> > http://maps.google.com/maps?ll=14.626109,76.959229&spn=4.72485
> 2,7.525085
> > &t=h&hl=en
> >
> >
> >
> >
> >  Hi,
> >
> >    1.  I found that in the CAPWAP specification, the WLAN
> > configuration
> > request sent from the AC to the WTP is acked by the WLAN Configuration
> > Response. This Message does not have any message elements.
> > And I presume
> > it is sent irrespective of success / failure of configuration.
> >
> >  Can we have the Radio Id , WLAN ID and Success Code Message Elements
> > (tlvs) to be sent as part of WLAN Configure Response ? ?If
> > not, is there
> > any other means of finding out if my WLAN Configuration (Add
> > / Update /
> > Delete ) succeeded or not?
> >
> >  2. The WTP Radio Information that lists the Radio type and Id is part
> > of the Discovery Request. It is not sent as part of any Message after
> > that.  But since the AC does not keep any state for a
> > Discovery Request,
> > the AC does not remember it. I assume that without knowing the Radio
> > type, the AC would not be able to configure the WTP. I suggest we add
> > Radio Type TLV to the Configure Request, to avoid this.
> >
> >
> >
> > Thanks
> >
> > Sujatha V
> >
> >
> > _________________________________________________________________
> > To unsubscribe or modify your subscription options, please visit:
> > http://lists.frascone.com/mailman/listinfo/capwap
> >
> > Archives: http://lists.frascone.com/pipermail/capwap
> >
> > _________________________________________________________________
> > To unsubscribe or modify your subscription options, please visit:
> > http://lists.frascone.com/mailman/listinfo/capwap
> >
> > Archives: http://lists.frascone.com/pipermail/capwap
> >
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
>
> Archives: http://lists.frascone.com/pipermail/capwap
>
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: sujay <[email-masked]>
Date: Thu, 15 Jun 2006 10:44:17 +0530

Thanks Dorothy,
 
It looks fine by me.
 
Regds,
Sujay G
My Location;
http://maps.google.com/maps?ll=14.626109,76.959229
<http://maps.google.com/maps?ll=14.626109,76.959229&spn=4.724852,7.52508
5&t=h&hl=en> &spn=4.724852,7.525085&t=h&hl=en

This e-mail and attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure,
reproduction, or dissemination) by persons other than the intended
recipient's) is prohibited. If you receive this e-mail in error, please
notify the sender by phone or email immediately and delete it! 

-----Original Message-----
From: Dorothy Stanley [mailto:[email-masked]] 
Sent: Thursday, June 15, 2006 4:09 AM
To: Michael Montemurro
Cc: sujay; [email-masked];
[email-masked]
Subject: Proposed Resolution for Issue 78:- no result code for WLAN
config command

All,

Thanks,

Dorothy
------------------------------------------------------------------------
---------------------------------------
Issue 78, Part 1:

On 3/16/06, Michael Montemurro <[email-masked]
<mailto:[email-masked]> > wrote: 

Cheers, 

        Mike

> http://maps.google.com/maps?ll=14.626109,76.959229
<http://maps.google.com/maps?ll=14.626109,76.959229&spn=4.72485>
&spn=4.72485 
2,7.525085

> Radio Type TLV to the Configure Request, to avoid this.
<http://lists.frascone.com/pipermail/capwap>