Subject: [Capwap] VLAN name in (section 4.4.8)Add Mobile Station

From: "David T. Perkins" <[email-masked]>
Date: Wed, 14 Jun 2006 17:03:46 -0700 (PDT)

HI,

The message element (4.4.8)Add Modile Station has subfield
"VLAN name". However, there are no CAPWAP messages or
message elements for VLAN names on a WTP to be managed
by the the AC. (A value for a VLAN Name is only approapriate
for a localMAC WTP.) Managed means to find out the list
of the VLAN names, create VLANs and apply attributes,
modify VLAN attributes, and delete VLANs. The attributes
include the VLAN name, and ports:tag pairs
in the VLAN. (By the way, this is sort of an expansion
of CAPWAP, but it is the price to pay to support localMAC.)

For example, consider a localMAC WTP with 4 802.3 ports.
It could have the following configuration:

VLAN RED - members: port 1:untagged, port 2:tag 23,
                    port 4:tag 56
VLAN GREEN - members: port 1:tag 96, port 2:tag 103
VLAN YELLOW - members: port 1:tag 200, port 4:untagged
(Port 3 is not a member of any VLAN)

This is not simple, esspecially since there may be restrictions,
such as 1) all ports in a VLAN must use the same tag, or
2) a port can be either a TRUNK port or a feeder port and
feeder ports are untagged, and the VLANs on the trunk
port must be all tagged. (I've seen many different
sets of limitations.)

I'm not sure what to suggest, other than to drop support
for localMAC WTPs (only joking).

Regards,
/david t. perkins

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Michael Montemurro" <[email-masked]>
Date: Wed, 14 Jun 2006 20:23:00 -0400

David,

I created issue 140 to track this.

Cheers,

Mike