Subject: [Capwap] Proposed Resolution to Issue 134/wasRe: New Issue - Local MAC MUST vs MAY forward associationrequest messages

From: "Dorothy Stanley" <[email-masked]>
Date: Mon, 12 Jun 2006 07:09:02 -0700

Pat, David,

Agree that the AC must be notified. However the text also states that
" the AC MAY reply
 with a failed Association Response if it deems it necessary. "

introducing a race condition, when the WTP may have already responded to the
Association Request with an Association Response (success), before it
receives the "failed Association Response" from the AC.

Proposed resolution of Issue 134:

Change from:

While the MAC is terminated on the WTP, it is necessary for the
AC to be aware of mobility events within the WTPs.
As a consequence, the WTP MUST forward the IEEE 802.11
Association Requests to the AC, and the AC MAY reply
 with a failed Association Response if it deems it necessary.

to

While the MAC is terminated on the WTP, it is necessary for the
AC to be aware of mobility events within the WTPs.
As a consequence, the WTP MUST forward the IEEE 802.11
Association Requests to the AC. The AC MAY reply
with a failed Association Response if it deems it necessary, and upon
receipt of a failed Association Response from the AC,  the
WTP must send a Disassociation frame to the mobile station.

Thanks,

Dorothy

On 6/8/06, Michael Montemurro <[email-masked]> wrote:
>
> I've captured this as issue 134.
>
> Cheers,
>
> Mike
>
>
>
> On 6/6/06, Dorothy Stanley <[email-masked]> wrote:
>
> >  Pat, David,
>
> Your comments are consistent with those received back in April, when
> this mail was sent out - thus
> I did not make, and had not planned to make the proposed change.
>
> Thanks,
>
> Dorothy
>
>
>  On 6/6/06, David T. Perkins <[email-masked] > wrote:
> >
> > HI,
> >
> > ABSOLUTELY agree with Pat. That is the AC MUST know what STAs
> > are be serviced by the WTPs, and MUST decide which STAs are
> > allowed to associate and send traffic.
> > This is the fundamental difference between a CAPWAP network
> > and a collection of APs.
> >
> > Regards,
> > /david t. perkins
> >
> > On Tue, 6 Jun 2006, Pat Calhoun (pacalhou) wrote:
> >
> > > I disagree with this change request. The AC MUST know what STAs are
> > > being serviced by WTPs. The term MUST cannot be changed to MAY.
> > >
> > >
> > > Pat Calhoun
> > > CTO, Wireless Networking Business Unit
> > > Cisco Systems
> > >
> > >
> > >
> > >
> > > ________________________________
> > >
> > >       From: Dorothy Stanley [mailto: [email-masked]]
> > >       Sent: Tuesday, April 11, 2006 11:41 AM
> > >       To: capwap
> > >       Subject: [Capwap] New Issue - Local MAC MUST vs MAY forward
> > > associationrequest messages
> > >
> > >
> > >       All,
> > >
> > >       Section 11.1.2 Local MAC describes the Local MAC operation. It
> > > currently states
> > >       (second paragraph below Figure 6):
> > >
> > >       While the MAC is terminated on the WTP, it is necessary for the
> > > AC to be aware of mobility events within the WTPs.
> > >       As a consequence, the WTP MUST forward the IEEE 802.11
> > > Association Requests to the AC, and the AC MAY reply
> > >       with a failed Association Response if it deems it necessary.
> > >
> > >
> > >       Since this is the Local MAC case, it seems that a MAY should be
> > >       sufficient.
> > >
> > >       Recommended change:
> > >
> > >       The MAC is terminated on the WTP, but the AC may need to be
> > > aware of mobility events within the WTPs.
> > >       As a consequence, the WTP MAY forward the IEEE 802.11
> > > Association Requests to the AC, and the AC MAY reply
> > >       with a failed Association Response.
> > >
> > >       Comments?
> > >
> > >       Thanks,
> > >
> > >       Dorothy
> > >
> > >
> > >
> >
> >
>
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
>
> Archives: http://lists.frascone.com/pipermail/capwap
>
>
>
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Michael Montemurro" <[email-masked]>
Date: Tue, 13 Jun 2006 09:48:55 -0400

This works for me.

Mike

On 6/12/06, Dorothy Stanley <[email-masked]> wrote:
> >  On 6/6/06, Dorothy Stanley < [email-masked]> wrote:
> >
> > >  Pat, David,
> >