Subject: Re: [Capwap] Proposed Resolution to Issue 134/wasRe: New Issue - LocalMAC MUST vs MAY forward associationrequest messages

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 12 Jun 2006 08:05:31 -0700

yup - that works for me.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

________________________________

	From: Dorothy Stanley [mailto:[email-masked]] 
	Sent: Monday, June 12, 2006 7:09 AM
	To: Michael Montemurro
	Cc: capwap
	Subject: [Capwap] Proposed Resolution to Issue 134/wasRe: New
Issue - LocalMAC MUST vs MAY forward associationrequest messages

	Pat, David,
	
	Agree that the AC must be notified. However the text also states
that 
	" the AC MAY reply
	 with a failed Association Response if it deems it necessary. "
	
	introducing a race condition, when the WTP may have already
responded to the
	Association Request with an Association Response (success),
before it
	receives the "failed Association Response" from the AC. 
	
	Proposed resolution of Issue 134:
	
	Change from:
	
	While the MAC is terminated on the WTP, it is necessary for the 
	AC to be aware of mobility events within the WTPs.
	As a consequence, the WTP MUST forward the IEEE 802.11
	Association Requests to the AC, and the AC MAY reply
	 with a failed Association Response if it deems it necessary. 
	
	to
	
	While the MAC is terminated on the WTP, it is necessary for the 
	AC to be aware of mobility events within the WTPs.
	As a consequence, the WTP MUST forward the IEEE 802.11
	Association Requests to the AC. The AC MAY reply
	with a failed Association Response if it deems it necessary, and
upon 
	receipt of a failed Association Response from the AC,  the
	WTP must send a Disassociation frame to the mobile station.
	
	Thanks,
	
	Dorothy

	On 6/8/06, Michael Montemurro <[email-masked]>
wrote: 

		I've captured this as issue 134.
		 
		Cheers,
		 
		Mike

		On 6/6/06, Dorothy Stanley < [email-masked]
<mailto:[email-masked]> > wrote: 

		Pat, David,
		 
		Your comments are consistent with those received back in
April, when
		this mail was sent out - thus
		I did not make, and had not planned to make the proposed
change. 
		 
		Thanks,

		Dorothy

		On 6/6/06, David T. Perkins <[email-masked] >
wrote: 

			HI,
			
			ABSOLUTELY agree with Pat. That is the AC MUST
know what STAs
			are be serviced by the WTPs, and MUST decide
which STAs are 
			allowed to associate and send traffic.
			This is the fundamental difference between a
CAPWAP network
			and a collection of APs.
			
			Regards,
			/david t. perkins
			
			On Tue, 6 Jun 2006, Pat Calhoun (pacalhou)
wrote: 
			
			> I disagree with this change request. The AC
MUST know what STAs are
			> being serviced by WTPs. The term MUST cannot
be changed to MAY.
			>
			>
			> Pat Calhoun
			> CTO, Wireless Networking Business Unit 
			> Cisco Systems
			>
			>
			>
			>
			> ________________________________
			>
			>       From: Dorothy Stanley [mailto:
[email-masked] <mailto:[email-masked]> ]
			>       Sent: Tuesday, April 11, 2006 11:41 AM 
			>       To: capwap
			>       Subject: [Capwap] New Issue - Local MAC
MUST vs MAY forward
			> associationrequest messages
			> 
			>
			>       All,
			>
			>       Section 11.1.2 Local MAC describes the
Local MAC operation. It 
			> currently states
			>       (second paragraph below Figure 6):
			>
			>       While the MAC is terminated on the WTP,
it is necessary for the 
			> AC to be aware of mobility events within the
WTPs.
			>       As a consequence, the WTP MUST forward
the IEEE 802.11
			> Association Requests to the AC, and the AC MAY
reply
			>       with a failed Association Response if it
deems it necessary. 
			>
			>
			>       Since this is the Local MAC case, it
seems that a MAY should be
			>       sufficient.
			>
			>       Recommended change:
			>
			>       The MAC is terminated on the WTP, but
the AC may need to be 
			> aware of mobility events within the WTPs.
			>       As a consequence, the WTP MAY forward
the IEEE 802.11
			> Association Requests to the AC, and the AC MAY
reply
			>       with a failed Association Response. 
			>
			>       Comments?
			>
			>       Thanks,
			>
			>       Dorothy
			>
			>
			>

_________________________________________________________________ 
		To unsubscribe or modify your subscription options,
please visit:
		http://lists.frascone.com/mailman/listinfo/capwap 
		
		Archives: http://lists.frascone.com/pipermail/capwap

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: zhaoyujin 31390 <[email-masked]>
Date: Tue, 13 Jun 2006 09:49:14 +0500

Why don't define a notification event from AP to AC to resolve the issue 134.  Maybe AP can directly use "Add mobile" to notify AC this event.

For local MAC, AP forward association request message to AC that maybe resolve issue 134, but the logic of this method is not better and not easy to be accepted.

Best regards
Michael

yup- that works for me.
 
Pat Calhoun

--------------------------------------------------------------------------------
From: Dorothy Stanley [mailto:[email-masked]] 
Sent: Monday, June 12, 2006 7:09 AM
To: Michael Montemurro
Cc: capwap
Subject: [Capwap] Proposed Resolution to Issue 134/wasRe: New Issue - LocalMAC MUST vs MAY forward associationrequest messages

Pat, David,

Agree that the AC must be notified. However the text also states that 
" the AC MAY reply
 with a failed Association Response if it deems it necessary. "

introducing a race condition, when the WTP may have already responded to the
Association Request with an Association Response (success), before it
receives the "failed Association Response" from the AC. 

Change from:

to

with a failed Association Response if it deems it necessary, and upon 

Thanks,

Dorothy

On 6/8/06, Michael Montemurro <[email-masked]> wrote: 
I've captured this as issue 134.
 
Cheers,
 
Mike

On 6/6/06, Dorothy Stanley < [email-masked]> wrote: 
Pat, David,
 
Your comments are consistent with those received back in April, when
this mail was sent out - thus
I did not make, and had not planned to make the proposed change. 
 
Thanks,
 
Dorothy

On 6/6/06, David T. Perkins <[email-masked] > wrote: 
HI,

ABSOLUTELY agree with Pat. That is the AC MUST know what STAs
are be serviced by the WTPs, and MUST decide which STAs are 
allowed to associate and send traffic.
This is the fundamental difference between a CAPWAP network
and a collection of APs.

Regards,
/david t. perkins

On Tue, 6 Jun 2006, Pat Calhoun (pacalhou) wrote: 

> I disagree with this change request. The AC MUST know what STAs are
> being serviced by WTPs. The term MUST cannot be changed to MAY.
>
>
> Pat Calhoun
>       From: Dorothy Stanley [mailto: [email-masked]]
>       Subject: [Capwap] New Issue - Local MAC MUST vs MAY forward
>       Section 11.1.2 Local MAC describes the Local MAC operation. It 
> currently states
>       Since this is the Local MAC case, it seems that a MAY should be
>       sufficient.
>
>       Recommended change:
>
>       The MAC is terminated on the WTP, but the AC may need to be 
>       As a consequence, the WTP MAY forward the IEEE 802.11

--------------------------------------------------------------------------------

yup - that works for me.

Pat Calhoun

	Pat, David,

	
	
	Change from:

	to

	Thanks,
	
	Dorothy

		 
		Cheers,
		 
		Mike

		Pat, David,

		Thanks,

		Dorothy

			HI,

			Regards,
			/david t. perkins

MUST know what STAs are
be changed to MAY.
MUST vs MAY forward
Local MAC operation. It 
it is necessary for the 
WTPs.
the IEEE 802.11
reply
deems it necessary. 
the AC may need to be 
the IEEE 802.11
reply

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 13 Jun 2006 06:52:50 -0700

Because the Association Request provides you with all of the information
that you need anyways. Otherwise, you'd end up breaking up the request
and creating another CAPWAP control message that we would have to define
in the protocol.

Pat Calhoun

> -----Original Message-----
> From: zhaoyujin 31390 [mailto:[email-masked]] 
> Sent: Monday, June 12, 2006 9:49 PM
> To: Pat Calhoun (pacalhou)
> Cc: Dorothy Stanley; Michael Montemurro; capwap
> Subject: Re:Re: [Capwap] Proposed Resolution to Issue 
> 134/wasRe: New Issue - LocalMAC MUST vs MAY forward 
> Why don't define a notification event from AP to AC to 
> resolve the issue 134.  Maybe AP can directly use "Add 
> mobile" to notify AC this event.
> 
> For local MAC, AP forward association request message to AC 
> that maybe resolve issue 134, but the logic of this method is 
> not better and not easy to be accepted.
> 
> Best regards
> Michael
>  
> 
> 
> yup- that works for me.
>  
> Pat Calhoun