Subject: Re: [Capwap] Proposed resolution for issue 100. Treatment of wirelessmanagement frames.

From: "Abhijit Choudhury" <[email-masked]>
Date: Sat, 3 Jun 2006 13:08:42 -0700

Mike,
I'm not sure this make sense.
 
The CAPWAP control channel is for "control and
provisioning" messages between the AC and the WTP.
Per-client information arriving at the WTP should
be sent in the data channel as it is all data to
the AC, and has nothing to do with "control and
provisioning" of the WTP.  
 
There could be radio technology specific information 
(e.g. RSSI/SNR) that are collected on a per-client 
basis at the AC, and separating out some of the 
messages into a separate channel will lead to either
erroneous accounting or more complicated logic that 
looks at both channels on a packet-by-packet basis. 
All packets sent by a client should come up
the same channel (the data channel).
 
As for security for management frames, 802.11w
should take care of that.
 
Thanks,
   Abhijit

	-----Original Message-----
	From: Michael Montemurro [mailto:[email-masked]] 
	Sent: Saturday, June 03, 2006 12:39 PM
	To: capwap
	Subject: [Capwap] Proposed resolution for issue 100. Treatment
of wirelessmanagement frames.

	Here is my proposed resolution to issue 100:

	- Fix the default priority settings in section 11.6 to the
values used in section 4.3.3.

	- Change the last paragraph in section 4.3 to state that radio
technology specific management frames are treated as CAPWAP control
messages. It makes sense because control frames are protected.

	Does this make sense?

	Cheers,

	Mike

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Michael Montemurro" <[email-masked]>
Date: Sat, 3 Jun 2006 18:50:37 -0400

Is there consensus that radio techology specific management frames should be
carried as CAPWAP data frames?

Thanks,

Mike

On 6/3/06, Abhijit Choudhury <[email-masked]> wrote:
> *From:* Michael Montemurro [mailto:[email-masked]]
> *Sent:* Saturday, June 03, 2006 12:39 PM
> *To:* capwap
> *Subject:* [Capwap] Proposed resolution for issue 100. Treatment of
> wirelessmanagement frames.
>
> - Fix the default priority settings in section 11.6 to the values used in
> section 4.3.3.
>
> - Change the last paragraph in section 4.3 to state that radio technology
> specific management frames are treated as CAPWAP control messages. It makes
> sense because control frames are protected.
>
> Does this make sense?
>
> Cheers,
>
> Mike
>
>
>
>

---

From: "Michael Montemurro" <[email-masked]>
Date: Sun, 4 Jun 2006 20:22:08 -0400

Actually, I need to make one clarification. If we decide to use CAPWAP data
encapsulation, IEEE 802.11 management frames passed from the WTP to the AC
in local MAC mode. That would mean there would be three possible forms of
processing at the WTP:
data frames - bridge locally or tunneled to the AC - CAPWAP data
802.11 management frames - encapulated as CAPWAP data and transmitted to the
AC
CAPWAP control frames.

I think it sounds cleaner to encapsulate management frames and transmit them
from the WTP to the AC as control frames. But I'm willing to go whichever
way the group decides.

Cheers,

Mike

On 6/3/06, Michael Montemurro <[email-masked]> wrote:
>
>  Is there consensus that radio techology specific management frames should
> be carried as CAPWAP data frames?
>
> Thanks,
>
> Mike
>
>
> > *From:* Michael Montemurro [mailto: [email-masked]]
> > - Fix the default priority settings in section 11.6 to the values used
> > in section 4.3.3.
> >

---

From: sujay <[email-masked]>
Date: Tue, 06 Jun 2006 10:57:31 +0530

Mike,
 
I would prefer encapsulating the 802.11 mgt frames as capwap data and
send to AC.
For , such binding specific mgt frames can be easily carried and
understood
by the AC.
 
There is no need for CAPWAP taking an extra operation of converting it
into an
equivalent control message.
 
But then again as it is in the data channel and the Ack for it is
carried implicitly in 
the control channel (add mobile message) OR as Response
message(Association response),
 in the data channel, retransmission mechanism implementations should be
 made aware of both possibilities.
 
Least it MAY cause inter-op issues.
 
>From Section 11.1.2
 
While the MAC is terminated on the WTP, it is necessary for the AC
to......
WTP MUST forward the IEEE 802.11 Association Requests to the AC, and
the AC " MAY " reply with a failed Association Response if it deems it
necessary.

Regds,
Sujay G
My Location;
http://maps.google.com/maps?ll=14.626109,76.959229
<http://maps.google.com/maps?ll=14.626109,76.959229&spn=4.724852,7.52508
5&t=h&hl=en> &spn=4.724852,7.525085&t=h&hl=en

This e-mail and attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure,
reproduction, or dissemination) by persons other than the intended
recipient's) is prohibited. If you receive this e-mail in error, please
notify the sender by phone or email immediately and delete it! 

-----Original Message-----
From: Michael Montemurro [mailto:[email-masked]] 
Sent: Monday, June 05, 2006 5:52 AM
To: Abhijit Choudhury
Cc: capwap
Subject: Re: [Capwap] Proposed resolution for issue 100. Treatment
ofwirelessmanagement frames.

Actually, I need to make one clarification. If we decide to use CAPWAP
data encapsulation, IEEE 802.11 management frames passed from the WTP to
the AC in local MAC mode. That would mean there would be three possible
forms of processing at the WTP: 
data frames - bridge locally or tunneled to the AC - CAPWAP data
802.11 management frames - encapulated as CAPWAP data and transmitted to
the AC
CAPWAP control frames.
 
I think it sounds cleaner to encapsulate management frames and transmit
them from the WTP to the AC as control frames. But I'm willing to go
whichever way the group decides.
 
Cheers,
 
Mike

Is there consensus that radio techology specific management frames
should be carried as CAPWAP data frames?
 
Thanks,
 
Mike

On 6/3/06, Abhijit Choudhury <[email-masked]
<mailto:[email-masked]> > wrote: 

Mike,

 
 
Thanks,

   Abhijit

-----Original Message-----
From: Michael Montemurro [mailto:  <mailto:[email-masked]>
[email-masked]] 
Sent: Saturday, June 03, 2006 12:39 PM
To: capwap
Subject: [Capwap] Proposed resolution for issue 100. Treatment of
wirelessmanagement frames.

Does this make sense?

Cheers,

Mike