Subject: [Capwap] Consistent range for radio ID and WLAN ID

From: "David T. Perkins" <[email-masked]>
Date: Wed, 14 Jun 2006 23:11:35 -0700 (PDT)

HI,

I've seen several places where the range of the
Radio ID and WLAN ID is inconsistant.

In section 4.1, in the transport header, the RID is
5 bits (a range of 0-31), but in section 4.4.34,
the max radios and radios in use is a 8 bits (range
of 0-255). Also, in sections 4.4.8, 4.4.11, 4.4.14,
4.4.15, 4.4.17, 4.4.28, 4.4.39, 11.10.1, 11.10.2,
11.10.5, 11.10.6, 11.10.8, 11.10.9, 11.10.10,
11.10.11, 11.10.13, 11.10.14, 11.10.15, 11.10.16,
11.10.17, 11.10.18, 11.10.19, 11.10.20, 11.10.21,
11.10.22, 11.10.23, and 11.10.24 the radio ID
field is 8 bits.   

In section 11.4, WLAN is a bit map of length 16
(thus a range of 0-15). However, in the following
sections, WLAN ID is 8 bits (a range of 0-255):
11.10.1, 11.10.9, 11.10.10, and 11.10.11.
And in sections 11.10.5 and 11.10.21 the WLAN ID
is 16 bits (0-65535)

Regards,
/david t. perkins

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Michael Montemurro" <[email-masked]>
Date: Thu, 15 Jun 2006 21:41:04 -0400

David,

Thanks for pointing this out. I've recorded it as issue 141.

Mike