Subject: Re: [Capwap] Encryption Capabilities

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 5 Jun 2006 08:20:55 -0700

Actually, this field was intended to allow the WTP to communicate
whether it is capable of providing its capabilities, and therefore allow
the AC to determine whether it should perform centralized encryption.
However, with the transition to DTLS, I propose that we always require
the WTP to provide wireless encryption, and use DTLS between the AC and
the WTP. 

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

________________________________

	From: Michael Montemurro [mailto:[email-masked]] 
	Sent: Saturday, June 03, 2006 12:12 PM
	To: David T. Perkins
	Cc: [email-masked]
	Subject: Re: [Capwap] Encryption Capabilities

	David,
	 
	Would it be sufficient to move Encryption Capabilities from the
WTP Descriptor (Section 4.4.34) to the WTP Radio Information message
element (Section 4.4.39)?
	 
	Mike

	On 6/3/06, Michael Montemurro <[email-masked]>
wrote: 

		David, 
		
		I've created issue 125 to track this issue.
		 
		Mike

		On 6/1/06, David T. Perkins <[email-masked] >
wrote: 

			HI,
			
			The "(4.4.34)WTP Descriptor" message element has
the
			subfield "encryption capabilities". What is this
used 
			for? If for radios, then it should be per radio.
If
			for the user data between the WTP and AC, then
			it doesn't seem appropriate to say the value is
			defined by "specific binding" definitions
because
			the WTP can be supporting multiple radios with
			some that provide encryption services and some
			that don't.
			
			In general, I don't feel that this subfield is
			well defined, and it appears to me that it
			should be a per radio attribute. 
			
			Regards,
			/david t. perkins

_________________________________________________________________
			To unsubscribe or modify your subscription
options, please visit:
	
http://lists.frascone.com/mailman/listinfo/capwap
			
			Archives:
http://lists.frascone.com/pipermail/capwap 

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Michael Montemurro" <[email-masked]>
Date: Mon, 5 Jun 2006 12:12:48 -0400

Pat,

Are you saying that we should remove the Encryption Capabilities field? If
not, do you agree that it makes more sense to include it as part of the
radio information.

Cheers,

Mike

On 6/5/06, Pat Calhoun (pacalhou) <[email-masked]> wrote:
>
>  Actually, this field was intended to allow the WTP to communicate whether
> it is capable of providing its capabilities, and therefore allow the AC to
> determine whether it should perform centralized encryption. However, with
> the transition to DTLS, I propose that we always require the WTP to provide
> wireless encryption, and use DTLS between the AC and the WTP.
>
>
> Pat Calhoun
>  ------------------------------
> *From:* Michael Montemurro [mailto:[email-masked]]
> *Sent:* Saturday, June 03, 2006 12:12 PM
> *To:* David T. Perkins
> *Cc:* [email-masked]
> *Subject:* Re: [Capwap] Encryption Capabilities
>
>
>
>  David,
>
> Would it be sufficient to move Encryption Capabilities from the WTP
> Descriptor (Section 4.4.34) to the WTP Radio Information message element
> (Section 4.4.39)?
>
> Mike
>
>
> On 6/3/06, Michael Montemurro <[email-masked]> wrote:
> >
> >  David,
> >
> >  On 6/1/06, David T. Perkins <[email-masked] > wrote:
> > >
> > > HI,
> > >
> > > The "(4.4.34)WTP Descriptor" message element has the
> > > subfield "encryption capabilities". What is this used
> > > for? If for radios, then it should be per radio. If
> > > defined by "specific binding" definitions because

---

From: "Dorothy Stanley" <[email-masked]>
Date: Mon, 5 Jun 2006 17:03:56 -0700

I do not agree with always requiring the WTP to provide wireless
encryption. The split MAC architecture allows 802.11 encryption/decryption
at either the WTP or the AC, and this flexibility should be retained, with
use of the
field in question clearly defined.

Dorothy

---

From: "Michael Montemurro" <[email-masked]>
Date: Tue, 6 Jun 2006 11:05:57 -0400

So then, I'll go back to my original proposed change to address this issue:

Cheers,

Mike

On 6/5/06, Dorothy Stanley <[email-masked]> wrote:
> > whether it is capable of providing its capabilities, and therefore allow the
> > AC to determine whether it should perform centralized encryption. However,
> > with the transition to DTLS, I propose that we always require the WTP to
> > provide wireless encryption, and use DTLS between the AC and the WTP.
> >
> >
> > Pat Calhoun

---

From: Scott G Kelly <[email-masked]>
Date: Tue, 06 Jun 2006 08:13:39 -0700

I second Dorothy's comments, and I think Mike is right: this should be 
included with the radio information element.

Michael Montemurro wrote:
> On 6/5/06, *Dorothy Stanley* <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
>     at either the WTP or the AC, and this flexibility should be
>     retained, with use of the
>     On 6/5/06, *Pat Calhoun (pacalhou)* < [email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>         Actually, this field was intended to allow the WTP to
>         communicate whether it is capable of providing its capabilities,
>         and therefore allow the AC to determine whether it should
>         perform centralized encryption. However, with the transition to
>         DTLS, I propose that we always require the WTP to provide
>             ------------------------------------------------------------------------
>             *From:* Michael Montemurro
>             [mailto:[email-masked]
>             <mailto:[email-masked]>]
>             *Cc:* [email-masked] <mailto:[email-masked]>
>         WTP Descriptor (Section 4.4.34) to the WTP Radio Information
>         message element (Section 4.4.39)?
>          
>         Mike
> 
>          
>         On 6/3/06, *Michael Montemurro* <[email-masked]
>         <mailto:[email-masked]>> wrote:
> 
>             David,
> 
>             On 6/1/06, *David T. Perkins* <[email-masked]
>             <mailto:[email-masked]>> wrote:
> 
>                 HI,
> 
>                 <http://lists.frascone.com/mailman/listinfo/capwap>
> 
>                 <http://lists.frascone.com/pipermail/capwap>
> 
> 
> 
> 
>         <http://lists.frascone.com/pipermail/capwap>
> 
> 
>      
> 
> 
> 
> ------------------------------------------------------------------------
>