Subject: Re: [Capwap] Proposed Resolution to Issue 97: Discovery Type DefinitionInconsistencies

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 5 Jun 2006 17:21:15 -0700

I would like to propose something different. How about:

The Discovery Type message element is used by the WTP to indicate how
it has come to know about the existence of the AC, to which it has sent
the Discovery Request.

0
0 1 2 3 4 5 6 7
+-+-+-+-+-+-+-+-+
| Discovery Type|
+-+-+-+-+-+-+-+-+

Type: 19 for Discovery Type

Length: 1

Discovery Type: An 8-bit value indicating WTP knowledge of the AC
The following values are supported:
   0 - Unknown
   1 - Statically Configured
   2 - DHCP
   3 - DNS

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

________________________________

	From: Dorothy Stanley [mailto:[email-masked]] 
	Sent: Wednesday, May 24, 2006 12:10 PM
	To: capwap
	Subject: [Capwap] Proposed Resolution to Issue 97: Discovery
Type DefinitionInconsistencies

	All,
	
	Issue 97 is listed below, together with a proposed resolution.
	
	Comments please.
	
	Thanks,
	
	Dorothy
	-------------
	
	Proposed Resolution: Accept, see 4.4.19,
	
	Change from:

	The Discovery message element is used to configure a WTP to
operate in a
	specific mode.
	 0
	 0 1 2 3 4 5 6 7
	+-+-+-+-+-+-+-+-+
	 | Discovery Type|
	 +-+-+-+-+-+-+-+-+
	
	Type: 19 for Discovery Type

	 Length: 1
	Discovery Type: An 8-bit value indicating how the AC was
discovered.
	The following values are supported:
	 0 - Broadcast
	1 - Configured
	
	to
	
	The Discovery Type message element is used to indicate that the
WTP has been
	
	configured with the AC address
	to which the corresponding Discovery Request message is sent.
	 0
	 0 1 2 3 4 5 6 7
	+-+-+-+-+-+-+-+-+
	 | Discovery Type|
	 +-+-+-+-+-+-+-+-+
	
	Type: 19 for Discovery Type

	 Length: 1
	Discovery Type: An 8-bit value indicating WTP knowledge of the
AC
	The following values are supported:
	 0 - Unknown
	1 -  Configured

	Issue 97:
	
	Section 5.1.1 Defines the Discovery Type message element. This
message element
	is included in the
	Discovery Request message, sent by WTPs to discover potential
ACs.
	
	The current definition is below:

	The Discovery message element is used to configure a WTP to
operate in a
	specific mode.
	 0
	 0 1 2 3 4 5 6 7
	+-+-+-+-+-+-+-+-+
	 | Discovery Type|
	 +-+-+-+-+-+-+-+-+
	
	Type: 58 for Discovery Type

	 Length: 1
	Discovery Type: An 8-bit value indicating how the AC was
discovered.
	The following values are supported:
	 0 - Broadcast
	1 - Configured
	
	Comments:
	1. The statement that " The Discovery message element is used to
configure a WTP
	
	to operate in a specific mode." seems inconsistent
	with its inclusion in the Discovery Request message.
	2. Discovery Type: An 8-bit value indicating how the AC was
discovered. - The AC
	hasn't been discovered yet. Does this mean the mode - unicast,
broadcast/multi-cast
	
	in which the discovery request message was sent? Must the WTP be
either
	configured with the AC address, or find the address on its own?
Seems like this
	would be part of WTP configuration, rather than being included
in the discovery
	
	request message.
	3. What is the purpose/value of including "Discovery Type"?
Either define
	consistently, or delete it
	
	Do we mean the following?

	The Discovery Type message element is used to indicate that the
WTP has been
	
	configured with the AC address
	to which the corresponding Discovery Request message is sent.
	 0
	 0 1 2 3 4 5 6 7
	+-+-+-+-+-+-+-+-+
	 | Discovery Type|
	 +-+-+-+-+-+-+-+-+
	
	Type: 58 for Discovery Type

	 Length: 1
	Discovery Type: An 8-bit value indicating WTP knowledge of the
AC
	The following values are supported:
	 0 - Unknown
	1 -  Configured

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Mon, 5 Jun 2006 17:37:31 -0700 (PDT)

HI,

In addition to the below, I would add the following:
  4 - AC downloaded a new image and rebooted the WTP
  5 - AC reset the WTP
  6 - AC provided this referral
  7 - AC was connected, but session was lost

That is (except for 6), there is a set of values that indicate 
that a WTP was connected to an AC, but an operation or event
caused the DTLS session to be terminated (and maybe the 
WTP process/device restarted). The WTP wants to "fast
trace" a reconnection to the AC without going through
the complete discovery (because this can take lots of
time), with possibly reusing cached DTLS session state. 

Did I get all of the operations and events?

Regards,
/david t. perkins

---

From: "Dorothy Stanley" <[email-masked]>
Date: Mon, 12 Jun 2006 14:26:33 -0700

I am fine with the proposed change.

Dorothy