Subject: Re: [Capwap] Process in CAPWAP

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 11 Jun 2006 15:46:14 +0300

Bob,

Thank you for the mail. 

You probably refer to the mail from Dorothy Gellert sent to the list on Tuesday 6/6 (US time):

'The CAPWAP editors have asked the Chairs to resolve the Mux vs Multiport issue # 115, in order to progress the specification.  Based on the discussion that has taken place the chairs are in agreement the simplest, cleanest solution for this is to add a Mux header.  Barring any unforseen events, we will instruct the editors resolve in favor of a new Mux header.

We intend to close this issue by the end of the week, Friday, 6/9.  Please review the issue and send any constructive comments to the list by Friday.'

I am looking together with my co-Area Director, David Kessens into the issues that you are raising and we shall respond in a matter of days.

In the meantime I would encourage the working group, the editors and the chairs to continue to work and seek consensus, in the best possible cooperation spirit. According to the traffic on the list during the last few days I agree that there still seem to be open issues and it does not seem to be consensus in the Working Group.

Dan

> -----Original Message-----
> From: Bob O'Hara (boohara) [mailto:[email-masked]] 
> Sent: Saturday, June 10, 2006 3:16 AM
> To: Romascanu, Dan (Dan)
> Cc: capwap
> Subject: Process in CAPWAP
> 
> Dan,
> 
> A few days ago Dorothy Gellert sent an email to the working 
> group on behalf of the chairs, announcing a decision on a 
> technical issue in the working group.  Specifically, she 
> declared that the chairs decided the discussion of the use of 
> a mux header vs. the use of separate ports for the 
> differentiation of control and data traffic in the protocol 
> to be over.  She also indicated that the chairs had chosen 
> the mux header as the method to be used in the protocol and 
> set a deadline of today for closing the issue.
> 
> As soon as I read her email, I replied and asked that she 
> document the process that the chairs used to arrive at their 
> decision.  My background is in the IEEE, where the process is 
> clear, transparent, and open to all participants.  CAPWAP is 
> my first IETF working group.  My understanding of 
> decision-making in IETF is that it is based on rough 
> consensus and that the chairs have responsibility to 
> determine that consensus.  With that understanding, I asked 
> Dorothy to document what the chairs used as evidence of rough 
> consensus on that issue, since I see evidence in the postings 
> to the list that there is more support for separate ports 
> than there is for the mux header.  At a minimum, there is no 
> consensus on this issue.
> 
> Since sending that email two days ago, neither chair has 
> responded.  I find that quite disturbing for several reasons.  
> 
> First, this is an issue that has been debated extensively 
> (and still is being debated, regardless of the pronouncement 
> from the chairs).  The working group deserves to know how 
> this technical issue was resolved.  
> 
> Second, standardization by fiat of the chair does not seem to 
> be in keeping with the open process requirements of the IETF. 
>  Perhaps I am being naïve, but I don't believe there is a 
> feted inner core (FIC) that is actually developing all the 
> IETF standards.  
> 
> Third, the time allowed for any response to the email was 
> only three days.  This is an absurdly short time, given that 
> it is the start of the summer vacation period in the northern 
> hemisphere.  It is quite possible that many participants will 
> not even see her email until after the deadline expires.  
> 
> Finally, if there is no consensus on the issue, the chairs 
> are expressing an engineering opinion and should be required 
> to justify that opinion just as any other member of the 
> working group.  I don't believe that the IETF anoints the 
> chairs of any working group as expert and able to make 
> technical decisions for the working group.
> 
> I would appreciate your thoughts, as the AD, and response on 
> these items.
> 
> Best regards,
>  -Bob
> 
> Bob O'Hara
> 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Bob O'Hara (boohara)" <[email-masked]>
Date: Mon, 12 Jun 2006 10:44:41 -0700

Dan,

Thank you for your email.  I look forward to your response.  As you have probably seen from the reflector traffic, CAPWAP is a lively group.  

 -Bob
 
-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Sunday, June 11, 2006 5:46 AM
To: Bob O'Hara (boohara)
Cc: capwap; [email-masked]
Subject: RE: Process in CAPWAP

Bob,

Thank you for the mail. 

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 15 Jun 2006 11:07:14 +0300

Hi Bob,

The ADs looked in the issue that you raised related to the consensus on the Mux vs Multiport issue # 115. We analyzed the traffic on the list and we also discussed with the WG chairs.  Our opinion is that although the chairs suggested a solution for consensus the WG did not agree with it. Despite the chairs and WG efforts to reach a timely conclusion according to the current WG schedules, more work needs to be done to reach at minimum rough consensus on this point.

The chairs have the responsibility to drive the consensus process, and the criteria for reaching the decisions should be clearly explained. 

In order to overcome the dead-end we recommend to the WG to bring in the discussion opinions about the consensus criteria (QoS, scalability, compatibility with routing and switching infrastructure), their priority and recommendations from external experts that were less involved in the discussions until now, for example by consulting the Routing Area.  We offer to approach the Routing Area ADs to have an expert designated to this purpose.

We recommend that the WG continues its work and capitalizes on the effort made until now to close a large number of open issues in the next version of the draft. This issue together with the other open issues should be brought for discussion on the list and in Montreal, and we hope that a conclusion based on rough consensus can be reached soon after the Montreal meeting, so that the impact on the Working Group schedules be minimized.

David and Dan

---

From: "Bob O'Hara (boohara)" <[email-masked]>
Date: Thu, 15 Jun 2006 11:11:32 -0700

Dan, David,

I certainly appreciate the difficulty that our chairs have to navigate the path to consensus necessary for a successful standard.  I do not envy them their task, particularly in this area where we believe that the success of the CAPWAP standard is critical to this market area and the customers in it.

There are certainly enough open issues to resolve, that asking for expert advice on this particular issue is not likely to adversely affect the time for completion of our work.  I think that this will be very helpful to us. 

Thank you.

 -Bob
 
-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Thursday, June 15, 2006 1:07 AM
To: Bob O'Hara (boohara)
Cc: capwap; [email-masked]
Subject: RE: Process in CAPWAP

Hi Bob,

David and Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 16 Jun 2006 11:57:25 +0300

I would suggest that the chairs draw a short list of clear questions and issues for clarification, including references that would help to focus the work of the experts. Can we have this list prepared in the next few days? 

Thanks and Regards,

Dan

> Sent: Thursday, June 15, 2006 9:12 PM
> To: capwap
> Cc: [email-masked]; Romascanu, Dan (Dan)
> I certainly appreciate the difficulty that our chairs have to 
> navigate the path to consensus necessary for a successful 
> standard.  I do not envy them their task, particularly in 
> this area where we believe that the success of the CAPWAP 
> standard is critical to this market area and the customers in it.
> 
> There are certainly enough open issues to resolve, that 
> asking for expert advice on this particular issue is not 
> likely to adversely affect the time for completion of our 
> work.  I think that this will be very helpful to us. 
> 
> Thank you.
> 
>  -Bob
>  
> The ADs looked in the issue that you raised related to the 
> consensus on the Mux vs Multiport issue # 115. We analyzed 
> the traffic on the list and we also discussed with the WG 
> chairs.  Our opinion is that although the chairs suggested a 
> solution for consensus the WG did not agree with it. Despite 
> the chairs and WG efforts to reach a timely conclusion 
> according to the current WG schedules, more work needs to be 
> done to reach at minimum rough consensus on this point.
> 
> The chairs have the responsibility to drive the consensus 
> process, and the criteria for reaching the decisions should 
> be clearly explained. 
> 
> In order to overcome the dead-end we recommend to the WG to 
> bring in the discussion opinions about the consensus criteria 
> (QoS, scalability, compatibility with routing and switching 
> infrastructure), their priority and recommendations from 
> external experts that were less involved in the discussions 
> until now, for example by consulting the Routing Area.  We 
> offer to approach the Routing Area ADs to have an expert 
> designated to this purpose.
> 
> We recommend that the WG continues its work and capitalizes 
> on the effort made until now to close a large number of open 
> issues in the next version of the draft. This issue together 
> with the other open issues should be brought for discussion 
> on the list and in Montreal, and we hope that a conclusion 
> based on rough consensus can be reached soon after the 
> Montreal meeting, so that the impact on the Working Group 
> schedules be minimized.
> 
> David and Dan
> 
>  
>  
> 
> group on 
> > behalf of the chairs, announcing a decision on a technical issue in 
> > the working group.  Specifically, she declared that the 
> chairs decided 
> > the discussion of the use of a mux header vs. the use of separate 
> > ports for the differentiation of control and data traffic in the 
> > protocol to be over.  She also indicated that the chairs had chosen 
> > the mux header as the method to be used in the protocol and set a 
> > deadline of today for closing the issue.
> > 
> document the 
> > process that the chairs used to arrive at their decision.  My 
> > background is in the IEEE, where the process is clear, transparent, 
> > and open to all participants.  CAPWAP is my first IETF 
> working group.  
> > My understanding of decision-making in IETF is that it is based on 
> > rough consensus and that the chairs have responsibility to 
> determine 
> > that consensus.  With that understanding, I asked Dorothy 
> to document 
> > what the chairs used as evidence of rough consensus on that issue, 
> > since I see evidence in the postings to the list that there is more 
> > support for separate ports than there is for the mux header.  At a 
> > minimum, there is no consensus on this issue.
> > 
> responded.  I 
> > find that quite disturbing for several reasons.
> > 
> (and still 
> > is being debated, regardless of the pronouncement from the 
> chairs).  
> > The working group deserves to know how this technical issue was 
> > resolved.
> > 
> > Second, standardization by fiat of the chair does not seem to be in 
> > keeping with the open process requirements of the IETF.
> feted inner 
> > core (FIC) that is actually developing all the IETF standards.
> > 
> only three 
> > days.  This is an absurdly short time, given that it is the 
> start of 
> > the summer vacation period in the northern hemisphere.  It is quite 
> > possible that many participants will not even see her email until 
> > after the deadline expires.
> > 
> > Finally, if there is no consensus on the issue, the chairs are 
> > expressing an engineering opinion and should be required to justify 
> > that opinion just as any other member of the working group. 
>  I don't 
> > believe that the IETF anoints the chairs of any working group as 
> > expert and able to make technical decisions for the working group.
> > 
> > I would appreciate your thoughts, as the AD, and response on these 
> > items.
> > 
> > Best regards,
> >  -Bob
> > 
> > Bob O'Hara
> > 
>

---

From: "Mani, Mahalingam (Mani)" <[email-masked]>
Date: Tue, 20 Jun 2006 06:12:23 -0600

Dan,

The list will be prepared posted here (by June 21 5pm Pacific) prior to sending to the experts.

Regards,
-mani
-----Original Message-----
From: Romascanu, Dan (Dan) 
Sent: Friday, June 16, 2006 1:57 AM
To: capwap
Subject: Re: [Capwap] Process in CAPWAP

Thanks and Regards,

Dan

---

From: "Mani, Mahalingam (Mani)" <[email-masked]>
Date: Wed, 21 Jun 2006 18:13:32 -0600

[The posting has been delayed till around midnight tonight (same TZ)].

-mani
-----Original Message-----
From: Mani, Mahalingam (Mani) 
Sent: Tuesday, June 20, 2006 5:12 AM
To: Romascanu, Dan (Dan); capwap
Subject: Re: [Capwap] Process in CAPWAP

Dan,

Regards,
-mani
-----Original Message-----
From: Romascanu, Dan (Dan) 
Sent: Friday, June 16, 2006 1:57 AM
To: capwap
Subject: Re: [Capwap] Process in CAPWAP

Thanks and Regards,

Dan