Subject: [Capwap] Issue #5: Benefits of Using UDP-Lite?

From: Margaret Wasserman <[email-masked]>
Date: Wed, 18 Jul 2007 10:43:46 -0400

Magnus Westerlund raised some questions regarding why we are using  
UDP-Lite in
order to turn off UDP checksums on most of the CAPWAP packet.  These  
questions
need to be discussed and answered by the WG.

You have had the discussion. Can someone please recap what arguments  
was used to
indicate that you would have better performance by not using the UDP  
checksum
over the payload? I was under the impression that unless your capwap  
boxes are
running very special hardware the UDP checksuming was done in  
hardware on the
network controler. Thus there is no cost for doing the checksum. And  
it would
save the DTLS processing in the case the packet has a bad checksum.

I am trying to understand your argumentation here, not necessarily  
change it.

The issue was also raised that the reason to use UDP-Lite is for  
protocols that
actually want to receive partial/corrupted packets.  That doesn't  
seem to apply
to CAPWAP, so what is our reason for using it?
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Abhijit Choudhury (achoudhu)" <[email-masked]>
Date: Wed, 18 Jul 2007 08:53:00 -0700

Included below is the original email arguing the need for
UDP-lite. Note that in CAPWAP, IP packets are
encapsulated in UDP or UDP-lite in WTPs and ACs, and not at
the source or sink of the data.  TSo, adding the
mandatory requirement for UDP checksum (as needed in IPv6)
imposes an additional burden on the hardware. Note that
for IPv4, typically the UDP checksum will be set to 0.

Thanks,
Abhijit
 
	-----Original Message-----
	From: David Melman [mailto:[email-masked]] 
	Sent: Tuesday, March 13, 2007 1:29 AM
	To: [email-masked]
	Subject: [Capwap] UDP-Lite as optional transport for CAPWAP

	Hi.

	In supporting CAPWAP-over-UDP-IPv6, I'm concerned about the cost
& performance overhead 
	of supporting a full UDP checksum over the entire UDP payload.

	While UDP over IPv4 allows the UDP checksum to be set 0
indicating the 
	UDP checksum is not calculated, UDP over IPv6 requires the UDP
header to 
	contain a checksum which covers the UDP pseudo header and the
UDP payload 
	(per RFC 2460). Calculating the checksum over the full data
payload adds 
	significant cost and performance overhead, both to the AC switch
(typically 
	implemented in hardware) and the WTP (typically implemented in
software).

	I propose to allow CAPWAP over UDP-Lite (RFC 3828) as an
optional transport 
	to UDP, particularly for the CAPWAP data channel which would be
impacted 
	the most by the requirement to calculate the UDP checksum over
the entire payload. 

	The UDP-Lite header is identical to the UDP header, except for
the UDP Length 
	field which is replaced with the Checksum Coverage field. The
Checksum Coverage 
	field indicates the number of octets, counting from the first
octet of the 
	UDP-Lite header, that are covered by the checksum. To minimize
the performance 
	impact, the UDP Checksum Coverage is set to the minimal value of
8, which limits 
	the UDP checksum to cover just the UDP pseudo-header, excluding
the UDP payload.  
	(Note that the UDP Length field is not required, as it can
easily be calculated 
	by subtracting 8 (UDP-Lite header length) from the IP Length
field.)

	UDP-Lite (RFC2460) is widely available in IPv6 stacks and in all
the common 
	operating systems we surveyed.

	I believe this change would have minimal impact to the CAPWAP
protocol and 
	has significant value to both hardware and software
implementations.

	Regards,
	David
 
	__________________________________________

	David Melman
	Architecture group - Marvell
	Email - [email-masked]

-----Original Message-----
From: Margaret Wasserman [mailto:[email-masked]] 
Sent: Wednesday, July 18, 2007 7:44 AM
To: capwap
Subject: [Capwap] Issue #5: Benefits of Using UDP-Lite?

Magnus Westerlund raised some questions regarding why we are using
UDP-Lite in order to turn off UDP checksums on most of the CAPWAP
packet.  These questions need to be discussed and answered by the WG.

You have had the discussion. Can someone please recap what arguments was
used to indicate that you would have better performance by not using the
UDP checksum over the payload? I was under the impression that unless
your capwap boxes are running very special hardware the UDP checksuming
was done in hardware on the network controler. Thus there is no cost for
doing the checksum. And it would save the DTLS processing in the case
the packet has a bad checksum.

The issue was also raised that the reason to use UDP-Lite is for
protocols that actually want to receive partial/corrupted packets.  That
doesn't seem to apply to CAPWAP, so what is our reason for using it?
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap