Subject: [Capwap] AD review ofdraft-ietf-capwap-protocol-binding-ieee80211-06 T10

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 27 Jun 2008 05:24:07 -0700

The AD Review comment is:

   T10. Section 6.23 - Country Code

      Special
      attention is required with use of this field, as implementations
      which take action based on this field could violate regulatory
      requirements.  Some regulatory bodies do permit configuration of
      the country code under certain restrictions, such as the FCC, when
      WTPs are certified as Software Defined Radios.

   I do not know what can be done with this text from a technical
(implementation 
   or processing) point of view. What 'special attention'
   means? What can an implementation know about regulatory restrictions?
   And what 'certain restrictions' mean? I suggest to reconsider if this
text is 
   needed and if it is clarify if there are any technical impacts or
move it to a 
   separate note or subsection.

Well, I'm not quite sure how to handle your comment. The issue here is
that some regulatory bodies, where WTP vendors will need to go to in
order to certify their radios, do not allow the "country code" to be
configurable. In these regulatory domains, the country code, and
therefore the channels, transmit power and other parameters must be
fixed and not modified by the end user. I also struggle with your
comment on moving this to another section in the document as I believe
it would end up getting lost. What if I were to modify the text to read
instead:

<text>
   Some regulatory domains do
   not allow WTPs to have user configurable country codes, and require
   that it be a fixed value during the manufacturing process. Therefore,
   WTP vendors that wish to allow for the configuration of this field
will
   need to validate this behavior during its radio certification
process.
   Other WTP vendors may simply wish to treat this WTP configuration
   parameter as read-only.
</text>

PatC
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 29 Jun 2008 12:53:39 +0200

Thanks, I think that the proposed text clarifies the issue. 

Dan

> -----Original Message-----
> From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
> Sent: Friday, June 27, 2008 3:24 PM
> To: [email-masked]
> Subject: [Capwap] AD 
> reviewofdraft-ietf-capwap-protocol-binding-ieee80211-06 T10
> 
>    I do not know what can be done with this text from a 
> technical (implementation 
>    And what 'certain restrictions' mean? I suggest to 
> reconsider if this text is 
>    needed and if it is clarify if there are any technical 
> impacts or move it to a 
> Well, I'm not quite sure how to handle your comment. The 
> issue here is that some regulatory bodies, where WTP vendors 
> will need to go to in order to certify their radios, do not 
> allow the "country code" to be configurable. In these 
> regulatory domains, the country code, and therefore the 
> channels, transmit power and other parameters must be fixed 
> and not modified by the end user. I also struggle with your 
> comment on moving this to another section in the document as 
> I believe it would end up getting lost. What if I were to 
> modify the text to read
> instead:
> 
> <text>
>    WTP vendors that wish to allow for the configuration of 
> this field will
>    need to validate this behavior during its radio 
> certification process.