Subject: [Capwap] CAPWAP IESG Review Comment T28

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 16 Jun 2008 11:01:43 -0700

All,
 
Here is the IESG Review Comment:

   T28 - Section 4.6.39 - I do not understand the semantics of the value
field - what 
   does 'The value associated with the vendor specific element' mean? Is
this one byte 
   as the diagram shows, or variable length as indicated by the fact
that the length 
   of the message shows >=7? If variable length what is the max length?

Here is my proposed changes, and note tha I picked 2048 octets as the
maximum length for the vendor specific info:

<text>
4.6.39.  Vendor Specific Payload
[...]

   Data:   Variable length vendor specific information, whose
           contents and format are proprietary and understood
           based on the Element ID field. This field MUST NOT
           exceed 2048 octets.
</text>

PatC
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 16 Jun 2008 20:06:37 +0200

OK with me. 

(although I am not crazy about fields that carry vendor specific
information in standards because they create no multivendor
interoperability)

Dan

> -----Original Message-----
> From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
> Sent: Monday, June 16, 2008 9:02 PM
> To: [email-masked]
> Subject: [Capwap] CAPWAP IESG Review Comment T28
> 
> All,
>  
>    T28 - Section 4.6.39 - I do not understand the semantics 
> of the value field - what 
>    does 'The value associated with the vendor specific 
> element' mean? Is this one byte 
>    as the diagram shows, or variable length as indicated by 
> the fact that the length 
> Here is my proposed changes, and note tha I picked 2048 
> octets as the maximum length for the vendor specific info:
> 
> <text>

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 18 Jun 2008 18:13:39 -0700

Ok, closing issue 69.

PatC 

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Monday, June 16, 2008 11:07 AM
To: Pat Calhoun (pacalhou); [email-masked]
Subject: RE: [Capwap] CAPWAP IESG Review Comment T28

OK with me. 

Dan

>    T28 - Section 4.6.39 - I do not understand the semantics of the 
> value field - what
>    does 'The value associated with the vendor specific element' mean? 
> Is this one byte