Subject: [Capwap] AD review ofdraft-ietf-capwap-protocol-binding-ieee80211-06 E10

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 27 Jun 2008 06:36:46 -0700

The AD Review Comment is:

   E10. Section 6.14 - IEEE 802.1P tag is three bits - why is the 802.1P

   Precedence Tag two octets? And why is it called Precedence Tag and
not 
   Priority Tag (same comment for 6.20, 6.22)?

I want to note first off that while I agree, it does change the packet
format,
so this is the first change that actually causes a backward
compatibility
issue, but in this case I believe it is necessary.

<text>
6.14.  IEEE 802.11 Station QoS Profile
[...]
        0                   1                   2                   3
        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |                           MAC Address                         |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |          MAC Address          |      802.1P Priority Tag      |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |802.1P Priority Tag
       +-+-+-+-+-+-+-+
[...]
   802.1P Priority Tag:   The maximum 802.1P priority value that the WTP
      will allow in the TID field in the extended 802.11e QOS Data
      header.

6.20.  IEEE 802.11 Update Station QoS
[...]
      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |   Radio ID    |                  MAC Address                  |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |          MAC Address          |   DSCP Tag    |  802.1P Tag   |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |          802.1P Tag           |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
[...]
   802.1P Tag:   The 802.1P priority value to use if packets are to be
      IEEE 802.1P tagged.

6.22.  IEEE 802.11 WTP Quality of Service
[...]
      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |  Queue Depth  |             CWMin             |     CWMax     |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |     CWMax     |     AIFS      |           Dot1P Tag           |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |   Dot1P Tag   |    DSCP Tag   |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
[...]
   Dot1P Tag:   The 802.1P priority value to use if packets are to be
      802.1P tagged.
</text>

PatC
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: [email-masked]
Date: Fri, 27 Jun 2008 07:14:02 -0700 (PDT)

That should be "IEEE 802.1p", the lower-case suffix indicating that it is
not a free-standing standard but rather it modifies a base standard
(802.1D in this case).

Jeff

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 29 Jun 2008 12:14:28 +0200

I believe this is correct. 

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Friday, June 27, 2008 5:14 PM
> To: Pat Calhoun (pacalhou)
> Cc: [email-masked]
> Subject: Re: [Capwap] AD review 
> ofdraft-ietf-capwap-protocol-binding-ieee80211-06 E10
> 
> That should be "IEEE 802.1p", the lower-case suffix 
> indicating that it is not a free-standing standard but rather 
> it modifies a base standard (802.1D in this case).
> 
> Jeff
> 
> > format, so this is the first change that actually causes a backward 
> > compatibility issue, but in this case I believe it is necessary.
> >
> > <text>
> > 6.14.  IEEE 802.11 Station QoS Profile [...]
> >         0                   1                   2           
>         3
> >        |                           MAC Address              
>            |
> >      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ [...]
> > 6.22.  IEEE 802.11 WTP Quality of Service [...]
> >       0                   1                   2                   3
> >      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ [...]

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 29 Jun 2008 12:24:28 +0200

I am afraid that I do not understand  the change that is suggested here.

My comment was 
1. The priority tag is 3 bits (BITS), so what two octets? 
2.  the name used in the IEEE 802.1 specification is priority and not
precedence. 

Your proposed solution seems now to allocate three octets (BYTES) which
is wrong. 

Also, as per another comment, IEEE 802.1p should be used rather than
IEEE 802.1P. 

Dan

> From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
> Sent: Friday, June 27, 2008 4:37 PM
> To: [email-masked]
> Subject: [Capwap] AD 
> reviewofdraft-ietf-capwap-protocol-binding-ieee80211-06 E10
> 
>    Precedence Tag two octets? And why is it called Precedence 
> Tag and not 
> I want to note first off that while I agree, it does change 
> the packet format, so this is the first change that actually 
> causes a backward compatibility issue, but in this case I 
> believe it is necessary.
> 
> <text>

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Sun, 29 Jun 2008 09:27:46 -0700

I am closing the issue, with the change to lowercase p.

PatC 

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Sunday, June 29, 2008 3:14 AM
To: [email-masked]; Pat Calhoun (pacalhou)
Cc: [email-masked]
Subject: Re: [Capwap] AD

Dan

> That should be "IEEE 802.1p", the lower-case suffix indicating that it

> is not a free-standing standard but rather it modifies a base standard

> the packet
> > 6.20.  IEEE 802.11 Update Station QoS [...]
> >       0                   1                   2                   3

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Sun, 29 Jun 2008 09:32:03 -0700

Ah, my bad. Well, I would much prefer to put the fields back to their
original size, ensuring that we do not break any compatibility issues,
and only state that the least three significant bits are used.

And yes to the change to priority and the lower case.

Ok?

PatC 

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Sunday, June 29, 2008 3:24 AM
To: Pat Calhoun (pacalhou); [email-masked]
Subject: RE: [Capwap] AD

My comment was

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 29 Jun 2008 18:33:33 +0200

OK with me. 

Dan

> Sent: Sunday, June 29, 2008 7:32 PM
> To: Romascanu, Dan (Dan); [email-masked]
> Subject: RE: [Capwap] AD 
> Ah, my bad. Well, I would much prefer to put the fields back 
> to their original size, ensuring that we do not break any 
> compatibility issues, and only state that the least three 
> significant bits are used.
> 
> 2.  the name used in the IEEE 802.1 specification is priority 
> and not precedence. 
> 
> Your proposed solution seems now to allocate three octets 
> (BYTES) which is wrong. 
> 
> Also, as per another comment, IEEE 802.1p should be used 
> rather than IEEE 802.1P. 
> 
> Dan
> 
>