Subject: [Cbor] cbor.me availability

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Jan 2018 21:18:17 +0100

For those who are wondering about the availability of cbor.me: we have had a few outages already this year.

It turns out that the haphazard diagnostic notation parser I threw together in the cbor-diag gem can’t quite handle multi-megabyte instances of diagnostic notation.  I need to debug this; while I do so please don’t send two-to-nine (or larger :-) megabyte diagnostic notation files in its direction…  Thank you.

(You can always install cbor-diag locally if the availability problem bothers you:

	gem install cbor-diag

… and then convert for example with

	diag2cbor.rb foo.diag >foo.cbor

but this still has the same performance bug…)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 18 Jan 2018 00:10:15 +0100

On Jan 17, 2018, at 21:18, Carsten Bormann <[email-masked]> wrote:
> 
> 
> It turns out that the haphazard diagnostic notation parser I threw together in the cbor-diag gem can’t quite handle multi-megabyte instances of diagnostic notation.  I need to debug this

I did.  💫😵

cbor-diag 0.5.2 no longer has quadratic behavior (blush).
I fixed a bug with handling \uNNNN in the process.
(None of these were bugs in my code, but I was able to find workarounds.)

You may want to do a

	gem update cbor-diag

to get those fixes locally.

(The diagnostic notation parser in cbor-diag still isn’t a performance champion: cbor.me chews about 10 s on every megabyte, so please do process those multi-megabyte files locally.  But at least sending one to cbor.me doesn’t result in a complete DoS any more.)

Grüße, Carsten