Subject: [Cbor] I-D Action: draft-ietf-cbor-array-tags-04.txt

From: [email-masked]
Date: Wed, 22 May 2019 07:34:26 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Concise Binary Object Representation Maintenance and Extensions WG of the IETF.

        Title           : Concise Binary Object Representation (CBOR) Tags for Typed Arrays
        Author          : Carsten Bormann
	Filename        : draft-ietf-cbor-array-tags-04.txt
	Pages           : 15
	Date            : 2019-05-22

Abstract:
   The Concise Binary Object Representation (CBOR, RFC 7049) is a data
   format whose design goals include the possibility of extremely small
   code size, fairly small message size, and extensibility without the
   need for version negotiation.

   The present document makes use of this extensibility to define a
   number of CBOR tags for typed arrays of numeric data, as well as two
   additional tags for multi-dimensional and homogeneous arrays.  It is
   intended as the reference document for the IANA registration of the
   CBOR tags defined.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-cbor-array-tags/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-cbor-array-tags-04
https://datatracker.ietf.org/doc/html/draft-ietf-cbor-array-tags-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-cbor-array-tags-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 22 May 2019 16:38:37 +0200

This is the version that should be addressing all WGLC comments.
Please check whether yours are properly handled.

I had a bit of a problem with issue 7, https://github.com/cbor-wg/array-tags/issues/7
because I believe the current text already says what needs to be said.
Jeffrey: I would welcome some hints how that can be improved.

See (hear) you all in 22 minutes…

Grüße, Carsten

> On May 22, 2019, at 16:34, [email-masked] wrote:
> 
> 
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor
>

---

From: Jim Schaad <[email-masked]>
Date: Thu, 23 May 2019 14:23:43 -0700

Carsten,

I am not sure why the URL for the [TypedArray] reference got lost.  It was there in the previous version.

I am happy with the way all of my issues have been addressed.

Jim

> -----Original Message-----
> From: CBOR <[email-masked]> On Behalf Of Carsten Bormann
> Sent: Wednesday, May 22, 2019 7:39 AM
> To: [email-masked]
> Subject: Re: [Cbor] I-D Action: draft-ietf-cbor-array-tags-04.txt
> 
> > This draft is a work item of the Concise Binary Object Representation
> Maintenance and Extensions WG of the IETF.
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 23 May 2019 23:32:00 +0200

Hi Jim,

On May 23, 2019, at 23:23, Jim Schaad <[email-masked]> wrote:
> 
> I am not sure why the URL for the [TypedArray] reference got lost.  

That URL is now a dead link (actually redirects to ES6 spec, which we already reference under a different anchor).

This is one of the references that should be in a third section of the References chapter (after “normative” and “informative”), which should best be called “historic” — you don’t need to read it, but it properly identifies the origin of some work.
(I didn’t check archive.org, BTW, but I’m not sure that we want to use that here.)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 23 May 2019 23:49:38 +0200

> (I didn’t check archive.org, BTW, but I’m not sure that we want to use that here.)

https://web.archive.org/web/20160329172607/https://www.khronos.org/registry/typedarray/specs/1.0/

Should we put that in?

Grüße, Carsten

---

From: Jim Schaad <[email-masked]>
Date: Thu, 23 May 2019 15:36:13 -0700

No I don't see any reason to reference that.  If it is gone it is gone.  It was just an oddity.  You might stick a note into the comments section for the RFC Editor though.

Jim

> From: Carsten Bormann <[email-masked]>
> Sent: Thursday, May 23, 2019 2:50 PM
> To: Jim Schaad <[email-masked]>
> Cc: [email-masked]