Subject: [Cbor] Correcting an error in draft-ietf-cbor-cddl-08

From: Carsten Bormann <[email-masked]>
Date: Thu, 23 May 2019 22:57:33 +0200

Dear RFC editor,

a technical error was caught in draft-ietf-cbor-cddl-08, which is currently at RFC-EDITOR stage.

Please see the thread starting with
  https://mailarchive.ietf.org/arch/msg/cbor/sg5dpdCjaPw7mtohdAWCWgnQdMk
for reference.

We also discussed this at the last virtual interim meeting of the CBOR working group, and we believe the following change to Appendix B is a correct and complete fix:

OLD:
     hexfloat = "0x" 1*HEXDIG ["." 1*HEXDIG] "p" exponent
NEW:
     hexfloat = ["-"] "0x" 1*HEXDIG ["." 1*HEXDIG] "p" exponent

At the meeting, we thought we should make you aware now, instead of waiting for AUTH48.

(The meeting minutes of the virtual interim have not yet been posted to the proceedings at
https://datatracker.ietf.org/doc/agenda-interim-2019-cbor-07-sessa/
but are captured in
https://etherpad.tools.ietf.org/p/notes-interim-220519-cbor
for reference.)

Grüße, Carsten

---

From: Lynne Bartholomew <[email-masked]>
Date: Thu, 23 May 2019 15:20:45 -0700

Dear Carsten,

Thank you for sending us this update.  We have corrected the "hexfloat =" line in this document (added the "["-"]" item).

We appreciate your letting us know now, rather than waiting for AUTH48.

Thanks for the pointers to the discussions as well!

RFC Editor/lb

> On May 23, 2019, at 1:57 PM, Carsten Bormann <[email-masked]> wrote:
> 
> Dear RFC editor,
>