Subject: [Cbor] Éric Vyncke's No Objection on draft-ietf-cbor-date-tag-06: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Mon, 07 Sep 2020 23:53:31 -0700

Éric Vyncke has entered the following ballot position for
draft-ietf-cbor-date-tag-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-cbor-date-tag/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work put into this document.

Thank you Samita Chakrabarti for your IoT directorate review at
https://datatracker.ietf.org/doc/review-ietf-cbor-date-tag-06-iotdir-telechat-chakrabarti-2020-08-31/

Please find below some nits.

I hope that this helps to improve the document,

Regards,

-éric

PS: your example in the security considerations applied to my own birthday in
Japan then in Canada ;-) and this was my only international date line crossing.
Good planing of mine ;-)

== NITS ==

-- Section 1 and IANA section --
In the text "The tagged integer is an unsigned or negative value", should it
rather be "The tagged integer is a positive or negative value" ?

---

From: Barry Leiba <[email-masked]>
Date: Tue, 8 Sep 2020 09:41:09 -0400

"Unsigned" and "negative" are the names two CBOR data types, and
that's what the text refers to.  It does sound odd when you consider
them as English terms, but they are meant as specific CBOR terms.

Barry

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 8 Sep 2020 13:54:05 +0000

It sounds odd indeed but if there is a sensible explanation, we are all set.

Thank you Barry for the added piece of information

-éric

-----Original Message-----
From: iesg <[email-masked]> on behalf of Barry Leiba <[email-masked]>
Date: Tuesday, 8 September 2020 at 15:41
To: Eric Vyncke <[email-masked]>
Cc: Samita Chakrabarti <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, Francesca Palombini <[email-masked]>
Subject: Re: Éric Vyncke's No Objection on draft-ietf-cbor-date-tag-06: (with COMMENT)

    Barry

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 9 Sep 2020 13:59:02 +0000

OTOH while reading draft-ietf-cbor-7049bis-14, the major type 0 is indicated as "integer" and not as "unsigned"

__

-éric

-----Original Message-----
From: Eric Vyncke <[email-masked]>
Date: Tuesday, 8 September 2020 at 15:54
To: Barry Leiba <[email-masked]>
Cc: Samita Chakrabarti <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, Francesca Palombini <[email-masked]>
Subject: Re: Éric Vyncke's No Objection on draft-ietf-cbor-date-tag-06: (with COMMENT)

    -éric

    -----Original Message-----
    From: iesg <[email-masked]> on behalf of Barry Leiba <[email-masked]>
    Date: Tuesday, 8 September 2020 at 15:41
    To: Eric Vyncke <[email-masked]>
    Cc: Samita Chakrabarti <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, Francesca Palombini <[email-masked]>
    Subject: Re: Éric Vyncke's No Objection on draft-ietf-cbor-date-tag-06: (with COMMENT)

        Barry

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 9 Sep 2020 20:32:05 +0200

On 2020-09-09, at 15:59, Eric Vyncke (evyncke) <evyncke=[email-masked]> wrote:
> 
> OTOH while reading draft-ietf-cbor-7049bis-14, the major type 0 is indicated as "integer" and not as “unsigned"

(We already have one comment that suggests this change to us:

Major type 0:
: an integer in the range 0..2**64-1 inclusive.  The value of the

Major type 0:
: an unsigned integer in the range 0..2**64-1 inclusive.  The value of the

in the introductory text for the major types, § 3.1.  
And I think we should go for that.)

Grüße, Carsten

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 9 Sep 2020 18:50:37 +0000

Carsten

This would indeed be more consistent

Regards

-éric

-----Original Message-----
From: Carsten Bormann <[email-masked]>
Date: Wednesday, 9 September 2020 at 20:32
To: Eric Vyncke <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, The IESG <[email-masked]>, Paul Hoffman <[email-masked]>
Subject: Re: [Cbor]  Éric Vyncke's No Objection on draft-ietf-cbor-date-tag-06: (with COMMENT)

    Major type 0:

    Major type 0:

    Grüße, Carsten

---

From: Barry Leiba <[email-masked]>
Date: Wed, 9 Sep 2020 17:10:25 -0400

> OTOH while reading draft-ietf-cbor-7049bis-14, the major type 0 is indicated as "integer" and not as "unsigned"

Iiiiinteresting, and something I didn't notice; thanks for picking it up.

Indeed, 7049 says this:
   Major type 0:  an unsigned integer.
   Major type 1:  a negative integer.

While 7049bis says this:
   Major type 0:  an integer in the range 0..2**64-1 inclusive.
   Major type 1:  a negative integer in the range -2**64..-1 inclusive.

So, CBOR folks, give that a number of people have already tripped over
the "unsigned or negative" wording, and that we've been defending it
based on "unsigned" being what it's called in CBOR, is it time for us
to align with 7049bis instead, and change the terms?

Barry

---

From: Barry Leiba <[email-masked]>
Date: Wed, 9 Sep 2020 17:11:56 -0400

Ah, never mind.  (Note to self: read the whole thread first.)
Carsten reports that it's 7049bis that's slated to change.

Barry