Subject: [Cbor] Robert Wilton's No Objection on draft-ietf-cbor-date-tag-06: (with COMMENT)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Thu, 03 Sep 2020 02:03:51 -0700

Robert Wilton has entered the following ballot position for
draft-ietf-cbor-date-tag-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-cbor-date-tag/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Hi,

Thanks for these simple CBOR date definitions.

I have a couple of minor suggestions related to the use of negative integers. 
Feel free to take them or leave them:

The abstract states:

It also defines a CBOR tag for days since the date
   1970-01-01 in the Gregorian calendar for applications needing a
   numeric date representation without a time.

Given that a negative value is allowed, would it be better if this was written
as "... for the count of days relative to the date 1970-01-01" rather than "for
days since the date 1970-01-01"?  Or alternatively, possibly "since" could be
changed to "before or since".

1.  Introduction

I find the wording of "unsigned or negative" to be slightly jarring, presumably
written this way to include 0 in the set of allowed values.

  This specification also defines a CBOR tag for an integer
   representing a date without a time.  The tagged integer is an
   unsigned or negative value indicating the number of days since the
   Gregorian calendar date 1970-01-01.

The document might be more clear if it was written something like:

   This specification also defines a CBOR tag for an integer
   representing a date without a time.  The tagged integer, which
   may also take a negative value or 0, indicates the number of days
   since the Gregorian calendar date 1970-01-01.

If you decide to change this then I would also recommend changing this in
section 2.1, e.g., to something like:
   o  Tag: 100 (ASCII 'd')
   o  Data Item: Integer.  Positive, negative, or 0.
   o  Semantics: Number of days since the epoch date 1970-01-01
   o  Reference: [[ this specification ]]

Regards,
Rob

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 3 Sep 2020 11:06:24 +0200

> written this way to include 0 in the set of allowed values.

Well, these are the two component major types we have in CBOR (0 for unsigned, 1 for negative) that together are used to span the integers, so I think we should stick with the established terminology.

Grüße, Carsten

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 3 Sep 2020 09:53:17 +0000

Hi Carsten,

> -----Original Message-----
> From: Carsten Bormann <[email-masked]>
> Sent: 03 September 2020 10:06
> To: Rob Wilton (rwilton) <[email-masked]>
> Cc: The IESG <[email-masked]>; [email-masked];
> [email-masked]; CBOR Working Group <[email-masked]>;
> [email-masked]
> Subject: Re: [Cbor] Robert Wilton's No Objection on draft-ietf-cbor-date-
> tag-06: (with COMMENT)
> 
> Well, these are the two component major types we have in CBOR (0 for
> unsigned, 1 for negative) that together are used to span the integers, so
> I think we should stick with the established terminology.
[RW]

Personally, at least for the introduction, I think that seems to be conflating the date model (signed integer) with the encoding.

Certainly, I think that the more prevalent and established terminology for integers is that they can be positive, negative, or 0 rather than "unsigned and negative".

But these are just comments.  The authors/WG are free to do with them as they wish ;-)

On a side point, not directly related to this draft, I note that in draft-ietf-cbor-7049bis, section 3.1 Major Types has:

"Major type 0:  an integer in the range ..."

Would it make sense to change that to "an unsigned integer in the range ..." (given that major type 1 is "a negative integer ...")?

Regards,
Rob

---

From: Mike Jones <[email-masked]>
Date: Thu, 10 Sep 2020 13:33:11 +0000

On the "unsigned or negative" comment, I followed what Carsten Bormann told me was prevailing CBOR terminology usage.  But if the IESG wants me to change the text in the introduction to "positive, zero, or negative", I'm open to that as well.

				Cheers,
				-- Mike

-----Original Message-----
From: Rob Wilton (rwilton) <[email-masked]> 
Sent: Thursday, September 3, 2020 2:53 AM
To: Carsten Bormann <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; [email-masked]; CBOR Working Group <[email-masked]>; [email-masked]
Subject: RE: [Cbor] Robert Wilton's No Objection on draft-ietf-cbor-date-tag-06: (with COMMENT)

Hi Carsten,

> On 2020-09-03, at 11:03, Robert Wilton via Datatracker 
> <[email-masked]>
> wrote:
> >
> unsigned, 1 for negative) that together are used to span the integers, 
> so I think we should stick with the established terminology.
[RW]

Regards,
Rob

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 10 Sep 2020 15:59:17 +0200

> On the "unsigned or negative" comment, I followed what Carsten Bormann told me was prevailing CBOR terminology usage.  But if the IESG wants me to change the text in the introduction to "positive,…

… and I would be strongly opposed.

Grüße, Carsten

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 10 Sep 2020 15:23:32 +0000

Hi Mike,

Given that Carsten feels strongly on this and I don't, leaving it is okay.

Regards,
Rob

> From: Mike Jones <[email-masked]>
> Sent: 10 September 2020 14:33
> To: Rob Wilton (rwilton) <[email-masked]>; Carsten Bormann
> <[email-masked]>; [email-masked]
> On the "unsigned or negative" comment, I followed what Carsten Bormann
> told me was prevailing CBOR terminology usage.  But if the IESG wants me
> to change the text in the introduction to "positive, zero, or negative",
> I'm open to that as well.
> 
> 				Cheers,
> 				-- Mike
> 
> Personally, at least for the introduction, I think that seems to be
> conflating the date model (signed integer) with the encoding.
> 
> Certainly, I think that the more prevalent and established terminology for
> integers is that they can be positive, negative, or 0 rather than
> "unsigned and negative".
> 
> On a side point, not directly related to this draft, I note that in draft-
> ietf-cbor-7049bis, section 3.1 Major Types has:
> 
> Would it make sense to change that to "an unsigned integer in the range
> ..." (given that major type 1 is "a negative integer ...")?
> 
> Regards,
> Rob
> 
> 
> >
> > Grüße, Carsten