Subject: [Cbor] Meeting today

From: Francesca Palombini <[email-masked]>
Date: Wed, 13 Jan 2021 13:25:49 +0000

Hi all,

Reminder that we are scheduled to have the first CBOR interim of 2021 in 95 minutes! Meeting links below - or here: https://codimd.ietf.org/notes-ietf-interim-2021-cbor-01-cbor 

Talk to you soon,
Francesca

On 02/12/2020, 19:19, "CBOR on behalf of IESG Secretary" <[email-masked] on behalf of [email-masked]> wrote:

    The Concise Binary Object Representation Maintenance and Extensions (cbor) WG will hold
    a virtual interim meeting on 2021-01-13 from 16:00 to 17:00 Europe/Stockholm (15:00 to 16:00 UTC).

    Agenda:
    The interim will happen over Webex:

    Meeting link: https://ietf.webex.com/ietf/j.php?MTID=m3ed3d0309a5f216c8a4d8463130b07cb 
    Meeting number (access code): 178 745 7694
    Meeting password: VDkAMXjG443

    Preliminary agenda:

    - WG documents status and issues
    - CBOR use in other SDOs
    - AOB

    Information about remote participation:
    https://ietf.webex.com/ietf/j.php?MTID=m3ed3d0309a5f216c8a4d8463130b07cb

    _______________________________________________
    CBOR mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/cbor

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 13 Jan 2021 15:36:06 +0100

> Reminder that we are scheduled to have the first CBOR interim of 2021 in 95 minutes! Meeting links below - or here: https://codimd.ietf.org/notes-ietf-interim-2021-cbor-01-cbor 

Wow. It seems the IETF interim meeting calendar function is broken, so I didn’t see this coming up…  Will be around, but totally unprepared.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 13 Jan 2021 15:58:58 +0100

Among other things, I was planning to put this proposal

https://docs.google.com/document/d/16aiDEBhJj3kipj_7PVppEhxAr5E6QhQreN61eCxvBjU

into draft-bormann-notable-tags and resubmit (the draft is currently in expired state).

Please have a quick look.
Note the relation to the sdfChoice discussion over in ASDF; this is one way to have an sdfChoice-like discriminated union.  Here, the compiler would call the shots on assigning numbers.

Grüße, Carsten

> On 2021-01-13, at 15:36, Carsten Bormann <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 13 Jan 2021 17:08:41 +0100

Re draft-ietf-cbor-cddl-control, I wanted to mention that we do have indications that an implementation of the remaining controls in that draft is upcoming:

https://github.com/anweiss/cddl/pull/79#issuecomment-759540390

Grüße, Carsten