Subject: Re: [Cbor] [Editorial Errata Reported] RFC8610 (6526)

From: Carsten Bormann <[email-masked]>
Date: Sun, 11 Apr 2021 19:02:11 +0200

Hi Sean,

thank you for submitting this errata report.
Strangely, another backslash has been swallowed in the text that was mailed around below (it is correct at https://www.rfc-editor.org/errata/eid6526).

This report should be marked as verified, once it has been ascertained that the backslashes in the record survived.

(For those following along with the other errata report:
This one is about the appendix for CBOR EDN extended diagnostic notation, which has subtly different syntax from CDDL itself, and which is not defined in ABNF.)

Grüße, Carsten

> On 2021-04-11, at 18:02, RFC Errata System <[email-masked]> wrote:
> 
> The following errata report has been submitted for RFC8610,
> "Concise Data Definition Language (CDDL): A Notational Convention to Express Concise Binary Object Representation (CBOR) and JSON Data Structures".
> 
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid6526
> 
> --------------------------------------
> Type: Editorial
> Reported by: Sean Bartell <[email-masked]>
> 
> Section: G.2
> 
> Original Text
> -------------
>   The escaping rules of JSON strings are applied equivalently for
>   text-based byte strings, e.g., "\" stands for a single backslash and
>   "'" stands for a single quote.  Whitespace is included literally,
>   i.e., the previous section does not apply to text-based byte strings.
> 
> Corrected Text
> --------------
>   The escaping rules of JSON strings are applied equivalently for
>   text-based byte strings, e.g., "\" stands for a single backslash and
>   "\'" stands for a single quote.  Whitespace is included literally,
>   i.e., the previous section does not apply to text-based byte strings.
> 
> Notes
> -----
> "\" and "'" need a backslash to escape them.
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party  
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC8610 (draft-ietf-cbor-cddl-08)
> --------------------------------------
> Title               : Concise Data Definition Language (CDDL): A Notational Convention to Express Concise Binary Object Representation (CBOR) and JSON Data Structures
> Publication Date    : June 2019
> Author(s)           : H. Birkholz, C. Vigano, C. Bormann
> Category            : PROPOSED STANDARD
> Source              : Concise Binary Object Representation Maintenance and Extensions
> Area                : Applications and Real-Time
> Stream              : IETF
> Verifying Party     : IESG

---

From: RFC Errata System <[email-masked]>
Date: Sun, 11 Apr 2021 09:02:26 -0700 (PDT)

Section: G.2

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------