Subject: [Cbor] Reminder: bi-weekly CBOR conference call on 21 April

From: Barry Leiba <[email-masked]>
Date: Tue, 20 Apr 2021 12:03:11 -0400

Hi, all,

We'll have our regular bi-weekly CBOR conference call on Wednesday, 21
April, at 1600 UTC.  Various pointers are here:
https://datatracker.ietf.org/meeting/interim-2021-cbor-07/session/cbor

In particular, see the agenda here:
https://codimd.ietf.org/notes-ietf-interim-2021-cbor-07-cbor?view

Meeting link: https://ietf.webex.com/ietf/j.php?MTID=m3ed3d0309a5f216c8a4d8463130b07cb
Meeting number: 178 745 7694
Password: VDkAMXjG443

-- 
Barry

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 21 Apr 2021 14:00:40 +0200

Hi Barry,

> https://codimd.ietf.org/notes-ietf-interim-2021-cbor-07-cbor?view

I think we want to discuss the errata reports 6527 and 6543.
I have written text for those in 

https://www.ietf.org/archive/id/draft-bormann-cbor-cddl-freezer-07.html#name-clarifications

(Submitted a small editorial update today on the ABNF.)

We should check
* that we agree on the resolutions proposed;
* agree whether and how to handle this in the errata reporting process and/or somewhere else.

If the “clarifications” part of the freezer document starts to grow, this might take up a role similar to that of draft-ietf-rohc-rtp-impl-guide which ultimately became RFC 4815 [1] (except that we probably want to rev 8610 instead).

Grüße, Carsten

[1]: https://datatracker.ietf.org/doc/rfc4815/

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 21 Apr 2021 14:48:39 +0200

> https://codimd.ietf.org/notes-ietf-interim-2021-cbor-07-cbor?view

The other item of unfinished business we can close today may be the CBOR tags for alternatives/unions.
https://docs.google.com/document/d/16aiDEBhJj3kipj_7PVppEhxAr5E6QhQreN61eCxvBjU/edit

At the last meeting, I was tasked with asking the authors about the relationship to Optional data structures (Maybe etc.).
The authors answered that they see this as a separate item that is best handled separately, so that the currently discussed set of tags can be cleanly focused on the specific use case.
(I forget to ask whether I can forward the reply to this list, hence my paraphrasing.)
I tend to agree with this position.

Unless there is some additional input today, I think that the designated expert for cbor-tags (yours truly) can approve this request.

Grüße, Carsten