Subject: Comments on draft-ietf-ccamp-lmp-test-sonet-sdh-04.txt.

From: "Philip Crocker" <[email-masked]>
Date: Wed, 16 Feb 2005 12:01:38 -0000

Jonathan,

I have recently been looking in detail at draft-ietf-ccamp-test-sonet-sdh-04.txt, and have a question and a comment on the draft.  I'd really appreciate it if you could spare the time to look at both these points.

1)  Firstly the question.  In section 1 (the 4th paragraph), the text indicates that SONET / SDH extensions to link verification and link property correlation require both section 3 and section 4 (Trace Monitoring).  However, it seems to me that the extensions described in section 3 alone are enough to perform link verification and link property correlation for SONET / SDH links.  Specifically, though the TraceMonitor<xx> and TraceMismatch messages defined in section 4 can be used to perform an external verification of SONET / SDH links, it is not clear why these messages are necessary in addition to the LMP link verification procedure (as extended by section 3).  Could you please explain this?

2)  Secondly, I have a minor comment on section 4.  I understand from section 4.1.1 that a TraceMonitor message should contain a single <TRACE> object.  However, section 4.1.2 can be read to imply that a TraceMonitor message can contain more than one <TRACE> object.  Can I suggest the following replacement text for section 4.1.2?

	The TraceMonitorAck message (Message Type TBA by IANA) is used to acknowledge receipt of the TraceMonitor message and indicate that the TRACE object in the TraceMonitor message have been received and processed correctly (i.e. no Trace Mismatch).

Thanks,

Phil Crocker

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 17 Feb 2005 10:28:48 -0000

Phil,
How nice to hear from you.

> I have recently been looking in detail at draft-ietf-ccamp-test-sonet-sdh-04.txt, 
> and have a question and a comment on the draft.  I'd really appreciate it if
> you could spare the time to look at both these points.
>
> 1)  Firstly the question.  In section 1 (the 4th paragraph), the text
> indicates that SONET / SDH extensions to link verification and link 
> property correlation require both section 3 and section 4 (Trace 
> Monitoring).  However, it seems to me that the extensions described
> in section 3 alone are enough to perform link verification and link
> property correlation for SONET / SDH links.  Specifically, though 
> the TraceMonitor<xx> and TraceMismatch messages defined in section
> 4 can be used to perform an external verification of SONET / SDH 
> links, it is not clear why these messages are necessary in addition
> to the LMP link verification procedure (as extended by section 3). 
> Could you please explain this?

It is slightly unclear what you are asking.
Note that the Trace object is defined in section 4 and is required for J0, J1 and J2 Test procedures as decribed in section 3. Thus, both sections 3 and 4 are necessary for the new link verification procedures.

It is possible that you are baulking at "This requires a new trace monitoring function that is also discussed in this document." "Requires" may be slightly too strong.

> 2)  Secondly, I have a minor comment on section 4.  I understand from
> section 4.1.1 that a TraceMonitor message should contain a single 
> <TRACE> object.  However, section 4.1.2 can be read to imply that a
> TraceMonitor message can contain more than one <TRACE> object.  Can
> I suggest the following replacement text for section 4.1.2?
>
>   The TraceMonitorAck message (Message Type TBA by IANA) is used to
>   acknowledge receipt of the TraceMonitor message and indicate that
>   the TRACE object in the TraceMonitor message have been received 
>   and processed correctly (i.e. no Trace Mismatch).

There is absolutely nothing wrong with the existing text. "All of the TRACE Objects in the TraceMonitor message" is perfectly fine when there is only one such object allowed. Leaving the text as it is reduces any changes should the number of Test objects on a TraceMonitor ever be increased.

Cheers,
Adrian