Subject: lmp linkcorrelation error code

From: <[email-masked]>
Date: Tue, 22 Feb 2005 08:25:53 +0100 (CET)

Hi,

In draft-ietf-ccamp-lmp-10 section 4 about link corelation states that
a "LinkSummaryNack message MUST be transmitted, indicating which interface
mapping and/or which properties are not accepted"

In case of wrong interface mapping which error code should be encoded in
the linkSummaryNack?

Thanks
Fab

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 22 Feb 2005 08:21:11 -0000

Fab,

See section 13.15.

        0x01 =Unacceptable non-negotiable LINK_SUMMARY parameters.
        0x02 =Renegotiate LINK_SUMMARY parameters.

Cheers,
Adrian

---

From: <[email-masked]>
Date: Tue, 22 Feb 2005 10:44:48 +0100 (CET)

Thanks Adrian,

But which one 0x01 or 0x02? Both (seems a bit contradictory)?

Section 12.6.3 list the error case but I don't see which one corresponds to
a "wrong interface mapping".
TE Link object and datalink object are negotiable object and interface Ids
are inside those objects.
But I don't think we can considere interface (or TE link) Id as negotiable?

What do you think?

Thanks
Fab

The TE
> Fab,
>
> See section 13.15.
>
>        0x01 =Unacceptable non-negotiable LINK_SUMMARY parameters. 0x02
>        =Renegotiate LINK_SUMMARY parameters.
>
> Cheers,
> Adrian
>> In case of wrong interface mapping which error code should be encoded
>> in the linkSummaryNack?
>>
>> Thanks
>> Fab

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 22 Feb 2005 20:18:00 -0000

Fab,

Someone else with an implementation may care to comment (since our aim is
interoperable implementations).

Adrian