Subject: Next steps for GMPLS control of Ethernet

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 17 Jul 2006 19:24:34 +0100

Hi CCAMPers and GELSters,

In CCAMP this time we explained the discussions and agreements that the 
chairs had with the ADs with respect to the way forward for developing
GMPLS extensions and procedures for the control of Ethernet devices. 
This email is to clarify the explanation and to give a base reference for 
the procedures that we expect to be followed.

- Work on procedures and extensions to GMPLS for the control
  of Ethernet devices will be done in CCAMP.

- This work is already covered by the CCAMP charter...
      The CCAMP working group coordinates the work within the
      IETF defining a common control plane and a separate common
      measurement plane for physical path and core tunneling
      technologies of Internet and telecom service providers (ISPs
      and SPs)
  However, if necessary, and if work is forthcoming, we will consider
  adding a specific work item an milestones to the charter. Such a
  charter change is not gating on this work, but may be useful for
  clarity and exposure of the work outside of CCAMP.

- Data plane specification is out of scope for the IETF. It must not
  be discussed on the CCAMP list. It may be discussed on the
  GELS list.

- CCAMP will not work on the specification of GMPLS except for
  data planes that are already approved by an SDO with responsibility
  for the Ethernet data plane. It is expected that the primary SDO
  in this case is IEEE.

We expect that you would use the following steps in order.

1. Decide upon the data plane behavior you wish to control

2. Ensure that the data plane you wish to control is approved
and documented by an SDO with responsibility for Ethernet
(e.g. IEEE).
This may be a null op in the case of existing standards, but
might require you to do work in the other SDO for new
standards for profiles of existing standards.

3. Start protocol work in CCAMP with an explicit pointer
to the approved data plane. If you feel the need to explain
your data plane in your I-D, then there is probably something
wrong with the specification in the other SDO and you
should return to step 2.

4. When it is clear that protocol work is progressing,
Deborah and I will liaise with the other SDO to get their
blessing for using a control plane for the nominated data
plane.

Note that this procedure can apply to multiple data planes at the same
time or separately, but we expect that the protocol encoding 
extensions will be flexible to all data planes.

Hope this is clear,
Adrian and Deborah

---

From: "CHO, JAI HYUNG" <[email-masked]>
Date: Tue, 18 Jul 2006 05:55:00 +0900

This is great and fair decision to everybody. 
I welcome and support this decision. 

Thank you Adrian and Debora. 

Jaihyung 

Dr. Jaihyung Cho 
ETRI, Korea 
phone :       042) 860-5514 
oversea: +82-42-860-5514 
fax:         +82-42-861-5550 

-----?? ???----- 
?? ??: "Adrian Farrel" <[email-masked]> 
?? ??: 2006-07-18 ?? 3:24:34 
?? ??: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]> 
??: "Ross Callon" <[email-masked]>, "Dimitri Papadimitriou" <[email-masked]>, "Brungard, Deborah A, ALABS" <[email-masked]>, "[email-masked]" <[email-masked]>, "Loa Andersson" <[email-masked]> 
??: Next steps for GMPLS control of Ethernet 

Hope this is clear, 
Adrian and Deborah