Subject: Future of the GELS mailing list

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 11 Jul 2006 00:35:01 +0100

Hi,

We reached a sort-of decision in CCAMP today on the future of GELS. You can 
see this on the chairs slides at 
http://www3.ietf.org/proceedings/06jul/slides/ccamp-15.ppt#286,8,GELS?

One question remains.
Should the GELS mailing list continue or should all discussions move to the 
CCAMP list?

I am personally inclined to think that the separate list is a useful venue 
for discussions that might not be completely dedicated to GMPLS protocol 
issues. On the other hand, maybe the WG would like all discussions in the 
same place.

I would prefer that we stopped copying emails to both lists.

Opinions?
Adrian

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 10 Jul 2006 20:14:57 -0400

Adrian,

I would suggest shutting down the gels list.  That would guarantee that we
only see the messages once.

Cheers,
Andy

---

From: Monique Morrow <[email-masked]>
Date: Tue, 11 Jul 2006 05:34:33 -0400

Agree with shutting down the GELS list.

/m

---

From: [email-masked]
Date: Tue, 11 Jul 2006 14:16:39 +0200

i can have different interpretations on why people are asking to shutdown 
the GELS list (so let's try one that goes beyond mailing list duplication 
which is oversimplistic)

shutting down the list means that -de facto- agreement that this effort is 
committed and to be chartered as a control plane only work item @CCAMP 
with data plane "solutions" sitting outside IETF scope

is my interpretation correct ?

if yes - GELS mailing can be shut down -

if not - it means we don't have agreement to continue this work either 
within GELS, CCAMP or whatsover

let's have the real discussion.

Monique Morrow <[email-masked]>
Sent by: [email-masked]
11/07/2006 11:34
 
        To:     Adrian Farrel <[email-masked]>, <[email-masked]>
        cc:     <[email-masked]>
        Subject:        Re: Future of the GELS mailing list

/m

---

From: "Don Fedyk" <[email-masked]>
Date: Tue, 11 Jul 2006 09:27:04 -0400

I too would be leery to shut down the list until CCAMP agreed to take on
the work as a charter item. I support the initiative but at the right
time. 

We have agreed we don't define the IEEE data planes in the IETF.  But we
will need a venue to discuss the profile of the data plane(s).  A
separate list may be useful.     

Don   

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Tuesday, July 11, 2006 8:17 AM
> To: Adrian Farrel
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> i can have different interpretations on why people are asking 
> to shutdown the GELS list (so let's try one that goes beyond 
> mailing list duplication which is oversimplistic)
> 
> shutting down the list means that -de facto- agreement that 
> this effort is committed and to be chartered as a control 
> plane only work item @CCAMP with data plane "solutions" 
> sitting outside IETF scope
> 
> if not - it means we don't have agreement to continue this 
> work either within GELS, CCAMP or whatsover
> 
> > We reached a sort-of decision in CCAMP today on the future of GELS. 
> > You
> can
> > Should the GELS mailing list continue or should all 
> discussions move 
> > to
> the
> > CCAMP list?
> > 
> > for discussions that might not be completely dedicated to GMPLS 
> > protocol issues. On the other hand, maybe the WG would like all 
> > discussions in
> the
> > same place.
> >

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 11 Jul 2006 14:35:49 +0100

> We have agreed we don't define the IEEE data planes in
> the IETF.  But we will need a venue to discuss the profile
> of the data plane(s).  A separate list may be useful.

That was also my thinking, and I would prefer *that* discussion to not 
happen on the CCAMP list.

Adrian

---

From: [email-masked]
Date: Tue, 11 Jul 2006 15:44:06 +0200

adrian & don

> We have agreed we don't define the IEEE data planes in the IETF.

this is agreed before starting GELS (from last year)

the point is that we need a place to discuss data plane elements that are 
in scope of the control plane

thanks,
- dimitri.

"Adrian Farrel" <[email-masked]>
Sent by: [email-masked]
11/07/2006 15:35
Please respond to "Adrian Farrel"
 
        To:     "Don Fedyk" <[email-masked]>, Dimitri 
PAPADIMITRIOU/BE/ALCATEL@ALCATEL
        cc:     <[email-masked]>, <[email-masked]>
        Subject:        Re: Future of the GELS mailing list

Adrian

---

From: "Don Fedyk" <[email-masked]>
Date: Tue, 11 Jul 2006 09:56:16 -0400

Hi Dimitri
> From: [email-masked] 
> 
> adrian & don
> 

I was just reinforcing the point about what we profile on the data
plane. 

> 
> the point is that we need a place to discuss data plane 
> elements that are in scope of the control plane

But many CCAMP people may not be interested in the details of that in
profile until it is finalized. 
> > We have agreed we don't define the IEEE data planes in the 
> IETF.  But 
> > we will need a venue to discuss the profile of the data 
> plane(s).  A 
> That was also my thinking, and I would prefer *that* 
> discussion to not happen on the CCAMP list.
> 
> Adrian 
> 
> 
> 
> 
> 
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 11 Jul 2006 10:00:48 -0400

Dimitri,

Since we've agreed that the data plane elements are out of the IETF's
charter, this discussion shouldn't occur on an IETF-sponsored list (such as
[email-masked]).  This should happen either on an IEEE-associated list,
or a private list not associated with the IETF.

Thanks,
Andy

On 7/11/06, [email-masked] <
[email-masked]> wrote:
> _______________________________________________
> gels mailing list
> [email-masked]
> https://rtg.ietf.org/mailman/listinfo/gels
>

---

From: "Don Fedyk" <[email-masked]>
Date: Tue, 11 Jul 2006 10:06:19 -0400

Andy
 
The goal is not to have discussion that are out of scope but the
messages will constantly be attempting to get the content into scope.  I
don't think this is the private discussions of the data plane but it is
the messages that are trying to define the profile we can talk about and
liaise to the IEEE.  The outcome of this will be shared with CCAMP. 
 
Don 

________________________________

	From: Andrew G. Malis [mailto:[email-masked]] 
	Sent: Tuesday, July 11, 2006 10:01 AM
	To: [email-masked]
	Cc: Adrian Farrel; [email-masked]; [email-masked];
[email-masked]; Fedyk, Don (BL60:1A00)
	Subject: Re: Future of the GELS mailing list

	Dimitri,
	 
	Since we've agreed that the data plane elements are out of the
IETF's charter, this discussion shouldn't occur on an IETF-sponsored
list (such as [email-masked]).  This should happen either on an
IEEE-associated list, or a private list not associated with the IETF. 
	 
	Thanks,
	Andy

	On 7/11/06, [email-masked]
<[email-masked] > wrote: 

		adrian & don
		
		> We have agreed we don't define the IEEE data planes in
the IETF.

elements that are
		
		thanks,
		- dimitri.

		"Adrian Farrel" < [email-masked]
<mailto:[email-masked]> >
		Sent by: [email-masked]
		11/07/2006 15:35
		Please respond to "Adrian Farrel"
		
		       To:     "Don Fedyk" < [email-masked]>,
Dimitri
		PAPADIMITRIOU/BE/ALCATEL@ALCATEL
		       cc:     <[email-masked]>, < [email-masked]
<mailto:[email-masked]> >
		       Subject:        Re: Future of the GELS mailing
list

discussion to not
		
		Adrian

---

From: [email-masked]
Date: Tue, 11 Jul 2006 16:14:51 +0200

andy 

gels list would not be there for discussing the data plane functionality - 
but discuss there specific topics that will be in scope of the control 
plane mechanisms e.g. signaling & routing to be discussed at CCAMP - once 
the item will be part of the charter (note: this is not yet explicitly the 
case afaik)

-d. 

"Andrew G. Malis" <[email-masked]>
Sent by: [email-masked]
11/07/2006 16:00
 
        To:     Dimitri PAPADIMITRIOU/BE/ALCATEL@ALCATEL
        cc:     "Adrian Farrel" <[email-masked]>, [email-masked], 
[email-masked], [email-masked], "Don Fedyk" 
<[email-masked]>
        Subject:        Re: Future of the GELS mailing list

Dimitri,
 
Since we've agreed that the data plane elements are out of the IETF's 
charter, this discussion shouldn't occur on an IETF-sponsored list (such 
as [email-masked]).  This should happen either on an IEEE-associated 
list, or a private list not associated with the IETF. 
 
Thanks,
Andy

On 7/11/06, [email-masked] <
[email-masked] > wrote: 
adrian & don

thanks,
- dimitri.

"Adrian Farrel" < [email-masked]>
Sent by: [email-masked]
11/07/2006 15:35
Please respond to "Adrian Farrel"

       To:     "Don Fedyk" < [email-masked]>, Dimitri
PAPADIMITRIOU/BE/ALCATEL@ALCATEL
       cc:     <[email-masked]>, < [email-masked]>
       Subject:        Re: Future of the GELS mailing list

Adrian

---

From: Loa Andersson <[email-masked]>
Date: Tue, 11 Jul 2006 16:26:46 +0200

> happen on the CCAMP list.

isn't this statement enough? wg chair says do not discuss this on the
main wg mailing list, do take somewhere?

I can understand asking for consensus, but this is an issue where
we are unlikely to get anyway near consensus

wg chairs decide!!

/Loa

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                           [email-masked]

---

From: Eric W Gray <[email-masked]>
Date: Tue, 11 Jul 2006 11:54:44 -0400

Andy,

    Because this is an over-simplification, I have to disagree.

    We need somewhere in which to talk about work - even if it is being done
somewhere else - partly because we are otherwise asking everyone to join an
IEEE mailing list (for example) and partly because we would otherwise gum up
the CCAMP mailing list with that discussion (as we are now doing).

--
Eric

Andrew G. Malis wrote:

> charter, this discussion shouldn't occur on an IETF-sponsored list 
> (such as [email-masked] <mailto:[email-masked]>).  This should 
> happen either on an IEEE-associated list, or a private list not 
> associated with the IETF.
>  
> Thanks,
> Andy
>
>  
> <mailto:[email-masked]> 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     adrian & don
>
>     "Adrian Farrel" < [email-masked] <mailto:[email-masked]>>
>     Sent by: [email-masked] <mailto:[email-masked]>
>     11/07/2006 15:35
>            To:     "Don Fedyk" < [email-masked]
>     <mailto:[email-masked]>>, Dimitri
>            cc:     <[email-masked] <mailto:[email-masked]>>, <
>     [email-masked] <mailto:[email-masked]>>
>     [email-masked] <mailto:[email-masked]>

---

From: [email-masked]
Date: Tue, 11 Jul 2006 16:23:15 +0200

don - 

indeed liaison toward IEEE needs to be committed by IETF so there is a 
need to maintain this discussion within IETF (open) mailing list 
discussion and consensus

otherwise situation will be identical to the one we faced in GELS (no WG, 
no WG document hence difficulty to communicate with IEEE beside private 
discussions, hence no backup of potential solutions and so finally no 
possibility to start the intended control plane work) 

thanks,
- dimitri.

"Don Fedyk" <[email-masked]>
11/07/2006 16:06
 
        To:     "Andrew G. Malis" <[email-masked]>, Dimitri 
PAPADIMITRIOU/BE/ALCATEL@ALCATEL
        cc:     "Adrian Farrel" <[email-masked]>, 
<[email-masked]>, <[email-masked]>, <[email-masked]>
        Subject:        RE: Future of the GELS mailing list

Andy
 
The goal is not to have discussion that are out of scope but the messages 
will constantly be attempting to get the content into scope.  I don't 
think this is the private discussions of the data plane but it is the 
messages that are trying to define the profile we can talk about and 
liaise to the IEEE.  The outcome of this will be shared with CCAMP. 
 
Don 

Dimitri,

Thanks,
Andy

thanks,
- dimitri.

Adrian