Subject: RE: Proposed response to OIF on OSPF ENNI

From: "Drake, John E" <[email-masked]>
Date: Tue, 25 Jul 2006 15:08:02 -0700

-----Original Message-----
	From: Ong, Lyndon [mailto:[email-masked]] 
	Sent: Tuesday, July 25, 2006 2:39 PM
	To: Drake, John E; [email-masked]
	Subject: RE: Proposed response to OIF on OSPF ENNI

	Hi John,
	 
	If you wish to discuss how the tests were carried out, you can
talk to the 
	7 major carriers that provided lab sites and the 13 router and
switch vendors that participated
	in the 2005 demo. 
	 
	JD:  Just as I suspected 
	 
	In what sense does IETF use the term interoperability test? 
	 
	JD:  You know, the stuff required to advance to proposed
standard
	 
	Is there an RFC on this? 
	 
	JD:  I'm sure.
	 
	I was unaware that IETF ran interoperability tests. 
	 
	JD:  I didn't say it did, and I don't know if it does. 
	 
	Cheers,
	 
	Lyndon

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Drake, John E
	Sent: Tuesday, July 25, 2006 2:28 PM
	To: [email-masked]
	Subject: RE: Proposed response to OIF on OSPF ENNI

	 Snipped
	 
	 Regarding Topic 2:

		Again I ask, wouldn't it be better to look at this
document which has been implemented by many vendors, and successfully
interoperability tested many times over many years to see what can be
leveraged instead of starting from scratch? 

		JD:  I noticed that Jonathan has put in this plug
several times.  I am wondering whether these events are truly
interoperability tests, in the sense that the IETF uses the term, or
rather rigged demos?  I seem to remember that the OIF characterized
itself as a marketing organization.  

________________________________

---

From: "Ong, Lyndon" <[email-masked]>
Date: Tue, 25 Jul 2006 18:22:19 -0400

I confess it was all rigged, John.  Little midgets were inside the
equipment plugging
fibers here and there and typing RSVP messages into mini keypads.

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Drake, John E
Sent: Tuesday, July 25, 2006 3:08 PM
To: [email-masked]
Subject: RE: Proposed response to OIF on OSPF ENNI

	-----Original Message-----
	From: Ong, Lyndon [mailto:[email-masked]] 
	Sent: Tuesday, July 25, 2006 2:39 PM
	To: Drake, John E; [email-masked]
	Subject: RE: Proposed response to OIF on OSPF ENNI

	Hi John,

	JD:  Just as I suspected 

	 
	Is there an RFC on this? 
	 
	JD:  I'm sure.

	 
	Cheers,
	 
	Lyndon

	 Snipped
	 
	 Regarding Topic 2:

---

From: [email-masked]
Date: Wed, 26 Jul 2006 09:52:37 +0200

lyndon - i don't think the issue is exactly there ;-)

the point is that having repeated demos and argue on 
its significance by the number and the affiliation of 
the participants does not make it necessarily a proof 
of validity both in terms of implementation and for 
what it related to the protocol arch./interoperability
- this is the point i think john wants to make -

so your question: how does IETF "validate" then ... well 
the answer by using the RFC2026 standard process - the
reports on implementation following that process can be 
found at 
<http://www.ietf.org/IESG/implementation.html>

for what it relates to MPLS/GMPLS there is addditionally
an initial launching process for starting the effort: 
the so-called MPLS/GMPLS change process - which is more 
clearly formalizing current practices when a new effort 
is started -

hope this answer your question 
- dimitri.

"Ong, Lyndon" <[email-masked]>
Sent by: [email-masked]
26/07/2006 00:22
 
        To:     "Drake, John E" <[email-masked]>, 
<[email-masked]>
        cc: 
        Subject:        RE: Proposed response to OIF on OSPF ENNI

From: [email-masked] [mailto:[email-masked]] On Behalf 
Of Drake, John E

-----Original Message-----
From: Ong, Lyndon [mailto:[email-masked]] 
Sent: Tuesday, July 25, 2006 2:39 PM
To: Drake, John E; [email-masked]
Subject: RE: Proposed response to OIF on OSPF ENNI

Hi John,
 
If you wish to discuss how the tests were carried out, you can talk to the 

7 major carriers that provided lab sites and the 13 router and switch 
vendors that participated
in the 2005 demo. 
 
JD:  Just as I suspected 

JD:  You know, the stuff required to advance to proposed standard
 
Is there an RFC on this? 
 
JD:  I'm sure.

 
Cheers,
 
Lyndon

From: [email-masked] [mailto:[email-masked]] On Behalf 
Of Drake, John E
Sent: Tuesday, July 25, 2006 2:28 PM
To: [email-masked]
Subject: RE: Proposed response to OIF on OSPF ENNI

 Snipped
 
 Regarding Topic 2:

Again I ask, wouldn’t it be better to look at this document which has been 
implemented by many vendors, and successfully interoperability tested many 
times over many years to see what can be leveraged instead of starting 
from scratch? 
 
JD:  I noticed that Jonathan has put in this plug several times.  I am 
wondering whether these events are truly interoperability tests, in the 
sense that the IETF uses the term, or rather rigged demos?  I seem to 
remember that the OIF characterized itself as a marketing organization.

---

From: "Ong, Lyndon" <[email-masked]>
Date: Wed, 26 Jul 2006 12:09:48 -0400

Hi Dimitri,

Understood, I was just taken aback by the idea that the demonstration
was
somehow "rigged" (by little elves?)

BTW it's not entirely clear what the testing process is to go from
Proposed to
Draft, the reports vary considerably in detail.   Some just list the
number
of implementations, without any test results.

Cheers,   

Lyndon

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] 
Sent: Wednesday, July 26, 2006 12:53 AM
To: Ong, Lyndon
Cc: [email-masked]; Drake, John E; [email-masked]
Subject: RE: Proposed response to OIF on OSPF ENNI

the point is that having repeated demos and argue on its significance by
the number and the affiliation of the participants does not make it
necessarily a proof of validity both in terms of implementation and for
what it related to the protocol arch./interoperability
- this is the point i think john wants to make -

so your question: how does IETF "validate" then ... well the answer by
using the RFC2026 standard process - the reports on implementation
following that process can be found at
<http://www.ietf.org/IESG/implementation.html>

for what it relates to MPLS/GMPLS there is addditionally an initial
launching process for starting the effort: 
the so-called MPLS/GMPLS change process - which is more clearly
formalizing current practices when a new effort is started -

 

Behalf 

-----Original Message-----
From: Ong, Lyndon [mailto:[email-masked]] 
Sent: Tuesday, July 25, 2006 2:39 PM
To: Drake, John E; [email-masked]
Subject: RE: Proposed response to OIF on OSPF ENNI

Hi John,
 
If you wish to discuss how the tests were carried out, you can talk to
the 

JD:  Just as I suspected 

 
Is there an RFC on this? 
 
JD:  I'm sure.

 
Cheers,
 
Lyndon

Behalf 

 Snipped
 
 Regarding Topic 2:

Again I ask, wouldn't it be better to look at this document which has
been 
implemented by many vendors, and successfully interoperability tested
many 
times over many years to see what can be leveraged instead of starting 
from scratch?