Subject: Re: RE: association object

From: Huub van Helvoort <[email-masked]>
Date: Wed, 19 Jul 2006 14:37:57 +0200

Dear Lucy,

You wrote:

> Thank you for the explanation. Thus, this association is only significant at
> the destination, is that right?

Yes, intermediate nodes do not have to be aware of the association between
the LSPs in a VCG.

>  Is VCG group value generated by the source?

I am not sure what you mean by value.
Is it the identifier for a specific VCG, or
is it the size (number of LSPs) of the VCG?

Cheers, Huub.
 
>   _____  
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Ong, Lyndon
> Sent: Tuesday, July 18, 2006 12:26 PM
> To: Lucy Yong; [email-masked]; [email-masked]
> Subject: RE: association object
> 
> Hi Lucy,
> 
> The association object is used to associate components of a VCG that are
> already diversely routed in the draft, I would think diverse routing is more
> a 
> feature of path computation than the signaling to set up the component.
> 
> What the association object does is allow you to tell what LSPs arriving at
> the destination are part of the same VCG.
> 
> Cheers,
> 
> Lyndon
> 
>   _____  
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Lucy Yong
> Sent: Tuesday, July 18, 2006 7:16 AM
> To: [email-masked]; [email-masked]
> Subject: association object
> 
> Richard,
> 
> It was nice to meet you in IETF meeting. I have a question about association
> object used to associate the diversely routed LSPs. 
> 
> If a LSP is established first, say LSP1, then another LSP (say LSP2) needs
> to be established and be diversely routed from LSP1, how association object
> is applied in this case? It is easy to use in the latter LSP request,
> however, how does LSP1 know that it needs to diverse from LSP2.
> 
> What is the relationship between this association object and diversity
> object in GMPLS.
> 
> Best Regards,
> 
> Lucy
>

---

From: Lucy Yong <[email-masked]>
Date: Wed, 19 Jul 2006 09:06:43 -0500

Huub,

Thank you fro the answer. The value I mentioned is for VCG group ID.

Regards,
Lucy

-----Original Message-----
From: Huub van Helvoort [mailto:[email-masked]] 
Sent: Wednesday, July 19, 2006 7:38 AM
To: Lucy Yong; 'Ong, Lyndon'; [email-masked]; [email-masked]
Subject: Re: RE: association object

Dear Lucy,

Cheers, Huub.

---

From: Richard Rabbat <[email-masked]>
Date: Wed, 19 Jul 2006 11:07:59 -0700

Lucy,

If you mean the value of the association id, we specifically left it out 
of the responsibility of the gmpls suite of protocols. An NMS or other 
outside entity is perfectly capable of making the assignment. 
In my mind this assignment should be centralized; otherwise, multiple 
independent sources may decide to use the same id.

Richard.

Lucy Yong wrote:
>> Thank you for the explanation. Thus, this association is only significant
>>     
> at
>   
>> already diversely routed in the draft, I would think diverse routing is
>>     
> more
>   
>> a 
>> What the association object does is allow you to tell what LSPs arriving
>>     
> at
>   
>> It was nice to meet you in IETF meeting. I have a question about
>>     
> association
>   
>> to be established and be diversely routed from LSP1, how association
>>     
> object
>