Subject: [CCAMP] Gen-ART review of draft-ietf-ccamp-gmpls-ethernet-pbb-te-06.txt

From: <[email-masked]>
Date: Fri, 1 Oct 2010 20:03:04 -0400

I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Summary:
This draft is basically ready for publication, but has nits that should be fixed before publication.

After the -06 version was posted, IESG discussion resulted in a couple of RFC Editor notes that address the open issues from the Gen-ART review of -05.

The following 3 IANA-related nits still need attention:

- In Section 4.1, remove the note to IANA after 2) and instead insert this instruction into Section 7.

- In Figure 4, the type is TBA.  Add an instruction to Section 7 for IANA to fill this in after it is
allocated.
 
- In the fourth bullet in Section 7, please state that the registry is created by the MLN-EXT draft if
that is the case.

It looks like IANA has figured out at least the third of these, but follow-up w/IANA is already needed because one of the RFC Editor Notes removes an IANA Action.  That follow-up should be used to confirm that the planned IANA Actions match what was intended.

The entire Gen-ART review of the -05 version is below.

Thanks,
--David

> -----Original Message-----
> From: Black, David
> Sent: Thursday, August 26, 2010 1:01 PM
> To: [email-masked]'; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Cc: Black, David; Lou Berger; Deborah Brungard; Adrian Farrel; Daniel King; [email-masked]'
> Subject: Gen-ART review of draft-ietf-ccamp-gmpls-ethernet-pbb-te-05.txt
> 
> I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at
> http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq .
> 
> Please resolve these comments along with any other comments you may receive.
> 
> Summary:
> This draft is on the right track, but has open issues, described in the review.
> 
> This draft describes the use of a GMPLS control plane to configure explicit forwarding in Ethernet
> bridges for PBB-TE (Provider Backbone Bridge Traffic Engineering).
> 
> In general, the draft is in good shape; the two open issues are in Section 5.1.2 and are minor:
> - Is the "has to allocate a VID" statement in Section 5.1.2 correct when shared forwarding
> 	is in use as described in Section 3.1 ?
> - The error value: MPLS Label allocation failure (9) appears to be inconsistent with the
> 	second bullet in Section 7 that requests IANA to allocate a new error value: "PBB-TE
> 	Ethernet Label VID allocation failure" (suggested value: 35?)  for this case.
> 
> Nits:
> 
> In Section 2, what are the I and B components of an IB-BEB?  Interface and Bridge?
> 
> In Figure 1, the VIP acronym is not in Section 2's list of acronyms.
> 
> In Section 4.1, remove the note to IANA after 2) and instead insert this instruction into Section 7.
> 
> In Figure 4, the type is TBA.  Add an instruction to Section 7 for IANA to fill this in after it is
> allocated.
> 
> In the fourth bullet in Section 7, please state that the registry is created by the MLN-EXT draft if
> that is the case.
> 
> idnits 2.12.04 ran clean.
> 
> Thanks,
> --David
> ----------------------------------------------------
> David L. Black, Distinguished Engineer
> EMC Corporation, 176 South St., Hopkinton, MA  01748
> +1 (508) 293-7953             FAX: +1 (508) 293-7786
> [email-masked]        Mobile: +1 (978) 394-7754
> ----------------------------------------------------
>

---

From: Adrian Farrel <[email-masked]>
Date: Sat, 02 Oct 2010 09:11:32 +0100

Thanks David,

[snip]

> insert this instruction into Section 7.

This is already the first bullet point in Section 7.
The RFC Editor will spot "suggested value" in 4.1 and update it.

> - In Figure 4, the type is TBA.  Add an instruction to Section 7 for IANA
> to fill this in after it is allocated.

RFC Editor has the practice of searching for TBA and replacing with the 
values assigned by IANA.

> - In the fourth bullet in Section 7, please state that the registry is 
> created
> by the MLN-EXT draft if that is the case.

This was already added in -06

Thanks,
Adrian

---

From: <[email-masked]>
Date: Mon, 4 Oct 2010 09:13:06 -0400

That'll suffice, Thanks, --David

> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Saturday, October 02, 2010 4:12 AM
> To: Black, David
> Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Black, David; gen-
> [email-masked]; [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: Gen-ART review of draft-ietf-ccamp-gmpls-ethernet-pbb-te-06.txt
> 
> Thanks David,
> 
> [snip]
>