Subject: Re: [CCAMP] Signaling extensions for G.709 - draft-khuzema-ccamp-gmpls-signaling-g709-00.txt

From: Fatai Zhang <[email-masked]>
Date: Thu, 28 Oct 2010 09:08:58 +0800

Hi Rajan,

Happy to see your draft, but except multi-stage muxing supported in your draft,  I don't see any substantial difference between your draft and [draft-zhang-ccamp-gmpls-evolving-g709-06.txt].

You may say that TPN info is incorporated into label Object, but you know it is easy for [draft-zhang-ccamp-gmpls-evolving-g709-06.txt] to do that and we already stated it in the slides for IETF78th meeting ( we just make the door open at this moment and there are some advantages to decouple TPN and Label).

In addtion, for multi-stage muxing, I really suspect that it can be resolved so easily, because it is MLN stuff and it needs to indicate how to create the infrastructure FA-LSP (See RFC4206 and 4206bis). If it can be done in this way as your draft describes, we all will be much happy.

Best Regards
 
Fatai
 
    ----- Original Message ----- 
    From: Rajan Rao 
    To: [email-masked] 
    Cc: Khuzema Pithewan ; Mohit Misra 
    Sent: Wednesday, October 27, 2010 5:26 AM
    Subject: [CCAMP] Signaling extensions for G.709 - draft-khuzema-ccamp-gmpls-signaling-g709-00.txt

    Hi,

    We have a draft on "GMPLS Signaling extensions for OTN" available for review.  It can be accessed from the following link:

    http://www.infinera.com/rfc/draft-khuzema-ccamp-gmpls-signaling-g709-00.txt

    The above draft is not on IETF repository as we missed the submission deadline.  We will submit to IETF as soon as possible. 

    Please review and comment.

    Abstract:

    As OTN network capabilities continue to evolve, there is an increased  need to support GMPLS control for the same. [RFC4328] introduced GMPLS signaling extensions for supporting early version of G.709 [G.709-v1].The basic routing considerations from signaling perspective is also specified in [RFC4328].

    The recent revision of ITU-T Recommendation G.709 [G.709-v3] and[GSUP.43] have introduced new ODU containers (both fixed and flexible) and additional ODU multiplexing capabilities, enabling support for optimal service aggregation.

    This document extends [RFC4328] to provide GMPLS signaling support for the new OTN capabilities defined in [G.709-v3] and [GSUP.43]. The signaling extensions described in this document caters to ODU layer switching only. Optical Channel Layer switching considerations in [RFC4328] are not modified in this document.

    Thanks

    Authors

----------------------------------------------------------------------------

    _______________________________________________
    CCAMP mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/ccamp

---

From: Rajan Rao <[email-masked]>
Date: Wed, 27 Oct 2010 23:17:17 -0700

Fatai,

Please see response inline.

thanks
Rajan
________________________________________
From: Fatai Zhang [[email-masked]]
Sent: Wednesday, October 27, 2010 6:08 PM
To: Rajan Rao; Khuzema Pithewan; Mohit Misra
Cc: [email-masked]; Zhang, Fatai
Subject: Re: [CCAMP] Signaling extensions for G.709 - draft-khuzema-ccamp-gmpls-signaling-g709-00.txt

Hi Rajan,

[Rajan]{
Multi stage muxing is one of the key drivers for  signaling extensions. Any solution is incomplete without this. The label format proposed is intended to support G.709-v3 & future OTN extensions. Section 5.2 in  draft-ietf-ccamp-gmpls-g709-framework-03  touches on this aspect!!
 
We see following key differences between the drafts:
 Our draft addresses
-          G.709 multi-stage multiplexing (v3 & beyond)
-          NMC treatment (ref to section-4 in the draft)
-          Support for VCAT (NVC >1 )
}

[Rajan]{
The key thing here is the mux layers.  The TPN in label object is intended to address per mux layer case…. more efficient. 
I think this should be captured in framework doc (section 3.1.2.1in framework doc doesn't cover hierarchy aspect clearly). 
}

[Rajan]{
The label structure we have defined is to address muxing levels of G.709.  This is not solving MLN using FA. i.e. it doesn’t result in creation of FA automatically. There is no FA involved or intended here (out of scope). Please refer to section-3.0 in https://datatracker.ietf.org/doc/draft-ashok-ccamp-gmpls-ospf-g709/.

 For example,  we need 3 labels to create an ODU0 LSP with following muxing structure on a given TeLink
 
Muxing hierarchy on a TeLink: OTU3-ODU3-ODU2-ODU1-ODU0
 
Num-of-mux-stages = 3
Stage-1 - Label#1: for ODU2 layer with 8 out of 32 bits set
Stage-2 - Label#2: for ODU1 layer with 2 out of 8 bits set
Stage-3 - Label#3: for ODU0 layer with 1 out of 2 bits set
 
}

Best Regards

Fatai

----- Original Message -----
From: Rajan Rao<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
Cc: Khuzema Pithewan<mailto:[email-masked]> ; Mohit Misra<mailto:[email-masked]>
Sent: Wednesday, October 27, 2010 5:26 AM
Subject: [CCAMP] Signaling extensions for G.709 - draft-khuzema-ccamp-gmpls-signaling-g709-00.txt

Hi,

We have a draft on “GMPLS Signaling extensions for OTN” available for review.  It can be accessed from the following link:
http://www.infinera.com/rfc/draft-khuzema-ccamp-gmpls-signaling-g709-00.txt
The above draft is not on IETF repository as we missed the submission deadline.  We will submit to IETF as soon as possible.

Thanks
Authors

________________________________

---

From: Fatai Zhang <[email-masked]>
Date: Fri, 29 Oct 2010 15:56:12 +0800

Hi Rajan,

You said there are the following differences between two drafts:
-  G.709 multi-stage multiplexing (v3 & beyond)
-  NMC treatment (ref to section-4 in the draft)
-  Support for VCAT (NVC >1 )
- TPN format

We have to repeat that there is not much substantial difference between two drafts except multi-stage muxing. 

We don't want to talk more on "NMC", "NVC", "TPN", because they have been discussed before and it is quite easy for [draft-zhang] to do that. For example, for NMC, there is an editors note in the previous versions  such as 04 version to discuss NMC stuff (and some people opposed to deprecate NMC). For NVC, it is obviously that [draft-zhang] can support it.

Now we can focus your key driver-multi-stage muxing.

1) At page 3, in the list of added OTN features is present explicitly the "Multi-stage ODU Multiplexing". Actually, multi-stage is not present at all as requirement/feature in G.709. Our intention to postpone technical solution regarding multi-stage multiplexing is justified by on going ITU-T SG15 progress. Before thinking about specific signaling and routing solutions we need to have stable ITU-T requirements. This why in all our common drafts (FWK, Info-Model, Routing and Signaling drafts) we just placed some placeholder on the subject.

2) We are confused by your simplified multi-stage muxing label distribution rule

There is no detailed text to describe multi-stage muxing label distribution procedures in your draft and your explaination in your below mail just focuses on one single node rather than how to create the end-to-end LSP.

It is known that GMPLS standard procedure impose that every node has to allocate a label/labels consistent with the Generalized Label Request. Very important: Generalized Label Request cannot be changed during signaling path.

For example, taking ODU1-ODU2-ODU3 two-stage muxing, which means that we need a service ODU1 that will be muxed into ODU2 and then ODU3. Assume the path is A-B-C-D-E, in node B and node D will finish the two-stage muxing/demuxing. How you to create the LSP? how you to distribute the labels in Node B, C, D? What is the traffic parameters will be transmitted in the nodes B, C, D and nodes A, E?

Thanks,

Authors of [draft-zhang-ccamp-gmpls-evolving-g709-06.txt]

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Mohit Misra" <[email-masked]>; "Ashok Kunjidhapatham" <[email-masked]>
Cc: <[email-masked]>; "Biao Lu" <[email-masked]>
Sent: Thursday, October 28, 2010 2:17 PM
Subject: RE: [CCAMP] Signaling extensions for G.709 - draft-khuzema-ccamp-gmpls-signaling-g709-00.txt

Fatai,

thanks
Rajan

Hi Rajan,

[Rajan]{

[Rajan]{

[Rajan]{

 
Num-of-mux-stages = 3
 
}

Best Regards

Fatai

----- Original Message -----
From: Rajan Rao<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
Cc: Khuzema Pithewan<mailto:[email-masked]> ; Mohit Misra<mailto:[email-masked]>
Sent: Wednesday, October 27, 2010 5:26 AM
Subject: [CCAMP] Signaling extensions for G.709 - draft-khuzema-ccamp-gmpls-signaling-g709-00.txt

Hi,

Thanks
Authors