Subject: [CCAMP] Comments on draft-ietf-ccamp-alarm-module-01 / operator actions

From: NICK HANCOCK <[email-masked]>
Date: Fri, 4 May 2018 09:27:03 +0000

Hi Stefan,

Entries in the list 'operator-state-change' have the leaf 'operator', but where does this come from? The action 'set-operator-state' does not have a corresponding leaf as input.

In addition, there is a notification 'operator-action' with the context of an entry in the list 'alarm'. YANG 1.1 allows you to define a notification in a data node, so this notification could be defined within the list 'alarm' as is the action 'set-operator-state'. I believe that this would be more consistent.

Best regards
Nick

---

From: stefan vallin <[email-masked]>
Date: Fri, 4 May 2018 19:25:32 +0200

Hi Nick!
Again, your comments are super important!

> 4 maj 2018 kl. 11:27 skrev NICK HANCOCK <[email-masked]>:
> 
> Hi Stefan,
>  
All NETCONF operations are authenticated so the user/operator info is picked from auth, for example ssh user. Will clarify in next version
> In addition, there is a notification ‘operator-action’ with the context of an entry in the list ‘alarm’. YANG 1.1 allows you to define a notification in a data node, so this notification could be defined within the list ‘alarm’ as is the action ‘set-operator-state’. I believe that this would be more consistent.
Good point!
Will consider in next version

Br
Stefan