Subject: [CCAMP] Alarm Module work

From: stefan vallin <[email-masked]>
Date: Mon, 28 May 2018 14:11:38 +0200

Hi!
Me and Martin are working on an updated version of the alarm module. Several smaller things pointed out by reviewers. Thank you all.

We would like to share 2 things for discussion:
1) Extended notification filtering
2) Alarm Severity Assignment Profile

We are now stretching the limit for being a first core module with only relevant features.
At this point I think it is more important to start having implementation support rather than adding even more features which might scare people of from implementing it.

1) Extended notification filtering
========================
See suggestion below, added the capability to filter on severity.
We did not include resource filtering since that would be too much overlap with shelving.

      choice notify-status-changes {
        description
          "This leaf controls the notifications sent for alarm status
           updates. There are three options:
           1. notifications are sent for all updates, severity level
              changes and alarm text changes
           2. notifications are only sent for alarm raise and clear
           3. notifications are sent for status changes equal to or
              above the specified severity level. Clear notifications
              shall always be sent
              Notifications shall also be sent for state changes that
              makes an alarm less severe than the specified level.
           In option 3, assuming the severity level is set to major,
           and that the alarm has the following state changes
           [(Time, severity, clear)]:
           [(T1, major, -), (T2, minor, -), (T3, warning, -),
            (T4, minor, -), (T5, major), (T6, major, clear)]
           In that case, notifications will be sent at
           T1, T2, T5 and T6";
        leaf notify-all-state-changes {
          type empty;
          description
            "Send notifications for all status changes.";
        }
        leaf notify-raise-and-clear {
          type empty;
          description
            "Send notifications only for raise, clear, and re-raise.
             Notifications for severity level changes or alarm text
             changes are not sent.";
        }
        leaf notify-severity-level {
          type severity;
          description
            "Only send notifications for alarm state changes
             crossing the specified level. Always send clear
             notifications.";
        }
      }

2) Alarm Severity Assignment Profile
============================

We have renamed ietf-alarms-x733 to ietf-alarms-itu since it now includes X.733 as well as M.3100/M.3160 features

  list alarm-severity-assignment-profile {
      if-feature alarm-severity-assignment-profile;
      key "alarm-type-id alarm-type-qualifier resource";
      ordered-by user;
      description
        "If an alarm matches the criteria in one of the entries
         in this list the configured severity levels shall be
         used instead of the system default. Note well that the
         mapping allows for several severity levels since this
         alarm module uses a stateful alarm model where
         the same alarm can have the following states:
         [(warning, not cleared),(minor, not cleared),
          (minor, cleared)]

         The configuration of this list shall update the
         /al:alarms/al:alarm-inventory/al:alarm-type list so that a
         client can always get a full picture of the possible alarms
         by reading the alarm inventory. If an alarm matches several
         entries in this list, the first match is used.";
      reference
        "M.3160/M.3100 Alarm Severity Assignment Profile, ASAP";
      leaf alarm-type-id {
        type al:alarm-type-id;
        description
          "The alarm type identifier to match for severity
           assignment.";
      }
      leaf alarm-type-qualifier {
        type string;
        description
          "A W3C regular expression that is used to match
           an alarm type qualifier.";
      }
      leaf resource {
        type al:resource-match;
        description
          "Specifies which resources to match for severity
           assignment.";
      }
      leaf-list severity-levels {
        type al:severity;
        ordered-by user;
        description
          "Specifies the configured severity level(s) for the
           matching alarm. If the alarm has several severity
           levels the leaf-list shall be given in rising severity
           order. The original M3100/M3160 ASAP function only
           allows for a one-to-one mapping between alarm type and
           severity but since the IETF alarm module supports stateful
           alarms the mapping must allow for several severity levels.

           Assume a high-utilisation alarm type with two
           thresholds with the system default severity levels of
           threshold1 = warning and threshold2 = minor. Setting this
           leaf-list to (minor, major) will assign the severity
           levels threshold1 = minor and threshold2 = major";
      }
      leaf description {
        type string;
        mandatory true;
        description
          "A description of the alarm severity profile.";
      }
    }

Stefan Vallin
[email-masked]
+46705233262

---

From: NICK HANCOCK <[email-masked]>
Date: Thu, 31 May 2018 16:24:21 +0000

Hi Stefan,

Thanks for sharing this for discussion.

I absolutely agree that it is most important that we can progress the YANG Alarm Module to RFC asap, so that support for it can begin to be implemented in the industry.

1) Extended notification filtering.

The introduction of 'notify-security-level' here has one drawback in that it is a global configuration applying to all alarm types and thus does not allow the behaviour to be assigned based on type of resource, such as interface or object. This does not allow you to suppress alarms below a certain severity for some interface types that are not so important, for example, but keep normal alarm behaviour for other more important interfaces.

Also just 'Crossing the specified level' may fulfil the desired behaviour for alarm types with a 1:1 mapping to severity level, but not for alarm types with severity life cycles. if the severity of the alarm continues to increase above the configured severity level, alarm notifications would also need to be sent.
Consider the following example assuming the severity-level is set to 'major':
           [(Time, severity, clear)]:
           [(T1, major, -), (T2, critical, -), (T3, major, -), (T4, minor, -), (T5, major), (T6, major, clear)]
I would expect alarm notifications at T1, T2, T3, and T6.

Changing this configuration to a choice does have its advantages, such as to allow the addition of other cases later or allow other SDOs or vendors to augment other cases.
So maybe a pragmatic approach so as to not block progress of this draft could be to keep the choice format but omit the 'notify-security-level' for now and continue discussions.

The proposed implementation provides the means to override severities for alarm types with severity life cycles, but at the same time the implementation is relatively simple.
Also the use of a criteria to assign the severity to alarms - and I am assuming that it would work like for the shelf - allows resource-independent overriding of factory default severities through specification of an alarm-type only, but also to add additional overrides for specific resources. The only question is if there are multiple assignments that apply to a specific alarm instance which assignment should apply? For example, if I create an entry for
[(alarm-type-id, alarm-type-id-qualifier, resource, severity-level]
[(los,,,major),(los,,"interface 1", critical)]
which severity assignment applies to interface 1? The more specific?

The implementation is also very specific to alarm severity assignment. The mechanism itself, though, is relatively generic, mapping information to alarms, in this case alarm severities. Other SDOs or vendors may wish to augment the list with other data nodes to use this mechanism to associate other data with alarm types and avoid having to implement multiple lists. So I believe that there would be a great advantage and added-value, if this list would be made more generic, such as renaming it to just 'alarm-profile', for example.

And although it does fulfil the requirements of M.3100/M.3160, including the list within the module ietf-alarms-itu would basically restrict the use and possible extension of the ASAP to ITU requirements only. Since possible augmentations could originate from requirements coming from other SDOs and vendors, it would IMHO not be prudent to include it in this module.

Best regards
Nick

This message has been classified General Business by NICK HANCOCK on Thursday, 31 May 2018 at 18:24:19.

From: CCAMP [mailto:[email-masked]] On Behalf Of stefan vallin
Sent: Monday, May 28, 2018 2:12 PM
To: Common Control and Measurement Plane Discussion List
Subject: [CCAMP] Alarm Module work

Hi!

Stefan Vallin
[email-masked]<mailto:[email-masked]>
+46705233262

---

From: stefan vallin <[email-masked]>
Date: Thu, 31 May 2018 21:02:46 +0200

Hi Nick!
Thanks for your comments, really appreciated!

> On 31 May 2018, at 18:24, NICK HANCOCK <[email-masked]> wrote:
> 
> Hi Stefan,
>  
> The introduction of ‘notify-security-level’ here has one drawback in that it is a global configuration applying to all alarm types and thus does not allow the behaviour to be assigned based on type of resource, such as interface or object. This does not allow you to suppress alarms below a certain severity for some interface types that are not so important, for example, but keep normal alarm behaviour for other more important interfaces. 
mmm, we could add resource and alarm type to notification filtering, but then we have alarm shelving and notification filtering as overlapping mechanisms.
I could argue that the manager/client could do the notification filtering.
My experience is that the severity level filtering is of less importance. You normally want to shelf based on resource and alarm type
> Also just 'Crossing the specified level' may fulfil the desired behaviour for alarm types with a 1:1 mapping to severity level, but not for alarm types with severity life cycles. if the severity of…
That was the intention, will clarify.

> Consider the following example assuming the severity-level is set to ‘major’:
Adding some severity changes to your scenario
[(T1, major, -), (T2, critical, -), (T3, major, -), (T4, minor, -), (T5, warning), (T6, major), (T7, clear)]

Notifications will be sent at T1, T2, T3, T4, T6, T7

> So maybe a pragmatic approach so as to not block progress of this draft could be to keep the choice format but omit the ‘notify-security-level’ for now and continue discussions.
Or keep it :)
> Also the use of a criteria to assign the severity to alarms – and I am assuming that it would work like for the shelf - allows resource-independent overriding of factory default severities through specification of an alarm-type only, but also to add additional overrides for specific resources. The only question is if there are multiple assignments that apply to a specific alarm instance which assignment should apply? For example, if I create an entry for 
> [(los,,,major),(los,,”interface 1”, critical)]
Good comment!
Priority order:
1) the more specific
  1.1) resource
  1.2) alarm type (remember hierarchical)
2) order in list

>  
> The implementation is also very specific to alarm severity assignment. The mechanism itself, though, is relatively generic, mapping information to alarms, in this case alarm severities. Other SDOs or vendors may wish to augment the list with other data nodes to use this mechanism to associate other data with alarm types and avoid having to implement multiple lists. So I believe that there would be a great advantage and added-value, if this list would be made more generic, such as renaming it to just ‘alarm-profile’, for example.
We are circling back and forth here.
The list has expressed the need to support ITU Alarm Severity Assignment Profile, this is exactly what the suggested model does.
>  
> And although it does fulfil the requirements of M.3100/M.3160,
as requested :)
> including the list within the module ietf-alarms-itu would basically restrict the use and possible extension of the ASAP to ITU requirements only.
Not sure what you mean with "restrict"

> Since possible augmentations could originate from requirements coming from other SDOs and vendors, it would IMHO not be prudent to include it in this module.
Nothing stops augmentations and additions of other features. Just felt there was a high pressure for ASAP which the suggestion captures.

best regards Stefan
>  <>From: CCAMP [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of stefan vallin
> [email-masked] <mailto:[email-masked]>
> +46705233262