Subject: [CCAMP] Benjamin Kaduk's No Objection on draft-ietf-ccamp-microwave-framework-06: (with COMMENT)

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 23 May 2018 06:17:51 -0700

Benjamin Kaduk has entered the following ballot position for
draft-ietf-ccamp-microwave-framework-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-microwave-framework/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I have a similar sentiment to Mirja, in that this document seems to
be describing the result of WG deliberations and the conclusions
that have been reached as to the path for future work.  As such,
it's unclear that there is lasting technical value to the Internet
Community from publication as an RFC (as opposed to remaining as a
WG-internal document until the publication of the associated
follow-up work).  That said, I am not making this a blocking
objection.

I'm happy to see the secdir thread coming to a conclusion about SDN
vs. NMS -- thanks for working to clear that up.

Otherwise, I just have some grammatical/style nits that I noted
while reading.

Is there any need to disambiguate "Wireless carrier" (i.e., a type of
company) vs. "carrier frequency"?  (I could certainly see an
argument for "no", given the target audience.)

Sections 1 and 2 differ about the lower bound for "microwave radio"
spectrum (1GHz vs. 1.4 GHz).

Section 2

   [...] Using multi-carrier systems operating in frequency bands
   with wider channels, the technology will be capable of providing
   capacities up 100 Gbps.

nit: "capacities of up to"

Section 3.2

   [...] Hence, an
   open and standardized node management interface are required in a
   multi-vendor environment.  Such standardized interface enables a
   unified management and configuration of nodes from different vendors
   by a common set of applications.

nit: singular/plural disagreement between "an" and "are"; also
between "such" (vs. "such a") and "interface enables" (vs.
"interfaces enable")

   On top of SDN applications to configure, manage and control the nodes
   and their associated transport interfaces including the L2 Ethernet
   and L3 IP interfaces as well as the radio interfaces, there are also
   a large variety of other more advanced SDN applications that can be
   exploited and/or developed.

FYI, the word "exploited" has connotations (in some circles) of a
malicious hack, i.e., that such an application has vulnerabilities
that are exploited for nefarious purposes.  (So far as I know,
"utilized" does not.)

The subsections in Section 4 read, stylistically, as if they are
bullet points under the heading of "use cases".  I wonder if there
would be benefit from adding some generic text about "This use
case involves ..." to them.

nit: In Section 6.1, "data plane technology specific" is used (multiple
times) as a compound adjective, which requires some hyphenation.  (I
believe different style guides have conflicting recommendations, but
at least a hyphen in "technology-specific" is generally accepted.)

---

From: "Yemin (Amy)" <[email-masked]>
Date: Mon, 28 May 2018 07:22:07 +0000

Hi Benjamin,

Thanks for the comments, and sorry for the late response.

Please see reply inline in blue.

BR,

Amy

-----Original Message-----
From: Benjamin Kaduk [mailto:[email-masked]]
Sent: Wednesday, May 23, 2018 9:18 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; Daniele Ceccarelli <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Benjamin Kaduk's No Objection on draft-ietf-ccamp-microwave-framework-06: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

COMMENT:

I have a similar sentiment to Mirja, in that this document seems to be describing the result of WG deliberations and the conclusions that have been reached as to the path for future work.  As such, it's unclear that there is lasting technical value to the Internet Community from publication as an RFC (as opposed to remaining as a WG-internal document until the publication of the associated follow-up work).  That said, I am not making this a blocking objection.

I'm happy to see the secdir thread coming to a conclusion about SDN vs. NMS -- thanks for working to clear that up.

Otherwise, I just have some grammatical/style nits that I noted while reading.

company) vs. "carrier frequency"?  (I could certainly see an argument for "no", given the target audience.)

[Amy] Maybe not necessary. Carrier is a widely used term in wireless technology.

spectrum (1GHz vs. 1.4 GHz).
[Amy] Thanks for pointing it out. Should be 1.4GHz.

Section 2

   capacities up 100 Gbps.

[Amy] will fix it.

Section 3.2

   [...] Hence, an

nit: singular/plural disagreement between "an" and "are"; also between "such" (vs. "such a") and "interface enables" (vs.

"interfaces enable")
[Amy] will fix it, see below:
   Hence, an
   open and standardized node management interface is required in a
   multi-vendor environment.  Such a standardized interface enables a
   unified management and configuration of nodes from different vendors
   by a common set of applications.

FYI, the word "exploited" has connotations (in some circles) of a malicious hack, i.e., that such an application has vulnerabilities that are exploited for nefarious purposes.  (So far as I know, "utilized" does not.)
[Amy] Thanks for suggestion, will change to "utilized”.

The subsections in Section 4 read, stylistically, as if they are bullet points under the heading of "use cases".  I wonder if there would be benefit from adding some generic text about "This use case involves ..." to them.
[Amy] How about add the following sentence to the end of first paragraph in section 4:
The use cases involves configuration management, inventory, status and statistics, performance management, fault management, troubleshooting and rout cause analysis.

times) as a compound adjective, which requires some hyphenation.  (I believe different style guides have conflicting recommendations, but at least a hyphen in "technology-specific" is generally accepted.)
[Amy] will use "technology-specific".

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 29 May 2018 13:26:46 -0500

Hi Amy,

No worries about the late response; all these updates work for me.

Thanks,

Benjamin