Subject: [CCAMP] WG adoption poll on draft-ye-ccamp-mw-topo-yang-02

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 22 Jan 2019 16:36:40 +0000

Working group,

We managed to complete at least one of the IPR polling procedures started.

This starts a two weeks poll on making  draft-ye-ccamp-mw-topo-yang-02 a
CCAMP working group document.

Please send email to the list indicating "yes/support" or "no/do not
support" and a motivation for  your reply, mandatory for the "not support"
and nice to have for the "support".

The polling will end on Tuesday February 5th.

Thanks,

Daniele & Fatai

---

From: Leeyoung <[email-masked]>
Date: Tue, 22 Jan 2019 17:21:38 +0000

Hi,

Yes/support.

Thanks.
Young

From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Tuesday, January 22, 2019 10:37 AM
To: CCAMP ([email-masked]) <[email-masked]>
Cc: [email-masked]
Subject: [CCAMP] WG adoption poll on draft-ye-ccamp-mw-topo-yang-02

Working group,

This starts a two weeks poll on making  draft-ye-ccamp-mw-topo-yang-02 a CCAMP working group document.

Please send email to the list indicating "yes/support" or "no/do not support" and a motivation for  your reply, mandatory for the "not support" and nice to have for the "support".

Thanks,

Daniele & Fatai

---

From: "Aihuaguo (Aihua Guo, CRC)" <[email-masked]>
Date: Tue, 22 Jan 2019 17:28:09 +0000

Yes/support (as co-author).

Thanks,
Aihua

Sent: Tuesday, January 22, 2019 11:37 AM

Working group,

Thanks,

Daniele & Fatai

---

From: "Yemin (Amy)" <[email-masked]>
Date: Tue, 22 Jan 2019 21:26:34 +0000

BR,
Amy
________________________________
发件人: CCAMP [[email-masked]] 代表 Daniele Ceccarelli [[email-masked]]
发送时间: 2019年1月23日 0:36
收件人: CCAMP ([email-masked])
抄送: [email-masked]
主题: [CCAMP] WG adoption poll on draft-ye-ccamp-mw-topo-yang-02

Working group,

Thanks,

Daniele & Fatai

---

From: Italo Busi <[email-masked]>
Date: Wed, 23 Jan 2019 06:55:56 +0000

Yes/support

Italo (as contributor)

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: mercoledì 23 gennaio 2019 00:37
To: CCAMP ([email-masked]) <[email-masked]>
Cc: [email-masked]
Subject: [CCAMP] WG adoption poll on draft-ye-ccamp-mw-topo-yang-02

Working group,

Thanks,

Daniele & Fatai

---

From: tom petch <[email-masked]>
Date: Wed, 23 Jan 2019 10:58:19 +0000

Uh huh; a YANG module from the Routing Area so you know what happens
next!

Requirements Language lacks reference RFC8174

Copyright (c) 2018 (I know, the I-D is October 22, 2018:-)

This document defines a YANG data model
lacks a reference for YANG language RFC

3.1.  The YANG Tree
no reference for the YANG Tree diagram RFC

YANG Module

YANG 'file' lacks date

YANG import statements lack references which then need adding to the I-D
References and which then need a mention in the body of the I-D lest you
get a warning for an unused reference

reference "draft-ietf-netmod-schema-mount: YANG Schema Mount";
wrong format - you need something like
         "RFC YYYY: YANG Schema Mount";
Note to RFC Editor please replace YYYY with the number assigned to
draft-ietf-netmod-schema-mount

    ID-draft authors:
hopefully this will move beyond the status of ID:-)

no copyright statement

            list mw-link-availability{
              key "availability";
              leaf availability {
                type decimal64 {

interesting choice of key type - I am unclear how this will be used -
could do with a more expansiive description

     augment "/nw:networks/nw:network/nw:network-types/"
          + "tet:te-topology" {
      container mw-topology {
        presence "indicates a topology type of microwave.";
no YANG 'when' and it is a presence container so will all boxes with
this YANG module have mw-topology for all te-topology?

IANA has assigned
It is more common to say
IANA is asked to assign
and let them make the change when they have done what you ask

7.2.  Informative References

   [I-D.ietf-netmod-schema-mount]
   [I-D.ietf-teas-yang-te-topo]

since you are importing from these, I believe that they have to be
Normative References.

Tom Petch

----- Original Message -----
From: "Daniele Ceccarelli" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, January 22, 2019 4:36 PM

> The polling will end on Tuesday February 5th.

------------------------------------------------------------------------
--------

> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>

---

From: "Spreafico, Daniela (Nokia - IT/Vimercate)" <[email-masked]>
Date: Wed, 23 Jan 2019 16:52:17 +0000

Yes/support (as co-author)

Regards, Daniela

From: CCAMP <[email-masked]> On Behalf Of Daniele Ceccarelli
Sent: Tuesday, January 22, 2019 5:37 PM
To: CCAMP ([email-masked]) <[email-masked]>
Cc: [email-masked]
Subject: [CCAMP] WG adoption poll on draft-ye-ccamp-mw-topo-yang-02

Working group,

Thanks,

Daniele & Fatai

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 24 Jan 2019 04:37:00 -0000

Yeah, Tom is right that the YANG model and document aren't perfect.

But his review doesn't show up anything that (to my mind) wouldn't be fixed
through normal WG process.

I think that we need this little model to supplement the many other YANG
models that are out there, and since MW falls in scope of CCAMP, this seems
like the right place to do the work.

"Adopt and polish"

Adrian

-----Original Message-----
From: CCAMP <[email-masked]> On Behalf Of tom petch
Sent: 23 January 2019 10:58
To: Daniele Ceccarelli <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [CCAMP] WG adoption poll on draft-ye-ccamp-mw-topo-yang-02

3.1.  The YANG Tree

YANG Module

YANG 'file' lacks date

    ID-draft authors:

no copyright statement

IANA has assigned
It is more common to say
IANA is asked to assign

Tom Petch

---

From: Loa Andersson <[email-masked]>
Date: Thu, 24 Jan 2019 13:37:50 +0800

Working Group, Chairs

I normally don't do +1, nut in this case it seems appropriate, Adrian 
said everything (and a bit) I wanted to say, so:

+1

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 24 Jan 2019 08:06:37 +0000

Hi Tom,

Thanks a lot for your thorough review. I would consider your comments
blocking for a WG last call but not for a WG adoption...where the WG is
supposed to start working on the document.  Would you agree?

Thanks,
Daniele  

-----Original Message-----
From: tom petch <[email-masked]> 
Sent: den 23 januari 2019 11:58
To: Daniele Ceccarelli <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [CCAMP] WG adoption poll on draft-ye-ccamp-mw-topo-yang-02

Uh huh; a YANG module from the Routing Area so you know what happens next!

3.1.  The YANG Tree

YANG Module

YANG 'file' lacks date

YANG import statements lack references which then need adding to the I-D
References and which then need a mention in the body of the I-D lest you get
a warning for an unused reference

reference "draft-ietf-netmod-schema-mount: YANG Schema Mount"; wrong format
- you need something like
         "RFC YYYY: YANG Schema Mount";
Note to RFC Editor please replace YYYY with the number assigned to
draft-ietf-netmod-schema-mount

    ID-draft authors:

no copyright statement

interesting choice of key type - I am unclear how this will be used - could
do with a more expansiive description

     augment "/nw:networks/nw:network/nw:network-types/"
          + "tet:te-topology" {
      container mw-topology {
        presence "indicates a topology type of microwave."; no YANG 'when'
and it is a presence container so will all boxes with this YANG module have
mw-topology for all te-topology?

IANA has assigned
It is more common to say
IANA is asked to assign

since you are importing from these, I believe that they have to be Normative
References.

Tom Petch

---

From: tom petch <[email-masked]>
Date: Thu, 24 Jan 2019 16:17:29 +0000

Daniele

Past experience tells me that the I-D will be adopted anyway so I do not
say support or no!

Past experience also tells me that this is a good moment to flag
concerns, that they get a wider audience at this time (like all the
authors instead of just one penholder) and are more likely to be
addressed promptly, while the issues that I raise are still fresh in my
mind; so this is a pattern of behaviour I am likely to persist in.

I do find missing references troublesome; I am currently looking at a
last call
where the description does not make sense but know that I have read a
understandable explanation in an MPLS RFC some years ago but how will I
find it?  Having references for anything makes it so much easier so I
tend to ask for them early on, before I delve into the technicalities.

In passing, a lawyer once advised me to be wary of a unanimous vote,
that if everyone agreed then it was probably not a good idea, so I
stopped being concerned about being in a minority of one!

HTH

Tom Petch

----- Original Message -----
From: "Daniele Ceccarelli" <[email-masked]>
To: "tom petch" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, January 24, 2019 8:06 AM

next!
> interesting choice of key type - I am unclear how this will be used -
could
> since you are importing from these, I believe that they have to be
Normative

---

From: Jonas Ahlberg <[email-masked]>
Date: Thu, 24 Jan 2019 16:01:17 +0000

Regards, JonasA

Sent: den 22 januari 2019 17:37

Working group,

Thanks,

Daniele & Fatai