Subject: Re: [CCAMP] WG last call on draft-ietf-ccamp-wson-yang-23

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 1 Apr 2020 16:09:08 +0000

Hi CCAMP,

The WG last call is over.
We checked with Rob (OPS AD) and agreed to have the transponders properties
carved out from both the L0 types and the WSON document.

This will allow progressing both the documents together.

At a later stage transponders can be added to a different module or we can
create an updated version of the L0 types document. This is a common
practice (e.g. RFC 6021 -> 6991 -> 6991bis) and a lot of work is going on in
NETMOD to describe how to evolve modules. (thanks Rob for the pointer).

Authors, please update the document and address the LC comments in light of
these directions.

Thanks,

Daniele  & Fatai

From: CCAMP <[email-masked]> On Behalf Of Daniele Ceccarelli
Sent: den 10 mars 2020 16:41
To: CCAMP <[email-masked]>
Subject: [CCAMP] WG last call on draft-ietf-ccamp-wson-yang-23

CCAMP,

the IPR declaration collection has been successfully completed and we can
move to the next step.

This starts a 3 weeks working group last call on
draft-ietf-ccamp-wson-yang-23.

The last call ends on Tuesday March 31st. Please send you comments to the
CCAMP mailing list.

All the IPR declarations from authors and contributors have been collected
and can be found in the history of the document.

If interested, please volunteer to be the shepherd of the draft (authors
excluded).

Authors please note that the YANG validation reports 135 ERRORS and IDNITS 7
warnings.

Thanks

Daniele & Fatai

---

From: tom petch <[email-masked]>
Date: Wed, 22 Apr 2020 09:48:07 +0000

From: CCAMP <[email-masked]> on behalf of Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>
Sent: 01 April 2020 17:09
Hi CCAMP,

The WG last call is over.
We checked with Rob (OPS AD) and agreed to have the transponders properties carved out from both the L0 types and the WSON document.
This will allow progressing both the documents together.

At a later stage transponders can be added to a different module or we can create an updated version of the L0 types document. This is a common practice (e.g. RFC 6021 -> 6991 -> 6991bis) and a lot of work is going on in NETMOD to describe how to evolve modules. (thanks Rob for the pointer).

<tp>
Looking at this, and looking at the module, I get the sense that this is the beginning of work on WSON and that other YANG modules will follow.  If so, it might be better to keep 'wson' as the initial four letters of all WSON modules and add another letter, such as 't' (as in 'tet') to this one so that they can be seen to be related and yet not confused.

Just a thought.

And while I am at it, two trivia.

s.1
/resource block models ... is not also/resource block models ... are not/

grouping-ttp-attributes
/tranponder/transponder/

Tom Petch

Authors, please update the document and address the LC comments in light of these directions.

Thanks,
Daniele  & Fatai

CCAMP,

the IPR declaration collection has been successfully completed and we can move to the next step.

This starts a 3 weeks working group last call on draft-ietf-ccamp-wson-yang-23.
The last call ends on Tuesday March 31st. Please send you comments to the CCAMP mailing list.

All the IPR declarations from authors and contributors have been collected and can be found in the history of the document.
If interested, please volunteer to be the shepherd of the draft (authors excluded).

Authors please note that the YANG validation reports 135 ERRORS and IDNITS 7 warnings.

Thanks

Daniele & Fatai