Subject: Re: [CCAMP] Summary of the CCAMP meeting on Optical Impairment Topology YANG model

From: Dieter Beller <[email-masked]>
Date: Thu, 2 Apr 2020 17:50:22 +0200

Hi Daniele,

I was aware that the WG LC has been concluded already for layer0-types. 
I posted my comments on GitHub because we discussed the dependencies of 
various
YANG modules on layer0-types during our weekly optical impairment 
topology call last week. Based on that discussion, I had the impression 
that the authors of
layer0-types already agreed to remove everything that is not related to 
spectrum management including the transponder model.

I would assume that there will be another WG LC for layer0-types when 
these modifications will have been done to give the WG an opportunity to 
review it before
the publication process will start.

Thanks,
Dieter

On 30.03.2020 14:29, Daniele Ceccarelli wrote:
>
> Hi Dieter,
>
> The L0 types has already concluded the last call, the draft in last 
> call is the WSON topology…but in any case it’s always good to have 
> further comments.
>
> Looking at the comments it seems they are all applicable also to the 
> proposal to remove transponder properties from the L0 types draft, right?
>
> BR
>
> Daniele
>
> *From:*Dieter Beller <[email-masked]>
> *Sent:* den 28 mars 2020 22:26
> *To:* Belotti, Sergio (Nokia - IT/Vimercate) 
> <[email-masked]>; [email-masked]; 
> [email-masked]; Italo Busi <[email-masked]>; Griseri, 
> Enrico (Nokia - IT/Vimercate) <[email-masked]>; Kelly, Colin 
> (Nokia - CA/Ottawa) <[email-masked]>; Gabriele Maria Galimberti 
> (ggalimbe) <[email-masked]>; ([email-masked]) 
> <[email-masked]>; Aihua Guo <[email-masked]>; 
> Zhenghaomian <[email-masked]>
> *Cc:* Daniele Ceccarelli <[email-masked]>; Fatai 
> <[email-masked]>; CCAMP <[email-masked]>
> *Subject:* Re: Summary of the CCAMP meeting on Optical Impairment 
> Topology YANG model
>
> Hi all,
>
> I completed my review of ietf-layer0-types.yang. Please find my 
> comments here: 
> https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-layer0-types/issues/9 
> <https://protect2.fireeye.com/v1/url?k=44194f13-1890e0da-44190f88-0cc47ad93e1c-9a756a5f63c40108&q=1&e=5547670a-4e75-42ee-aad0-9ab56d8dea6d&u=https%3A%2F%2Fgithub.com%2Fietf-ccamp-wg%2Fdraft-ietf-ccamp-layer0-types%2Fissues%2F9>.
>
> Thanks,
> Dieter
>
> On 20.03.2020 19:06, Belotti, Sergio (Nokia - IT/Vimercate) wrote:
>
>     During the meeting the major topic been discussed was related to
>     the e-mail exchange regarding [CCAMP] WG last call on
>     draft-ietf-ccamp-wson-yang-23 and in particular the issue raise by
>     Dieter with the mail sent March 10 on , regarding the alignment
>     among the different L0 YANG models with respect ietf-layer0-types.
>
>     These are the list of drafts we need to consider
>
>      1. ietf-ccamp-wson-yang;
>      2. ietf-ccamp-flexigrid-yang;
>      3. ietf-ccamp-wson-tunnel;
>      4. ietf-ccamp-flexigrid-media-channel-yang;
>      5. ietf-dwdm-if-param-yang;
>      6. ietf-ccamp-optical-impairment-topology-yang
>
>     There are practically two options on the table:
>
>      1. Go ahead to publish ietf-layer0-types as reference “types”
>         module for the set of drafts addressing “only” specific use
>         cases that basically is  “spectrum allocation” (a,b,c d
>         drafts) , creating in parallel a new ietf-layer0-types-xxx
>         that can be used for ietf-dwdm-if-param-yang and
>         ietf-ccamp-optical-impairment-topology-yang.
>
>     In this solution there is the problem to understand if the use
>     case claimed to be supported is possible without e.g. transpoder
>     information like the ones contained in the e, f drafts.
>
>      2. Use “versioning” YANG paradigm, this solution permits to move
>         ahead in parallel two version of the same files “types”, and
>         v2 will incorporate all the needed update for e and f drafts.
>
>     Before to take any choice, attendees of the call  decided that a
>     careful review of the ietf-layer0-types is needed to understand
>     possible gaps with respect all optical impairments and
>     transponders description .
>
>     Moreover a new issue will be open in the ietf-layer0-types github
>     to report optical impairments related comments/concerns.
>
>     Attached the e-mail exchange I mentioned at the beginning.
>
>     Feel free to amend and add what is missing.
>
>     Thanks
>
>     Sergio
>
>     Sergio Belotti
>
>     Senior System Engineer and Standardization Architect
>
>     IP/Optical Networks, Optics BU
>
>     Nokia
>
>     M: +39-335761776
>
>     Via Energy Park, 20871 Vimercate (MB) , Italy
>
>     [email-masked] <mailto:[email-masked]>
>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 3 Apr 2020 07:13:18 +0000

Hi Dieter,

We need another WG last call if there are major changes in the draft that
require it. 

Most of the changes are already widely agreed among the working group. I
would say that your comments and others still pending can be treated as WG
last call comments.

Cheers,

Daniele  

From: Dieter Beller <[email-masked]> 
Sent: den 2 april 2020 17:50
To: Daniele Ceccarelli <[email-masked]>
Cc: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>;
[email-masked]; [email-masked]; Italo Busi
<[email-masked]>; Griseri, Enrico (Nokia - IT/Vimercate)
<[email-masked]>; Kelly, Colin (Nokia - CA/Ottawa)
<[email-masked]>; Gabriele Maria Galimberti (ggalimbe)
<[email-masked]>; ([email-masked]) <[email-masked]>; Aihua
Guo <[email-masked]>; Zhenghaomian <[email-masked]>; Fatai
<[email-masked]>; CCAMP <[email-masked]>
Subject: Re: Summary of the CCAMP meeting on Optical Impairment Topology
YANG model

Hi Daniele,

I was aware that the WG LC has been concluded already for layer0-types. I
posted my comments on GitHub because we discussed the dependencies of
various
YANG modules on layer0-types during our weekly optical impairment topology
call last week. Based on that discussion, I had the impression that the
authors of
layer0-types already agreed to remove everything that is not related to
spectrum management including the transponder model.

I would assume that there will be another WG LC for layer0-types when these
modifications will have been done to give the WG an opportunity to review it
before
the publication process will start.

Thanks,
Dieter

Hi Dieter,

The L0 types has already concluded the last call, the draft in last call is
the WSON topology.but in any case it's always good to have further comments.

BR

Daniele  

From: Dieter Beller  <mailto:[email-masked]>
<[email-masked]> 
Sent: den 28 mars 2020 22:26
To: Belotti, Sergio (Nokia - IT/Vimercate)
<mailto:[email-masked]> <[email-masked]>;
[email-masked] <mailto:[email-masked]> ;
[email-masked] <mailto:[email-masked]> ; Italo Busi
<mailto:[email-masked]> <[email-masked]>; Griseri, Enrico
(Nokia - IT/Vimercate)  <mailto:[email-masked]>
<[email-masked]>; Kelly, Colin (Nokia - CA/Ottawa)
<mailto:[email-masked]> <[email-masked]>; Gabriele Maria
Galimberti (ggalimbe)  <mailto:[email-masked]> <[email-masked]>;
([email-masked] <mailto:[email-masked]> )
<mailto:[email-masked]> <[email-masked]>; Aihua Guo
<mailto:[email-masked]> <[email-masked]>; Zhenghaomian
<mailto:[email-masked]> <[email-masked]>
Cc: Daniele Ceccarelli  <mailto:[email-masked]>
<[email-masked]>; Fatai  <mailto:[email-masked]>
<[email-masked]>; CCAMP  <mailto:[email-masked]> <[email-masked]>
Subject: Re: Summary of the CCAMP meeting on Optical Impairment Topology
YANG model

Hi all,

I completed my review of ietf-layer0-types.yang. Please find my comments
here:
https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-layer0-types/issues/9
<https://protect2.fireeye.com/v1/url?k=44194f13-1890e0da-44190f88-0cc47ad93e
1c-9a756a5f63c40108&q=1&e=5547670a-4e75-42ee-aad0-9ab56d8dea6d&u=https%3A%2F
%2Fgithub.com%2Fietf-ccamp-wg%2Fdraft-ietf-ccamp-layer0-types%2Fissues%2F9>
.

Thanks,
Dieter

During the meeting the major topic been discussed was related to the e-mail
exchange regarding [CCAMP] WG last call on draft-ietf-ccamp-wson-yang-23 and
in particular the issue raise by Dieter with the mail sent March 10 on ,
regarding the alignment among the different L0 YANG models with respect
ietf-layer0-types.

a.	ietf-ccamp-wson-yang;
b.	ietf-ccamp-flexigrid-yang;
c.	ietf-ccamp-wson-tunnel; 
d.	ietf-ccamp-flexigrid-media-channel-yang;
e.	ietf-dwdm-if-param-yang;
f.	ietf-ccamp-optical-impairment-topology-yang

1.	Go ahead to publish ietf-layer0-types as reference "types" module
for the set of drafts addressing "only" specific use cases that basically is
"spectrum allocation" (a,b,c d drafts) , creating in parallel a new
ietf-layer0-types-xxx that can be used for ietf-dwdm-if-param-yang and
ietf-ccamp-optical-impairment-topology-yang.

In this solution there is the problem to understand if the use case claimed
to be supported is possible without e.g. transpoder information like the
ones contained in the e, f drafts.

2.	Use "versioning" YANG paradigm, this solution permits to move ahead
in parallel two version of the same files "types", and v2 will incorporate
all the needed update for e and f drafts.

Before to take any choice, attendees of the call  decided that a careful
review of the ietf-layer0-types is needed to understand possible gaps with
respect all optical impairments and transponders description .

Moreover a new issue will be open in the ietf-layer0-types github to report
optical impairments related comments/concerns.

Thanks

Sergio

Sergio Belotti

Nokia 

M: +39-335761776