Subject: [CDNi] I-D Action: draft-ietf-cdni-use-cases-02.txt

From: [email-masked]
Date: Wed, 18 Jan 2012 07:13:59 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Content Delivery Networks Interconnection Working Group of the IETF.

	Title           : Use Cases for Content Delivery Network Interconnection
	Author(s)       : Gilles Bertrand
                          Stephan Emile
                          Grant Watson
                          Trevor Burbridge
                          Philip Eardley
                          Kevin Ma
	Filename        : draft-ietf-cdni-use-cases-02.txt
	Pages           : 18
	Date            : 2012-01-18

   Content Delivery Networks (CDNs) are commonly used for improving the
   End User experience of a content delivery service, at a reasonable
   cost.  This document outlines real world use cases (not technical
   solutions) for interconnecting CDNs.  It focuses on use cases that
   correspond to identified industry needs and that are expected to be
   realized once a CDN Interconnection (CDNI) solution is available.
   This document can be used to provide guidance to the CDNI WG about
   the interconnection arrangements to be supported and to validate the
   requirements of the various CDNI interfaces.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-cdni-use-cases-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-cdni-use-cases-02.txt

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Mon, 23 Jan 2012 14:08:04 -0800

Hi Gilles. The draft looks good. Just last few comments from me. :)

1) Why "as directed by the uCDN's RRI"? The content acquisition
information can come from the CDNI Metadata Interface. Did I miss the
discussion on using RRI for this particular case? 

Sect. 3.2.2:

   o  a downstream CDN may acquire content from an alternate Surrogate
      within an upstream CDN, as directed by the upstream CDN's request
      routing interface,

2) Typo "endusers" to "End Users".

Sect. 5.3:

                        For instance, a CSP may desire to ensure that
   content is delivered with URIs appearing to the endusers under the

3) Undefined terminology "CDN Exchange".

Sect. 5.3:

   Conversely, a CDN Provider might not want the brand of a CDN Exchange
   to be visible, even if the CDN Exchange is involved in the content
   delivery call flow.

4) Typo: .. authorizes the End User to access the content

Sect. 8:

   d.  The relationship between the End User and the CSP: the contract
       that authorizes the End User to access to the content.

Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, January 18, 2012 7:14 AM
To: [email-masked]
Cc: [email-masked]
Subject: [CDNi] I-D Action: draft-ietf-cdni-use-cases-02.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories. This draft is a work item of the Content Delivery Networks
Interconnection Working Group of the IETF.

	Title           : Use Cases for Content Delivery Network
Interconnection
	Author(s)       : Gilles Bertrand
                          Stephan Emile
                          Grant Watson
                          Trevor Burbridge
                          Philip Eardley
                          Kevin Ma
	Filename        : draft-ietf-cdni-use-cases-02.txt
	Pages           : 18
	Date            : 2012-01-18

_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 25 Jan 2012 11:22:42 +0100

Gilles and co-authors,

The poll on the list confirmed that we are ready to go to WG Last Call with the use-case document.
Can you issue a new rev addressing Kent's comments and we'll issue the Last Call on the updated version?

Thanks

Francois & Rich

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 25 Jan 2012 11:35:41 +0100

Kent, Gilles,

A few suggestions (as an Individual):

> discussion on using RRI for this particular case? 

The purpose of this section is (i) to describe the options for alternative content acquisition and (ii) clarify that while acquisition itself is out of scope for CDNI, the mechanism to allow selection among the several options is in scope.
So I'd suggest that in the use case document you simply don't attempt to specify which mechanism/interfaces is going to be used (ie don't even mention RRI or Metadata interface).
However, I would expect the framework document to get into that discussion. Would you mind reaching out to the framework authors to ensure it is covered appropriately there?

> 3) Undefined terminology "CDN Exchange".

We have agreed to try avoid using that term that means too many different things to different people.
I'd suggest something like a "transit CDN" or "an entity involved in the CDN interconnection" or "an intermediary in the CDN delegation chain".. 

>   to be visible, even if the CDN Exchange is involved in the content

BTW, I think "similarly" may be more appropriate than "conversely" since this is bringing up a similar scenario.

Cheers

Francois

> ftp://ftp.ietf.org/internet-drafts/draft-ietf-cdni-use-cases-02.txt

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: <[email-masked]>
Date: Thu, 26 Jan 2012 11:13:23 +0100

Hi François,

I'll answer your comments at the beginning of next week, and we will issue a revision at the end of next week.

Cheers,

Gilles

-----Message d'origine-----
De : Francois Le Faucheur [mailto:[email-masked]] 
Envoyé : mercredi 25 janvier 2012 11:23
À : BERTRAND Gilles RD-CORE-ISS
Cc : Le Faucheur Francois; [email-masked]; Kent Leung (kleung)
Objet : Re: [CDNi] I-D Action: draft-ietf-cdni-use-cases-02.txt

Gilles and co-authors,

Thanks

Francois & Rich 

On 23 Jan 2012, at 23:08, Kent Leung (kleung) wrote:

> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of [email-masked]
> directories. This draft is a work item of the Content Delivery 
> Networks Interconnection Working Group of the IETF.
>

---

From: Francois Le Faucheur <[email-masked]>
Date: Thu, 26 Jan 2012 14:15:48 +0100

> I'll answer your comments at the beginning of next week, and we will issue a revision at the end of next week.

Sounds like a plan.
Tx

(the comments were actually from Kent. I only added my 2cents on top of it).

Francois

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Fri, 27 Jan 2012 08:40:54 -0800

Hi Francois. My comments below.

From: Francois Le Faucheur (flefauch) 
Sent: Wednesday, January 25, 2012 2:36 AM
To: Kent Leung (kleung); [email-masked]
Cc: [email-masked]
Subject: Re: [CDNi] I-D Action: draft-ietf-cdni-use-cases-02.txt

Kent, Gilles,

KL> I agree that the draft should not specify which CDNI interface.

Kent

Sect. 3.2.2:

Sect. 5.3:

Sect. 5.3:

Cheers

Francois

Sect. 8:

Kent

-----Original Message-----

 

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked] <mailto:[email-masked]> 
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com <http://www.cisco.com> 

 Think before you print.

---

From: <[email-masked]>
Date: Mon, 30 Jan 2012 11:46:32 +0100

Kent, François,

Thanks for proofreading the draft.

About your comments:

1)      Ok, I have rephrased. In fact the call flows in the framework draft present cases where the "dCDN acquires content from an alternate Surrogate within an upstream CDN, as directed by the upstream CDN's request routing interface". However, currently, the framework draft does not address "Content Acquisition Resiliency" specifically.

OLD    o  a downstream CDN may acquire content from an alternate Surrogate
     within an upstream CDN, as directed by the upstream CDN's request
     routing interface,

NEW   o  a downstream CDN may acquire content from an alternate Surrogate
     within an upstream CDN, 

2)       Corrected

3)       Ok, I have rephrased.

OLD      Conversely, a CDN Provider might not want the brand of a CDN Exchange
  to be visible, even if the CDN Exchange is involved in the content
  delivery call flow.

NEW     Similarly, a CDN Provider might not want the

        brand of an intermediary in the CDN delegation chain to be visible, 

        even if the intermediary is involved in the content delivery call flow.

4)       Corrected

Cheers,

Gilles

De : Kent Leung (kleung) [mailto:[email-masked]] 
Envoyé : vendredi 27 janvier 2012 17:41
À : Francois Le Faucheur (flefauch); BERTRAND Gilles RD-CORE-ISS
Cc : [email-masked]
Objet : RE: [CDNi] I-D Action: draft-ietf-cdni-use-cases-02.txt

Kent, Gilles,

Kent

Sect. 3.2.2:

Sect. 5.3:

Sect. 5.3:

Cheers

Francois

Sect. 8:

Kent

-----Original Message-----

 

Francois Le Faucheur
Distinguished Engineer
Corporate Development

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France

 Think before you print.