Subject: [CDNi] Question regarding downstream CDN selection

From: Jan Seedorf <[email-masked]>
Date: Fri, 10 Feb 2012 14:57:40 +0000

Folks,

I have a question regarding downstream CDN selection. The introduction of the CDNI problem statement draft says: "As an example, a CSP could contract with an "authoritative" CDN Provider for the delivery of content and that authoritative CDN Provider could contract with one or more downstream CDN Provider(s) to distribute and deliver some or all of the content on behalf of the authoritative CDN Provider.  The formation and details of any business relationships between a CSP and a CDN Provider and between one CDN Provider and another CDN Provider are out of scope of this document.  However, no standards or open specifications currently exist to facilitate such CDN interconnection."

My question is if we always assume this model, where there is an "authoritative" CDN provider which transitively has itself contracted several downstream CDN providers. Or do we account for the possibility that potentially a CSP has own its own made several independent agreements with other CDNs (e.g. because they are covering different geographical areas). If we want to consider the latter case, how does the upstream CDN know for a given downstream CDN if it serves the content for a given CSP?

 - Jan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Francois Le Faucheur
> Sent: Monday, January 30, 2012 2:38 PM
> To: [email-masked]
> Subject: [CDNi] Working Group Last Call on draft-ietf-cdni-use-cases-03.txt
> 
> All,
> 
> This is the start of a two-week working group last call on draft-ietf-cdni-use-
> cases-03.txt:
> https://datatracker.ietf.org/doc/draft-ietf-cdni-use-cases/
> 
> This working group last call will end 13 Feb 2012. Please send your comments
> to the CDNI mailing list.
> 
> Francois & Rich
> 
> 
> Begin forwarded message:
> 
> 
> 	From: <[email-masked]>
> 
> 	Date: 30 January 2012 12:12:50 CET
> 
> 	To: <[email-masked]>
> 
> 	Subject: [CDNi] TR: I-D Action: draft-ietf-cdni-use-cases-03.txt
> 
> 
> 	Hi,
> 
> 	We have submitted a revision addressing Kent's comments.
> 
> 	http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-ietf-
> cdni-use-cases-02.txt&url2=http://tools.ietf.org/id/draft-ietf-cdni-use-
> cases-03.txt
> 
> 	Best regards,
> 
> 	Gilles
> 
> 
> 
> 
> 	-----Message d'origine-----
> 	De : [email-masked] [mailto:[email-masked]] De la
> part de [email-masked]
> 	Envoyé : lundi 30 janvier 2012 12:07
> 	À : [email-masked]
> 	Cc : [email-masked]
> 	Objet : [CDNi] I-D Action: draft-ietf-cdni-use-cases-03.txt
> 
> 
> 	A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Content Delivery Networks
> Interconnection Working Group of the IETF.
> 
> 	Title           : Use Cases for Content Delivery Network Interconnection
> 	Author(s)       : Gilles Bertrand
> 	                         Stephan Emile
> 	                         Grant Watson
> 	                         Trevor Burbridge
> 	                         Philip Eardley
> 	                         Kevin Ma
> 	Filename        : draft-ietf-cdni-use-cases-03.txt
> 	Pages           : 18
> 	Date            : 2012-01-30
> 
> 	  Content Delivery Networks (CDNs) are commonly used for
> improving the
> 	  End User experience of a content delivery service, at a reasonable
> 	  cost.  This document outlines real world use cases (not technical
> 	  solutions) for interconnecting CDNs.  It focuses on use cases that
> 	  correspond to identified industry needs and that are expected to be
> 	  realized once a CDN Interconnection (CDNI) solution is available.
> 	  This document can be used to provide guidance to the CDNI WG
> about
> 	  the interconnection arrangements to be supported and to validate
> the
> 	  requirements of the various CDNI interfaces.
> 
> 
> 	A URL for this Internet-Draft is:
> 	http://www.ietf.org/internet-drafts/draft-ietf-cdni-use-cases-03.txt
> 
> 	Internet-Drafts are also available by anonymous FTP at:
> 	ftp://ftp.ietf.org/internet-drafts/
> 
> 	This Internet-Draft can be retrieved at:
> 	ftp://ftp.ietf.org/internet-drafts/draft-ietf-cdni-use-cases-03.txt
> 
> 	_______________________________________________
> 	CDNi mailing list
> 	[email-masked]
> 	https://www.ietf.org/mailman/listinfo/cdni
> 	_______________________________________________
> 	CDNi mailing list
> 	[email-masked]
> 	https://www.ietf.org/mailman/listinfo/cdni
> 
> 
>

---

From: Ina Minei <[email-masked]>
Date: Fri, 10 Feb 2012 10:16:39 -0800

Jan, 

The answer to that question depends on how you assume redirection is done in the case you are describing, and I think this boils down to the different models of CDN federations. 

The first (the one described in the quote), relies on bilateral agreements. In that case, the request is redirected to the authoritative, who will  redirect to the best downstream.  

The second model (the one you describe), sounds like an exchange model, with multiple members of the exchange having a relation to the same CSP, and the request being redirected to a coordinating entity for the exchange.  In the second case, as you are pointing out, user location information is not enough to determine the CDN from which the content will be served (because that CDN may not be serving content for the CSP), and the set of candidate CDNs has to be determined based on the content. 

Ina 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jan Seedorf
Sent: Friday, February 10, 2012 6:58 AM
To: [email-masked]
Subject: [CDNi] Question regarding downstream CDN selection

Folks,

 - Jan

---

From: Jan Seedorf <[email-masked]>
Date: Tue, 28 Feb 2012 14:53:51 +0000

Dear Ina,

Thanks for your reply and sorry for my late answer. From your answer, it seems my description of the two different models was clear :), which is good.

Still, my question to this WG remains: do we assume either model or are we considering both of them?

And if we consider the second model (independent agreements with CP), is the fact that a dCDN can serve content for a given CP part of the "capabilities" part of the request routing interface?

 - Jan

> From: Ina Minei [mailto:[email-masked]]
> Sent: Friday, February 10, 2012 7:17 PM
> To: Jan Seedorf; [email-masked]
> Subject: RE: Question regarding downstream CDN selection
> 
> Jan,
> 
> The answer to that question depends on how you assume redirection is
> done in the case you are describing, and I think this boils down to the
> different models of CDN federations.
> 
> The first (the one described in the quote), relies on bilateral agreements. In
> that case, the request is redirected to the authoritative, who will  redirect to
> the best downstream.
> 
> The second model (the one you describe), sounds like an exchange model,
> with multiple members of the exchange having a relation to the same CSP,
> and the request being redirected to a coordinating entity for the exchange.
> In the second case, as you are pointing out, user location information is not
> enough to determine the CDN from which the content will be served
> (because that CDN may not be serving content for the CSP), and the set of
> candidate CDNs has to be determined based on the content.
> 
> Ina
> 
> Jan Seedorf
> I have a question regarding downstream CDN selection. The introduction of
> the CDNI problem statement draft says: "As an example, a CSP could contract
> with an "authoritative" CDN Provider for the delivery of content and that
> authoritative CDN Provider could contract with one or more downstream
> CDN Provider(s) to distribute and deliver some or all of the content on behalf
> of the authoritative CDN Provider.  The formation and details of any business
> relationships between a CSP and a CDN Provider and between one CDN
> Provider and another CDN Provider are out of scope of this document.
> However, no standards or open specifications currently exist to facilitate such
> CDN interconnection."
> 
> My question is if we always assume this model, where there is an
> "authoritative" CDN provider which transitively has itself contracted several
> downstream CDN providers. Or do we account for the possibility that
> potentially a CSP has own its own made several independent agreements
> with other CDNs (e.g. because they are covering different geographical
> areas). If we want to consider the latter case, how does the upstream CDN
> know for a given downstream CDN if it serves the content for a given CSP?
> 
>  - Jan
>