Subject: Re: [CDNi] Working Group Last Call on draft-ietf-cdni-use-cases-03.txt

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 22 Feb 2012 17:31:33 +0100

Folks,

The Last Call period for draft-ietf-cdni-use-cases has now closed, but we haven't received any comments, so we'll extend it until 2 March.
 
As per the show of hand at the last IETF meeting, quite a few of you are familiar with this document. So can you please have a look at the latest version and pass on your comments, or a brief statement like "I think it's ready" or "I think it needs rework before going further", so we can get explicit confirmation that the document is ready (or not) from the WG perspective.

Thanks

Francois & Rich

On 30 Jan 2012, at 14:37, Francois Le Faucheur wrote:

> All,
> 
> This is the start of a two-week working group last call on draft-ietf-cdni-use-cases-03.txt:
> https://datatracker.ietf.org/doc/draft-ietf-cdni-use-cases/
> 
> This working group last call will end 13 Feb 2012. Please send your comments to the CDNI mailing list.
> 
> Francois & Rich
> 
> 
> Begin forwarded message:
> 
>> From: <[email-masked]>
>> Date: 30 January 2012 12:12:50 CET
>> To: <[email-masked]>
>> Subject: [CDNi] TR: I-D Action: draft-ietf-cdni-use-cases-03.txt
>> 
>> Hi,
>> 
>> We have submitted a revision addressing Kent's comments.
>> 
>> http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-ietf-cdni-use-cases-02.txt&url2=http://tools.ietf.org/id/draft-ietf-cdni-use-cases-03.txt 
>> 
>> Best regards,
>> 
>> Gilles
>> 
>> 
>> 
>> 
>> -----Message d'origine-----
>> De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
>> Envoyé : lundi 30 janvier 2012 12:07
>> À : [email-masked]
>> Cc : [email-masked]
>> Objet : [CDNi] I-D Action: draft-ietf-cdni-use-cases-03.txt
>> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Content Delivery Networks Interconnection Working Group of the IETF.
>> 
>> 	Title           : Use Cases for Content Delivery Network Interconnection
>> 	Author(s)       : Gilles Bertrand
>>                          Stephan Emile
>>                          Grant Watson
>>                          Trevor Burbridge
>>                          Philip Eardley
>>                          Kevin Ma
>> 	Filename        : draft-ietf-cdni-use-cases-03.txt
>> 	Pages           : 18
>> 	Date            : 2012-01-30
>> 
>>   Content Delivery Networks (CDNs) are commonly used for improving the
>>   End User experience of a content delivery service, at a reasonable
>>   cost.  This document outlines real world use cases (not technical
>>   solutions) for interconnecting CDNs.  It focuses on use cases that
>>   correspond to identified industry needs and that are expected to be
>>   realized once a CDN Interconnection (CDNI) solution is available.
>>   This document can be used to provide guidance to the CDNI WG about
>>   the interconnection arrangements to be supported and to validate the
>>   requirements of the various CDNI interfaces.
>> 
>> 
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-cdni-use-cases-03.txt
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> This Internet-Draft can be retrieved at:
>> ftp://ftp.ietf.org/internet-drafts/draft-ietf-cdni-use-cases-03.txt
>> 
>> _______________________________________________
>> CDNi mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/cdni
>> _______________________________________________
>> CDNi mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/cdni
> 
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 22 Feb 2012 17:59:54 +0100

To cdni-use-cases authors,

I had another look and here are a few additional comments:

1) references to the "CDNI Working Group":
The IESG recommends we avoid referring to the Working Groups because those are only ephemeral and will be outlasted by this document.
For example:
"This document can be used to provide guidance to the CDNI WG about
   the interconnection arrangements to be supported and to validate the
   requirements of the various CDNI interfaces.
"
I suggest this is rephrased into something like "This document can be used to guide the definition of the requirements to be supported by the various CDNI interfaces defined in [I-D.ietf-cdni-problem-statement]".

2) references to the "CDNI solution":
The IESG requires that we do not refer to "solutions" from a given Working Group as this is too vague and changing.
For example:
"It focuses on use cases that correspond to identified industry needs and that are expected to be
   realized once a CDN Interconnection (CDNI) solution is available.
"
Perhaps this could be rephrased into something like:
"It focuses on use cases that correspond to identified industry needs and that are expected to be
   realized once open interfaces and protocols supporting interconnection of CDNs are specified and implemented."

3) "1.4.  The Need for CDN Interconnection Standards"
I think this section is in complete overlap with the cdni-problem-statement. In fact, it actually starts with:
"   The problem statement draft [I-D.ietf-cdni-problem-statement]
   describes extensively the CDNI problem space and explains why CDNI
   standards are required.
"
I suggest this section be removed altogether, and a reference to the cdni-problem-statement should appear earlier in the document (i.e. in teh first paragraphs of section 1).

Cheers

Francois

---

From: <[email-masked]>
Date: Mon, 27 Feb 2012 16:38:37 +0100

Hi François,

thanks for this review. 

We will wait for any other comment on the list until march 2nd (end of extended last-call period) and submit a final revision.

Best regards,

Gilles

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Francois Le Faucheur
Envoyé : mercredi 22 février 2012 18:00
À : [email-masked]
Cc : [email-masked]
Objet : Re: [CDNi] Working Group Last Call ondraft-ietf-cdni-use-cases-03.txt

Cheers

Francois

On 22 Feb 2012, at 17:31, Francois Le Faucheur wrote:

>>> http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-i
>>> etf-cdni-use-cases-02.txt&url2=http://tools.ietf.org/id/draft-ietf-c
>>> dni-use-cases-03.txt
>>> 
>>> Best regards,
>>> 
>>> Gilles
>>> 
>>> 
>>> 
>>> 
>>> De : [email-masked] [mailto:[email-masked]] De la part 
>>> de [email-masked] Envoyé : lundi 30 janvier 2012 12:07 À : 
>>> [email-masked] Cc : [email-masked] Objet : [CDNi] I-D Action: 
>>> draft-ietf-cdni-use-cases-03.txt
>>> 
>>>