Subject: [CDNi] FW: New Version Notification for draft-brandenburg-cdni-has-03.txt

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Fri, 13 Jul 2012 12:54:07 +0000

Hi all,

As you can see we just uploaded a new version of the HAS-CDNI draft. This is the version of the draft that we will be presenting during the Vancouver meeting. 

I'm looking forward to your comments and seeing you all in Vancouver!

Best regards,

Ray van Brandenburg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: vrijdag 13 juli 2012 14:50
To: Brandenburg, R. (Ray) van
Cc: [email-masked]; [email-masked]; Deventer, M.O. (Oskar) van
Subject: New Version Notification for draft-brandenburg-cdni-has-03.txt

A new version of I-D, draft-brandenburg-cdni-has-03.txt has been successfully submitted by Ray van Brandenburg and posted to the IETF repository.

Filename:	 draft-brandenburg-cdni-has
Revision:	 03
Title:		 Models for adaptive-streaming-aware CDN Interconnection
Creation date:	 2012-07-12
WG ID:		 Individual Submission
Number of pages: 43
URL:             http://www.ietf.org/internet-drafts/draft-brandenburg-cdni-has-03.txt
Status:          http://datatracker.ietf.org/doc/draft-brandenburg-cdni-has
Htmlized:        http://tools.ietf.org/html/draft-brandenburg-cdni-has-03
Diff:            http://tools.ietf.org/rfcdiff?url2=draft-brandenburg-cdni-has-03

Abstract:
   This documents presents thoughts on the potential impact of
   supporting HTTP Adaptive Streaming technologies in CDN
   Interconnection scenarios.  Our intent is to spur discussion on how
   the different CDNI interfaces could, and should, deal with content
   delivered using adaptive streaming technologies and to facilitate
   working group decisions.

The IETF Secretariat
This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/emaildisclaimer

---

From: Scott Wainner <[email-masked]>
Date: Mon, 23 Jul 2012 10:33:13 -0400

Ray,

Question on Section 3.5.4 Option 5.2.1: Flexible URL Signing by CSP

Fourth Paragraph:

"However, instead of signing the entire URL, the CSP signs
    the Relative URL (i.e. invariant portion of the URL) and conveys the
    protected portion in the authorization parameters embedded in the
    chunk URL."

Are we proposing query string semantics in the URL that define what 
portion of the URL elements are protected and the method?

In doing so, the CSP, uCDN, surrogates, and delivery nodes must support 
the query string semantics and methods.  The uCDN must be made aware of 
the dCDN's capabilities to support this method of authorization prior to 
dCDN selection.

I think this is noted in the section ...

"Effect on CDN Interfaces:

  o  Requires the ability to exclude the variant portion of URL in the
       signing process (NOTE: Issue is specific to URL Signing support
       for HAS content and not CDNI?)"

I think this issue is relevant not only for HAS and needs to be address 
in CDNI capabilities advertisement if we're recommending Flexible URL 
Signing.

Scott

On 7/13/12 8:54 AM, Brandenburg, R. (Ray) van wrote:
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni
> .
>

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Mon, 23 Jul 2012 15:00:30 +0000

Hi Scott,

Good point. 

Kent is the main author of URL signing section, so he's best suited to answer your question, but I think you have a point regarding the capability exchange this behavior would probably require. 

@Kent, what do you think?

BTW, now that we're talking about URL signing, I think the CDNI interfaces would require some document that describes URL signing in general anyway, and I'm not sure which document would be best suited for this. The obvious place would be the Request Routing draft, although URL signing might also have some repercussions on the Metadata interface. Any ideas on that? Or have I missed something and has this already been discussed on the list earlier? 

Ray

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott Wainner
Sent: maandag 23 juli 2012 16:33
To: [email-masked]
Subject: Re: [CDNi] FW: New Version Notification for draft-brandenburg-cdni-has-03.txt

Ray,

Fourth Paragraph:

Are we proposing query string semantics in the URL that define what portion of the URL elements are protected and the method?

In doing so, the CSP, uCDN, surrogates, and delivery nodes must support the query string semantics and methods.  The uCDN must be made aware of the dCDN's capabilities to support this method of authorization prior to dCDN selection.

I think this issue is relevant not only for HAS and needs to be address in CDNI capabilities advertisement if we're recommending Flexible URL Signing.

Scott

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Mon, 23 Jul 2012 16:15:46 +0000

On 23 Jul 2012, at 17:00, Brandenburg, R. (Ray) van wrote:

BTW, now that we're talking about URL signing, I think the CDNI interfaces would require some document that describes URL signing in general anyway,

and also describes it quite specifically (i.e. how exactly to locate the signature in URI, how to identify the fields in scope and parameters, and how to validate the signature).

and I'm not sure which document would be best suited for this. The obvious place would be the Request Routing draft, although URL signing might also have some repercussions on the Metadata interface.

I would picture:
* Request Routing Interface/Redirection specifies the URI Signing mechanism (algorithm, fields, parameters, encoding in URI,...)
* Metadata Interface specifies the CDNI Metadata object that needs to be exchanged across CDNs to allow signature validation by dCDN.

Cheers

Francois

Any ideas on that? Or have I missed something and has this already been discussed on the list earlier?

Ray

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Scott Wainner
Sent: maandag 23 juli 2012 16:33
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [CDNi] FW: New Version Notification for draft-brandenburg-cdni-has-03.txt

Ray,

Fourth Paragraph:

Scott

Best regards,

Ray van Brandenburg

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: vrijdag 13 juli 2012 14:50
To: Brandenburg, R. (Ray) van
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Deventer, M.O. (Oskar) van
Subject: New Version Notification for
draft-brandenburg-cdni-has-03.txt

Abstract:

The IETF Secretariat
This e-mail and its contents are subject to the DISCLAIMER at
http://www.tno.nl/emaildisclaimer
_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni
.

_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni
_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Mon, 23 Jul 2012 17:26:38 +0000

Hi Ray and Scott.

Thanks for the comments. Flexible URL Signing needs to be defined further. I'm planning to publish on URL Signing before the following IETF after Vancouver. This should cover some of the details for Flexible URL Signing such as protected query string in the URL used to specify the invariant portion.

I agree that this would require support in the CDNI's Request Routing Interface for capabilities advertisement.

As for CDNI document that covers URL Signing in a general way, should this be in the Framework doc? Currently, that draft does mention URI Signing for the CDNI Metadata Interface. The implications to the CDNI interfaces are covered in the last paragraph of the CDNI Considerations section. Probably should be incorporated into the Framework doc? Larry, what do you think?

Kent

-----Original Message-----
From: Brandenburg, R. (Ray) van [mailto:[email-masked]] 
Sent: Monday, July 23, 2012 8:01 AM
To: Scott Wainner (swainner); [email-masked]; Kent Leung (kleung)
Subject: RE: [CDNi] FW: New Version Notification for draft-brandenburg-cdni-has-03.txt

Hi Scott,

Good point. 

Ray

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott Wainner
Sent: maandag 23 juli 2012 16:33
To: [email-masked]
Subject: Re: [CDNi] FW: New Version Notification for draft-brandenburg-cdni-has-03.txt

Ray,

Fourth Paragraph:

Scott