Subject: Re: [CDNi] I-D Action: draft-lelouedec-cdni-request-routing-00.txt

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Wed, 18 Jul 2012 13:14:11 +0000

Authors,

This document spends a lot of time proposing to split the "Request Routing" interface into two interfaces. In particular, its conclusions include:

"
We also recommend to review the charter of the CDNI WG, in particular
   to replace the following objective:

   o  "WG Creation + 18 months: Submit specification of the CDNI Request
      Routing protocol to IESG as Proposed Standard"

   by the two following objectives:

   o  "WG Creation + 18 months: Submit specification of the CDNI Routing
      interface to IESG as Proposed Standard"

   o  "WG Creation + 18 months: Submit specification of the CDNI
      Downstream Resource Identifier Signaling (DRIS) Interface to IESG
      as Proposed Standard"
"

Can you guys consider the fact that the charter has already been updated two months ago (http://www.ietf.org/mail-archive/web/cdni/current/msg00989.html) to split the Request Routing into 2 interfaces and already reads:
"
	o Dec 2012 - Submit specification of the CDNI Request Routing/Redirection interface to IESG as Proposed Standard
...
	o Jun 2013 - Submit specification of the CDNI Request Routing/Footprint & Capabilities Advertisement interface to IESG as Proposed Standard
"

Does this not basically already address your point?

Cheers

Francois

On 9 Jul 2012, at 18:54, <[email-masked]>
 <[email-masked]> wrote:

> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : CDNI Request Routing
> 	Author(s)       : Yannick Le Louedec
>                          Anne Marrec
>                          Gilles Bertrand
>                          Marcin Pilarski
> 	Filename        : draft-lelouedec-cdni-request-routing-00.txt
> 	Pages           : 30
> 	Date            : 2012-07-09
> 
> Abstract:
>   The present document proposes to clarify the CDNI Request Routing
>   interface introduced in [I-D.ietf-cdni-framework] and [I-D.ietf-cdni-
>   problem-statement], as well as related terminology.
> 
>   In particular the present document proposes to split the CDNI Request
>   Routing interface into two separate interfaces with clearer roles,
>   named respectively CDNI Routing interface and CDNI Downstream
>   Resource Identifier Signaling interface (CDNI DRIS interface).
> 
>   This part of the CDN interconnection framework the IETF has been
>   referring to so far with the term "CDNI Request Routing" is just
>   another routing, signaling and forwarding problem in a long series of
>   the telecommunication history.  For example, one can draw a direct
>   analogy between the IP/MPLS-TE framework and the CDN interconnection
>   framework.
> 
>   In addition, this document recommends that the specification of ALL
>   CDN interconnection interfaces in the scope of the CDNI IETF WG
>   relies on the equivalent concept to IP prefix for CDN
>   interconnection, named 'contentRequestScope'.  This highly useful and
>   powerful concept SHALL be used to simplify the specification of ALL
>   CDN interconnection interfaces, as well as to ensure performance and
>   scalability in CDN interconnection.
> 
>   All these proposals can be smoothly integrated in the WG drafts,
>   especially [I-D.ietf-cdni-framework] and
>   [I-D.ietf-cdni-requirements], as they essentially propose (useful)
>   clarifications of the existing framework.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-lelouedec-cdni-request-routing
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-lelouedec-cdni-request-routing-00
> 
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: <[email-masked]>
Date: Thu, 19 Jul 2012 08:35:43 +0000

François,

Our draft proposes a constructive approach to help the working group progress on CDNI the request routing and signaling aspects. We therefore propose clarifications of the fundamental routing concepts in CDNI as we think that these concepts were not yet defined clearly enough.

The new charter indeed introduces a splitting of the request routing interface. We consider this as a good progress towards refining the interface roles and this move is consistent the spirit of our propositions, even if we are not fully satisfied with the current terminology, as explained in http://tools.ietf.org/html/draft-lelouedec-cdni-request-routing-00. 

We could live along with the current charter text and consider that:
- "Redirection interface" interface is close to what we call the "Downstream Resource Identifier Signaling interface"
- "Footprint & Capabilities Advertisement" is close to what we call the "CDNI Routing interface"
with the clarifications provided in http://tools.ietf.org/html/draft-lelouedec-cdni-request-routing-00.

We could start discussing this issue in the informal gathering on request routing proposed by Yannick on Sunday evening.

Best regards,
--
Gilles

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Francois Le Faucheur (flefauch)
Envoyé : mercredi 18 juillet 2012 15:14
À : [email-masked]
Objet : Re: [CDNi] I-D Action: draft-lelouedec-cdni-request-routing-00.txt

Authors,

"

Can you guys consider the fact that the charter has already been updated two months ago (http://www.ietf.org/mail-archive/web/cdni/current/msg00989.html) to split the Request Routing into 2 interfaces and already reads:
"
	o Dec 2012 - Submit specification of the CDNI Request Routing/Redirection interface to IESG as Proposed Standard ...
	o Jun 2013 - Submit specification of the CDNI Request Routing/Footprint & Capabilities Advertisement interface to IESG as Proposed Standard "

Cheers

Francois

On 9 Jul 2012, at 18:54, <[email-masked]>  <[email-masked]> wrote:

> Internet-Draft directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Fri, 20 Jul 2012 09:09:52 +0000

Hello Gilles,

> We could start discussing this issue in the informal gathering on request routing proposed by Yannick on Sunday evening.

Right.

My suggestion is that, after this discussion, you identify the incremental changes/clarification you still want to propose - given the current definition/description of the RR/Redirection interface and the RR/Footprint & Capabilities Advertisement interface (for example, consider also the description of these interfaces in the problem-statement) - and then structure those as:
	* proposed changes to the Framewok
	* proposed input into the work of the RR/Footprint & Advertisement Design Team 
	* proposed input into a RR/Redirection interface spec

This is just a suggestion aiming at making your input effective for the WG.

Cheers

Francois