Subject: [CDNi] FW: New Version Notification for draft-song-cdni-slr-based-footprint-01.txt

From: Songhaibin <[email-masked]>
Date: Mon, 16 Jul 2012 10:36:08 +0000

Hi,

We just submitted a draft about service level requirements based footprint. This draft is mainly used to generate the discussion on this aspect and it is still on a high level idea stage. We have not given deep thought on the details in this document. So any discussion and comments are welcome!

http://www.ietf.org/internet-drafts/draft-song-cdni-slr-based-footprint-01.txt

BR,
-Haibin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, July 16, 2012 6:31 PM
> To: Songhaibin
> Cc: [email-masked]
> Subject: New Version Notification for draft-song-cdni-slr-based-footprint-01.txt
> 
> 
> A new version of I-D, draft-song-cdni-slr-based-footprint-01.txt
> has been successfully submitted by Haibin Song and posted to the
> IETF repository.
> 
> Filename:	 draft-song-cdni-slr-based-footprint
> Revision:	 01
> Title:		 A SLR (Service Level Requirements) based footprint for CDNI
> Creation date:	 2012-07-16
> WG ID:		 Individual Submission
> Number of pages: 7
> URL:
> http://www.ietf.org/internet-drafts/draft-song-cdni-slr-based-footprint-01.txt
> Status:
> http://datatracker.ietf.org/doc/draft-song-cdni-slr-based-footprint
> Htmlized:
> http://tools.ietf.org/html/draft-song-cdni-slr-based-footprint-01
> Diff:
> http://tools.ietf.org/rfcdiff?url2=draft-song-cdni-slr-based-footprint-01
> 
> Abstract:
>    Footprint advertisement is a very important step for CDN
>    interconnection and generates a lot of discussion.  Actually, each
>    CDN can serve the whole world if its surrogates are publicly
>    reachable by IP addresses.  But if a CDN does that, it can not
>    satisfy the requirements from the applications.  So CDNs deliver
>    contents for applications, and the basic requirements should be from
>    the applications, but there is rare discussion on service level
>    requirements based footprint.  This document is used to generate the
>    discussion on this aspect.
> 
> 
> 
> 
> The IETF Secretariat

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Wed, 25 Jul 2012 07:53:01 +0000

Hello Haibin,

As per your request, you'll have a 5 min slot in Vancouver to introduce this notion of service level requirements based footprint. 
Moving forward, I strongly recommend you input your ideas directly into the work of the "CDNI Footprint and Capabilities Advertisement" Design Team that is chartered with defining the semantics of the information that is to be advertised.

Thanks

Francois

On 16 Jul 2012, at 12:36, Songhaibin wrote:

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Songhaibin <[email-masked]>
Date: Thu, 26 Jul 2012 04:55:41 +0000

OK. Thanks for the good suggestion. I notice there will be side meeting on footprint and cap advertisement. I will try to join the discussion.

-Haibin

> From: Francois Le Faucheur (flefauch) [mailto:[email-masked]]
> Sent: Wednesday, July 25, 2012 3:53 PM
> To: Songhaibin
> Cc: [email-masked]; Jan Seedorf; Jon Peterson ([email-masked]);
> Stefano Previdi (sprevidi)
> Subject: Re: [CDNi] New Version Notification for
> draft-song-cdni-slr-based-footprint-01.txt
> 
> Hello Haibin,
> 
> As per your request, you'll have a 5 min slot in Vancouver to introduce this notion
> of service level requirements based footprint.
> Moving forward, I strongly recommend you input your ideas directly into the
> work of the "CDNI Footprint and Capabilities Advertisement" Design Team that is
> chartered with defining the semantics of the information that is to be advertised.
> 
> Thanks
> 
> Francois
> 
> > We just submitted a draft about service level requirements based footprint.
> This draft is mainly used to generate the discussion on this aspect and it is still on
> a high level idea stage. We have not given deep thought on the details in this
> document. So any discussion and comments are welcome!
> >
> >> Subject: New Version Notification for
> draft-song-cdni-slr-based-footprint-01.txt
> >>
> >>

---

From: Songhaibin <[email-masked]>
Date: Wed, 1 Aug 2012 00:19:53 +0000

I just lost my chance to present this draft with my bad English. It reserved my energy:) Someone asked me, why do not you call it SLA based footprint? The answer is, the upstream CDN needs to sign SLA with each application for the content distribution, but I do not know if the upstream CDN needs to sign SLA with the downstream CDN for each application, probably not. In that case, the upstream CDN has to translate the performance and other requirements to the technical parameters and tells the downstream CDN. And the downstream CDN just tells the upstream CDN its footprint which can satisfy these requirements. Besides that,   SLA is out of scope for IETF.

We do not talk in the document about the issue when some downstream CDNs can cover the same area (while satisfies the application requirements). It is reasonable to choose one with even better performance (needs a lot of work), or just choose the cheaper one(saves energe for this WG).

BR,
-Haibin
________________________________________
From: [email-masked] [[email-masked]] on behalf of Songhaibin [[email-masked]]
Sent: Thursday, July 26, 2012 12:55 PM
To: Francois Le Faucheur (flefauch)
Cc: [email-masked]
Subject: Re: [CDNi] New Version Notification    for     draft-song-cdni-slr-based-footprint-01.txt

-Haibin

---

From: zhangyunfei <[email-masked]>
Date: Wed, 1 Aug 2012 08:47:10 +0800

Does this involves request redirection interface interactions? I mean, maybe the request redirected by uCDN can fetch the SLA information (after translation to parameters). In this sense, it should be transferred in the request routing interface.

BR
Yunfei

zhangyunfei

From: Songhaibin
Date: 2012-08-01 08:19
CC: [email-masked]

BR,
-Haibin

-Haibin

---

From: Songhaibin <[email-masked]>
Date: Wed, 1 Aug 2012 01:21:52 +0000

It's okay to do it, but footprint may have its own interface, although all these CDNI interfaces migh share a same underlying protocol (e.g. http).

-Haibin

________________________________
From: zhangyunfei [[email-masked]]
Sent: Wednesday, August 01, 2012 8:47 AM
To: Songhaibin; Francois Le Faucheur (flefauch)
Cc: [email-masked]
Subject: Re: Re: [CDNi] New Version Notification for draft-song-cdni-slr-based-footprint-01.txt

BR
Yunfei

________________________________
zhangyunfei

From: Songhaibin<mailto:[email-masked]>
Date: 2012-08-01 08:19
To: Francois Le Faucheur (flefauch)<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>
Subject: Re: [CDNi] New Version Notification for draft-song-cdni-slr-based-footprint-01.txt
I just lost my chance to present this draft with my bad English. It reserved my energy:) Someone asked me, why do not you call it SLA based footprint? The answer is, the upstream CDN needs to sign SLA with each application for the content distribution, but I do not know if the upstream CDN needs to sign SLA with the downstream CDN for each application, probably not. In that case, the upstream CDN has to translate the performance and other requirements to the technical parameters and tells the downstream CDN. And the downstream CDN just tells the upstream CDN its footprint which can satisfy these requirements. Besides that,   SLA is out of scope for IETF.

BR,
-Haibin

-Haibin

---

From: zhangyunfei <[email-masked]>
Date: Wed, 1 Aug 2012 09:27:24 +0800

I am not sure if I understand right
The SLR parameters are from the user agent instead of from the CDN itself. Is it in the same category as footprint interface?

zhangyunfei

From: Songhaibin
Date: 2012-08-01 09:21
To: zhangyunfei; Francois Le Faucheur (flefauch)
CC: [email-masked]
Subject: RE: Re: [CDNi] New Version Notification for draft-song-cdni-slr-based-footprint-01.txt
It's okay to do it, but footprint may have its own interface, although all these CDNI interfaces migh share a same underlying protocol (e.g. http).

-Haibin

BR
Yunfei

zhangyunfei

From: Songhaibin
Date: 2012-08-01 08:19

BR,
-Haibin

-Haibin

---

From: Songhaibin <[email-masked]>
Date: Wed, 1 Aug 2012 05:19:46 +0000

No. The SLR parameters are translated from the SLA by upstream CDN. This SLA is signed by upstream CDN and content distribution applications.

BR,

-Haibin

________________________________
From: zhangyunfei [[email-masked]]
Sent: Wednesday, August 01, 2012 9:27 AM
To: Songhaibin; Francois Le Faucheur (flefauch)
Cc: [email-masked]
Subject: Re: RE: [CDNi] New Version Notification for draft-song-cdni-slr-based-footprint-01.txt

From: Songhaibin<mailto:[email-masked]>
Date: 2012-08-01 09:21
To: zhangyunfei<mailto:[email-masked]>; Francois Le Faucheur (flefauch)<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>
Subject: RE: Re: [CDNi] New Version Notification for draft-song-cdni-slr-based-footprint-01.txt

-Haibin

BR
Yunfei

BR,
-Haibin

-Haibin