Subject: Re: [CDNi] Long Tail personalized content delivery over CDN Interconnections

From: ramki Krishnan <[email-masked]>
Date: Fri, 3 Aug 2012 08:04:11 -0700

Hi Kevin,

Thanks a lot for your comments. Please see response below

Kevin:

>>Wrt CDNI, what is it that draft-krishnan-cdni-long-tail-00 is proposing?

>>The CDNI requirements (specifically META-14) already discuss distribution control policies, including preventing delegation.  Beyond the ability to >>prevent delegation, are you proposing that CDNs be required to implement analytics-based delegation policies?  That seems somewhat beyond our scope.

Ramki:
The CDNi req META-14 is about the selection of dCDN, but what long tail draft is proposing is the selection of uCDN based on the content attribute, i.e. whether the content is long tail personalized or not. The long tail draft also brings in the concept of no caching in the uCDN and dCDN for certain types of content based on the content attribute, for e.g. long tail personalized content. The impacts of this on CDNi request routing is also explained.

Thanks, ramki

From: Bhumip Khasnabish [mailto:[email-masked]]
Sent: Tuesday, July 31, 2012 10:55 AM
To: [email-masked]
Cc: Ram Krishnan; ramki Krishnan; [email-masked]
Subject: Fwd: Long Tail personalized content delivery over CDN Interconnections

FYI.. looking for comments and suggestions on delivery of
the most popular to long tail personalized content over CDNI.

This document presents the issues and suggests solutions in delivering long tail
personalized content in CDN Interconnection scenarios. Thanks a lot.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
I-D Action: draft-krishnan-cdni-long-tail-00.txt
________________________________

 *   To: i-d-announce at ietf.org<mailto:[email-masked]>
 *   Subject: I-D Action: draft-krishnan-cdni-long-tail-00.txt
 *   From: internet-drafts at ietf.org<mailto:[email-masked]>
 *   Date: Mon, 30 Jul 2012 16:49:30 -0700
 *   Delivered-to: i-d-announce at ietfa.amsl.com<mailto:[email-masked]>
 *   List-archive: <http://www.ietf.org/mail-archive/web/i-d-announce>
 *   List-help: <mailto:[email-masked]?subject=help>
 *   List-id: Internet Draft Announcements only <i-d-announce.ietf.org<http://i-d-announce.ietf.org/>>
 *   List-post: <mailto:[email-masked]>
 *   List-subscribe: <https://www.ietf.org/mailman/listinfo/i-d-announce>, <mailto:[email-masked]?subject=subscribe>
 *   List-unsubscribe: <https://www.ietf.org/mailman/options/i-d-announce>, <mailto:[email-masked]?subject=unsubscribe>
 *   Reply-to: internet-drafts at ietf.org<mailto:[email-masked]>

________________________________

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Long Tail personalized content delivery over CDN Interconnections

        Author(s)       : Ram Krishnan

                          Mian Li

                          Bhumip Khasnabish

        Filename        : draft-krishnan-cdni-long-tail-00.txt

        Pages           : 7

        Date            : 2012-07-30

Abstract:

   The content desire of users is evolving from most popular to long

   tail personalized content. This document presents the issues and

   suggests solutions in delivering long tail personalized content in

   CDN Interconnection scenarios.

The IETF datatracker status page for this draft is:

https://datatracker.ietf.org/doc/draft-krishnan-cdni-long-tail

There's also a htmlized version available at:

http://tools.ietf.org/html/draft-krishnan-cdni-long-tail-00

Internet-Drafts are also available by anonymous FTP at:

ftp://ftp.ietf.org/internet-drafts/

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Fri, 3 Aug 2012 15:15:01 +0000

On 3 Aug 2012, at 17:04, ramki Krishnan wrote:

Hi Kevin,

>>The CDNI requirements (specifically META-14) already discuss distribution control policies, including preventing delegation.  Beyond the ability to >>prevent delegation, are you proposing that CDNs…

Ramki:
The CDNi req META-14 is about the selection of dCDN, but what long tail draft is proposing is the selection of uCDN

the selection of uCDN by whom?

based on the content attribute, i.e. whether the content is long tail personalized or not. The long tail draft also brings in the concept of no caching in the uCDN

The intra-CDN decision of the uCDN to cache or not is generally outside the scope of CDNI. We are not disagreeing that the uCDN may elect to not cache some content (and in that case to not redirect to a dCDN), but this does not seem directly related to CDNI.

and dCDN for certain types of content based on the content attribute, for e.g. long tail personalized content. The impacts of this on CDNi request routing is also explained.

Can you summarize again very briefly the interaction you see between the desire to not cache some content and the CDNI interfaces? (when discussing Request Routing, please separate the impact you see on the Request Routing/Redirection interface vs Request Routing/Footprint & Cap Interface).

Thanks

Thanks, ramki

From: Bhumip Khasnabish [mailto:[email-masked]]
Sent: Tuesday, July 31, 2012 10:55 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Ram Krishnan; ramki Krishnan; [email-masked]<mailto:[email-masked]>
Subject: Fwd: Long Tail personalized content delivery over CDN Interconnections

        Author(s)       : Ram Krishnan

                          Mian Li

                          Bhumip Khasnabish

        Pages           : 7

        Date            : 2012-07-30

Abstract:

_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni