Subject: [CDNi] XML vs JSON

From: "Matt Caulfield (mcaulfie)" <[email-masked]>
Date: Fri, 22 Feb 2013 21:12:17 +0000

Hi everyone,

While writing the CDNI metadata draft, we have been struggling with the choice between XML and JSON for encoding metadata. 

We are turning to the list for inspiration and hopefully a decision. Below is an extremely high level synopsis of the options. 

XML
  Verbose.
  Flexible.
  Allows for both elements and attributes.
  Standardized schema definition language.
  Includes concept of namespaces.

JSON
  Terse. 
  Fast to parse.
  Allows for ordered lists.

If you feel strongly one way or the other, please chime in. 

See the metadata draft for an example of both: http://tools.ietf.org/html/draft-ietf-cdni-metadata-00#section-5.4

Thanks,
Matt

---

From: Michael Hallgren <[email-masked]>
Date: Fri, 22 Feb 2013 22:45:00 +0100

>   Includes concept of namespaces.

In favor of XML, because it's a more general one than JSON.

>   Allows for ordered lists.

A good choice for light-weight specific things. Am I missing something?

Cheers,
mh

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Gurer Ozen <[email-masked]>
Date: Sat, 23 Feb 2013 14:35:13 -0500

Cheers,
mh

---

From: Gurer Ozen <[email-masked]>
Date: Sat, 23 Feb 2013 14:36:58 -0500

> Includes concept of namespaces.

JSON has couple of options for namespaces:

http://tools.ietf.org/html/draft-saintandre-json-namespaces-00
http://www.tbray.org/ongoing/When/201x/2010/01/17/Extensible-JSON

P.S.: Sorry for the other repost, gmail (+…) feature caused some problems with mailing list.

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Tue, 26 Feb 2013 14:00:49 +0000

Slight preference for JSON, as I see 'fast to parse' and 'terse' as the most important properties. 

Ray

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Matt Caulfield (mcaulfie)
Sent: vrijdag 22 februari 2013 22:12
To: [email-masked]
Subject: [CDNi] XML vs JSON

Hi everyone,

XML
  Verbose.
  Flexible.

JSON
  Terse. 
  Fast to parse.

Thanks,
Matt
_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni
This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/emaildisclaimer

---

From: zhangyunfei <[email-masked]>
Date: Wed, 27 Feb 2013 11:42:00 +0800

+1 in case that JSON can support self-defined elements/attributes (I am not sure of this).

BR
Yunfei

zhangyunfei

From: Brandenburg, R. (Ray) van
Date: 2013-02-26 22:00
To: Matt Caulfield (mcaulfie)
CC: [email-masked]
Subject: Re: [CDNi] XML vs JSON
Slight preference for JSON, as I see 'fast to parse' and 'terse' as the most important properties. 

Ray

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Matt Caulfield (mcaulfie)
Sent: vrijdag 22 februari 2013 22:12
To: [email-masked]
Subject: [CDNi] XML vs JSON

Hi everyone,

XML
  Verbose.
  Flexible.

JSON
  Terse. 
  Fast to parse.

Thanks,
Matt

https://w