Subject: [CDNi] draft-ietf-cdni-metadata and ccid/sid

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Mon, 10 Jun 2013 12:50:25 +0000

To cdni-metadata authors,

In cdni-logging, we need to define logging fields to record the Content Collection ID (CCID) and Session ID (SID). 
Is a format for these fields already specified in cdni-metadata? 
If not, do you plan to do so in the next rev?

Thanks

Francois

---

From: "Matt Caulfield (mcaulfie)" <[email-masked]>
Date: Mon, 10 Jun 2013 20:17:48 +0000

Hello Francois,

A format for these fields is not yet defined. Both will be included in the next revision of the metadata draft.

Regards,
Matt

-----Original Message-----
From: Francois Le Faucheur (flefauch) 
Sent: Monday, June 10, 2013 8:50 AM
To: [email-masked]
Cc: Francois Le Faucheur (flefauch); <[email-masked]>; Roy Peterkofsky; [email-masked]
Subject: draft-ietf-cdni-metadata and ccid/sid

Thanks

Francois

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 11 Jun 2013 13:40:56 +0000

Matt and all,

Just did a little more thinking on this, and it occurred to me that:
	* while both CCID and SID need to be conveyed inside CDNI Logging
	* only CCID probably needs to be conveyed in CDN Metadata

Basically, the idea is that the CCID is indeed distributed by uCDN to dCDN (as a property of the content), the Session-ID (when supported) is something that is generated locally, on a per session basis obviously, by the dCDN. So the SID shoudl not be distributed through CDNI metadata.

I checked back in http://www.ietf.org/id/draft-brandenburg-cdni-has-05.txt and the wording seems consistent with what I describe above.

"
 … a "Content Collection IDentifier (CCID)" field is
   distributed through the CDNI Metadata Interface and the same CCID
   value is associated through the CDNI Metadata interface with every
   chunk of the same Content Collection.  
   … When distributed, and CCID logging is
   requested from the dCDN, the dCDN Surrogates are to store the CCID
   value in the corresponding log entries.
"

"
, if the downstream CDN happens to have sufficient HAS
   awareness to be able to generate a "Session IDentifier (Session-ID)",
   optionally including such Session-ID (in addition to the CCID) in the
   per-chunk log record would further facilitate optional summarization
   performed at step [f]. 
"

Do we all agree that CCID needs to be distributed in cdni-metadata but SID need not?

If yes, then:
	1) sorry for misleading you earlier in requesting definition of SID in the cdni-metadata document.
	2) please have next rev of cdni-metadata defines CCID and not SID
	2) we'll have cdni-logging refer to cdni-metadata for CCID , and cdni-logging refer to cdni-has for SID.

Cheers

Francois

---

From: "Matt Caulfield (mcaulfie)" <[email-masked]>
Date: Tue, 11 Jun 2013 13:43:50 +0000

Thanks for the clarification, Francois - that makes more sense (I was wondering why SID was necessary). I agree with your statements below.

The next revision of the metadata draft will include CCID but not SID (assuming no objections).

-----Original Message-----
From: Francois Le Faucheur (flefauch) 
Sent: Tuesday, June 11, 2013 9:41 AM
To: Matt Caulfield (mcaulfie)
Cc: Francois Le Faucheur (flefauch); [email-masked]; <[email-masked]>; Roy Peterkofsky; [email-masked]
Subject: Re: draft-ietf-cdni-metadata and ccid/sid

Matt and all,

"
 ... a "Content Collection IDentifier (CCID)" field is
   distributed through the CDNI Metadata Interface and the same CCID
   value is associated through the CDNI Metadata interface with every
   chunk of the same Content Collection.  
   ... When distributed, and CCID logging is
   requested from the dCDN, the dCDN Surrogates are to store the CCID
   value in the corresponding log entries.
"

"

If yes, then:

Cheers

Francois