Subject: Re: [CDNi] Stephen Farrell's Discuss on draft-ietf-cdni-redirection-17: (with DISCUSS and COMMENT)

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 12 Jul 2016 21:49:55 +0100

Stephen, WG group,

Following up on the other outstanding comment.

> On 29 Apr 2016, at 13:00, Niven - Jenkins, Ben (Nokia - GB) <[email-masked]> wrote:
> On 16/04/2016 07:44, "EXT Ben Niven-Jenkins" <[email-masked]>
> wrote:
>>> On 24 Mar 2016, at 15:07, Ben Niven-Jenkins <[email-masked]>
>>> wrote:
>>>> On 17 Mar 2016, at 10:10, Stephen Farrell <[email-masked]>
>>>> wrote:I 
>>>> - 4.4.2: a JSON "string" is not the same as a DNS name is it?
>>>> What about i18n? (ULABEL or ALABEL?) what about odd characters
>>>> allowed in JSON but not in DNS names?  In general the fields
>>>> in this dictionary (and others) seem underspecified to me.
>>> 
>>> I’m afraid I’m not an expert in JSON strings, unicode or i18n. I think
>>> what you’re getting at is that a JSON string can contain more characters
>>> than allowed by an ALABEL or a ULABEL and we should be more precise in
>>> constraining the allowed characters? And that you think there are other
>>> fields in the document that would also benefit from constraining the
>>> allowable set of characters. If that’s the case I’m happy to make the
>>> edits to improve the document but I will need some help on what the
>>> right terminology is and the right references for the allowable
>>> characters.
>> 
>> Any suggestions for someone who could help with reviewing the doc from a
>> unicode & i18n angle and helping me get the terminology and set of
>> allowable characters right?
> 
> Nudging again as to whether you have any suggestions for someone to help
> out here?

At the risk of exposing my lack of knowledge in this area, I did some reading and gave it a bit of thought and think I have a proposal:

We state that the values for the qname & cname dictionary keys "MUST contain the ASCII-compatible encoded (ACE) representation of an internationalised domain name”.

My thinking is the ACE representation (ALABEL) is the on the wire format and it is better to pass the on the wire format across as-is than try to convert it to a unicode label & back again just to represent it in JSON.

If that sounds a sensible approach, is there a DNS expert who I could work with to make sure I have the terminology & wording right?

(I’m not sure if the wording above would also adequately cover non-internationalised domain names?)

Thanks
Ben

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 26 Jul 2016 12:58:10 +0100

Hi Ben,

On Tue, Jul 12, 2016, at 09:49 PM, Ben Niven-Jenkins wrote:
> At the risk of exposing my lack of knowledge in this area, I did some
> reading and gave it a bit of thought and think I have a proposal:
> 
> We state that the values for the qname & cname dictionary keys "MUST
> contain the ASCII-compatible encoded (ACE) representation of an
> internationalised domain name”.
> 
> My thinking is the ACE representation (ALABEL) is the on the wire format
> and it is better to pass the on the wire format across as-is than try to
> convert it to a unicode label & back again just to represent it in JSON.

Make sense.

> If that sounds a sensible approach, is there a DNS expert who I could
> work with to make sure I have the terminology & wording right?
> 

A-LABEL is the correct term for non ASCII domain labels. NR-LDH is the
correct term for ASCII only labels. I think your text in -19 looks right
as written.