Subject: [CDNi] TR: New Version Notification for draft-fieau-cdni-interfaces-https-delegation-04.txt

From: <[email-masked]>
Date: Tue, 3 Jul 2018 09:14:34 +0000

Dear all,

I posted an update of the draft "CDNI extensions for HTTPS delegation" that aims at extending CDNI metadata to handle delegation methods being proposed at the IETF.

We've made few corrections in the text and in the metadata model. We also added potential support for the LURK mechanism.
We still think that this topic is of interest for the CDNI WG and that it deserves more attention.

Regards,
Frederic

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : lundi 2 juillet 2018 13:47
À : Sanjay Mishra; STEPHAN Emile IMT/OLN; STEPHAN Emile IMT/OLN; FIEAU Frédéric IMT/OLN
Objet : New Version Notification for draft-fieau-cdni-interfaces-https-delegation-04.txt

A new version of I-D, draft-fieau-cdni-interfaces-https-delegation-04.txt
has been successfully submitted by Frederic Fieau and posted to the
IETF repository.

Name:		draft-fieau-cdni-interfaces-https-delegation
Revision:	04
Title:		CDNI extensions for HTTPS delegation
Document date:	2018-07-02
Group:		Individual Submission
Pages:		13
URL:            https://www.ietf.org/internet-drafts/draft-fieau-cdni-interfaces-https-delegation-04.txt
Status:         https://datatracker.ietf.org/doc/draft-fieau-cdni-interfaces-https-delegation/
Htmlized:       https://tools.ietf.org/html/draft-fieau-cdni-interfaces-https-delegation-04
Htmlized:       https://datatracker.ietf.org/doc/html/draft-fieau-cdni-interfaces-https-delegation
Diff:           https://www.ietf.org/rfcdiff?url2=draft-fieau-cdni-interfaces-https-delegation-04

Abstract:
   The delivery of content over HTTPS involving multiple CDNs raises
   credential management issues.  This document proposes extensions in
   CDNI Control and Metadata interfaces to setup HTTPS delegation from
   an Upstream CDN (uCDN) to a Downstream CDN (dCDN).

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Kevin Ma <[email-masked]>
Date: Sun, 8 Jul 2018 15:02:27 -0400

Hi Frederic,

  Couple of comments (as an individual) on the updated draft:

  - section 4.1: Do we need MI.SecureDelegation?  Doesn't the presence (or
lack thereof) of an AcmeStarDelegationMethod, SubcertsDelegationMethod,
and/or LurkDelegationMethod imply support (or lack thereof) for the given
method?  Support for the "*Method" objects would seem to obviate the need
for the SecureDelegation object?

  - section 4.1: There is a missing set of curly braces around the
TimeWindowRule and a missing "]" for the list of TimeWindowRules, in the
TimeWindowACL example.

  - sections 6.1/6.2/6.3: The references to "Section 5.1" need to be
updated to be for section 4.1, 4.2.1, and 4.2.2, respectively.

  - section 6.4: There is a section missing for LurkDelegationMethod,
referencing section 4.2.3.

thanx.

--  Kevin J. Ma

On Tue, Jul 3, 2018 at 5:14 AM, <[email-masked]> wrote:

> Dear all,
>
> I posted an update of the draft "CDNI extensions for HTTPS delegation"
> that aims at extending CDNI metadata to handle delegation methods being
> proposed at the IETF.
>
> We've made few corrections in the text and in the metadata model. We also
> added potential support for the LURK mechanism.
> ____________________________________________________________
> _____________________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni
>

---

From: Kevin Ma <[email-masked]>
Date: Sun, 8 Jul 2018 15:09:53 -0400

also, for each metadata property, please add a "Mandatory-to-Specify: "
description.

On Sun, Jul 8, 2018 at 3:02 PM, Kevin Ma <[email-masked]> wrote:

>> URL:            https://www.ietf.org/internet-
>> drafts/draft-fieau-cdni-interfaces-https-delegation-04.txt
>> Status:         https://datatracker.ietf.org/
>> doc/draft-fieau-cdni-interfaces-https-delegation/
>> Htmlized:       https://tools.ietf.org/html/d
>> raft-fieau-cdni-interfaces-https-delegation-04
>> Htmlized:       https://datatracker.ietf.org/
>> doc/html/draft-fieau-cdni-interfaces-https-delegation
>> Diff:           https://www.ietf.org/rfcdiff?
>> url2=draft-fieau-cdni-interfaces-https-delegation-04
>>
>> Abstract:

---

From: <[email-masked]>
Date: Mon, 9 Jul 2018 09:39:53 +0000

Hi Kevin,

Thanks for your comments. I will update the draft accordingly.

Regards,
Frederic

De : Kevin Ma [mailto:[email-masked]]
Envoyé : dimanche 8 juillet 2018 21:10
À : FIEAU Frédéric IMT/OLN
Cc : [email-masked]
Objet : Re: [CDNi] TR: New Version Notification for draft-fieau-cdni-interfaces-https-delegation-04.txt

also, for each metadata property, please add a "Mandatory-to-Specify: " description.

On Sun, Jul 8, 2018 at 3:02 PM, Kevin Ma <[email-masked]<mailto:[email-masked]>> wrote:
Hi Frederic,

  - section 4.1: Do we need MI.SecureDelegation?  Doesn't the presence (or lack thereof) of an AcmeStarDelegationMethod, SubcertsDelegationMethod, and/or LurkDelegationMethod imply support (or lack thereof) for the given method?  Support for the "*Method" objects would seem to obviate the need for the SecureDelegation object?

  - section 4.1: There is a missing set of curly braces around the TimeWindowRule and a missing "]" for the list of TimeWindowRules, in the TimeWindowACL example.

  - sections 6.1/6.2/6.3: The references to "Section 5.1" need to be updated to be for section 4.1, 4.2.1, and 4.2.2, respectively.

  - section 6.4: There is a section missing for LurkDelegationMethod, referencing section 4.2.3.

thanx.

--  Kevin J. Ma

On Tue, Jul 3, 2018 at 5:14 AM, <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Regards,
Frederic

-----Message d'origine-----
De : [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Envoyé : lundi 2 juillet 2018 13:47
À : Sanjay Mishra; STEPHAN Emile IMT/OLN; STEPHAN Emile IMT/OLN; FIEAU Frédéric IMT/OLN
Objet : New Version Notification for draft-fieau-cdni-interfaces-https-delegation-04.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni