Subject: Re: [CDNi] Fwd: New Version Notification for draft-finkelman-cdni-rr-sva-extensions-01.txt

From: Kevin Ma <[email-masked]>
Date: Sun, 8 Jul 2018 15:51:34 -0400

Hi Ori,

  (As an individual) I think the extensions are applicable outside of SVA
OC, but I don't think it's bad to have that motivation in the draft.

  Some comments on the updated draft:

  - section 2: Maybe add something in the beginning that more explicitly
describes why this is a capability and not a bootstrap or metadata (i.e.,
it can change over time due to dynamic scaling or failover so doesn't fit
in bootstrap and goes from dCDN to uCDN, unlike metadata which goes from
uCDN to dCDN).

  - esction 2.1: Do you want to add a simple json example?

  - section 2.2: Don't know if it would help, but you could add a simple
ABNF for constructing the Location URI.

  - section 2 nits:
    "route client request" -> "route client requests"
    "may be to rough" -> "may be too rough"
    "limitations, for example" -> "limitations: for example,"
    "or a list of uCDN hosts" -> "a list of uCDN hosts"
    "advertise them within" -> "advertise the hosts within"
    "that this redirect target is attached to" -> "to which this redirect
target is attached"
    "which is attached" -> "that is attached"
    "Example of MI." -> "Example of a MI."

  - section 2.2 nits:
    "with trailing slash" -> "with a trailing slash"
    "weather or not" -> "whether or not"
    "Example of MI." -> "Example of a MI."

  - section 3 nits:
    "to which it can route the request to" -> "to which it can route the
request"
    "failures, or temporary" -> "failures or temporary"
    "In this case the cache" -> "In this case, the cache"
    "HTTP redirect, in the case of HTTP redirection mode": remove the comma
or even just remove the whole clause after the comma?
    "dCDN responsibility" -> "dCDN's responsibility"
    "which is used for requesting" -> "that may have been used to request"
    "Example of MI." -> "Example of a MI."
    remove "(which contains two fallback-address objects)"
    "which hosts addreses" -> "which host address"

thanx!

--  Kevin J. Ma

On Wed, May 16, 2018 at 5:55 AM, Ori Finkelman <[email-masked]> wrote:

> Dear colleagues,
> We have just submitted version 01 of this draft.
>
> A general question about this draft and next to come. do you think we
> should keep it in the context of SVA extensions ? currently SVA and Open
> Caching a references in this draft as the source of the requirements.
> Should we keep it this way, or remove it and make it more generic ?
>
> Thanks,
> Ori
>
>
>
> ---------- Forwarded message ----------
> From: <[email-masked]>
> Date: Wed, May 16, 2018 at 12:51 PM
> Subject: New Version Notification for draft-finkelman-cdni-rr-sva-
> extensions-01.txt
> To: Sanjay Mishra <[email-masked] <[email-masked]>>,
> Ori Finkelman <[email-masked]>
>
>
>
> A new version of I-D, draft-finkelman-cdni-rr-sva-extensions-01.txt
> has been successfully submitted by Ori Finkelman and posted to the
> IETF repository.
>
> Name:           draft-finkelman-cdni-rr-sva-extensions
> Revision:       01
> Title:          CDNI SVA Request Routing Extensions
> Document date:  2018-05-15
> Group:          Individual Submission
> Pages:          11
> URL:            https://www.ietf.org/internet-
> drafts/draft-finkelman-cdni-rr-sva-extensions-01.txt
> Status:         https://datatracker.ietf.org/
> doc/draft-finkelman-cdni-rr-sva-extensions/
> Htmlized:       https://tools.ietf.org/html/d
> raft-finkelman-cdni-rr-sva-extensions-01
> Htmlized:       https://datatracker.ietf.org/
> doc/html/draft-finkelman-cdni-rr-sva-extensions
> Diff:           https://www.ietf.org/rfcdiff?
> url2=draft-finkelman-cdni-rr-sva-extensions-01
>
> Abstract:
>    The Open Caching working group of the Streaming Video Alliance is
>    focused on the delegation of video delivery requests from commercial
>    CDNs to a caching layer at the ISP.  In that aspect, Open Caching is
>    a specific use case of CDNI, where the commercial CDN is the upstream
>    CDN (uCDN) and the ISP caching layer is the downstream CDN (dCDN).
>
>
>
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
>
>
> --
>
> *Ori Finkelman*Qwilt | Work: +972-72-2221647 | Mobile: +972-52-3832189 |
> [email-masked]
>
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni
>
>

---

From: Ori Finkelman <[email-masked]>
Date: Mon, 9 Jul 2018 12:39:54 +0300

Hi Kevin,
Thanks for the feedback.
I have incorporated all your comments but the ABNF.
Let's keep the ABNF to be discussed in the CDNI meeting.

Thanks,
Ori

On Sun, Jul 8, 2018 at 10:51 PM, Kevin Ma <[email-masked]> wrote:

>     "HTTP redirect, in the case of HTTP redirection mode": remove the
> comma or even just remove the whole clause after the comma?
>> Subject: New Version Notification for draft-finkelman-cdni-rr-sva-ex
>> tensions-01.txt

--