Subject: Re: [CDNi] I-D Action: draft-ietf-cdni-request-routing-extensions-02.txt

From: Kevin Ma <[email-masked]>
Date: Sun, 5 May 2019 00:24:45 -0400

Hi All,

  (as chair) I added a milestone after the last IETF to get this draft
submitted by June.  I believe the contents are uncontroversial (though
please speak up if you disagree), and the proposed metadata and
capabilities submitted via WG draft are inline with the extensibility model
we sought to achieve for the MI and FCI interfaces.

  To that end, as is our custom, I've done a pre-shepherd review.  I
encourage everyone to also give it a read and speak up if you have any
thoughts or concerns, as we try to move it forward.

Ori/Sanjay:

  Please find my comments below.

thanx!

--  Kevin J. Ma

- section 2:
  - I would add a sentence before the property definitions (and possibly
make it a subsection): "The Redirect Target capability object consists of
the following three properties:
  - I would make the json example its own section, referenced from section
4.1.1
  - I would add the http-target json from section 2.2 to this full example.
  - nits:
    ", for example" -> ", for example," or ", e.g.,"
    ", for example" -> ", for example," or ", e.g.,"
    ", or due to network problems" -> " or network problems"
    "Due to this variable" -> "Given the variable"
    ", and a more dynamic," -> ".  A more dynamic"
    "may be using third party DNS resolver" -> "may be using a third party
DNS resolver"
    "or it can be set" -> "or can be set"
    "Redirect Target Capability" -> "Redirect Target capability"
    "When dCDN is" -> "When a dCDN is"
    "one of these uCDN hosts" -> "one of those uCDN hosts"
    "DNS routers take routing decisions" -> "DNS routers make routing
decisions"
    "URI to be used as a value of" -> "URI to be used as the value for"
    "Example of Redirect Target Capability object" -> "The following is an
example of a Redirect Target capability object serialization"
    "Target address for DNS A record" -> "Target address for a DNS A record"
    "No. but" -> "No, but"
    "Target URI for HTTP redirect" -> "Target URI for a HTTP redirect"

- section 2.1:
  - nits:
    "gives the instructions to construct the target address for the DNS
response for delegation" -> "gives the target address for the DNS response
to delegate"

- section 2.2:
  - nits:
    "gives the instructions to construct the target Location URI for http
redirection" -> "gives the necessary information to construct the target
Location URI for HTTP redirection."
    ", i.e." -> ", i.e.,"
    ", i.e." -> ", i.e.,"
    "In case this flag is true" -> "If set to true"
    "In case this flag is true" -> "If set to true"

- section 3:
  - I would add a sentence before the property definition (and possibly
make it a subsection): "The MI.FallbackTarget Metadata object consists of
the following single property:
  - I would make the json example its own section, referenced from section
4.1.2
  - In the case of DNS redirect, would it be acceptable for the uCDN to
advertise a host with a port, and say the dCDN must ignore/drop the port?
or should there be two properties, one for DNS and one for HTTP, similar to
Redirect Target?
  - nits:
    "requires that the uCDN should provide" -> "requires that the uCDN
provide a"
    "to the dCDN to be used" -> "to the dCDN, to be used"
    "differnet than the original address at the uCDN" -> "different from
the original uCDN address"
    "caches, or a client located outside" -> "caches or outside"
    "DNS redirection mode" -> "DNS redirection"
    "dCDN path-prefix and the uCDN host name" -> "dCDN path-prefix and/or
the uCDN hostname"

- section 4.1:
  "IANA CDNI Payload Type registry" -> "IANA \"CDNI Payload Types\"
registry"

- section 5:
  - I think you also need to add a "Privacy" section?

On Sun, Mar 31, 2019 at 7:53 AM <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Content Delivery Networks Interconnection
> WG of the IETF.
>
>         Title           : CDNI Request Routing Extensions
>         Authors         : Ori Finkelman
>                           Sanjay Mishra
>         Filename        : draft-ietf-cdni-request-routing-extensions-02.txt
>         Pages           : 11
>         Date            : 2019-03-31
>
> Abstract:
>    The Open Caching working group of the Streaming Video Alliance is
>    focused on the delegation of video delivery requests from commercial
>    CDNs to a caching layer at the ISP.  In that aspect, Open Caching is
>    a specific use case of CDNI, where the commercial CDN is the upstream
>    CDN (uCDN) and the ISP caching layer is the downstream CDN (dCDN).
>    The extensions specified in this document to the CDNI Metadata and
>    FCI interfaces are derived from requirements raised by Open Caching
>    but are applicable to CDNI use cases in general.
>
>
>
> The IETF datatracker status page for this draft is:
>
> https://datatracker.ietf.org/doc/draft-ietf-cdni-request-routing-extensions/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-cdni-request-routing-extensions-02
>
> https://datatracker.ietf.org/doc/html/draft-ietf-cdni-request-routing-extensions-02
>
> A diff from the previous version is available at:
>
> https://www.ietf.org/rfcdiff?url2=draft-ietf-cdni-request-routing-extensions-02
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni
>

---

From: "Ori Finkelman (IETF)" <[email-masked]>
Date: Sun, 5 May 2019 11:49:55 +0300

Thanks Kevin for the review and comments.
I'll fix the draft accordingly and will wait for others to comment before
submitting a fixed version.

Best regards,
Ori

On Sun, May 5, 2019 at 7:25 AM Kevin Ma <[email-masked]> wrote:

>> This draft is a work item of the Content Delivery Networks
>> Interconnection WG of the IETF.
>>
>>         Filename        :
>> draft-ietf-cdni-request-routing-extensions-02.txt
>>         Pages           : 11
>>         Date            : 2019-03-31
>>
>> Abstract:
>> https://datatracker.ietf..org/doc/draft-ietf-cdni-request-routing-extensions/
>> <https://datatracker.ietf.org/doc/draft-ietf-cdni-request-routing-extensions/>
>>