Subject: [Cellar] Cleaning up the Codec Specs section of the Matroska specification

From: Ashley Blewer <[email-masked]>
Date: Tue, 1 Nov 2016 22:49:06 -0400

Hello! I just opened this pull request on matroska-specification, here:
https://github.com/Matroska-Org/matroska-specification/pull/66

With the following sentiment...
"Hello! This pull request seeks, primarily, to break the approved codecs
out of their occasionally-hierarchical table and into more simple charting
for better viewing in Markdown, HTML, and (most importantly) RFC text. This
pull request does NOT attempt to make assertions about the codecs or their
descriptions, which will need to be reviewed by people with a stronger
historical knowledge."

So, like I said in the comment, the descriptions, and maybe the codecs
existing or not, need a lot of refinements that I can't solely work on, so
any help is appreciated.

I think this above pull request should be (commented/modified) and merged
based on structural changes only, and then we can proceed to refactor the
content at a more granular level. Is there redundant information? Are there
codecs that should be eliminated from the list? Has a codec been modified?
Should a CodecPrivate element be defined, or must it?

Thanks!

Ashley

---

From: Michael Bradshaw <[email-masked]>
Date: Wed, 2 Nov 2016 11:57:11 -0700

Is there a particular Markdown renderer I should use to look at this? GitHub's
rendering isn't very readable
<https://github.com/ablwr/matroska-specification/blob/0641157dcb8221874d523c710d58cd629a38e1d3/codec_specs.md>
(granted,
the original looked even worse on GitHub
<https://github.com/Matroska-Org/matroska-specification/blob/e5d06fbde1cc3d2eaaeaa7a27c3b50a756c7f13f/codec_specs.md>).
I think making the spec more readable is a good idea.

On Tue, Nov 1, 2016 at 7:49 PM, Ashley Blewer <[email-masked]>
wrote:

> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>
>

---

From: Ashley Blewer <[email-masked]>
Date: Wed, 2 Nov 2016 15:01:39 -0400

Ohhh. You'd think I'd take a look at the results IN Markdown (in addition
to the other two) after changing them TO Markdown, right? I forget Github
gets a little finicky with the acknowledgement of new line characters.
Thanks, let me just bulk-add some spaces in between.

On Wed, Nov 2, 2016 at 2:57 PM, Michael Bradshaw <[email-masked]> wrote:

> <https://github.com/ablwr/matroska-specification/blob/0641157dcb8221874d523c710d58cd629a38e1d3/codec_specs.md> (granted,

---

From: Ashley Blewer <[email-masked]>
Date: Wed, 2 Nov 2016 15:38:14 -0400

The latest in the branch should look better in Github Markdown:
https://github.com/ablwr/matroska-specification/blob/ab/codec_specs-table/
codec_specs.md

I also added emphasis around the Codec ID, name, description for improved
readability.

On Wed, Nov 2, 2016 at 3:01 PM, Ashley Blewer <[email-masked]>
wrote:

>>> I think this above pull request should be (commented/modified) and
>>> merged based on structural changes only, and then we can proceed to
>>> refactor the content at a more granular level. Is there redundant
>>> information? Are there codecs that should be eliminated from the list? Has
>>> a codec been modified? Should a CodecPrivate element be defined, or must it?
>>>
>>> Thanks!
>>>
>>> Ashley
>>>
>>>

---

From: Dave Rice <[email-masked]>
Date: Sat, 19 Nov 2016 12:18:23 -0500

I added a few comments in the pull request, but support merging this as-is as a formatting update, so that we can work on content adjustments in subsequent pull requests.
Dave

> On Nov 2, 2016, at 3:38 PM, Ashley Blewer <[email-masked]> wrote:
> 
> The latest in the branch should look better in Github Markdown: https://github.com/ablwr/matroska-specification/blob/ab/codec_specs-table/codec_specs.md <https://github.com/ablwr/matroska-specification/blob/ab/codec_specs-table/codec_specs.md>
> 
> I also added emphasis around the Codec ID, name, description for improved readability.
> 
> On Wed, Nov 2, 2016 at 3:01 PM, Ashley Blewer <[email-masked] <mailto:[email-masked]>> wrote:
> Ohhh. You'd think I'd take a look at the results IN Markdown (in addition to the other two) after changing them TO Markdown, right? I forget Github gets a little finicky with the acknowledgement of new line characters. Thanks, let me just bulk-add some spaces in between.
> 
> On Wed, Nov 2, 2016 at 2:57 PM, Michael Bradshaw <[email-masked] <mailto:[email-masked]>> wrote:
> Is there a particular Markdown renderer I should use to look at this? GitHub's rendering isn't very readable <https://github.com/ablwr/matroska-specification/blob/0641157dcb8221874d523c710d58cd629a38e1d3/codec_specs.md> (granted, the original looked even worse on GitHub <https://github.com/Matroska-Org/matroska-specification/blob/e5d06fbde1cc3d2eaaeaa7a27c3b50a756c7f13f/codec_specs.md>). I think making the spec more readable is a good idea.
> 
> On Tue, Nov 1, 2016 at 7:49 PM, Ashley Blewer <[email-masked] <mailto:[email-masked]>> wrote:
> Hello! I just opened this pull request on matroska-specification, here: https://github.com/Matroska-Org/matroska-specification/pull/66 <https://github.com/Matroska-Org/matroska-specification/pull/66>
> 
> "Hello! This pull request seeks, primarily, to break the approved codecs out of their occasionally-hierarchical table and into more simple charting for better viewing in Markdown, HTML, and (most importantly) RFC text. This pull request does NOT attempt to make assertions about the codecs or their descriptions, which will need to be reviewed by people with a stronger historical knowledge."
> 
> So, like I said in the comment, the descriptions, and maybe the codecs existing or not, need a lot of refinements that I can't solely work on, so any help is appreciated.
> 
> I think this above pull request should be (commented/modified) and merged based on structural changes only, and then we can proceed to refactor the content at a more granular level. Is there redundant information? Are there codecs that should be eliminated from the list? Has a codec been modified? Should a CodecPrivate element be defined, or must it?
> 
> Thanks!
> 
> Ashley
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> 
> 
> 
>