Subject: [Cellar] The upcoming transition to xml2rfc v3 (fwd) RFC Editor: The upcoming transition to xml2rfc v3

From: Michael Richardson <[email-masked]>
Date: Sun, 08 Sep 2019 12:56:09 +0100

Subject: The upcoming transition to xml2rfc v3
From: RFC Editor <[email-masked]>
To: RFC Interest <[email-masked]>, [email-masked]
Cc: [email-masked], [email-masked], IESG <[email-masked]>, [email-masked], RFC Editor <[email-masked]>
Date: Thu, 5 Sep 2019 21:23:25 -0700
List-Id: IETF-Discussion <ietf.ietf.org>

Greetings,

With the RFC format transition approaching quickly, we want to share
some of the transition details.  

The RFC Editor will be switching to using xml2rfc v3 [0] [1] [2] to
create RFCs. (Authors do not have to change what they submit as an
Internet-Draft.)

There will be new publication formats (HTML, PDF, and text) and an XML
source file, which uses the v3 vocabulary as described in [3] and
[4]. 

Next week the RFC Editor's code base and database will be updated.
>From 16 September 2019, the RFC Editor will be ready to publish in the
new format.  See the transition details [6] for more information.  

For more details on why this change is taking place, see the "RFC
Format Framework” [5]. 

* How does this affect you?  
Please see the transition details page [6], especially if you
currently have a document in the RFC Editor queue [7].

* What if you find a bug in xml2rfc? 
Please add a ticket to the issue tracker [8] or send mail to the
xml2rfc-dev list [9].

[0] Tool: https://pypi.org/project/xml2rfc/
[1] Intro: https://tools.ietf.org/src/xml2rfc/trunk/cli/doc/xml2rfc3.html
[2] FAQ: https://www.rfc-editor.org/materials/FAQ-xml2rfcv3.html
[3] RFC 7991: https://www.rfc-editor.org/rfc/rfc7991
[4] Implementation Notes: https://tools.ietf.org/html/draft-levkowetz-xml2rfc-v3-implementation-notes-09
[5] RFC 7990: https://www.rfc-editor.org/rfc/rfc7990.txt
[6] Transition Details: https://www.rfc-editor.org/rse/wiki/doku.php?id=v3implementation 
[7] Current Queue: https://www.rfc-editor.org/current_queue.php
[8] Issue Tracker: https://trac.tools.ietf.org/tools/xml2rfc/trac/
[9] XML Development Mailing list: https://www.ietf.org/mailman/listinfo/xml2rfc-dev

Thank you.
RFC Editor

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 22 Sep 2019 09:27:56 +0200

Since we generate XML files in v2 and then generate HTML and TXT
versions, should we transition to generate v3 XML files and just
submit that ?

Le dim. 8 sept. 2019 à 13:55, Michael Richardson <[email-masked]> a écrit :
>
>
>
>
> ---------- Forwarded message ----------
> Bcc:
> ---------- Forwarded message ----------
> From: Michael Richardson <[email-masked]>
> To: [email-masked]
> Cc:
> Bcc:
> Date: Sun, 08 Sep 2019 12:56:09 +0100
> Subject: [Cellar] The upcoming transition to xml2rfc v3 (fwd) RFC Editor: The upcoming transition to xml2rfc v3
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman