Subject: [Cellar] Roman Danyliw's No Objection on draft-ietf-cellar-ebml-14: (with COMMENT)

From: Roman Danyliw via Datatracker <[email-masked]>
Date: Tue, 03 Dec 2019 10:54:07 -0800

Roman Danyliw has entered the following ballot position for
draft-ietf-cellar-ebml-14: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-cellar-ebml/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 1.  Please add a reference to Matroska instead of an inline URL

Section 1.  Please add a reference for WebM

Section 2 and Table 4 of Section 5.  These sections define EBML Class. 
However, it isn’t used else where in the document.  What is it supposed to be
used for?

Section 4.4.  Recommend replacing “This table” text to be the name of specific
table in question (i.e., Table 1, Table 2)

Section 6.2.  Per “Unknown-Sized Element MUST NOT be used or defined
unnecessarily; however if the Element Data Size is not known before the Element
Data is written, such as in some cases of data streaming, then Unknown- Sized
Elements MAY be used.”, should this text be read as “the Unknown- Sized
Elements MUST only be used if the Element Data Size is not known before the
Element Data is written”.  I’m having trouble understanding how to handle
normative language for a qualitative statement of “unnecessarily”

Section 11.1.5.1.  Double checking on the grammar of the name attribute – it is
permitted to start with a “-“ or a “.”?

Section 11.1.5.3.  Are there any uniqueness properties for an id attribute? 
Drawing a parallel from XML,  I would have thought that each EBML element would
have unique ID per doctype (say like an xml:id)

Section 11.1.7.2.  documentation@purpose has a number of possible enumerated
values, however, none are defined in the text (they are only listed)

---

From: Steve Lhomme <[email-masked]>
Date: Tue, 10 Dec 2019 20:53:32 +0100

Hello Roman,

Thanks for taking the time to read and comment the document. Here are
my replies to your remarks.

> https://datatracker.ietf.org/doc/draft-ietf-cellar-ebml/

OK

> Section 1.  Please add a reference for WebM

OK

> However, it isn’t used else where in the document.  What is it supposed to be

It was used later in the document for Class A to Class D. But we don't
use that terminology anymore. Dave Rice has been replaced in a new
Pull Request:
https://github.com/cellar-wg/ebml-specification/pull/306

> table in question (i.e., Table 1, Table 2)

OK

> Element Data is written”.

Yes, your suggestion has been integrated.

>  I’m having trouble understanding how to handle

No. The text has been updated accordingly.

> have unique ID per doctype (say like an xml:id)

No, the same id can be used by multiple element. Only the Path must be
unique. Although it's not explicitly mentioned.

> values, however, none are defined in the text (they are only listed)

A table has been added to define the various values in detail.

>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman

---

From: Dave Rice <[email-masked]>
Date: Fri, 13 Dec 2019 09:13:45 -0500

> On Dec 10, 2019, at 2:53 PM, Steve Lhomme <[email-masked]> wrote:
> 
> Hello Roman,
> 
> <[email-masked] <mailto:[email-masked]>> a écrit :
>> 
> https://github.com/cellar-wg/ebml-specification/pull/306 <https://github.com/cellar-wg/ebml-specification/pull/306>

This has been reviewed and merged.

> unique. Although it's not explicitly mentioned.

This mention is added in https://github.com/cellar-wg/ebml-specification/pull/310/files <https://github.com/cellar-wg/ebml-specification/pull/310/files>.

I think all comments here have been addressed. Thanks so much for your review, Roman.

>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> 
> 
> 
> -- 
> Steve Lhomme
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 13 Dec 2019 18:19:29 +0000

Hi Steve!

Thanks for making these changes and explaining the id attribute.  They address my COMMENTs.

Regards,
Roman

From: iesg <[email-masked]> On Behalf Of Dave Rice
Sent: Friday, December 13, 2019 9:14 AM
To: Steve Lhomme <[email-masked]>
Cc: Roman Danyliw <[email-masked]>; Steven Villereal <[email-masked]>; [email-masked]; [email-masked]; The IESG <[email-masked]>; Codec Encoding for LossLess Archiving and Realtime transmission <[email-masked]>
Subject: Re: [Cellar] Roman Danyliw's No Objection on draft-ietf-cellar-ebml-14: (with COMMENT)

On Dec 10, 2019, at 2:53 PM, Steve Lhomme <[email-masked]<mailto:[email-masked]>> wrote:

Hello Roman,

Le mar. 3 déc. 2019 à 19:54, Roman Danyliw via Datatracker
<[email-masked]<mailto:[email-masked]>> a écrit :

OK

OK

OK

This mention is added in https://github.com/cellar-wg/ebml-specification/pull/310/files.

_______________________________________________
Cellar mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cellar

_______________________________________________
Cellar mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cellar