Subject: [Cellar] DRAFT AGENDA for VIRTUAL INTERIM MEETING 2019-12-10

From: Michael Richardson <[email-masked]>
Date: Sun, 01 Dec 2019 16:14:29 -0500

{additions and changes welcome}

CELLAR -- DRAFT AGENDA for Virtual Interim Meeting
December 10, 2019      19:00 UTC
                       21:00 Amsterdam
                       15:00 NYC
                       12:00 San Francisco

INFO:
   https://datatracker.ietf.org/meeting/interim-2019-cellar-10/session/cellar
   https://datatracker.ietf.org/doc/agenda-interim-2019-cellar-10-sessa/

WEB CONFERENCE:
   https://appear.in/cellar-interim
   THERE IS NO TELEPHONE DIALIN (You can try this at any time.)
   These notes at: https://github.com/cellar-wg/chair-notes

1. Note Well.
2. Accept draft minutes from September 24 meeting (attached below)

3. Logistics for Meeting.
   2a) Etherpad for notes
       https://etherpad.ietf.org/p/notes-cellar-virtual?useMonospaceFont=true

   2b) APPEAR.IN is not called "whereby.com"
       https://whereby.com/cellar-interimw

   2c) Roll call

4. Establish meeting schedule for 2020!

5. WG status update
   * EBML -- version 13 was posted 2019-10-22, on IESG telechat for 2019-12-05
   * FFV1 -- version 10 was posted 2019-10-23, waiting for AD writeup.

6. Work on Matroska issues.

7. Any other business.

NEXT meeting is TBD.

====
CELLAR -- DRAFT AGENDA for Virtual Interim Meeting
October 22, 2019     19:00 UTC
                       21:00 Amsterdam
                       15:00 NYC
                       12:00 San Francisco

Present:
	1. Michael Richardson
	1. Martin Below
	1. Jérôme Martinez
	1. Steve Lhomme
	1. Dave Rice

INFO:
   https://datatracker.ietf.org/meeting/interim-2019-cellar-09/session/cellar
   https://datatracker.ietf.org/doc/agenda-interim-2019-cellar-09-sessa/

WEB CONFERENCE:
    https://whereby.com/cellar-interim
   THERE IS NO TELEPHONE DIALIN (You can try this at any time.)
   These notes at: https://github.com/cellar-wg/chair-notes

1. Note Well. https://www.ietf.org/about/note-well/
2. Accept draft minutes from September 24 meeting (attached below)

3. Logistics for Meeting.
   2a) Etherpad for notes
       https://etherpad.ietf.org/p/notes-cellar-virtual?useMonospaceFont=true

   2b) APPEAR.IN is now called "whereby.com"
       https://whereby.com/cellar-interim

   2c) Roll call

4. WG status update
   * EBML -- version 13 was posted 2019-10-22, waiting for AD.
   * FFV1  -- version 10 was posted 2019-10-10, waiting for AD.

5. Interest in using gerrithub.io?
   For non-CLI uses, github has limitations lacking a web-based rebase
   process.  http://gerrithub.io/

6. Work on Matroska issues.
  ** now that EBML has provided the side-data container, we can start adding side-data types to Matroska.
  ** Google (WEBM) has created some new blocks (for HDR information) in the container, and we need to make sure we do not collide.     https://github.com/cellar-wg/matroska-specification/issues/345
		*** can we get them to coordinate better?
		*** now it is finished, but we need to try again.  We could say that values up to 10 are reserved.

EBML issue: implementation note default? publish a new version?
mcr: says go ahead with new version as you wish.

FFV1: still waiting, but there are some issues raised by new decoder for v3. And we should clarify the text.

7. Any other business.

NEXT meeting is 2019-12-03 moved to 2019-12-10.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Dave Rice <[email-masked]>
Date: Sun, 1 Dec 2019 16:53:40 -0500

> On Dec 1, 2019, at 4:14 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

There was a lot of recent updates based on the feedback, so I just posted version 14.

>   * FFV1 -- version 10 was posted 2019-10-23, waiting for AD writeup.

Version 11 was posted on 2019-10-23.

> FFV1: still waiting, but there are some issues raised by new decoder for v3.. And we should clarify the text.
> 
> 
> 7. Any other business.
> 
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

---

From: Reto Kromer <[email-masked]>
Date: Mon, 2 Dec 2019 09:17:06 +0100

>December 10, 2019      19:00 UTC

I am afraid, I cannot make it, because I will be teaching all
week in Hyderabad (where the meeting would start at 00:30 next
day).

Best regards, Reto

---

From: Michael Richardson <[email-masked]>
Date: Tue, 10 Dec 2019 14:10:39 -0500

Just to remind.

---

From: "Peter B." <[email-masked]>
Date: Tue, 10 Dec 2019 20:55:36 +0100

Short question about web conference URL for this meeting:

>      >https://whereby.com/cellar-interimw

You wrote "appear.in is *not* called whereby.com", but 
"appear.in/cellar-interim" returns a "404 not found", but 
"whereby.com/cellar-interim" seems to work.

Which one is the correct URL?

Thank you very much,
Peter B.

---

From: Steve Lhomme <[email-masked]>
Date: Tue, 10 Dec 2019 21:02:00 +0100

Indeed, I had to create a group and then I'm alone. It looks quite
different from the previous times.

Michael, any help ?

-- 
Steve Lhomme
Matroska association Chairman

---

From: Steve Lhomme <[email-masked]>
Date: Tue, 10 Dec 2019 21:05:33 +0100

https://whereby.com/cellar-interim is the one

---

From: Michael Richardson <[email-masked]>
Date: Tue, 10 Dec 2019 16:17:29 -0500

Future meetings will probably be:

   2020-01-21.
   2020-02-25
   2020-03-31   (IETF week is 20-27, I goofed during the call)
   2020-04-28
   2020-05-26
   2020-06-23
   skip July    (IETF week is july 25-31 in Madrid)
   2020-08-28
   2020-09-22   possibly in-person with NoTimeToWait - 2020 in AMS.
   2020-10-27
   2020-12-01

Here are the draft minutes from today.

REGRETS:
     1) Reto Kromer

PRESENT:
    1) Michael Richardson
    2) Benjamin Turkus
    3) Dave Rice
    4) Martin Below
    5) Michael Niedermayer
    6) Peter Bubestinger
    7) Steve Lhomme
    8) Jerome Martinez
    9) Dante Bromkovsky

INFO:

WEB CONFERENCE:

1. Note Well.  https://www.ietf.org/about/note-well/
2. Accept draft minutes from October 22 meeting (attached below)
	no objections or changes noted.

   2c) Roll call

4. Establish meeting schedule for 2020!
     Fourth tuesday of the month.  Starting January 28, 2020.
     No meeting in July.
     September meeting might be 22nd, at conference "No Time to Wait". (web page for the last one: https://mediaarea.net/NoTimeToWait4 , in Amsterdam 2020 September)
     November meeting moved to Tuesday, December 1.

5. WG status update
   * EBML -- version 14 was posted 2019-12-02, on IESG telechat for 2019-12-05
               --- deferred as document was too long for some IESG membes to get a handle on
   * FFV1 -- version 11 was posted 2019-10-23, waiting for AD writeup.

Dave Rice reports that changes that occured today was as a result of a review; some figures and tables are now cross-referenced more clearly.
The same was done to ffv1.  Some help is needed to get appropriate captions on the tables.
Robert Sparks asks that new versions not be updated until there are replies and instructions.
ACTION: MCR to followup with Robert Sparks on IANA issue.
  -> EBML is a "general purpose audio/video container"  Steve to fix #304.

Split the main Matroska document to take the Chapters in another document?
Only elements required for proper playback should be in the main document.
Document 166 pages today.
Chapters is 6 pages, section 11.  --- but the section is not finished.
Core document 9.3.4 "Tracks" is pages 45->106.

MCR: hears support for splitting the chapter off, but asks if there is really that much savings.
Steve: we could make the document smaller by grouping things that have only one parent or one child, with some better transformation of the formatting.

The chapters section is not finished, and there are lot of incomplete sections which will
make the section significantly larger, and so splitting it off into another document may still be justified.
It makes no sense to work on it now, but make the split off now.
Steve will give it a try and see what the savings is, and if we have a lot references that break, but does not think that this is the case.
Dave Rice is hesistant, not sure he sees enough of an advantage.
Tags and Meta-data are developed asynchronously, but the chapters are not going to evolve in place.
This issue will be deferred.

Peter B:
	ffv1 support in davinci / black-magic.  Would rather do this after the document is published. What is status?
	did Derek's feedback about the implementation in GO make it back into the document.
	DR: Yes, this went back into the document about three months ago.  This resulted in a few issues being created, and the review was very helpful.

Noting that there are three decoders: ffmpeg, Derek-GO, and Jerome's decoder

7. Any other business.

7.1  Side Data Format for MKV
	Benjamin: side data format for MKV!
	Dave Rice: it is merged into Matroska, can add side data to frames.
	Three competing things how to encode time code into the file. Related discussion at https://mailarchive.ietf.org/arch/browse/cellar/?q=matroska%20and%20side%20data%20vs%20timecode.
	1) use side data. A debated proposal is at https://github.com/cellar-wg/matroska-specification/pull/348. (needsd to mentioned in main document) A sample of matroska with side data timecode is at https://github.com/Matroska-Org/matroska-test-files/pull/5.
	2) meta-data tag or segment info(needs to be in main document)
	3) seperate track (codec-like document)

NEXT meeting is 2020-01-22,

====

Present:
        1. Michael Richardson
        1. Martin Below
        1. Jérôme Martinez
        1. Steve Lhomme
        1. Dave Rice

INFO:

WEB CONFERENCE:

   2c) Roll call

4. WG status update

7. Any other business.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 10 Dec 2019 17:13:28 -0500

>> >https://whereby.com/cellar-interimw

"now" called.

    > "whereby.com/cellar-interim" seems to work.

They stopped the transition system.

Sorry for the confusion.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 15 Dec 2019 10:12:17 +0100

Hi,

The 2020-08-28 is a Friday, is this correct?

---

From: Michael Richardson <[email-masked]>
Date: Tue, 17 Dec 2019 12:51:02 -0500

> The 2020-08-28 is a Friday, is this correct?

no.
It should be 2020-08-25.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 17 Dec 2019 12:55:38 -0500

I appear to have gotten the date correct in the meeting page at:
  https://datatracker.ietf.org/wg/cellar/meetings/

You can get a calendar feed from:
    https://datatracker.ietf.org/meeting/upcoming.ics?filters=cellar