Subject: [Cfrg] Fwd: DRAFT Recommendation for Password-Based Key Derivation - Part 1: Storage Applications.

From: Russ Housley <[email-masked]>
Date: Fri, 25 Jun 2010 17:12:35 -0400

The document can be found here:
http://csrc.nist.gov/publications/drafts/800-132/draft-sp800-132_june2010.pdf

I'd like to highlight one normative statement I noticed:
A minimum iteration count of 100,000 shall be used. For especially
critical keys, or for very powerful systems or systems where
user-perceived performance is not critical, an iteration count of
10,000,000 may be appropriate.

-------- Original Message --------
Subject: 	DRAFT Recommendation for Password-Based Key Derivation - Part
1: Storage Applications.
Date: 	Fri, 25 Jun 2010 15:22:15 -0400
From: 	Barker, Elaine B. <[email-masked]>
To: 	Barker, Elaine B. <[email-masked]>

NIST announces the release of draft Special Publication 800-132,
Recommendation for Password-Based Key Derivation - Part 1: Storage
Applications. This Recommendation specifies techniques for the
derivation of master keys from passwords to protect electronic data in a
storage environment. Please submit comments to
[email-masked]
<_mailto:[email-masked]>   with "Comments on Draft
SP800-132" in the subject line. The comment period closes on July 28, 2010.

---

From: "Grewal, Ken" <[email-masked]>
Date: Mon, 28 Jun 2010 10:00:40 -0600

All, 
A new draft is available describing a small modification to the AES-GCM algorithm for using two independent keys.
http://www.ietf.org/id/draft-grewal-aes-gcm-bifurcated-key-00.txt

I look forward to your feedback.

Thanks, 
- Ken