Subject: Re: [Cfrg] KCipher-2

From: Joachim Strömbergson <[email-masked]>
Date: Fri, 25 Jan 2013 10:09:22 +0100

Aloha!

On 2012-12-07 20:00 , Jon Callas wrote:
> Yes, put the table in. It's a long-standing frustration of mine that
> crypto documents seem to think that part of the fun is to guess about
> implementation until you finally get it right. A sort of
> gameification, I suppose, that makes a spec a choose-your-own
> adventure. This gets boring, fast. The vast majority of us
> implementors want to get it done, fast and accurate. Anything that
> helps that is a Good Thing.

(Slight OT)

+100

At the absolute minimum add test vectors. Adding a clean, well 
documented reference implementation that uses std types (stdint.h) is 
makes it even better and if you also include internal states during 
processing of at least one test vector you make the implementers life 
_much_ easier.

The siphash specification includes good test vectors and a great walk 
through that made the implementation pretty comfortable. The C reference 
code is, shall we say, terse. Also it really helps if one defines 
operation symbols before using them in the spec...

https://131002.net/siphash/

-- 
Med vänlig hälsning, Yours

Joachim Strömbergson - Alltid i harmonisk svängning.
========================================================================

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Fri, 25 Jan 2013 15:55:06 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Joachim Strömbergson
> Sent: Friday, January 25, 2013 4:09 AM
> To: [email-masked]
> Subject: Re: [Cfrg] KCipher-2
> 
> Aloha!
> 

For extra bonus points, include a test vector that lists the internal cipher state at various points (for example, after each round).  This makes life a lot easier on an implementer if the ever need to diagnose why their implementation doesn't work.

> code is, shall we say, terse. Also it really helps if one defines operation
> symbols before using them in the spec...
> 
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg

---

From: Shinsaku Kiyomoto <[email-masked]>
Date: Mon, 28 Jan 2013 10:01:29 +0900

Hello, 

Appendix C.2 in the document "draft-kiyomoto-kcipher2-08" includes a test vector that lists internal state bits. I hope that that would be appropriate information for implementers.

Best regards, 

Shinsaku

On Fri, 25 Jan 2013 15:55:06 +0000

--