Subject: Re: [Cfrg] RFC 7253 on The OCB Authenticated-Encryption Algorithm

From: Yoav Nir <[email-masked]>
Date: Sun, 1 Jun 2014 07:23:07 +0000

+1

I've noticed that on the tools page, neither RFC 7253 nor draft-irtf-cfrg-ocb have an IPR link, but draft-krovetz-ocb does. Is that just something that has been missed, or has the IPR situation changed?

Yoav

-----Original Message-----
From: Cfrg [mailto:[email-masked]] On Behalf Of Manger, James
Sent: Friday, May 30, 2014 4:44 AM
To: [email-masked]
Subject: Re: [Cfrg] RFC 7253 on The OCB Authenticated-Encryption Algorithm

Congratulations to Ted Krovetz, Phillip Rogaway, and CFRG on OCB becoming an RFC.

I like Matthew Green’s comments on OCB [from 2012, http://blog.cryptographyengineering.com/2012/05/how-to-choose-authenticated-encryption.html]

"In performance terms OCB blows the pants off of all the other modes"
"If OCB was your kid, he'd play three sports and be on his way to Harvard. You'd brag about him to all your friends."

--
James Manger

----------
Subject: [Cfrg] RFC 7253 on The OCB Authenticated-Encryption Algorithm

        RFC 7253

        Title:      The OCB Authenticated-Encryption Algorithm 
        Author:     T. Krovetz, P. Rogaway
        Status:     Informational
        Stream:     IRTF
        Date:       May 2014
        Mailbox:    [email-masked], 
                    [email-masked]

        URL:        http://www.rfc-editor.org/rfc/rfc7253.txt

This document specifies OCB, a shared-key blockcipher-based encryption scheme that provides confidentiality and authenticity for plaintexts and authenticity for associated data.  This document is a product of the Crypto Forum Research Group (CFRG).

_______________________________________________
Cfrg mailing list
[email-masked]
http://www.irtf.org/mailman/listinfo/cfrg
f  ǜ   o  y  )

---

From: "Eggert, Lars" <[email-masked]>
Date: Sun, 1 Jun 2014 07:56:29 +0000

Hi,

> I've noticed that on the tools page, neither RFC 7253 nor draft-irtf-cfrg-ocb have an IPR link, but draft-krovetz-ocb does. Is that just something that has been missed, or has the IPR situation cha…

the canonical source for IPR information is the datatracker. If you search for 7253, you will get several disclosures, because 7253 replaces draft-irtf-cfrg-ocb and in turn draft-krovetz-ocb.

Lars

---

From: Yoav Nir <[email-masked]>
Date: Sun, 1 Jun 2014 10:59:38 +0300

> the canonical source for IPR information is the datatracker. If you search for 7253, you will get several disclosures, because 7253 replaces draft-irtf-cfrg-ocb and in turn draft-krovetz-ocb.

Ah, OK.

https://datatracker.ietf.org/ipr/search/?option=document_search&id=draft-irtf-cfrg-ocb

So the IPR issues still apply.

Thanks

Yoav