Subject: [Cfrg] Assisted EC key pair generation (via ECDSA)

From: Dan Brown <[email-masked]>
Date: Wed, 22 Jul 2015 13:35:46 +0000

Hi all,

SEC1 version 2, http://www.secg.org/sec1-v2.pdf, Section 3.2.4 talks about
(verifiable and) assisted key generation, by way of ECDSA.  There was
something similar done for RSA previous to that.

So, if CFRG is really interested in such a thing, then they might want to
consider that option.

Side note: I've been planning forever to write a paper on the benefits of
verifiable key generation, but other things keep popping up.

Best regards,

Daniel Brown

Research In Motion Limited

---

From: Bryan Ford <[email-masked]>
Date: Wed, 22 Jul 2015 17:10:58 +0200

> On Jul 22, 2015, at 3:35 PM, Dan Brown <[email-masked]> wrote:
> Hi all,
>  
> SEC1 version 2, http://www.secg.org/sec1-v2.pdf, Section 3.2.4 talks about (verifiable and) assisted key generation, by way of ECDSA.  There was something similar done for RSA previous to that.

Interesting, I hadn’t seen that - thanks for the pointer.

Henry Corrigan-Gibbs and Dan Boneh at Stanford also developed different methods of verifiably-random keypair generation for both RSA and DSA keys in this CCS ’13 paper:

	Ensuring High-Quality Randomness in Cryptographic Key Generation
	http://www.henrycg.com/pubs/ccs13ensuring/

Cheers
Bryan

>  So, if CFRG is really interested in such a thing, then they might want to consider that option.
>  
> Side note: I’ve been planning forever to write a paper on the benefits of verifiable key generation, but other things keep popping up.
>  
> Best regards,
>  
> Daniel Brown