Subject: [Cfrg] Review request for SM4 block cipher draft: draft-ribose-cfrg-sm4-00

From: Ronald Tse <[email-masked]>
Date: Thu, 14 Sep 2017 03:19:13 +0000

Dear Members of the CFRG,

We started an Internet Draft to detail the workings of the SM4 block cipher and would like to submit this Internet Draft under the IRTF stream.

SM4, currently the only China-approved symmetric encryption algorithm, was recently standardized as a Chinese standard (GB/T 32907-2016) and is also on track in being published as ISO/IEC 18033-3/AMD2 this year.

All its previous iterations / standards were only available in Chinese, including those from 2003 (GB 15629.11-2003), 2006 (OSCCA), 2012 (GM/T 0006-2012) and 2016 (GB/T 32907-2016). The upcoming ISO/IEC 18033-3/AMD2 however will be in English, but slightly abstracted. There was an unofficial English translation dating to 2008 on IACR, but the algorithm was slightly modified since the 2012 version. Another purpose of this document is to serve as a stable reference for future IETF documents.

With SM4’s rather long history and there are plenty of implementations out there, including Botan (we contributed SM4), GmSSL (Chinese fork of OpenSSL), Intel’s IPP, and a number of hardware implementations including TCG’s Trusted Platform Module (TPM).

The draft is available here:
https://tools.ietf.org/html/draft-ribose-cfrg-sm4-00

From my understanding of RFC 5743 we need a RG to review this work, and we tried to make the draft follow RFC 5743 rules as closely as we can.

Would the CFRG be interested in reviewing this document and perhaps assigning a RG / Editor?

Thank you very much — your feedback is much appreciated!

Kind regards,
Ronald

P.S. There are two minor typos in the draft but somehow draft replacement isn’t working at the moment in the datatracker.

_____________________________________

Ronald Tse
Ribose Inc.

+=========================================================+
This message may contain confidential and/or privileged
information.  If you are not the addressee or authorized to
receive this for the addressee, you must not use, copy,
disclose or take any action based on this message or any
information herein.  If you have received this message in
error, please advise the sender immediately by reply e-mail
and delete this message.  Thank you for your cooperation.
+=========================================================+

---

From: Ronald Tse <[email-masked]>
Date: Thu, 14 Sep 2017 03:27:32 +0000

Update - new draft at: https://tools.ietf.org/html/draft-ribose-cfrg-sm4-01

Thanks!

Kind regards,
Ron

Ronald Tse
Ribose Inc.

On Sep 14, 2017, at 11:11 AM, Ronald Tse <[email-masked]<mailto:[email-masked]>> wrote:

Kind regards,
Ronald

Ronald Tse
Ribose Inc.