Subject: Re: [Cfrg] Review request for SM4 block cipher draft: draft-ribose-cfrg-sm4-00

From: "Paterson, Kenny" <[email-masked]>
Date: Fri, 15 Sep 2017 09:29:37 +0000

Dear Ronald,

Thanks for your request to make SM4 an Internet Draft under the IRTF
stream. We assume you are asking for this document to be adopted by CFRG.

The CFRG co-chairs are considering your request carefully and will get
back to you soon with a response.

Best wishes,

Alexey and Kenny

On 14/09/2017 04:19, "Cfrg on behalf of Ronald Tse" <[email-masked]
on behalf of [email-masked]> wrote:

>Dear Members of the CFRG,
>
>We started an Internet Draft to detail the workings of the SM4 block
>cipher and would like to submit this Internet Draft under the IRTF stream.
>
>
>SM4, currently the only China-approved symmetric encryption algorithm,
>was recently standardized as a Chinese standard (GB/T 32907-2016) and is
>also on track in being published as ISO/IEC 18033-3/AMD2 this year.
>
>
>All its previous iterations / standards were only available in Chinese,
>including those from 2003 (GB 15629.11-2003), 2006 (OSCCA), 2012 (GM/T
>0006-2012) and 2016 (GB/T 32907-2016). The upcoming ISO/IEC 18033-3/AMD2
>however will be in English,
> but slightly abstracted. There was an unofficial English translation
>dating to 2008 on IACR, but the algorithm was slightly modified since the
>2012 version. Another purpose of this document is to serve as a stable
>reference for future IETF documents.
>
>
>With SM4’s rather long history and there are plenty of implementations
>out there, including Botan (we contributed SM4), GmSSL (Chinese fork of
>OpenSSL), Intel’s IPP, and a number of hardware implementations including
>TCG’s Trusted Platform Module (TPM).
>
>The draft is available here:
>https://tools.ietf.org/html/draft-ribose-cfrg-sm4-00
>
>
>From my understanding of RFC 5743 we need a RG to review this work, and
>we tried to make the draft follow RFC 5743 rules as closely as we can.
>
>
>Would the CFRG be interested in reviewing this document and perhaps
>assigning a RG / Editor?
>
>Thank you very much — your feedback is much appreciated!
>
>Kind regards,
>Ronald
>
>P.S. There are two minor typos in the draft but somehow draft replacement
>isn’t working at the moment in the datatracker.
>
>_____________________________________
>
>Ronald Tse
>Ribose Inc.
>
>+=========================================================+
>This message may contain confidential and/or privileged
>information.  If you are not the addressee or authorized to
>receive this for the addressee, you must not use, copy,
>disclose or take any action based on this message or any
>information herein.  If you have received this message in
>error, please advise the sender immediately by reply e-mail
>and delete this message.  Thank you for your cooperation.
>+=========================================================+
>
>
>

---

From: Ronald Tse <[email-masked]>
Date: Fri, 15 Sep 2017 09:38:32 +0000

Dear Alexey and Kenny,

Thank you for your kind message and for considering the review of this document.

Indeed, we believe there is no better place to review this document other than the CFRG. Your review process could greatly improve the document’s quality for the benefit of all.

We look forward to your response, and hope we could soon begin a fruitful review session!

Kind regards,
Ron

Ronald Tse
Ribose Inc.

On Sep 15, 2017, at 5:29 PM, Paterson, Kenny <[email-masked]<mailto:[email-masked]>> wrote:

Dear Ronald,

Best wishes,

Alexey and Kenny

On 14/09/2017 04:19, "Cfrg on behalf of Ronald Tse" <[email-masked]<mailto:[email-masked]>
on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Kind regards,
Ronald

Ronald Tse
Ribose Inc.