Subject: Re: [Cfrg] ECC mod 8^91+5

From: "Paterson, Kenny" <[email-masked]>
Date: Sat, 21 Oct 2017 17:28:33 +0000

Dear CFRG,

Dan has specifically asked for CFRG adoption of his draft. Any support for
this from the group?

Cheers,

Kenny 

On 16/10/2017 16:08, "Cfrg on behalf of Dan Brown" <[email-masked]
on behalf of [email-masked]> wrote:

>Hi CFRG,
>
>For those still interested, I've uploaded an Internet-Draft on ECC on
>2y^2=x^3+x/GF(8^91+5):
>
>https://tools.ietf.org/html/draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-00
>https://datatracker.ietf.org/doc/draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-
>5/
>
>It is very much a work-in-progress, maybe more so than a typical I-D.
>
>If I have incorporated some CFRG list comments into the draft, then I
>hope to properly acknowledge in the next update.
>
>The main point of this curve is to use it in a system of multiply-applied
>diverse crypto, where its security features (special CM curve, minimal
>room for trapdoor) could complement those of other crypto algorithms
>(including PQC and other ECC algorithms).  Using this variant of ECC as
>the sole (PK) crypto would be risky (due to lack of
>track-record/aegis/scrutiny/etc.).
>
>If the IETF and CFRG intend to generally pursue and encourage support of
>multiply-applied diverse crypto, at least where it is affordable (in the
>higher user-to-user network layers?), then I would ask the CFRG to
>consider this I-D as a work item.  Otherwise, maybe this I-D should stay
>on the individual submission stream.
>
>Best regards,
>
>Dan
>
>-----Original Message-----
>From: Dan Brown 
>Sent: Tuesday, May 16, 2017 1:36 PM
>To: [email-masked]
>Subject: ECC mod 8^91+5
>
>Hi all,
>
>I'm considering writing an I-D on doing ECC over the field of size
>   8^91+5    (=2^273+5),
>because it:
>...
>
>For ECC with this field, I am also considering the special curve
>   2y^2=x^3+x,
>because it:
>...
>
>
>
>_______________________________________________
>Cfrg mailing list
>[email-masked]
>https://www.irtf.org/mailman/listinfo/cfrg

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 21 Oct 2017 23:18:31 +0100

I'd have no objection to CFRG producing an RFC for
this, if there is support. I don't support doing so
myself, but if the RG do go ahead with that I would
really hope that the resulting RFC is clearly cast
as not being as "preferred" as the curves already
documented.

If additional curves were to be documented by CFRG
without such distinctions, then I would object to
that on the grounds that the inevitable confusion
arising would devalue CFRG for the IETF at least.

So, while I'm not qualified wrt the crypt details
myself, I'd prefer to not see this adopted. If it
is adopted, I'd strongly argue that it be flagged
as being less preferred vs. the currently documented
curves.

S.