Subject: [Cfrg] RGLC on draft-irtf-cfrg-re-keying-11

From: Alexey Melnikov <[email-masked]>
Date: Sat, 10 Feb 2018 17:16:59 +0000

Dear CFRG participants,

This message starts a 2-week RGLC on "Re-keying Mechanisms for Symmetric
Keys" (draft-irtf-cfrg-re-keying-11), that will end on February 24th.
See https://datatracker.ietf.org/doc/draft-irtf-cfrg-re-keying for the
latest version of the draft.

Please send your comments, as well as expression of support to publish
as an RFC (or possible reasons for not doing so) in reply to this
message or directly to CFRG chairs. Your feedback will help chairs to
decide whether the document is ready for review by IRSG and subsequent
publication as an RFC.

Thank you,

Kenny and Alexey

---

From: Russ Housley <[email-masked]>
Date: Sat, 10 Feb 2018 14:07:11 -0500

I have reviewed an earlier version of this document.  I just looked at the diffs, and I think the document is ready.

Russ

> On Feb 10, 2018, at 12:16 PM, Alexey Melnikov <[email-masked]> wrote:
> 
> Dear CFRG participants,
>

---

From: Ira McDonald <[email-masked]>
Date: Sat, 10 Feb 2018 14:40:52 -0500

Hi,

I agree with Russ that this document is ready to publish.  And it addresses
an important topic.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Sat, Feb 10, 2018 at 12:16 PM, Alexey Melnikov <[email-masked]
> wrote:

> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>

---

From: Tony Arcieri <[email-masked]>
Date: Sun, 11 Feb 2018 13:49:51 -0800

I have not thoroughly reviewed all of this document: I have only been
particularly interested in section 5.2: parallelizable KDFs (and in
particular 5.2.1 describing a parallelizable cipher-based KDF).

I can at least say that I second what Ira said: it addresses an important
topic, and in absence of a comprehensive document like this I have seen
people refer to earlier, expired drafts (e.g. draft-agl-ckdf) looking for
solutions for these same needs as my own.

Therefore I support its publication.

-- 
Tony Arcieri

---

From: Tim Hollebeek <[email-masked]>
Date: Thu, 15 Feb 2018 19:56:01 +0000

It would be useful if section 5.2.3 referenced the AES DUKPT standard
(ASC X9.24 part 3).  It provides a modern and extremely efficient way
of deriving a tree that produces billions of derived keys from a single 
base key.

It's a concrete and established standard, as opposed to the slightly more
hand-wavy examples in the re-keying document and in NIST SP-800-108.

-Tim

> -----Original Message-----
> From: Cfrg [mailto:[email-masked]] On Behalf Of Alexey Melnikov
> Sent: Saturday, February 10, 2018 10:17 AM
> To: [email-masked]
> Subject: [Cfrg] RGLC on draft-irtf-cfrg-re-keying-11
> 
> Dear CFRG participants,
> 
latest
> version of the draft.
> 
> 
> Please send your comments, as well as expression of support to publish as
an
> RFC (or possible reasons for not doing so) in reply to this message or
directly to
> CFRG chairs. Your feedback will help chairs to decide whether the document
is
> ready for review by IRSG and subsequent publication as an RFC.
> 
> Thank you,
> 
> Kenny and Alexey
>