Subject: Re: [Cfrg] I-D Action: draft-irtf-cfrg-randomness-improvements-00.txt

From: Dan Brown <[email-masked]>
Date: Thu, 29 Mar 2018 00:41:02 +0000

inline...

Sent from my BlackBerry 10 smartphone on the Rogers network.
From: Christopher Wood
Sent: Monday, March 26, 2018 5:39 PM
To: Mark D. Baushke; Dan Brown; Salz, Rich
Cc: Crypto Forum Research Group
Subject: Re: [Cfrg] I-D Action: draft-irtf-cfrg-randomness-improvements-00.txt

On Mar 26, 2018, 8:26 AM -0700, Salz, Rich <rsalz=[email-masked]>, wrote:

It's like the old joke, you get 10 cryptographers in a room and you end up with 12 definitions of entropy, randomness, etc.

Most of the people reading this document, especially if it is to have an impact on the Internet, will be engineers and not cryptographers. And almost everyone will have an intuitive, and even correct, sense of what "random bytes" means.

Sure, most people asked to fill k with 'random bytes' in ECDSA‎, would do the right thing. But some might not. That's the main reason for 'deterministic' ECDSA, so I thought, or maybe I'm once again not getting the joke.

---

From: Dan Brown <[email-masked]>
Date: Thu, 29 Mar 2018 00:41:02 +0000

inline...