Subject: Re: [Cfrg] I-D Action: draft-mcgrew-hash-sigs-09.txt

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Mon, 5 Mar 2018 15:13:21 +0300

Dear David, Michael and Scott,

Unfortunately, the current version does not address most of the concerns
mentioned in my review that I made as a Crypto Review Panel member (posted
12.11.2017 to the CFRG list).

I understand that you may not agree with all the concerns, but there
haven't been any comments on those concerns on the list.

Moreover, such obvious concerns as misprints ("pseuddorandom",
"cryptographical secure method", "and . Andreas Hulsing") have not been
addressed too.
There have also been several significant concerns, it would be great if you
could address them or at least comment them.

Have you received the message with the review?

Best regards,
Stanislav

2018-02-27 22:59 GMT+03:00 Russ Housley <[email-masked]>:

> Thanks for posting the update.  I looked at the diff, and it seems like
> the posted comments were addressed.  Also, the additional examples will be
> helpful.
>
> I think this document is ready to go to the IRSG and the RFC Editor.
>
> Russ
>
>
> > On Feb 26, 2018, at 3:34 PM, [email-masked] wrote:
> >
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> > This draft is a work item of the Crypto Forum RG of the IRTF.
> >
> >        Title           : Hash-Based Signatures
> >        Authors         : David McGrew
> >                          Michael Curcio
> >                          Scott Fluhrer
> >       Filename        : draft-mcgrew-hash-sigs-09.txt
> >       Pages           : 54
> >       Date            : 2018-02-23
> >
> > Abstract:
> >   This note describes a digital signature system based on cryptographic
> >   hash functions, following the seminal work in this area of Lamport,
> >   Diffie, Winternitz, and Merkle, as adapted by Leighton and Micali in
> >   1995.  It specifies a one-time signature scheme and a general
> >   signature scheme.  These systems provide asymmetric authentication
> >   without using large integer mathematics and can achieve a high
> >   security level.  They are suitable for compact implementations, are
> >   relatively simple to implement, and naturally resist side-channel
> >   attacks.  Unlike most other signature systems, hash-based signatures
> >   would still be secure even if it proves feasible for an attacker to
> >   build a quantum computer.
> >
> >
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-mcgrew-hash-sigs/
> >
> > There are also htmlized versions available at:
> > https://tools.ietf.org/html/draft-mcgrew-hash-sigs-09
> > https://datatracker.ietf.org/doc/html/draft-mcgrew-hash-sigs-09
> >
> > A diff from the previous version is available at:
> > https://www.ietf.org/rfcdiff?url2=draft-mcgrew-hash-sigs-09
> >
> >
> > Please note that it may take a couple of minutes from the time of
> submission
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> > _______________________________________________
> > Cfrg mailing list
> > [email-masked]
> > https://www.irtf.org/mailman/listinfo/cfrg
>
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Tue, 6 Mar 2018 09:59:15 +0300

Dear colleagues,

Yesterday David, Michael and Scott posted a new version of the I-D,
addressing the vast majority of my concerns provided in the review. Also
we've had an off-list discussion with Scott, he provided his comments on
the remaining concerns – now I am completely satisfied with the current
condition of the document and support further steps with it.

Thank you!

Best regards,
Stanislav Smyshlyaev, Ph.D.
CISO, CryptoPro LLC

2018-03-05 15:13 GMT+03:00 Stanislav V. Smyshlyaev <[email-masked]>:

> There have also been several significant concerns, it would be great if
> you could address them or at least comment them.
>