Subject: [Cfrg] Is a Hackathon planned regarding RFC8391-XMSS on hash-based-signatures?

From: "Wheeler, David M" <[email-masked]>
Date: Sat, 11 Aug 2018 14:36:01 +0000

Greetings,
I am wondering if there is a hackathon planned for an upcoming IETF meeting for XMSS? I will not be able to attend Bangkok, but will be in Prague.

I am currently implementing XMSS as a proof-of-concept reference implementation and would very much like to test interoperation of the signatures with another implementation. Additionally, implementing this from scratch from the RFC, I have found on minor correction to Algorithm 1 which may be a useful errata (or may be a mistake on my part).

I am wondering if you can point me to others who may be also doing implementation work of the RFC.
Thanks,
David M. Wheeler
CISSP CSSLP GSLC GREM
Sr. Principal Engineer
PSD Security Architecture, SSG

o: 503.712.5776
A good leader is a person who takes a little more than his share of the blame and a little less than his share of the credit.
                     John C Maxwell, Author

---

From: "A. Huelsing" <[email-masked]>
Date: Mon, 13 Aug 2018 09:31:05 +0200

David,

there is no hackathon planned for any of the next IETF meetings. However, you
can find our full reference implementation online and can verify your code
against it. The link is given in the RFC.

-- Andreas

Am 11-08-18 um 16:36 schrieb Wheeler, David M:
>
> Greetings,
>
> I am wondering if there is a hackathon planned for an upcoming IETF meeting
> for XMSS? I will not be able to attend Bangkok, but will be in Prague.
>
>  
>
> I am currently implementing XMSS as a proof-of-concept reference
> implementation and would very much like to test interoperation of the
> signatures with another implementation. Additionally, implementing this from
> scratch from the RFC, I have found on minor correction to Algorithm 1 which
> may be a useful errata (or may be a mistake on my part).
>
>  
>
> *David M. Wheeler*
> *Sr. Principal Engineer*
> *PSD Security Architecture, SSG*
>
> * *
>
> *o:*503.712.5776
>
> A good leader is a person who takes a little more than his share of the blame
> and a little less than his share of the credit.
>
>                      *John C Maxwell, Author*
>
>  
>