Subject: [Cfrg] Error in the examples for draft-mcgrew-hash-sigs/

From: Jim Schaad <[email-masked]>
Date: Wed, 6 Mar 2019 14:56:03 -0800

I have been toiling away to get my implementation of this draft working.  In
the process of doing so, I ended up spending a certain amount of time trying
to figure out this problem.  If you attempt to generate the public key from
the private key seed given in the document, you will never be able to
succeed.  The problem is that the sample program from Cisco takes this key
and performs some transformations on it in order to generate the identifier
and the real seed for Appendix A.

The correct seed is
55 8B 89 66 C4 8A E9 CB 89 8B 42 3C 83 44 3A AE 
01 4A 72 F1 B1 AB 5C C8 5C F1 D8 92 90 3B 54 39

Jim

---

From: mcgrew <[email-masked]>
Date: Wed, 6 Mar 2019 19:59:04 -0500

> On Mar 6, 2019, at 5:56 PM, Jim Schaad <[email-masked]> wrote:
> 
> succeed.  The problem is that the sample program from Cisco

What sample program?   Can you please point us to the code you mean?

thanks

David

> takes this key
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg

---

From: Jim Schaad <[email-masked]>
Date: Wed, 6 Mar 2019 17:11:35 -0800

Appendix E.  Example Implementation

   An example implementation can be found online at
   https://github.com/cisco/hash-sigs.

Jim

> -----Original Message-----
> From: mcgrew <[email-masked]>
> Sent: Wednesday, March 6, 2019 4:59 PM
> To: Jim Schaad <[email-masked]>
> Cc: [email-masked]; Scott Fluhrer (sfluhrer) <[email-masked]>
> Subject: Re: [Cfrg] Error in the examples for draft-mcgrew-hash-sigs/
> 
> 
> 
> > I have been toiling away to get my implementation of this draft
> > working.  In the process of doing so, I ended up spending a certain
> > amount of time trying to figure out this problem.  If you attempt to
> > generate the public key from the private key seed given in the
> > document, you will never be able to succeed.  The problem is that the
> > sample program from Cisco
> 
> > and performs some transformations on it in order to generate the
> > identifier and the real seed for Appendix A.
> >
> > The correct seed is

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Thu, 7 Mar 2019 16:27:54 +0000

Yup, you're right; the test vector is wrong.

I believe that's something I can fix in the AUTH48 corrections at the end of the RFC process...

> From: Cfrg <[email-masked]> On Behalf Of Jim Schaad
> Sent: Wednesday, March 06, 2019 5:56 PM
> To: [email-masked]
> Subject: [Cfrg] Error in the examples for draft-mcgrew-hash-sigs/
>

---

From: mcgrew <[email-masked]>
Date: Thu, 7 Mar 2019 12:48:54 -0500

Hi Scott,

> On Mar 7, 2019, at 11:27 AM, Scott Fluhrer (sfluhrer) <[email-masked]> wrote:
> 
> I believe that's something I can fix in the AUTH48 corrections at the end of the RFC process…

Perfect, thanks!   

Jim, thanks for reporting the issue before AUTH48.

David