Subject: Re: [Cfrg] I-D Action: draft-irtf-cfrg-argon2-04.txt

From: Milan Broz <[email-masked]>
Date: Sun, 3 Mar 2019 20:17:36 +0100

Hello,

the draft mentioned below is waiting for action for several months
(and I think there was a consensus already), is there any date when
it is planned to be published (or reviewed)?

We are using Argon2 in LUKS2 disk encryption, and we would like
to avoid referencing expiring RFC draft in the specification.

Thanks,
Milan

On 23/11/2018 10:21, [email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Crypto Forum RG of the IRTF.
> 
>         Title           : The memory-hard Argon2 password hash and proof-of-work function
>         Authors         : Alex Biryukov
>                           Daniel Dinu
>                           Dmitry Khovratovich
>                           Simon Josefsson
> 	Filename        : draft-irtf-cfrg-argon2-04.txt
> 	Pages           : 29
> 	Date            : 2018-11-23
> 
> Abstract:
>    This document describes the Argon2 memory-hard function for password
>    hashing and proof-of-work applications.  We provide an implementer-
>    oriented description together with sample code and test vectors.  The
>    purpose is to simplify adoption of Argon2 for Internet protocols.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-irtf-cfrg-argon2/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-irtf-cfrg-argon2-04
> https://datatracker.ietf.org/doc/html/draft-irtf-cfrg-argon2-04
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-irtf-cfrg-argon2-04
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>

---

From: Ira McDonald <[email-masked]>
Date: Sun, 3 Mar 2019 18:14:00 -0500

Hi,

The datatracker says IRTF state is "Waiting for Document Shepherd" and the
IESG state is "I-D Exists: AD Followup".  Which is to say that it's not had
any
IETF Last Call yet.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Sun, Mar 3, 2019 at 2:17 PM Milan Broz <[email-masked]> wrote:

> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 5 Mar 2019 11:10:31 +0000

Hi all,

On 03/03/2019 23:14, Ira McDonald wrote:
> IESG state is "I-D Exists: AD Followup".  Which is to say that it's 
> not had any
> IETF Last Call yet.

This document needs to go to IRSG review next. With IRTF chair changing 
in a few weeks, this will have to wait till the Prague IETF meeting.

Best Regards,

Alexey

> mailto: [email-masked] <mailto:[email-masked]>
> On Sun, Mar 3, 2019 at 2:17 PM Milan Broz <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hello,
>
>     On 23/11/2018 10:21, [email-masked]
>     <mailto:[email-masked]> wrote:
>
>     > until the htmlized version and diff are available at
>     tools.ietf.org <http://tools.ietf.org>.
>     >
>     [email-masked] <mailto:[email-masked]>