Subject: Re: [Cfrg] PAKEs for IoT // Feedback appreciated regarding candidate libraries for the requested for reference implementations on constrained targets.

From: Björn Haase <[email-masked]>
Date: Wed, 20 Nov 2019 08:54:41 +0000

Dear Hannes,

regarding performance data, there is a detailed section on low-end microcontrollers in  ia.cr/2018/286<https://ia.cr/2018/286>.

For code size on other targets you could add the code sizes as required for X25519 and SHA512. The adder for the mapping could almost be neglected since it shares the same field arithmetic. We are also planning to prepare a stand-alone implementation based on an extension of Tweet-NaCl with elligator2, e.g. for inter-operability tests in addition to the optimized ARM v5 / v6 code that is already published.

@CFRG:
Regarding a reference implementation for short-Weierstrass curves on constrained devices, such as P-256, I’d appreciate any recommendation on which library candidate might be most suitable. My personal first approach would have been to use BearSSL for the field arithmetics or possibly Arm MBED. However, maybe there is some library where a reference implementation code could be integrated with less effort.

>There is a push from governments not to use passwords on IoT devices
Maybe you could give me a detailed pointer regarding this information? I currently don’t dispose of any such information. FYI, in Germany BSI explicitly declared interest in the current developments regarding PAKE standardization, specifically when considering the aspect of resilience with respect to quantum computing. This topic will be on the agenda for the upcoming BRAINPOOL meeting in January.

Yours,

Björn.

Mit freundlichen Grüßen I Best Regards 

Dr. Björn Haase 

Senior Expert Electronics | TGREH Electronics Hardware
Endress+Hauser Conducta GmbH+Co.KG | Dieselstrasse 24 | 70839 Gerlingen | Germany
Phone: +49 7156 209 377 | Fax: +49 7156 209 221
[email-masked] |  www.conducta.endress.com 

Endress+Hauser Conducta GmbH+Co.KG
Amtsgericht Stuttgart HRA 201908
Sitz der Gesellschaft: Gerlingen
Persönlich haftende Gesellschafterin:
Endress+Hauser Conducta Verwaltungsgesellschaft mbH
Sitz der Gesellschaft: Gerlingen
Amtsgericht Stuttgart HRA 201929
Geschäftsführer: Dr. Manfred Jagiella

Gemäss Datenschutzgrundverordnung sind wir verpflichtet, Sie zu informieren, wenn wir personenbezogene Daten von Ihnen erheben.
Dieser Informationspflicht kommen wir mit folgendem Datenschutzhinweis (https://www.endress.com/de/cookies-endress+hauser-website) nach.

Disclaimer: 

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you receive this in error, please contact the sender and delete the material from any computer. This e-mail does not constitute a contract offer, a contract amendment, or an acceptance of a contract offer unless explicitly and conspicuously designated or stated as such.

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 20 Nov 2019 10:33:15 +0000

Hi Björn,

thanks for the pointer to the publication.

Regarding a crypto library for embedded devices: We have split our TLS implementation such that those who only want to use the crypto can use the Mbed Crypto library alone without having to re-configure the stack with C pre-processor directives to omit code generation for the TLS/DTLS handshake

Here is the link: https://github.com/ARMmbed/mbed-crypto

As an API, it uses our new PSA Crypto API (PSA = Platform Security Architecture).

Regarding the IoT security recommendations I will look up the references and post them to the list. It is interesting to hear that BSI is interested in this work.

Ciao
Hannes

From: Björn Haase <[email-masked]>
Sent: Wednesday, November 20, 2019 4:55 PM
To: Hannes Tschofenig <[email-masked]>; cfrg <[email-masked]>
Subject: AW: PAKEs for IoT // Feedback appreciated regarding candidate libraries for the requested for reference implementations on constrained targets.

Dear Hannes,

@CFRG:
Regarding a reference implementation for short-Weierstrass curves on constrained devices, such as P-256, I'd appreciate any recommendation on which library candidate might be most suitable. My personal first approach would have been to use BearSSL for the field arithmetics or possibly Arm MBED. However, maybe there is some library where a reference implementation code could be integrated with less effort.

>There is a push from governments not to use passwords on IoT devices
Maybe you could give me a detailed pointer regarding this information? I currently don't dispose of any such information. FYI, in Germany BSI explicitly declared interest in the current developments regarding PAKE standardization, specifically when considering the aspect of resilience with respect to quantum computing. This topic will be on the agenda for the upcoming BRAINPOOL meeting in January.

Yours,

Björn.

Dr. Björn Haase

________________________________
Senior Expert Electronics | TGREH Electronics Hardware
Endress+Hauser Conducta GmbH+Co.KG | Dieselstrasse 24 | 70839 Gerlingen | Germany
Phone: +49 7156 209 377 | Fax: +49 7156 209 221
[email-masked]<mailto:[email-masked]> | www.conducta.endress.com<http://www.conducta.endress.com>
________________________________

Endress+Hauser Conducta
Verwaltungsgesellschaft mbH

________________________________

Dieser Informationspflicht kommen wir mit folgendem Datenschutzhinweis<https://www.de.endress.com/de/cookies-endress+hauser-website> nach.

________________________________

Disclaimer:

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged
material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities
other than the intended recipient is prohibited. If you receive this in error, please contact the sender and delete the material from any computer.
This e-mail does not constitute a contract offer, a contract amendment, or an acceptance of a contract offer unless explicitly and conspicuously designated or stated as such.

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.