Subject: Re: [Cfrg] I-D Action: draft-irtf-cfrg-randomness-improvements-08.txt

From: "Christopher Wood" <[email-masked]>
Date: Tue, 03 Dec 2019 13:17:45 -0800

On Wed, Nov 27, 2019, at 1:56 AM, Stanislav V. Smyshlyaev wrote:
> >> In this case, it seems like a separate document for other constructions
> is definitely more appropriate---no sense introducing serious delay for
> this document
> 
> Many thanks, Riad!
> 
> I'll definitely think about this - maybe it will be reasonable to 
> arrange a discussion of this (with slides, at CFRG) at IETF 107 and 
> initiate a document on this.
> If you don't mind, I'll get in touch with you off-list in the beginning 
> of 2020 - to discuss, what should be included in such a document. Would 
> you like to participate in this?..
> 
> >> But: would it be possible to clarify, maybe just in the intro, that 
> this document is primarily geared toward the HSM case?
> I think that mentioning HSMs as one of most important cases when the 
> construction is needed, can be helpful. 
> Chris, Nick, what do you think?

+1 -- this makes sense to me!

Best,
Chris

---

From: Nick Sullivan <[email-masked]>
Date: Tue, 3 Dec 2019 13:46:20 -0800

> +1 -- this makes sense to me!

I think HSM is too narrow a term. I'd be open to talking about cases in
which the private key is inaccessible to the application, but a signing
interface is available. HSMs, TPMs are the most concrete examples, but not
the only ones.

---

From: "Christopher Wood" <[email-masked]>
Date: Tue, 03 Dec 2019 14:02:45 -0800

On Tue, Dec 3, 2019, at 1:46 PM, Nick Sullivan wrote:
> interface is available. HSMs, TPMs are the most concrete examples, but 
> not the only ones. 

Sure, sure. I took Stanislav's suggestion to mean that we highlight HSMs (or TPMs) as a specific example of cases where the private key is inaccessible.

Best,
Chris

---

From: Benjamin Beurdouche <[email-masked]>
Date: Tue, 3 Dec 2019 22:48:52 +0100

> I think HSM is too narrow a term. I'd be open to talking about cases in which the private key is inaccessible to the application, but a signing interface is available. HSMs, TPMs are the most concrete examples, but not the only ones.  

“Cryptographic token” ?

B.

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 4 Dec 2019 16:07:55 +0000

Most people will be familiar with hardware crypto devices, such as HSM’s.  Sure, lots of things out there, from keyless SSL to NetHSM, but optimize for the common case.

---

From: Richard Outerbridge <[email-masked]>
Date: Wed, 4 Dec 2019 12:58:31 -0500

Ditto, ditto.
__outer

> On 2019-12-04 (338), at 11:07:55, Salz, Rich <[email-masked]> wrote:
> 
> _______________________________________________
> Cfrg mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/cfrg <https://www.irtf.org/mailman/listinfo/cfrg>