Subject: [CGA-EXT] Call for adoption of draft-jiang-csi-dhcpv6-cga-ps-03.txt

From: marcelo bagnulo braun <[email-masked]>
Date: Mon, 21 Sep 2009 08:49:56 +0200

Hi,

This is the call for adoption of draft-jiang-csi-dhcpv6-cga-ps-03.txt as 
the WG item to cover the charter itema described as:

- Develop an informational document analysing different approaches to
allow SeND and CGAs to be used in conjunction with DHCP, and making
recommendations on which are the best suited. Recharter based on the
result of the analysis.

Find the information about the document below.

Please comment before the 28th of september.

Thanks, marcelo

-------- Mensaje original --------
Asunto: 	I-D Action:draft-jiang-csi-dhcpv6-cga-ps-03.txt
Fecha: 	Fri, 18 Sep 2009 03:45:01 -0700 (PDT)
De: 	[email-masked]
Responder a: 	[email-masked]
Para: 	[email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : DHCPv6 and CGA Interaction: Problem Statement
	Author(s)       : S. Jiang
	Filename        : draft-jiang-csi-dhcpv6-cga-ps-03.txt
	Pages           : 8
	Date            : 2009-09-18

This document describes potential issues in the interaction between 
DHCPv6 and Cryptographically Generated Addresses (CGAs). Firstly, the 
scenario of using CGAs in DHCPv6 environments is discussed.
Some 
operations are clarified for the interaction of DHCPv6 servers and 
CGA-associated hosts. We then also discuss how CGAs and DHCPv6 may 
have mutual benefits for each other, including using CGAs in DHCPv6 
operations to enhance its security features and using DHCPv6 to 
provide the CGA generation function.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-jiang-csi-dhcpv6-cga-ps-03.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: gx su <[email-masked]>
Date: Tue, 22 Sep 2009 10:33:40 +0800

Hi all,

We're a team from BUPT (Beijing University of Post & Telecommunication),
and recently we've been writing some codes on Dibbler trying to apply CGA
to DHCPv6.
Since current draft about the issue didn't cover every details, updating the
document will be of great help to our work.

Best regards.

2009/9/21 marcelo bagnulo braun <[email-masked]>:
> Hi,
>
> This is the call for adoption of draft-jiang-csi-dhcpv6-cga-ps-03.txt as the
> WG item to cover the charter itema described as:
>
> This document describes potential issues in the interaction between DHCPv6
> and Cryptographically Generated Addresses (CGAs). Firstly, the scenario of
> using CGAs in DHCPv6 environments is discussed.
> Some operations are clarified for the interaction of DHCPv6 servers and
> CGA-associated hosts. We then also discuss how CGAs and DHCPv6 may have
> mutual benefits for each other, including using CGAs in DHCPv6 operations to
> enhance its security features and using DHCPv6 to provide the CGA generation
> function.
>
> CGA-EXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cga-ext
>
>

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 22 Sep 2009 12:23:16 +0800

> We're a team from BUPT (Beijing University of Post & 
> Telecommunication), and recently we've been writing some 
> codes on Dibbler trying to apply CGA to DHCPv6.

Hi, Su, thanks for your hard work.

> Since current draft about the issue didn't cover every 
> details, updating the document will be of great help to our work.

I am not sure what exactly you meant here. Do you actually mean our draft-jiang-csi-dhcpv6-cga-ps needs further refine (if so, please comments in details), or current RFCs do not cover CGA & DHCPv6 issues? If it is later, I guess this draft-jiang-csi-dhcpv6-cga-ps is exact the document that meet you need.

Please clarify it. Thanks & regards,

Sheng
 
> > This is the call for adoption of 
> draft-jiang-csi-dhcpv6-cga-ps-03.txt 
> > as the WG item to cover the charter itema described as:
> >
> > Some operations are clarified for the interaction of DHCPv6 servers 
> > and CGA-associated hosts. We then also discuss how CGAs and 
> DHCPv6 may 
> > Internet-Draft directories: http://www.ietf.org/shadow.html or 
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >
> >

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 22 Sep 2009 14:44:02 +0800

> > Since current draft about the issue didn't cover every details, 
> > updating the document will be of great help to our work.
> 
> I am not sure what exactly you meant here. Do you actually 
> mean our draft-jiang-csi-dhcpv6-cga-ps needs further refine 
> (if so, please comments in details), or current RFCs do not 
> cover CGA & DHCPv6 issues? If it is later, I guess this 
> draft-jiang-csi-dhcpv6-cga-ps is exact the document that meet 
> you need.

Actually, I guess you want more. draft-jiang-csi-dhcpv6-cga-ps only
driscribes the possible interactions between cga & dhcpv6. The detailed
specification of these interactions should be defined too. 
http://tools.ietf.org/html/draft-jiang-csi-cga-config-dhcpv6-00.txt
http://tools.ietf.org/html/draft-jiang-dhc-secure-dhcpv6-02.txt
are such documents define the extension dhc options to enable possible
interactions mentioned in draft-jiang-csi-dhcpv6-cga-ps.

These works are not in the current CSI charters. However, they may be
included in the future CSI work items.

Many thanks & best regards,

Sheng

> > > A New Internet-Draft is available from the on-line 
> Internet-Drafts 
> > > directories.
> > >

---

From: gx su <[email-masked]>
Date: Tue, 22 Sep 2009 15:13:40 +0800

Hi,

> draft-jiang-csi-dhcpv6-cga-ps is exact the document that meet

It doesn't mean that draft-jiang-csi-dhcpv6-cga-ps needs refining.
We think that applying CGA to DHCPv6 could provide stateful CGA
auto-configuration, while it could also enhance the security level of
DHCPv6. Thus we support this draft being adopted
as a wg draft.

> included in the future CSI work items.

Yes, you're right. Those drafts are what we wanted in our work.
We hope these drafts will be included in CSI wg items,
and we would like to make some contributions to it.

Many thank & best regards.

gx su

---

From: marcelo bagnulo braun <[email-masked]>
Date: Tue, 22 Sep 2009 10:27:24 +0200

> Since current draft about the issue didn't cover every details,
so this means you are against adopting this document as a WG item?
Regards, marcelo

>  updating the

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 22 Sep 2009 16:36:41 +0800

Hi, Marcelo,

The following mails of this thread have clarified their opinion. They are
support the adoption.

Cheers,

Sheng 

> -----Original Message-----
> From: marcelo bagnulo braun [mailto:[email-masked]] 
> Sent: Tuesday, September 22, 2009 4:27 PM
> To: gx su
> Cc: 王文东老师; Sheng Jiang; [email-masked]
> Subject: Re: [CGA-EXT] Call for adoption of 
> > Telecommunication), and recently we've been writing some codes on 
> > Dibbler trying to apply CGA to DHCPv6.
> >> and CGA-associated hosts. We then also discuss how CGAs and DHCPv6 
> >> may have mutual benefits for each other, including using CGAs in 
> >> DHCPv6 operations to enhance its security features and 
> using DHCPv6 
> >> to provide the CGA generation function.
> >>

---

From: gx su <[email-masked]>
Date: Wed, 23 Sep 2009 11:18:37 +0800

Hi,

It doesn't mean that draft-jiang-csi-dhcpv6-cga-ps needs refining.
we support this draft being adopted as a wg item.
Plz check the mails of the thread.

Many thanks & best regards.

2009/9/22 marcelo bagnulo braun <[email-masked]>:
>>> the
>>> DHCPv6