Subject: Re: [cicm] Ports

From: "Novikov, Lev" <[email-masked]>
Date: Tue, 17 May 2011 19:11:12 -0400

Hema,

On 2011-05-17 at 11:32, Hema Krishnamurthy wrote:
> Could you provide me some info on the usage of ports(remote/local) in the channel manager?

Sure. I highly recommend you look at Figure 6 in the CICM Logical Model:
http://tools.ietf.org/html/draft-lanz-cicm-lm-00#section-5

I've reproduced it here.

                  Security Domain         Security Domain
                     Boundary                Boundary
                        .                       .
               +--------.--------+     +--------.--------+
    Client  --(a) Cryptographic (b)---(c) Cryptographic (d) -- Client
   Program X   |      Module     |     |      Module     |    Program Y
               +--------.--------+     +--------.--------+
                        .                       .

               X local    X remote     Y remote    Y local
               port (a)   port (b)     port (c)   port (d)

   Figure 6.  Local and Remote Port Nomenclature for Channels that
   Operate in Two Security Domains

The terms remote/local are relative to the client program. We chose these terms to avoid directionality (e.g., input / output) because the direction depends on the operation (e.g., encrypt / decrypt), but we need to specify the ports consistently (regardless of the operation).

Let me know if this needs more elaboration.

Lev

---

From: "Krishnamurthy, Hema - ES" <[email-masked]>
Date: Thu, 19 May 2011 09:56:52 -0400

Thanks Lev. That's helpful.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Novikov, Lev
Sent: Tuesday, May 17, 2011 4:11 PM
To: CICM Discussion List
Subject: Re: [cicm] Ports

Hema,

I've reproduced it here.

Lev
_______________________________________________
cicm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cicm

This e-mail and any files transmitted with it may be proprietary and are intended solely for the use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify the sender.
Please note that any views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of ITT Corporation. The recipient should check this e-mail and any attachments for the presence of viruses. ITT accepts no liability for any damage caused by any virus transmitted by this e-mail.