Subject: Re: [cicm] BoF Request for CICM at IETF 81

From: "Novikov, Lev" <[email-masked]>
Date: Mon, 16 May 2011 20:54:24 -0400

On 2011-05-13 at 13:34, John Davidson wrote:
> I am wondering if we need to (or even can) clarify what we mean by 
> High Assurance.

On 2011-05-13 at 17:56, John Fitton wrote:
> I would suggest defining High Assurance in terms of  FIPS-140-2 
> Level 4. Of course FIPS 140-2 refers to the Common Criteria AL4 or 
> higher, but does offer specific criteria to be used in the evaluation.
> That being said, however, while the stated goal is for a high 
> assurance API, there is nothing in principal which limits the API to 
> high assurance applications.

On 2011-05-14 at 18:12, Dennis Bourget wrote:
> I just don't see how any API can provide "high assurance", it is the
> implementation of the API, host platform and operating system that 
> would need to be evaluated to FIPS 140-2 or Common Criteria.  For 
> example, the API does not and cannot provide domain separation, I 
> suggest that we strike that text from the charter.

On 2011-05-16 at 13:08, Jim Cottrell wrote:
> I agree that the API by itself cannot provide "high assurance" but 
> this API has been designed to be targeted for use in high assurance 
> applications.

Interesting discussion. 

What do people think of the following? It is based on Dennis's suggestion, 
but emphasizes that the API targets high assurance environments.

  The Common Interface to Cryptographic Modules (CICM) defines an application 
  programming interface for the security services provided by cryptographic 
  modules developed by multiple vendors. The API is intended to support high 
  assurance cryptography, and thus offers security domain separation, and 
  enhanced module, key, and channel management capabilities that are vendor 
  agnostic.

Lev

---

From: "Bourget, Dennis" <[email-masked]>
Date: Mon, 16 May 2011 18:10:33 -0700

Again, I may be picking nits, but I still don't believe that the API
offers any security domain separation.  
I would just delete "and thus offers".

It would then read: 
"The API is intended to support high assurance cryptography, security
domain separation, and 
 enhanced module, key, and channel management capabilities that are
vendor agnostic."

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Novikov, Lev
Sent: Monday, May 16, 2011 5:54 PM
To: CICM Discussion List
Subject: Re: [cicm] BoF Request for CICM at IETF 81

Interesting discussion. 

What do people think of the following? It is based on Dennis's
suggestion, 
but emphasizes that the API targets high assurance environments.

  The Common Interface to Cryptographic Modules (CICM) defines an
application 
  programming interface for the security services provided by
cryptographic 
  modules developed by multiple vendors. The API is intended to support
high 
  assurance cryptography, and thus offers security domain separation,
and 
  enhanced module, key, and channel management capabilities that are
vendor 
  agnostic.

Lev
_______________________________________________
cicm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cicm

---

From: "Davidson, John A." <[email-masked]>
Date: Mon, 16 May 2011 20:35:44 -0700

WARNING: contains banned part

Subject: RE: [cicm] BoF Request for CICM at IETF 81
From: "Davidson, John A." <[email-masked]>
To: "CICM Discussion List" <[email-masked]>
Date: Mon, 16 May 2011 20:35:44 -0700

Dennis wrote:  ...I still don't believe that the API offers any security domain separation.
I wish I had written that!  Policy enforcement is not an API's thing, IMHO.  

-----Original Message-----
From: [email-masked] on behalf of Bourget, Dennis
Sent: Mon 5/16/2011 6:10 PM
To: CICM Discussion List
Subject: Re: [cicm] BoF Request for CICM at IETF 81

It would then read: 

-----Original Message-----

Interesting discussion. 

Lev

---

From: "Cottrell Jr., James R." <[email-masked]>
Date: Tue, 17 May 2011 11:06:08 -0400

Sound good.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bourget, Dennis
Sent: Monday, May 16, 2011 9:11 PM
To: CICM Discussion List
Subject: Re: [cicm] BoF Request for CICM at IETF 81

It would then read: 

-----Original Message-----

Interesting discussion. 

Lev

---

From: "Kevin W. Wall" <[email-masked]>
Date: Tue, 17 May 2011 13:31:08 -0400

And while we're picking nits, should read "vendor NEUTRAL", not "vendor
agnostic"...unless you believe that nothing can be known / proven wrt the
existance of vendors. ;-)

-kevin
--
Kevin W. Wall
Sent from DroidX; please excuse typos.
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Bourget, Dennis