Subject: [cicm] Proposed WG Charter

From: "Novikov, Lev" <[email-masked]>
Date: Fri, 13 May 2011 10:52:28 -0400

CICM is at a critical point. July 24 - 29, 2011 is IETF 81 in Quebec City, 
Canada, where I want to propose CICM as a Working Group (WG) so that we can 
publish CICM as an IETF Proposed Standard.

To do this, we must discuss our WG Charter (draft below) and get maximum 
participation at IETF 81 (in-person and/or on the Jabber rooms) to prove that 
there is a community of high assurance crypto module developers, vendors, and 
users who are interested in having a standard API.

Here's what needs to happen:
1. Read the charter below. The most recent version will be hosted at:
   http://code.google.com/p/ietf-cicm/wiki/WGCharter
   
2. By COB Friday, 2011-05-20, reply to this email with one of the following:
    (a) I would vote for this charter as-is.
    (b) I would vote for a similar charter with following changes: <specify>
    (c) I would not vote for this charter at all.

3. Once a BOF is scheduled for IETF 81, we will get our own Jabber chat room. 
As many people as possible should join that chat room on the scheduled date 
(to be announced) and vote to adopt the Charter we agree to on this list.

With a Working Group we will be able to move forward in the IETF and propose 
it as a Standard. Please help make this a reality.

Thank you,
Lev

Draft CICM Working Group Charter

= Description of Working Group =
The Common Interface to Cryptographic Modules (CICM) API provides high 
assurance crypto applications with a security framework that accommodates the 
needs of a high assurance environment including security domain separation, 
and enhanced module, key, and channel management capabilities.

The purpose of the CICM Working Group is to shepherd the CICM specification 
documents to publication and provide guidance for any new submissions related 
to high assurance cryptos.

Specifically, the Working Group will:

  * Complete existing requests:
    * replace algorithm strings with OIDs
    * use ABNF notation for unique identifiers syntax
    * add module events for symmetric and asymmetric key filled

  * Shepard the following documents to publication:
    * draft-lanz-cicm
    * draft-lanz-cicm-lm
    * draft-lanz-cicm-mm
    * draft-lanz-cicm-km
    * draft-lanz-cicm-cm

= Goals and Milestones =
TBD   WGLC on draft-lanz-cicm-lm
TBD   WGLC on draft-lanz-cicm
TBD   WGLC on draft-lanz-cicm-mm
TBD   WGLC on draft-lanz-cicm-km
TBD   Submit draft-lanz-cicm to the IESG as Proposed Standard

---

From: "Krishnamurthy, Hema - ES" <[email-masked]>
Date: Mon, 16 May 2011 10:05:21 -0400

I would vote for this charter as-is.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Novikov, Lev
Sent: Friday, May 13, 2011 7:52 AM
To: CICM Discussion List ([email-masked])
Subject: [cicm] Proposed WG Charter

Thank you,
Lev

= Goals and Milestones =
TBD   WGLC on draft-lanz-cicm-lm
TBD   WGLC on draft-lanz-cicm
TBD   WGLC on draft-lanz-cicm-mm
TBD   WGLC on draft-lanz-cicm-km
TBD   Submit draft-lanz-cicm to the IESG as Proposed Standard
_______________________________________________
cicm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cicm

This e-mail and any files transmitted with it may be proprietary and are intended solely for the use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify the sender.
Please note that any views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of ITT Corporation. The recipient should check this e-mail and any attachments for the presence of viruses. ITT accepts no liability for any damage caused by any virus transmitted by this e-mail.

---

From: [email-masked]
Date: Mon, 16 May 2011 12:06:08 -0400

(a) I vote for this charter as-is.

Jim Howard
Director and Chief Engineer - Information Assurance
L-3 Communications, Communication Systems - East
Phone: 856-338-3504
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Novikov, Lev
Sent: Friday, May 13, 2011 10:52 AM
To: CICM Discussion List ([email-masked])
Subject: [cicm] Proposed WG Charter

   

Thank you,
Lev

= Goals and Milestones =

---

From: "Kevin W. Wall" <[email-masked]>
Date: Tue, 17 May 2011 00:55:54 -0400

Lev,

Looks fine to me, as is, assuming that everyone has a common understanding
of "high assurance", which I'm not so certain of.

-kevin

-- 
Blog: http://off-the-wall-security.blogspot.com/
"The most likely way for the world to be destroyed, most experts agree,
is by accident. That's where we come in; we're computer professionals.
We *cause* accidents."        -- Nathaniel Borenstein