Subject: [clue] VC mandatory in MCC?

From: Christer Holmberg <[email-masked]>
Date: Thu, 26 Sep 2013 10:01:13 +0000

Hi,

When I indicate a MCC, do I have to list which VC(s) are associated with it?

I may have an endpoint that e.g. requests a MCC with the most active speaker of the whole conference, and it doesn't really care about which VC(s) are used as "input" to the MCC.

Regards,

Christer

---

From: Christian Groves <[email-masked]>
Date: Thu, 26 Sep 2013 23:03:32 +1000

Hello Christer,

On 26/09/2013 10:11 PM, Christer Holmberg wrote:
> Hi,
>
> >From an Advertiser point of view it can populate an MCC with what it likes with respect to the captures involved. It can choose which captures make up the MCC. It doesn't have to include the source captures if it doesn't want to.
>
> Ok.
>
>> Although this means that it can't indicate source capture specific attributes and the consumer looses the benefit of being able to configure based on that information.
> Sure. But, I guess there can still be capture specific attributes for the MCC, so that I can configure things local to the MCU generating the MCC.
[CNG] Yes there can still be MCC specific capture attributes.
>
>> All the consumer would know is that the MCC contains media from a number of unknown sources with the most active speaker being shown at any particular point in time.
>>
>>  From a Consumer point of view if it receives a MCC with multiple VCs, it doesn't have to select any VCs in particular (although it can). All it needs to do is just return the MCC and an encoding.
> Good.
>
> Regards,
>
> Christer
Regards, Christian