Subject: [clue] Is 2nd most active speaker a role?

From: Christer Holmberg <[email-masked]>
Date: Tue, 24 Sep 2013 15:31:05 +0000

Hi,

Previously, I gave a comment on the role document, indicating that I would like to have the possibility to indicate things like "2nd most active speaker", "3rd most active speaker" etc. Etc it is a dynamic role, which isn't bound the role of a physical person, but rather to the system.

However, when thinking more about it, I am not sure whether it really fits the role concept, or whether it should be something else.

Do people have comments on this?

Regards,

Christer

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 24 Sep 2013 09:47:30 -0600

On 9/24/13 9:31 AM, Christer Holmberg wrote:
> Hi,
> 
> 
> 
> Previously, I gave a comment on the role document, indicating that
> I would like to have the possibility to indicate things like "2nd
> most active speaker", "3rd most active speaker" etc. Etc it is a
> dynamic role, which isn't bound the role of a physical person, but
> rather to the system.
> 
> 
> 
> However, when thinking more about it, I am not sure whether it
> really fits the role concept, or whether it should be something
> else.
> 
> 
> 

I don't even think most active speaker is a role. IMHO a role is
something less dynamic (host, scribe, presenter, etc.), whereas "the
two or three people who are producing the most sound right now" is a
kind of eventing that doesn't result in changes of roles.

Just my centigram of silver...

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 24 Sep 2013 15:59:09 +0000

Hi Peter,

I agree with you - it's not really a role :)

That's why I was wondering whether it should be kept separate from the role draft (obviously I would have to put together a separate draft for it).

Regards,

Christer

________________________________
From: Peter Saint-Andre [[email-masked]]
Sent: Tuesday, September 24, 2013 6:47 PM
To: Christer Holmberg
Cc: CLUE
Subject: Re: [clue] Is 2nd most active speaker a role?

Peter

- --
Peter Saint-Andre
https://stpeter.im/

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 24 Sep 2013 14:45:27 -0400

On 9/24/13 11:47 AM, Peter Saint-Andre wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>

I agree that we don't want roles that change frequently for a given 
capture. So attaching this to a capture when speaking, and removing when 
not is a really bad idea.

But "most active speaker" and "second most active speaker" *could* be 
roles carried by *switched* captures. They would be statically assigned 
- this switched capture always contains the most active speaker.

I'm undecided whether I like that. It could solve some problems for us.

What do others think?

	Thanks,
	Paul

> Peter
>
> - --
> Peter Saint-Andre
> https://stpeter.im/
>
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.19 (Darwin)
> Comment: GPGTools - http://gpgtools.org
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
>
> iQIcBAEBAgAGBQJSQbQRAAoJEOoGpJErxa2p2gYQAKEmIQhCaekyng/Gj0B5I+4A
> qCB/eWQulUjqsxPIpqb8qx4ZDhwZEJhIg6qxve+MOWY5gUO8Yby2+wYBGzwQYXl6
> /Aas6xox9suGt6UranW7VvJUOlDmnRvkUe7dyww3lBaLPzt+W1DK2VrHlET6GwHe
> MPr6cJaA/OziXqoMQcsT5hayJ0gJIm5o0Ol7Qho665iHh5hQf8VXuboLbTTjrcTb
> AgKddjoCudBcDaCsey3hAWCmk8OlYHvHNNSgVCbbK+UGxebadzmDNctic4xoV38y
> nA9z5+n4fWAWGWJf+mNX7mcwLpM9e720nk9X7o8YhxM7uhBmVkSxJnEaxYQTXc1h
> RhALsieIxQ5vZ/poJiX66i8RZ/jH94p81iwuBaVftlg+MsVI40tKY4hBtqS/U73H
> Bq2oK2wKAeoyZClLB39R+9RfzNvNeJoNBST3tvzMMhUWh3iDeJgfirVNaaqrqF7R
> ucN+cWISz1cFigznKPJvno4UqgpLbAwI8bYalu3sGPMY1p2t8ulEgUiCSQti6DSm
> TL2vuFDSqKH7ATCYUNMsuOzOpV/Mr/Y47Eu3Ksqi/XPj+IcmjbTPvyZ0kU7j/6vU
> 66WQhHWlc9fl82Wl6J2WicmIDDCOtZ9YagBwObme09XqKCDSl3JlXB1y+t9zn9EK
> bkuiL3QvoacUrL+QXIeW
> =FRgG
> -----END PGP SIGNATURE-----
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 25 Sep 2013 07:07:14 +0000

Hi,

>>> Previously, I gave a comment on the role document, indicating that I 
>>> would like to have the possibility to indicate things like "2nd most 
>>> active speaker", "3rd most active speaker" etc. Etc it is a dynamic 
>>> role, which isn't bound the role of a physical person, but rather to 
>>> the system.
>>>
>>> However, when thinking more about it, I am not sure whether it really 
>>> fits the role concept, or whether it should be something else.
>>>
> I agree that we don't want roles that change frequently for a given capture. So attaching this to a capture when speaking, and removing when not is a really bad idea.
>
> But "most active speaker" and "second most active speaker" *could* be roles carried by *switched* captures. They would be statically assigned

I sounds reasonable to me.

Regards,

Christer

---

From: Christian Groves <[email-masked]>
Date: Wed, 25 Sep 2013 17:39:29 +1000

Hello Christer,

I don't think "most active, second most active, etc" really fit what 
roles are about. To me they're more related to switching and switching 
policy. To me they seem to be an attribute related to a switched 
capture. I.e. the capture is switched to always show the most active 
speaker, etc.

This fits with what I have been trying to do with my multiple content 
capture draft.

Using the example of MCC that I previously posted to the list, a 
possible implementation could be:
CapScene9[Description=Output9streams,
MCC4(VC4,VC5,VC6,VC7,VC8,VC9,VC10,VC11,VC12,VC13,
VC14,VC15){MaxCaptures:1}{Policy=most_active_speaker}{Encodinggroup4}

MCC5(VC4,VC5,VC6,VC7,VC8,VC9,VC10,VC11,VC12,VC13,
VC14,VC15){MaxCaptures:1}{Policy=2nd_active_speaker}{Encodinggroup5}

etc.

This would indicate that MCC4 would contain the most active speaker from 
source captures VC4 to VC15 and MCC5 would contain the 2nd active 
speaker from source captures VC4 to VC15. If a consumer only wanted to 
see the most active speaker it would only select MCC4.

Regards, Christian

On 25/09/2013 4:45 AM, Paul Kyzivat wrote:
> capture. So attaching this to a capture when speaking, and removing 
> when not is a really bad idea.
>
> roles carried by *switched* captures. They would be statically 
> assigned - this switched capture always contains the most active speaker.
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 25 Sep 2013 11:37:23 +0000

Hi Christian,

After a first look, your proposal looks ok.

I DO have some comments about, for a given MCC, list all associated VCs, but I'll deal with that in a separate thread :)

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christian Groves
Sent: 25. syyskuuta 2013 10:39
To: [email-masked]
Subject: Re: [clue] Is 2nd most active speaker a role?

Hello Christer,

I don't think "most active, second most active, etc" really fit what roles are about. To me they're more related to switching and switching policy. To me they seem to be an attribute related to a switched capture. I.e. the capture is switched to always show the most active speaker, etc.

This fits with what I have been trying to do with my multiple content capture draft.

Using the example of MCC that I previously posted to the list, a possible implementation could be:
CapScene9[Description=Output9streams,
MCC4(VC4,VC5,VC6,VC7,VC8,VC9,VC10,VC11,VC12,VC13,
VC14,VC15){MaxCaptures:1}{Policy=most_active_speaker}{Encodinggroup4}

etc.

This would indicate that MCC4 would contain the most active speaker from source captures VC4 to VC15 and MCC5 would contain the 2nd active speaker from source captures VC4 to VC15. If a consumer only wanted to see the most active speaker it would only select MCC4.

Regards, Christian

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 25 Sep 2013 04:01:50 -0700

Comments inline.
Mark

> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Paul Kyzivat
> Sent: Tuesday, September 24, 2013 2:45 PM
> To: [email-masked]
> >> really fits the role concept, or whether it should be something else.
> >>
> I agree that we don't want roles that change frequently for a given capture.
> So attaching this to a capture when speaking, and removing when not is 
> a really bad idea.

 [Duckworth, Mark] I agree.

> assigned

[Duckworth, Mark] I'm undecided also.  I can see limited cases where it could be useful.  It fits somewhat with "segment switching", as described in the use cases.  But not a complete fit, because in that scenario there is a "most active left speaker" and "most active right speaker" etc.  And for other scenarios, like the "site switching" case, it would be more like having a set of switched captures in a scene that collectively have a role "most active speaker", but an individual capture would not always be most active speaker.  So it quickly gets complicated, and would require more thought to work out how this could be more broadly useful for CLUE.  I'll keep it in mind as I think about the switching MCU cases we still need to discuss.

---

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 24 Sep 2013 13:02:40 -0700

Comments inline.
Mark

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Paul Kyzivat
> So attaching this to a capture when speaking, and removing when not is a
> really bad idea.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sat, 28 Sep 2013 19:04:59 +0000

This appears to me to be the correct direction.

Keith

> Christian Groves
> Sent: 25 September 2013 08:39
> To: [email-masked]