Subject: [clue] Data Channel: Same stream id value in both directions?

From: Christer Holmberg <[email-masked]>
Date: Thu, 6 Feb 2014 13:30:34 +0000

Hi,

As you may have seen on the rtcweb list, when the DCP is used, one MUST use the same stream id values in both directions. That way one can associate the ACK with the OPEN.

So, if we mandate the same for CLUE (no matter if we use DCP or not), we don't need to worry about that.

I have also asked whether the data channel core could mandate the same values. Currently it doesn't.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 06 Feb 2014 11:04:05 -0500

> I have also asked whether the data channel core could mandate the same values. Currently it doesn't.

Yes, it *could*. I don't know why it doesn't now.

In principle we could define an SDP O/A procedure that negotiates pairs 
of stream ids for channels the same way you negotiate pairs of addr/port 
for RTP sessions. If one did that, then there could be independent 
stream IDs for the two directions of the channel.

But what is currently proposed is 
draft-ejzak-dispatch-webrtc-data-channel-sdpneg which requires the same 
stream ID for both directions.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 6 Feb 2014 16:27:40 +0000

Hi,

> Yes, it *could*. I don't know why it doesn't now.

I really think it should. Then people would not have to depend on other protocols (DCP, O/A, whatever).

The only reason why someone would want to use different values is because a given value is already taken on one side.

Regards,

Christer