Subject: Re: [clue] <capturePoint> should be optional

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 6 Feb 2014 10:00:45 -0800

I see <capturePoint> is still mandatory in data-model-schema-03.  Does the rest of the group agree we should change this to optional?

Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Christian Groves
> Sent: Sunday, January 19, 2014 9:38 PM
> To: [email-masked]
> Subject: Re: [clue] <capturePoint> should be optional
> 
> Hello Mark,
> 
> I agree.
> 
> Regards,
> Christian
> 
> On 18/01/2014 9:57 AM, Duckworth, Mark wrote:
> >
> > In the data model section 10.4, in "spatialInformationType", the
> > "capturePoint" element is mandatory. It really should be optional. In
> > earlier versions of the framework it was optional. This is described
> > in section 10.4.1: "If the point of capture is not specified, it means
> > the consumer should not assume anything about the spatial location of
> > the capturing device."
> >
> > So I think the schema should have minOccurs="0" for "capturePoint"
> > element. And the text right below the schema part should say optional
> > instead of mandatory.
> >
> > Mark
> >
> >
> >
> > _______________________________________________
> > clue mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/clue
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Christian Groves <[email-masked]>
Date: Fri, 07 Feb 2014 11:58:44 +1100

Yes,
Christian