Subject: [clue] Global Alternative Captures List - How to choose from multiple scenes

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 19 Feb 2014 14:28:44 -0800

At the Feb 11 design team meeting we thought this idea from Paul was worth considering.  Paul wrote (Feb 10):

================================================

- Leave existing per-scene CSE lists as-is.

- Add another advertisement-wide CSE list.  The entries in it could use shorthand, by referencing CSEs from the individual scenes.

E.g.,

                Scene1 (CSE11, CSE12, CSE13)

                Scene2 (CSE21, CSE22)

                Scene3 (CSE31)

                Scene4 (CSE41)

                Global-CSE-List (

                  CSEg1(CSE11, CSE21, CSE31)

                  CSEg2(CSE12, CSE22, CSE31)

                  CSEg3(CSE13, CSE22, CSE31)

                )

Here the global CSE list has recommended a subset of the possible combinations of CSEs from the different scenes, and has omitted Scene4 altogether. This is a value judgement of what combinations make sense.

Note that I would still allow the CSEs in the global list to reference individual captures if desired. But referencing other CSEs is a convenient shorthand.

================================================

I included a slide showing a slightly more detailed example for the case we have been discussing at previous meetings.  Slide 9 of http://trac.tools.ietf.org/wg/clue/trac/raw-attachment/wiki/Design-Team/Framework_Issues_140211.pptx  This example gives alternatives for a consumer that wants to receive only one capture, all the way up to a consumer that wants nine captures, with all possibilities in between.

I think this new proposed list could be called "global alternative captures list" rather than a "global CSE list".  Maybe somebody has a better suggestion for what to call it?  The purpose of the list is for the provider to give suggestions to the consumer about which captures to choose, considering the entire advertisement.  Each entry in the list is an alternative.  Each entry consists of a set of captures (for shorthand, could reference multiple captures at once by referencing a CSE instead of individual capture).

For an advertisement with multiple scenes, where each scene can have multiple CSEs with different number of captures in each, we have been discussing how a consumer can make a good choice between requesting captures from fewer scenes with more captures per scene, vs. requesting captures from more scenes with fewer captures per scene.  The "global alternative captures list" gives the provider a way to suggest which makes more sense from the provider's viewpoint.  Of course the consumer can still take into account all the other information such as priority, description, participant information and view attributes.

Does the group support adding this additional list to an advertisement?  Should I make a specific proposal for text to add to the framework?  Or do we need more discussion or examples?

Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 20 Feb 2014 00:01:49 -0500

Mark,

Unsurprisingly, I think this is a good idea. :-)

	Thanks,
	Paul

On 2/19/14 5:28 PM, Duckworth, Mark wrote:
> - Add another advertisement-wide CSE list.  The entries in it could use
> shorthand, by referencing CSEs from the individual scenes.
>
> E.g.,
>
> Here the global CSE list has recommended a subset of the possible
> combinations of CSEs from the different scenes, and has omitted Scene4
> altogether. This is a value judgement of what combinations make sense.
>
> Note that I would still allow the CSEs in the global list to reference
> individual captures if desired. But referencing other CSEs is a
> convenient shorthand.
>
> I included a slide showing a slightly more detailed example for the case
> we have been discussing at previous meetings.  Slide 9 of
> http://trac.tools.ietf.org/wg/clue/trac/raw-attachment/wiki/Design-Team/Framework_Issues_140211.pptx
> This example gives alternatives for a consumer that wants to receive
> only one capture, all the way up to a consumer that wants nine captures,
> with all possibilities in between.
>
> I think this new proposed list could be called “global alternative
> captures list” rather than a “global CSE list”.  Maybe somebody has a
> better suggestion for what to call it?  The purpose of the list is for
> the provider to give suggestions to the consumer about which captures to
> choose, considering the entire advertisement.  Each entry in the list is
> an alternative.  Each entry consists of a set of captures (for
> shorthand, could reference multiple captures at once by referencing a
> CSE instead of individual capture).
>
> For an advertisement with multiple scenes, where each scene can have
> multiple CSEs with different number of captures in each, we have been
> discussing how a consumer can make a good choice between requesting
> captures from fewer scenes with more captures per scene, vs. requesting
> captures from more scenes with fewer captures per scene.  The “global
> alternative captures list” gives the provider a way to suggest which
> makes more sense from the provider’s viewpoint.  Of course the consumer
> can still take into account all the other information such as priority,
> description, participant information and view attributes.
>
> Does the group support adding this additional list to an advertisement?
> Should I make a specific proposal for text to add to the framework?  Or
> do we need more discussion or examples?
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>

---

From: Christian Groves <[email-masked]>
Date: Fri, 21 Feb 2014 17:05:18 +1100

I'd like to see more detail for this, i.e. is it optional/mandatory, can 
a consumer choose another combination?, at most one CSE from a Scene in 
a CSEg? As such I'd like to see a complete example 
Advertisement/Configure and proposed text for the framework. Also if we 
do add this then I think the CSEid should be explained more in the 
framework like we do for the CaptureID.

Regards, Christian

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 21 Feb 2014 10:47:24 -0500

On 2/21/14 1:05 AM, Christian Groves wrote:
> a CSEg?

This is all subject to debate. *My* thinking is:

- the entire global CSE list is optional.
   (And the per-scene CSE lists should also be optional.)

- each entry in the global CSE list identifies a set of captures in
   the advertisement that is intended to provide a recommended valid
   rendition of the entire advertisement. It can reference each of the
   individual captures it it wishes. Or it can use "shorthand", by
   referencing other CSEs defined in the advertisement. Or a mixture
   of individual captures and CSEs.

- (Note that the shorthand here is probably the same as the shorthand
   that can be used to define the components of an MCC.
   But the restrictions on what can be referenced are different.)

- We would have to specify what to do if a global CSE references the
   same capture more than once. (As might happen if it referenced
   multiple CSEs that contain the same capture.) The obvious answer
   is to just take each one once. (I think we have discussed this
   before.)

- It now occurs to me that we might also want to allow the definition
   of global MCCs. (I haven't thought through the implications of this.)

> As such I'd like to see a complete example
> Advertisement/Configure and proposed text for the framework.

Mark already made one.

> Also if we

Maybe.

But perhaps we don't need to discuss referencing CSEs in the framework 
at all. We could just define it in the fw in terms of individual 
captures. The shorthand of referencing whole CSEs could then be limited 
to the data model. It is just another alternative, like using REs, to 
reference groups of captures.

(We might simply have the fw mention that the syntax of advertisement 
messages may include a variety of ways to simply referencing of multiple 
captures.)

	Thanks,
	Paul

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 21 Feb 2014 07:59:11 -0800

Here is a bit more detail for a proposal:
- Call it a list of "Global Capture Entries" (GCE)
- An advertisement may include an optional list of GCEs
- A GCE references a set of media captures of a particular media type.  The referenced captures can be from any capture scene in the advertisement.
- The set of captures included in a GCE are a suggestion from the provider as to which captures would be a good choice for the consumer to request, to represent a good view of the entire advertisement
- The list of GCEs may include any number of GCEs
- the order of GCEs within the list has no importance
- each GCE may include any number of captures
- the order of captures within a GCE has no importance
- The Provider MUST be capable of encoding and sending all Captures in a single Global Capture Entry simultaneously
- a GCE is similar to a CSE, but a GCE is not associated with a particular capture scene
- The Media Consumer can choose to receive all Media Captures from one Global Capture Entry for each media type (e.g. audio and video), or it can pick and choose Media Captures regardless of how the Provider arranges them in Global Capture Entries.  In other words, the CSE lists and GCE list are suggestions from the provider to consumer.  A consumer may choose, in a configure message, to request any media captures regardless of how the captures are listed in CSEs and GCEs.

I think this is all consistent with what Paul just wrote.
I am in favor of keeping the syntax related detail in the data model, such as exactly how to reference captures from a GCE or MCC.

I will add a more complete example to the framework presentation for IETF89, adding to what we had already from the Feb 11 design team meeting.  I'll ask Paul and Mary to post it so you can review it before the meeting.  I will be on vacation all next week and will not be active on this email list next week.

Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Christian Groves
> Sent: Friday, February 21, 2014 1:05 AM
> To: [email-masked]
> Subject: Re: [clue] Global Alternative Captures List - How to choose from
> multiple scenes
> 
> I'd like to see more detail for this, i.e. is it optional/mandatory, can a
> consumer choose another combination?, at most one CSE from a Scene in a
> CSEg? As such I'd like to see a complete example Advertisement/Configure
> and proposed text for the framework. Also if we do add this then I think the
> CSEid should be explained more in the framework like we do for the
> CaptureID.
> 
> Regards, Christian
> 
> >> - Add another advertisement-wide CSE list.  The entries in it could
> >> use shorthand, by referencing CSEs from the individual scenes.
> >>
> >> E.g.,
> >>
> >> combinations of CSEs from the different scenes, and has omitted
> >> Scene4 altogether. This is a value judgement of what combinations make
> sense.
> >>
> >> Note that I would still allow the CSEs in the global list to
> >> reference individual captures if desired. But referencing other CSEs
> >> is a convenient shorthand.
> >>
> >> I included a slide showing a slightly more detailed example for the
> >> case we have been discussing at previous meetings.  Slide 9 of
> >> only one capture, all the way up to a consumer that wants nine
> >> captures, with all possibilities in between.
> >>
> >> I think this new proposed list could be called "global alternative
> >> captures list" rather than a "global CSE list".  Maybe somebody has a
> >> better suggestion for what to call it?  The purpose of the list is
> >> for the provider to give suggestions to the consumer about which
> >> captures to choose, considering the entire advertisement.  Each entry
> >> in the list is an alternative.  Each entry consists of a set of
> >> captures (for shorthand, could reference multiple captures at once by
> >> referencing a CSE instead of individual capture).
> >>
> >> captures from fewer scenes with more captures per scene, vs.
> >> requesting captures from more scenes with fewer captures per scene.
> >> The "global alternative captures list" gives the provider a way to
> >> suggest which makes more sense from the provider's viewpoint.  Of
> >> course the consumer can still take into account all the other
> >> information such as priority, description, participant information and view
> attributes.
> >>
> >> Should I make a specific proposal for text to add to the framework?
> >> Or do we need more discussion or examples?
> >>
> >> Mark
> >>
> >>
> >>

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 21 Feb 2014 12:03:05 -0500

> - Call it a list of "Global Capture Entries" (GCE)

How about GCSE (Global Capture Set Entry), so the relationship to CSE is 
clear?

---

From: Christian Groves <[email-masked]>
Date: Mon, 24 Feb 2014 13:02:00 +1100

Hello Mark,

Please see my comments below.

Regards, Christian

> - A GCE references a set of media captures of a particular media type.  The referenced captures can be from any capture scene in the advertisement.
[CNG] Does a GCE need to reference multiple capture types? i.e. the 
Provider indicates a list of video GCEs and a list of audio GCEs, do we 
need to be able to tie them together?
> - The Media Consumer can choose to receive all Media Captures from one Global Capture Entry for each media type (e.g. audio and video), or it can pick and choose Media Captures regardless of how th…
[CNG] I assume a GCE must only have at most one CSE from each scene in 
the Advertisement?

       I'm also not too sure about GCEs listing individual captures. 
What does an individual capture mean at that level? The CSEs indicate 
what captures represent a scene. Why would a provider indicate that you 
need a set of captures and then contradict itself by suggesting another 
set of captures.
> I am in favor of keeping the syntax related detail in the data model, such as exactly how to reference captures from a GCE or MCC.
[CNG] With the above description you've avoided mentioning CSEs. I see 
CSEs beyond a syntax detail. We've mentioned text in the framework 
regarding CaptureID and their nature of being advertisement wide. Given 
that we have CSEs is the STS and now potentially in the GCEs, I don't 
think it hurts to say each CSE has an Adverisement wide unique 
identifier that facilitates it being referenced in STSs and GCEs.