Subject: Re: [clue] Maxcaptures in MCC

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 6 Feb 2014 08:55:50 -0800

Hi Christian,

I think I understand the general idea you are getting at, but I don't understand specifically what you are proposing as an improvement.
More comments inline.

Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Christian Groves
> Sent: Wednesday, February 05, 2014 7:20 PM
> To: [email-masked]
> Subject: Re: [clue] Now Maxcaptures - Re: spatial information can't describe
> video locations within composed MCC
> 
> Hello Paul and Mark,
> 
> The Max-captures attributes currently indicates the maximum number of
> captures that appears in a MCC at any particular point in time.
> 
> i.e. MCC(VC1,VC2,VC3),MaxCaptures=3
> So a Consumer has to assume because this is a maximum that VC1, VC2, VC3,
> (VC1,VC2), (VC1,VC3), (VC2,VC3) or (VC1,VC2,VC3) can appear at any point in
> time.

[Duckworth, Mark] I agree, that is consistent with framework-13.

> However the Consumer only ever sends a composition of (VC1,VC2,VC3). It is
> never going to change that combination. 

[Duckworth, Mark] Do you mean the Provider will always send a composition of (VC1,VC2,VC3)?  And the provider would like to be more explicit about this in the advertisement?

> It seems to me that in this case
> using MaxCaptures as it is currently defined is semantically incorrect.

[Duckworth, Mark] I think it is correct, but maybe not giving as much information as the provider wants to express.

> So what I am suggesting is simply to add a way to correctly indicate this
> "constant number of captures" case, i.e. (VC1,VC2,VC3).

[Duckworth, Mark] If I understand your suggestion correctly, then one way to do that would be to add a new optional MinCaptures attribute to an MCC.  MinCaptures is the minimum number of constituent captures that may appear in the MCC at a time.  If this attribute is not set, then it is assumed to have the default value of 1.  For this scenario, the value of both MinCaptures and MaxCaptures would be 3.  Is this what you are suggesting, or do you have something else in mind?
 
> I think Paul is questioning the attribute in general. I do believe that knowing
> the number of sources may be beneficial for a consumer in deciding which
> MCC/Captures to select. There may be tradeoffs vs a MCC only showing a
> limited number (i.e. one source) at a time vs another MCC showing multiple
> sources at a time.
> 
> Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Fri, 07 Feb 2014 11:45:25 +1100

Hello Mark,

My proposed improvement is to update the MaxCaptures parameter add the 
possibility to indicate indicate that the value is "equal to" as well as 
allowing the specification as per today "less than or equal to".

Regards, Christian

> [Duckworth, Mark] I think it is correct, but maybe not giving as much information as the provider wants to express.
[CNG] I can't see its correct. If I tell you that I can do a set of 
behaviour but I only intend to do one then I don't think that's 
truthful. Sort of like telling you I'm coming to your house one day next 
week when in fact I only intend on coming on Friday.
> [Duckworth, Mark] If I understand your suggestion correctly, then one way to do that would be to add a new optional MinCaptures attribute to an MCC.  MinCaptures is the minimum number of constituen…
[CNG] No all I had in mind was something like:
         MaxCaptures "="/"<=" value
       The Advertiser would chose to indicate "equal" or "equal to or 
less than".
>> limited number (i.e. one source) at a time vs another MCC showing multiple
[CNG] I agree I think its beneficial.

---

From: Christian Groves <[email-masked]>
Date: Fri, 07 Feb 2014 15:49:35 +1100

Hello Mark,

To be more concrete here's the text I would propose for the framework:

7.2.1.1. Maximum Number of Captures within a MCC

    The Maximum Number of Captures MCC attribute indicates the maximum
    number of individual captures that may appear in a Capture Encoding
    at a time. <<An Advertiser may indicate whether or not>>> the actual number at any given time can be less than
    this maximum.  It may be used to derive how the Single Media
    Captures within the MCC are composed / switched with regards to
    space and time. <<If the Advertiser indicates that the number of captures is equal
    to the maximum the Consumer MUST not choose a subset of captures from the MCC in a
    Configure message.>>

    Max Captures MAY be set to one so that only content related to one
    of the sources are shown in the MCC Capture Encoding at a time or
    it may be set to any value up to the total number of Source Media
    Captures in the MCC.

    If this attribute is not set then as default it is assumed that <<any numbers of sources>>
    can appear concurrently in the Capture Encoding associated with the MCC.

    For example: The use of MaxCaptures equal to 1 on a MCC with three
    Video Captures VC1, VC2 and VC3 would indicate that the Advertiser
    in the capture encoding would switch  between VC1, VC2 or VC3 as
    there may be only a maximum of one capture at a time.

Regards, Christian

On 7/02/2014 11:45 AM, Christian Groves wrote:
> possibility to indicate indicate that the value is "equal to" as well 
> as allowing the specification as per today "less than or equal to".
>
> Regards, Christian
>
>> I think I understand the general idea you are getting at, but I don't 
>> understand specifically what you are proposing as an improvement.
>> More comments inline.
>>
>> Mark
>>
>> [Duckworth, Mark] Do you mean the Provider will always send a 
>> composition of (VC1,VC2,VC3)?  And the provider would like to be more 
>> explicit about this in the advertisement?
>>
>> [Duckworth, Mark] I think it is correct, but maybe not giving as much 
>> information as the provider wants to express.
> truthful. Sort of like telling you I'm coming to your house one day 
> next week when in fact I only intend on coming on Friday.
>>
>> [Duckworth, Mark] If I understand your suggestion correctly, then one 
>> way to do that would be to add a new optional MinCaptures attribute 
>> to an MCC.  MinCaptures is the minimum number of constituent captures 
>> that may appear in the MCC at a time.  If this attribute is not set, 
>> then it is assumed to have the default value of 1.  For this 
>> scenario, the value of both MinCaptures and MaxCaptures would be 3.  
>> Is this what you are suggesting, or do you have something else in mind?
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>