Subject: [clue] CLUE-enabled call's fallback

From: "Liuyan (Scarlett)" <[email-masked]>
Date: Sat, 30 Aug 2014 02:16:29 +0000

Hello,

     I have some issues about CLUE-enabled call’s fallback.
     The signaling draft says:
            A call in which two CLUE-capable devices have successfully negotiated support for a CLUE data channel in SDP.
A CLUE-enabled call is not necessarily immediately able to send CLUE-controlled media; negotiation of the data channel and of the CLUE protocol must complete first

         But the signaling does not say something as below:

1)       When and how to stop the basic media streams?
wait and until the two CLUE-capable device finish the negotiation and use “a=inactive” or set the port number zero related to the basic media streams

2)       When and how to trigger a CLUE-enabled call fall back?
the data channel is explicitly closed by SDP O/A ;
the data channel is closed by SCTP SSN Reset (see the draft draft-ietf-rtcweb-data-protocol-03) ;or
the all CLUE-controlled media streams are removed by SDP O/A

     That’s all and comments welcome.

Best Regards,
Scarlett
________________________________

华为技术有限公司 Huawei Technologies Co., Ltd.

Phone: 0086-755-28974289
Fax:
Mobile:
Email: [email-masked]
地址：深圳市龙岗区坂田华为基地 邮编：518129
Huawei Technologies Co., Ltd.
Bantian, Longgang District,Shenzhen 518129, P.R.China
http://www.huawei.com
________________________________
本邮件及其附件含有华为公司的保密信息，仅限于发送给上面地址中列出的个人或群组。禁
止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、或散发）本邮件中
的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本邮件！
This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

---

From: Mary Barnes <[email-masked]>
Date: Sat, 30 Aug 2014 09:21:59 -0500

You are correct that this is underspecified. We do have an issue in the
tracker for this:  http://trac.tools.ietf.org/wg/clue/trac/ticket/50

So, if you have suggestions as to what we should specify in the signaling
document, that would be very helpful.

Thanks for your comments,
Mary.

On Fri, Aug 29, 2014 at 9:16 PM, Liuyan (Scarlett) <
[email-masked]> wrote:

>             A call in which two CLUE-capable devices have successfully
> negotiated support for a CLUE data channel in SDP.
>
> A CLUE-enabled call is not necessarily immediately able to send
> CLUE-controlled media; negotiation of the data channel and of the CLUE
> protocol must complete first
>
>
>
> wait and until the two CLUE-capable device finish the negotiation and use
> “a=inactive” or set the port number zero related to the basic media streams
>
>  ------------------------------
>
>
>  ------------------------------
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>
>