Subject: Re: [clue] Updates in framework-17

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 10 Oct 2014 15:20:11 -0700

Thanks Paul.
comments inline.
Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: Monday, September 29, 2014 4:55 PM
> To: [email-masked]
> Subject: Re: [clue] Updates in framework-17
> 
> A few comments on the changes in this version:
> 
> Section 3:
> 
>     Global View: A set of references to one or more Capture Scene Views
>     of the same media type that are defined within scenes of the same
>     advertisement.  Each Global View in the list is a suggestion from
>     the Provider to the Consumer for which CSVs provide a complete
>     representation of the simultaneous captures provided by the
>     Provider, across multiple scenes.
> 
> This has munged two things into one. It is in part a definition of
> Global View and in part a definition of Global View List. I think both
> should be in the definitions.
[Duckworth, Mark] How about this:

Global View: A set of references to one or more Capture Scene Views
     of the same media type that are defined within scenes of the same
     Advertisement.  A  Global View is a suggestion from
     the Provider to the Consumer for which CSVs provide a complete
     representation of the simultaneous captures provided by the
     Provider, across multiple scenes.

Global View List: A list of Global Views included in an Advertisement.

> 
>     Media Consumer: a CLUE-capable device that that is capable of
>     receiving Capture Encodings
> 
>     Media Provider: a CLUE-capable device that is capable of sending
>     Capture Encodings
> 
> I wonder if these defs should say "a CLUE-enabled* device.

[Duckworth, Mark] We don't have a definition for "CLUE-enabled device".  Would that be "a CLUE-capable device in a CLUE-enabled call"?

> Figure 1:
> 
> While this shows the Global View List, it doesn't show any Global Views.
> Ideally it would - each referencing Scene Views. But it may be hard to
> fit all that into the single diagram.

 [Duckworth, Mark] I could make a separate diagram to show just Scenes, CSVs, Global Views, and a Global View List if you think that would be helpful.

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 13 Oct 2014 10:44:37 -0400

>       Provider, across multiple scenes.

Fine.

> Global View List: A list of Global Views included in an Advertisement.

I think we need to clarify: does a Global View List contain only Global 
Views of a single media type? (This implies that we need a separate 
Global View List for each media type.) Or is there a single Global View 
List containing Global Views of different types? The data model 
currently has followed the second model.

> [Duckworth, Mark] We don't have a definition for "CLUE-enabled device".  Would that be "a CLUE-capable device in a CLUE-enabled call"?

ISTM the following are different states a *device* may be in:

- is entirely clueless. It hasn't included the clue feature tag or
   the clue group. This is already defined as a Non-CLUE device.

- it is aware of clue, but is unable or unwilling to use CLUE right now.
   It has included the clue feature tag, but not the clue group. Or else
   it has included the clue group but not included any SCTP m-line in
   the clue group. Perhaps this could be called CLUE-aware but
   CLUE-disabled.

- it is aware of clue, and wishes to use it. It has included the clue
   feature tag, and the clue group, and has included an SCTP m-line
   in the clue group. Perhaps we can call this a CLUE-enabled device.
   (This doesn't mean the *call* is CLUE-enabled.)

Note that this is distinct from the state of the call. You can have a 
clue-enabled *device* yet not have a clue-enabled *call* - both ends 
must be clue-enabled before the call is.

>   [Duckworth, Mark] I could make a separate diagram to show just Scenes, CSVs, Global Views, and a Global View List if you think that would be helpful.

I think that would be good to have. What do others think?

	Thanks,
	Paul

---

From: Christian Groves <[email-masked]>
Date: Tue, 14 Oct 2014 10:21:00 +1100

Hello

> I think we need to clarify: does a Global View List contain only 
> Global Views of a single media type? (This implies that we need a 
> separate Global View List for each media type.) Or is there a single 
> Global View List containing Global Views of different types? The data 
> model currently has followed the second model.
[CNG] Scenes contains different types of media (e.g. audio and video) so 
would then a list of scenes (Global View List) then also refers to 
different types of media?

..snip..
>>   [Duckworth, Mark] I could make a separate diagram to show just 
>> Scenes, CSVs, Global Views, and a Global View List if you think that 
>> would be helpful.
>
[CNG] I think it would be beneficial.
>
>     Thanks,
>     Paul
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 14 Oct 2014 11:27:51 -0400

> different types of media?

- Each scene contains a number of captures,
   each of a particular media type.
- Each scene contains a single sceneViews element.
   That contains a number of sceneView elements.
   This includes sceneView elements of differing media types.
- Each sceneView element contains a mediaCaptureIDs element
   referencing a number of mediaCapture elements in the scene
   and all of a single media type.
- The advertisement contains a *single* globalViews element,
   that contains multiple globalView elements.
   (Hence it had better encompass multiple media types.)
- The globalView element references multiple sceneView elements.

There is currently no statement whether or not all the sceneView 
elements referenced by a globalView must be of the same type.

We must make a choice here:

1) for a particular globalView element, all of the referenced
    sceneView elements must be of a single media type.
    In this case, a consumer should choose one globalView element
    of each type.

2) each globalView element may reference sceneView elements of
    multiple media types. Presumably in this case the chosen
    sceneView elements of differing types have been chosen to
    work well together. Presumably a consumer should choose
    a single globalView element.

We already made a similar choice when we decided to restrict the 
elements of a sceneView to a single type. If we want to be consistent 
with that, then we should choose (1) above.

The tradeoffs are:

For (1):
- the assumption is that the choice of views for different media
   types are independent - any audio will work equally well with
   any video. This may not be true.

For (2):
- this is (arguably) easier for the consumer. It need only
   search for a single globalView that it can render. And
   when it chooses one, it can assume that it is a well tuned
   combination of the different media types.

- if media of different types *are* independent, then it will
   take more globalView elements to describe all the combinations
   than (1) does.

	Thanks,
	Paul