Subject: Re: [clue] CLUE agenda for IETF91 - CLUE data channel

From: Christer Holmberg <[email-masked]>
Date: Thu, 30 Oct 2014 17:24:22 +0000

Hi,

Regarding the data channel, I think there are two technical open issues:

1)      Are we going to use SHOULD for SCTP interleaving, or are we going to allow not to use it at all?

There are currently ongoing discussions about this in both RTCWEB and TSVWG, so I guess we have to wait for the outcome.

2)      Are we going to use “Richard’s draft” (draft-ejzak-mmusic-data-channel-sdpneg)?

As we have discussed, we are open to use it, if it progresses. I guess it relates more to the CLUE signaling draft, though.

Regards,

Christer

From: clue [mailto:[email-masked]] On Behalf Of Simon Pietro Romano
Sent: 30. lokakuuta 2014 9:35
To: Paul Kyzivat; CLUE
Subject: Re: [clue] CLUE agenda for IETF91

Hi Paul,

I think that a total of 1 hour is enough for presenting both the protocol and the data model drafts.

Simon
Il 29 ottobre 2014 19:51:04 CET, Paul Kyzivat <[email-masked]<mailto:[email-masked]>> ha scritto:

You can find a very preliminary agenda for our CLUE sessions at IETF91:

     http://www.ietf.org/proceedings/91/agenda/agenda-91-clue

I tried to prioritize those things that need the most work, and that
have had recent action.

Note that for now I gave no time to the call flows, because there have
been no changes since the last meeting.

For the RTP Mapping, who will be leading the discussion? Roni or Jonathan?

I request that all authors/presenters please review this and consider
how much time you can effectively use. We don't have enough
discretionary time for followup, so if you don't need as much time as I
allotted please let me know.

And note that the agenda needs to be finalized by Monday, so I need your
feedback before then.

        Thanks,
        Paul

________________________________

clue

mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/clue

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 30 Oct 2014 13:58:02 -0400

On 10/30/14 1:24 PM, Christer Holmberg wrote:
> 1)Are we going to use SHOULD for SCTP interleaving, or are we going to
> allow not to use it at all?
>
> There are currently ongoing discussions about this in both RTCWEB and
> TSVWG, so I guess we have to wait for the outcome.

Since the discussion of data channels is on the agenda for Friday we 
will have the advantage of knowing whatever has happened on this during 
the week.

> 2)Are we going to use “Richard’s draft”
> (draft-ejzak-mmusic-data-channel-sdpneg)?
>
> As we have discussed, we are open to use it, if it progresses. I guess
> it relates more to the CLUE signaling draft, though.

Agree that is a signaling issue. I think we understand that it is a 
possibility if it gets done in time. But Mary and I agree that we 
shouldn't delay things to fit this in.

What might be work discussing is what to do if it is done in time. 
Notably, would we require it to be signaled for CLUE, or would either 
way be valid?

	Thanks,
	Paul

> Regards,
>
> Christer
>
> *From:*clue [mailto:[email-masked]] *On Behalf Of *Simon Pietro
> Romano
> *Sent:* 30. lokakuuta 2014 9:35
> *To:* Paul Kyzivat; CLUE
> *Subject:* Re: [clue] CLUE agenda for IETF91
>
> Hi Paul,
>
> Il 29 ottobre 2014 19:51:04 CET, Paul Kyzivat <[email-masked]
> <mailto:[email-masked]>> ha scritto:
>
> ------------------------------------------------------------------------
>
>
> clue
>
>
>
> mailing list
> [email-masked]  <mailto:[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 30 Oct 2014 18:30:35 +0000

Hi,

> Since the discussion of data channels is on the agenda for Friday we will have the advantage > of knowing whatever has happened on this during the week.

Let's hope so. But, I was told that Michael Tuexen will not attend the Hawaii meeting, so... 

> Agree that is a signaling issue. I think we understand that it is a possibility if it gets done in 
> time. But Mary and I agree that we shouldn't delay things to fit this in.

Earlier today I checked the MMUSIC, and the draft wasn't there. But, I heard that the chairs have received a request for agenda time, so let's see what happens.

>Notably, would we require it to be signaled for CLUE, or would either way be valid?

I guess we will ANYWAY need the CLUE grouping attribute value, since we need to group the CLUE audio- and video m- lines. So, we CAN use it to indicate that the data channel is used for CLUE.

But, I still think it would be good to have a general way for negotiating the data channel usages. Especially if someone also wants to use the data channel for something else than CLUE, I think it is bad to have different mechanisms for negotiating the usage.

Having said that, NOT having such mechanism should of course not hold CLUE hostage. 

Regards,

Christer

> discretionary time for followup, so if you don't need as much time as 
> I allotted please let me know.
>
> And note that the agenda needs to be finalized by Monday, so I need 
> your feedback before then.
>
>          Thanks,
>          Paul
>