Subject: [clue] FW: Meaning of SHOULD support/use interleaving

From: Christer Holmberg <[email-masked]>
Date: Mon, 27 Oct 2014 13:23:16 +0000

FYI,

As agreed at the design team meeting a few weeks ago, I have sent the following e-mail to the RTCWEB list.

Regards,

Christer

From: rtcweb [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 27. lokakuuta 2014 15:13
To: [email-masked]
Subject: [rtcweb] Meaning of SHOULD support/use interleaving

Hi,

Within the CLUE WG, we had a discussion regarding the following statement in section 6.1 of draft-ietf-rtcweb-data-channel-12.txt:

"The support for message interleaving as defined in
                [I-D.ietf-tsvwg-sctp-ndata] SHOULD be used."

First, it is a little unclear what "the support SHOULD be used" means.

Second, does it mean that any data channel protocol (e.g CLUE) SHOULD use interleaving, even if the characteristics of the protocol wouldn't require it?

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 27 Oct 2014 10:24:12 -0400

> following e-mail to the RTCWEB list.

Thanks Christer!

> Regards,
>
> Christer
>
> *From:*rtcweb [mailto:[email-masked]] *On Behalf Of *Christer
> Holmberg
> *Sent:* 27. lokakuuta 2014 15:13
> *To:* [email-masked]
> *Subject:* [rtcweb] Meaning of SHOULD support/use interleaving
>
> Hi,
>
> Within the CLUE WG, we had a discussion regarding the following
> statement in section 6.1 of draft-ietf-rtcweb-data-channel-12.txt:
>
> “The support for message interleaving as defined in
>
>                  [I-D.ietf-tsvwg-sctp-ndata] SHOULD be used.”
>
> First, it is a little unclear what “the support SHOULD be used” means.
>
> Second, does it mean that any data channel protocol (e.g CLUE) SHOULD
> use interleaving, even if the characteristics of the protocol wouldn’t
> require it?
>
> Regards,
>
> Christer
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>

---

From: Christian Groves <[email-masked]>
Date: Tue, 28 Oct 2014 11:58:23 +1100

It seems that RTCWEB is leaning to that this is now "MUST"?

Christian

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 28 Oct 2014 08:08:03 +0000

Hi,

>It seems that RTCWEB is leaning to that this is now "MUST"?

Yes.

I have not manage to get a reply whether it's really needed for CLUE, though :)

Regards,

Christer

On 28/10/2014 1:24 AM, Paul Kyzivat wrote:
>> *From:*rtcweb [mailto:[email-masked]] *On Behalf Of 
>> *Christer Holmberg
>> use interleaving, even if the characteristics of the protocol 
>> wouldn't require it?
>>
>> Regards,
>>
>> Christer
>>
>>
>>