Subject: [clue] Minutes & Action Items from today's design team meeting: 21-oct-2014

From: Paul Kyzivat <[email-masked]>
Date: Tue, 21 Oct 2014 10:41:56 -0400

I posted the minutes from today's design team call to the clue wiki:

http://trac.tools.ietf.org/wg/clue/trac/attachment/wiki/Design-Team/minutes-141021.txt

I didn't do a great job of minute taking. Please take a look and if 
necessary send me corrections.

Especially check the action items:

* Roni: write a proposal to the mailing list regarding what to
   do about simulcast.

* Jonathan: write a proposal for how long to send capture-id
   in RTP/RTCP.

* Rob: update signaling draft to discuss MCCs that have sources
   not listed in MCC description.

I am not confident that I have captured them accurately. (I'm not even 
sure that Rob's action item is properly an action on the signaling draft.)

	Thanks,
	Paul

---

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 21 Oct 2014 08:38:32 -0700

Hi Paul,
Your notes are consistent with my memory of the meeting.  Additionally, Rob's action to discuss MCCs with sources not in the MCC description was at least in part motivated by a use case Jonathan mentioned:
An MCU provider is sending an MCC (which includes listed individual captures, and meant to include current talker).
Then a new endpoint joins, and quickly becomes the current talker.
The MCU can include media captures from the new endpoint in the existing MCC, even before it has a chance to update its advertisement and get a new configure message from the consumer.

Regarding this part of the minutes:
Jonathan: is it possible to have both named and unnamed captures? If so, need to do some work in the draft about it.
Others: [didn't catch what was said. I think the general sense was "don't know".]

That was regarding the captures that contribute to an MCC.  As I recall, we said the advertisement can't express it that way, with both named and unnamed captures as contributors to an MCC (according to framework and data model).  But race conditions like mentioned above can happen, which led to Rob's action item.

Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: Tuesday, October 21, 2014 10:42 AM
> To: CLUE
> Subject: [clue] Minutes & Action Items from today's design team meeting:
> 21-oct-2014
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue