Subject: [clue] Updated CLUE protocol draft

From: Simon Pietro Romano <[email-masked]>
Date: Fri, 6 Feb 2015 00:39:19 +0100

Dear all,

we have just uploaded version -03 of the protocol draft. We believe we have addressed most of the issues that were raised at last IETF in Honolulu. The document should now be perfectly aligned with the companion drafts produced by the WG (with special regard to the signaling document).

Cheers,

Simon
                     					       _\\|//_
                           				      ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked]

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
  ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

---

From: Christian Groves <[email-masked]>
Date: Fri, 06 Feb 2015 12:03:47 +1100

Hello Simon,

I noticed the diff mechanism was removed. I didn't see anywhere that it 
was agreed to do this? If it was I didn't see how to handle the partial 
update mechanism moving forward.

Regards, Christian

On 6/02/2015 10:39 AM, Simon Pietro Romano wrote:
> Dear all,
>
> we have just uploaded version -03 of the protocol draft. We believe we 
> have addressed most of the issues that were raised at last IETF in 
> Honolulu. The document should now be perfectly aligned with the 
> companion drafts produced by the WG (with special regard to the 
> signaling document).
>
> Cheers,
>
> Simon
>   _\\|//_
>       ( O-O )
>            e-mail: [email-masked] <mailto:[email-masked]>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Simon Pietro Romano <[email-masked]>
Date: Wed, 11 Feb 2015 15:40:57 +0100

Hello Christian,

we actually had a long discussion on this point in Honolulu:

http://recordings.conf.meetecho.com/Playout/watch.jsp?recording=IETF91_CLUE&chapter=chapter_0 <http://recordings.conf.meetecho.com/Playout/watch.jsp?recording=IETF91_CLUE&chapter=chapter_0>

Time marks for the above recording:

- 01:02:31 --> diffs discussion starts
- 01:11:06 --> discussion seems to stop...
- 01:12:55 --> The tough question arrives: rather than deciding whether or not to make the diffs mechanism optional, we hum on whether or not to "define" the diffs mechanism
- 01:13:50 --> in the absence of clear consensus on one of the options, the chairs decide to send this to mailing list
- 01:15.13 --> we change topic

Once done with the f2f meeting, we've had your e-mail on the mailing list about this subject (on the 28th of November), to which just Paul answered on December 1st. So, no decision was taken on the ML.

My personal feeling is that there's not enough energy/interest around CLUE to justify keeping on discussing. Together with Roberta, we tried to make an effort and put the documents we're responsible for (protocol and data model) into a consistent (hopefully FINAL) state, in order to allow the group as a whole to make progress on their final revisions and bring them (as well as the companion drafts associated with framework, signaling and data channel) to successful completion. My expectation is that we're gonna close the WG anyhow sooner or later (rather sooner than later, indeed). And I personally agree with this plan, given the overall state of CLUE activities. You will certainly have noticed, e.g., that I have stopped boring you all with my thoughts on why we keep on strictly coupling CLUE with SIP!

All that said, the diffs mechanism is ready to be re-introduced in our documents, if the WG sees it fit.

My 2 cents,

Simon

> On 06/feb/2015, at 02:03, Christian Groves <[email-masked]> wrote:
> 
> Hello Simon,
> 
> I noticed the diff mechanism was removed. I didn't see anywhere that it was agreed to do this? If it was I didn't see how to handle the partial update mechanism moving forward.
> 
> Regards, Christian
> 
>>           e-mail: [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/clue <https://www.ietf.org/mailman/listinfo/clue>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/clue <https://www.ietf.org/mailman/listinfo/clue>
                     					       _\\|//_
                           				      ( O-O )