Subject: Re: [clue] [OPS-DIR] OPS-DIR review of draft-ietf-clue-data-model-schema-14

From: Simon Pietro Romano <[email-masked]>
Date: Thu, 2 Jun 2016 17:19:15 +0200

Looks great. Thanks for the hint. We’ll definitely follow the suggested path.

Simon

> On 02/giu/2016, at 15:26, Stefan Winter <[email-masked]> wrote:
> 
> Hi,
> 
>>> Of course a cleaner way would be to replace the <documentation> with an
>>> IANA registry which is then the authoritative source of all enumerated
>>> values. I think that's ultimately the cleanest option.
>> 
>> Can you please expand a bit on this? How should we modify the schema in
>> such a case?
> 
> You turn it into a simple string; with an annotation pointing to the
> IANA registry:
> 
> <xs:element name=“view" type="xs:string">
>    <xs:annotation>
>        <xs:documentation>
> 		Acceptable values (enumerations) for this type are managed by IANA in
> the "CLUE Schema <view> registry, accessible at TBD-IANA.
>        </xs:documentation>
>    </xs:annotation>
> </xs:element>
> 
> Then, in IANA considerations add a new subsection:
> 
> Registry for acceptable <view> values
> 
> IANA is requested to create a registry of acceptable values for the the
> <view> tag as defined in section ... . The initial values for this
> registry are ... ... ... .
> New values are assigned by
> (your choice of "Expert review - [name the experts]" "specification
> required [means: need RFC]")
> 
> Don't forget to add
> 
> IANA is further requested to update this draft with the URL to the new
> registry in section ..., marked as "TBD-IANA".
> 
> And then you are done.
> 
> Stefan
> 
> 
>> 
>> Thanks,
>> 
>> Simon
>> 
>>> 
>>> Greetings,
>>> 
>>> Stefan Winter
>>> 
>>>> 
>>>> Looking forward to your feedback,
>>>> 
>>>> Simon & Roberta
>>>> 
>>>> P.S. A very good summary of some of the most widely deployed
>>>> extension approaches (including the two we briefly illustrated in
>>>> this mail) can be found, e.g., here:
>>>> 
>>>> http://www.ibm.com/developerworks/library/x-extenum/
>>>> 
>>>> 
>>>> 
>>>> 
>>>>                          _\\|//_
>>>>                               ( O-O )
>>>>  ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
>>>>                   Simon Pietro Romano
>>>>            Universita' di Napoli Federico II
>>>>                   Computer Engineering Department
>>>>            Phone: +39 081 7683823 -- Fax: +39 081 7683816
>>>>                                          e-mail: [email-masked]
>>>> 
>>>>   <<Molti mi dicono che lo scoraggiamento è l'alibi degli
>>>>   idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
>>>>                                  oooO
>>>> ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
>>>>                \ (            (   )
>>>>                                 \_)          ) /
>>>>                                                                      (_/
>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>>> 
>>> <0x8A39DC66.asc>
>> 
>>                            _\\|//_
>>                                 ( O-O )
>>   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
>>                    Simon Pietro Romano
>>              Universita' di Napoli Federico II
>>                     Computer Engineering Department 
>>             Phone: +39 081 7683823 -- Fax: +39 081 7683816
>>                                           e-mail: [email-masked]
>> <mailto:[email-masked]>
>> 
>>    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
>>    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
>>                                    oooO
>>  ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
>>                 \ (            (   )
>>                                  \_)          ) /
>>                                                                       (_/
>> 
>> 
>> 
>> 
>> 
>> 
> 
> 
> -- 
> Stefan WINTER
> Ingenieur de Recherche
> Fondation RESTENA - Réseau Téléinformatique de l'Education Nationale et
> de la Recherche
> 2, avenue de l'Université
> L-4365 Esch-sur-Alzette
> 
> Tel: +352 424409 1
> Fax: +352 422473
> 
> PGP key updated to 4096 Bit RSA - I will encrypt all mails if the
> recipient's key is known to me
> 
> http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xC0DE6A358A39DC66
> <0x8A39DC66.asc>

                     					       _\\|//_
                           				      ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked]

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
  ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

---

From: Simon Pietro Romano <[email-masked]>
Date: Fri, 3 Jun 2016 21:10:41 +0200

Hello Stefan,

as anticipated, version -16 of the draft (which has just been posted) contains the modifications you suggested. Would you mind having a look at it in order to double-check whether or not the applied modifications are OK? Thanks a lot once again for your advice!

Cheers,

Simon & Roberta

P.S. BTW, version -16 of the schema file has been uploaded here:

http://wpage.unina.it/spromano/CLUE/DataModel/DataModel-16.xsd <http://wpage.unina.it/spromano/CLUE/DataModel/DataModel-16.xsd>

> On 02/giu/2016, at 17:19, Simon Pietro Romano <[email-masked]> wrote:
> 
>> On 02/giu/2016, at 15:26, Stefan Winter <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>> 
>>>>> http://www.ibm.com/developerworks/library/x-extenum/ <http://www.ibm.com/developerworks/library/x-extenum/>
>>>>> 
>>>>> 
>>>>> 
>>>>> 
>>>>>                          _\\|//_
>>>>>                               ( O-O )
>>>                                           e-mail: [email-masked] <mailto:[email-masked]>
>>> <mailto:[email-masked] <mailto:[email-masked]>>
>>> 
>> http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xC0DE6A358A39DC66 <http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xC0DE6A358A39DC66>
>> <0x8A39DC66.asc>
> 
>                      					       _\\|//_
>                            				      ( O-O )
>                                            e-mail: [email-masked] <mailto:[email-masked]>
> 

                     					       _\\|//_
                           				      ( O-O )

---

From: Stefan Winter <[email-masked]>
Date: Mon, 6 Jun 2016 09:16:21 +0200

Hello,

In 11.13 you introduced a new sentence:

"Such an attribute is compliant with [RFC2119]."

RFC2119 is not at all about XML attributes. Can you double-check the RFC
number you reference, please?

(similar in 11.15)

Other than that, I'm okay with the document now.

Greetings,

Stefan Winter

Am 03.06.2016 um 21:10 schrieb Simon Pietro Romano:
> Hello Stefan,
> 
> as anticipated, version -16 of the draft (which has just been posted)
> contains the modifications you suggested. Would you mind having a look
> at it in order to double-check whether or not the applied modifications
> are OK? Thanks a lot once again for your advice!
> 
> Cheers,
> 
> Simon & Roberta
> 
> http://wpage.unina.it/spromano/CLUE/DataModel/DataModel-16.xsd
> 
> 
>> On 02/giu/2016, at 17:19, Simon Pietro Romano <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>>> On 02/giu/2016, at 15:26, Stefan Winter <[email-masked]
>>> <mailto:[email-masked]>> wrote:
>>>
>>> Hi,
>>>

Tel: +352 424409 1
Fax: +352 422473