Subject: Re: [clue] Kathleen Moriarty's Discuss on draft-ietf-clue-data-model-schema-14: (with DISCUSS)

From: Alissa Cooper <[email-masked]>
Date: Wed, 1 Jun 2016 10:27:01 -0700

Hi Kathleen,

> On May 31, 2016, at 2:38 PM, Kathleen Moriarty <[email-masked]> wrote:
> 
> Kathleen Moriarty has entered the following ballot position for
> draft-ietf-clue-data-model-schema-14: Discuss
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> 
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-clue-data-model-schema/
> 
> 
> 
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
> 
> The document looks good, I just have a couple of items on the security
> considerations to discuss as they are not mentioned and I'm not sure if
> they have a good reason to be excluded.
> 
> 1. Session encryption to prevent active (tampering) or passive
> (information gathering for example) attacks.  Integrity protection and
> authentication are mentioned, but without looking through a few
> documents, I don't know if that means encryption or some hash value
> comparisons or something else. 

This is covered in the documents referenced in Section 25: draft-ietf-clue-framework, draft-ietf-clue-datachannel, and draft-ietf-clue-protocol.

Alissa

> 
> 2. Schema drafts tend to cover the need for well-formed schemas as part
> of the security considerations.  Can you add something in about that (not
> much is required, but it's good for implementers to know this is
> important)?  You can see two recent examples for guidance:
> YANG - https://datatracker.ietf.org/doc/draft-ietf-netmod-rfc6020bis/
> IODEF - https://datatracker.ietf.org/doc/draft-ietf-mile-rfc5070-bis/
> 
> 
> 
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: [email-masked]
Date: Wed, 1 Jun 2016 14:10:06 -0400

Sent from my iPhone

> On Jun 1, 2016, at 1:27 PM, Alissa Cooper <[email-masked]> wrote:
> 
> Hi Kathleen,
> 
Thanks, Alissa!  I should have checked, but ran out of time yesterday and wanted yo get this out.  I'll wait for a response on #2, then update comments.

Kathleen

---

From: Simon Pietro Romano <[email-masked]>
Date: Fri, 3 Jun 2016 13:02:34 +0200

Hello Kathleen,

>>> IODEF - https://datatracker.ietf.org/doc/draft-ietf-mile-rfc5070-bis/

…are you sure this is really needed? This seems definitely pleonastic to me. This said, if you think we’d better explicitly mention such a point, would you be ok with the following text
(entirely borrowed from the YANG RFC)?

"XML parsers need to be robust with respect to malformed documents. Reading malformed documents from unknown or untrusted sources could result in an attacker gaining 
privileges of the user running the XML parser. In an extreme situation, the entire machine could be compromised.”

Thanks,

Simon

                     					       _\\|//_
                           				      ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked]

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
  ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

---

From: [email-masked]
Date: Fri, 3 Jun 2016 08:41:12 -0400

Sent from my iPhone

> On Jun 3, 2016, at 7:02 AM, Simon Pietro Romano <[email-masked]> wrote:
> 
> Hello Kathleen,
> 

Yes, this would be very good.  I liked the text in that document, hence the reference.

Thanks,
Kathleen

---

From: Simon Pietro Romano <[email-masked]>
Date: Fri, 3 Jun 2016 15:12:24 +0200

Perfect. Version -16 of the draft will embed the mentioned paragraph.

Thanx,

Simon & Roberta

> On 03/giu/2016, at 14:41, [email-masked] wrote:
> 
> 
> 
> Sent from my iPhone
> 

                     					       _\\|//_
                           				      ( O-O )