Subject: [Coin] Final minutes

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 9 Aug 2019 05:02:58 -0700

The final meeting minutes are attached and uploaded in data tracker.

We will also request an interim meeting for Tuesday October 8 starting a
9am eastern time (US). Details to come.

J/E/M

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]
[email-masked]

---

From: <[email-masked]>
Date: Fri, 9 Aug 2019 10:36:33 -0400

I didn’t attend the IETF nor did I listen to any meeting minutes, if any audio exists.  Going by the pdf Marie-Jose sent out, item 6 is interesting to me.  

Dave Oran asked merging two P4 programs.  A uses case is being discussed in the P4 community.  An operator is using a P4 switch from Cisco/Arista.   However, the operator has some new service in mind.  The operator writes his/her P4 program.  How does the operator (customer) merge the customer with vendor P4 program?  Cisco was first with an incremental P4 merging tool called daPIPE.  My company also developed a tool called P4-Ansible (https://mnkcg.com/products/p4-ansible/).  Cisco only supports p4-14 programs.  Our tool supports p4-16 programs and much more.  Such merging of P4 programs changes firmware of the switch asic.  Thus, the switch data plane has to reset to run the new merged P4 programs.  The switch cpu operates control-plane and continue to run.  The whole switch doesn’t need a reset. 

Regarding, changing P4 program without resetting switch data-plane, one can change tables and table actions of the MAU (Match-Action Unit) in data plane.  P4runtime (https://s3-us-west-2.amazonaws.com/p4runtime/docs/master/P4Runtime-Spec.html) is used for such changes. 

Hemant

From: Coin <[email-masked]> On Behalf Of Marie-Jose Montpetit
Sent: Friday, August 09, 2019 8:03 AM
To: [email-masked]
Subject: [Coin] Final minutes

We will also request an interim meeting for Tuesday October 8 starting a 9am eastern time (US). Details to come.

J/E/M

 

[email-masked] <mailto:[email-masked]> 

[email-masked] <mailto:[email-masked]>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 9 Aug 2019 07:44:49 -0700

Thanks! The audio is on the datatracker for coinrg:
https://datatracker.ietf.org/rg/coinrg/meetings/

On August 9, 2019 at 10:36:06 AM, [email-masked] ([email-masked]) wrote:

I didn’t attend the IETF nor did I listen to any meeting minutes, if any
audio exists.  Going by the pdf Marie-Jose sent out, item 6 is interesting
to me.

Dave Oran asked merging two P4 programs.  A uses case is being discussed in
the P4 community.  An operator is using a P4 switch from Cisco/Arista.
 However, the operator has some new service in mind.  The operator writes
his/her P4 program.  How does the operator (customer) merge the customer
with vendor P4 program?  Cisco was first with an incremental P4 merging
tool called daPIPE.  My company also developed a tool called P4-Ansible (
https://mnkcg.com/products/p4-ansible/).  Cisco only supports p4-14
programs.  Our tool supports p4-16 programs and much more.  Such merging of
P4 programs changes firmware of the switch asic.  Thus, the switch data
plane has to reset to run the new merged P4 programs.  The switch cpu
operates control-plane and continue to run.  The whole switch doesn’t need
a reset.

Regarding, changing P4 program without resetting switch data-plane, one can
change tables and table actions of the MAU (Match-Action Unit) in data
plane.  P4runtime (
https://s3-us-west-2.amazonaws.com/p4runtime/docs/master/P4Runtime-Spec.html)
is used for such changes.

Hemant

*From:* Coin <[email-masked]> *On Behalf Of *Marie-Jose Montpetit
*Sent:* Friday, August 09, 2019 8:03 AM
*To:* [email-masked]
*Subject:* [Coin] Final minutes

J/E/M

[email-masked]

---

From: <[email-masked]>
Date: Fri, 9 Aug 2019 11:14:15 -0400

Merging P4 programs has several issues to deal with.  We have documented the issues at our P4-Ansible link below.     

Hemant

From: Marie-Jose Montpetit <[email-masked]> 
Sent: Friday, August 09, 2019 10:45 AM
To: [email-masked]; [email-masked]
Subject: RE: [Coin] Final minutes

Thanks! The audio is on the datatracker for coinrg: https://datatracker.ietf.org/rg/coinrg/meetings/

On August 9, 2019 at 10:36:06 AM, [email-masked] <mailto:[email-masked]>  ([email-masked] <mailto:[email-masked]> ) wrote:

Hemant

From: Coin <[email-masked] <mailto:[email-masked]> > On Behalf Of Marie-Jose Montpetit
Sent: Friday, August 09, 2019 8:03 AM
To: [email-masked] <mailto:[email-masked]> 
Subject: [Coin] Final minutes

J/E/M