Subject: [Coin] INT and COIN

From: Marc LeClerc <[email-masked]>
Date: Fri, 25 Oct 2019 11:19:42 -0400

Hello all,

In-band Network Telemetry is an up-and-coming mechanism to extract greater and finer-grained information from forwarding planes and make it more accessible for analytics, orchestration and automation systems - especially when paired with programmable network infrastructure.

Is this something with which the IRTF/IETF should become more involved?

Here are the current docs on INT (Open Source Technical References):

In-band Network Telemetry (P4.org App WG) by Alibaba, Arista, Barefoot, Dell, Intel, VMware: https://github.com/p4lang/p4-applications/tree/master/docs <https://github.com/p4lang/p4-applications/tree/master/docs> 

Telemetry Report Format Specification (P4.org App WG) by Barefoot, VMware, Xilinx https://github.com/p4lang/p4-applications/tree/master/docs <https://github.com/p4lang/p4-applications/tree/master/docs> 

In-situ OAM (IETF) by Facebook, Cisco, Barefoot, Comcast, etc: https://tools.ietf.org/html/draft-brockners-inband-oam-data-07 <https://tools.ietf.org/html/draft-brockners-inband-oam-data-07> 

VBR/Marc

Marc LeClerc
VP Strategy and Marketing
NoviFlow Inc.
Tel: +1-438-807-4363
Mob: +1-514-402-5948
[email-masked]

www.noviflow.com

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 25 Oct 2019 22:48:53 +0000

Thanks Marc. This raises an interesting avenue for the control plane
support to data plane programmability.

Would you like to present in Singapore - remotely it’s 10pm Thursday 11/21.

mjm

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]
[email-masked]

On October 25, 2019 at 11:19:51 AM, Marc LeClerc ([email-masked])
wrote:

Hello all,

In-band Network Telemetry is an up-and-coming mechanism to extract greater
and finer-grained information from forwarding planes and make it more
accessible for analytics, orchestration and automation systems - especially
when paired with programmable network infrastructure.

In-band Network Telemetry (P4.org App WG) by Alibaba, Arista, Barefoot,
Dell, Intel, VMware:
https://github.com/p4lang/p4-applications/tree/master/docs

Telemetry Report Format Specification (P4.org App WG) by Barefoot,
VMware, Xilinx https://github.com/p4lang/p4-applications/tree/master/docs

In-situ OAM (IETF) by Facebook, Cisco, Barefoot, Comcast, etc:
https://tools.ietf.org/html/draft-brockners-inband-oam-data-07

VBR/Marc

Marc LeClerc

www.noviflow.com

-- 
Coin mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/coin

---

From: Marc LeClerc <[email-masked]>
Date: Sun, 27 Oct 2019 14:53:59 -0400

Hello MJM,

I would be pleased to give a short presentation on why NoviFlow believes INT (P4.org <http://p4.org/>) is likely to be a fruitful avenue for research by the members of COIN and the IETF.

Please let me know the details.

VBR/Marc

Marc LeClerc

www.noviflow.com

> On Oct 25, 2019, at 6:48 PM, Marie-Jose Montpetit <[email-masked]> wrote:
> 
> Thanks Marc. This raises an interesting avenue for the control plane support to data plane programmability.
> 
> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> On October 25, 2019 at 11:19:51 AM, Marc LeClerc ([email-masked] <mailto:[email-masked]>) wrote:
> 
>> Hello all,
>> 
>> In-band Network Telemetry (P4.org <http://p4.org/> App WG) by Alibaba, Arista, Barefoot, Dell, Intel, VMware: https://github.com/p4lang/p4-applications/tree/master/docs <https://github.com/p4lang/p4-applications/tree/master/docs> 
>> 
>> Telemetry Report Format Specification (P4.org <http://p4.org/> App WG) by Barefoot, VMware, Xilinx https://github.com/p4lang/p4-applications/tree/master/docs <https://github.com/p4lang/p4-applications/tree/master/docs> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> 
>> www.noviflow.com <http://www.noviflow.com/>
>> <[email-masked]>
>> 
>> --  
>> Coin mailing list 
>> [email-masked] <mailto:[email-masked]> 
>> https://www.irtf.org/mailman/listinfo/coin <https://www.irtf.org/mailman/listinfo/coin>