Subject: [Coin] Academic contributions in COIN

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 8 Oct 2019 15:54:51 +0000

Today at the Interim Noa Zilberman raised the issue on how to help
academics contribute to COIN (thanks Noa!).

Obviously drafts are not the right vehicle for most academics and Colin
Perkins added that we could have other mechanisms.

Some inputs:
- academic presentations at the meeting with appropriate papers stored in
the Github and datatracker (we already have done some of this)
- if a topic could lead to a RFC support academic collaborators in writing
a draft
- keeping a list of related conferences and try to have mini-PRG meetings
there

But I am sure there is much more. So what are the list’s ideas?

The minutes of the meeting will be issued and I have a recording I will
upload to the GitHub.

Thanks all!

mjm

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]
[email-masked]

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 8 Oct 2019 18:31:51 +0000

Some comments below.

On October 8, 2019 at 2:01:33 PM, Noa Zilberman ([email-masked])
wrote:

Hi,

I would suggest that we need to find ways to incentivize academics to
engage with COIN.

Some ideas that I can think of are:
1. Clearly list challenges on the wiki. These may be accompanied by drafts,
but not necessarily, and can be something that was discussed on the mailing
list,
   a presentation from a meeting etc. Ideally those will be accompanied by
one or two lines to describe the challenge (+pointers). This helps not only
to identify gaps, but also if there's a graduate student looking for a
project in in-network computing, there may be a "go to page" hosted by
COINRG with potential research challenges, and potential collaborators.

This is at good idea for the Github - if we phase out the wiki - as it is
easier to collaborate. I think challenges could be discussed on the mailing
list then uploaded and I would love for people involved (the collaborators)
to edit the challenge as things progress - or at least send us the updates
As for the “go to page” it’s for me part of the description like you say
“the posters”..

2. Invite postdocs and students to talk at the meetings. They are usually
the first authors of papers so they know the tech side well, are more
likely to have the time to travel, and are eager to discuss their research.

In my mind when we invite someone any member of the team can come :) Of
course there are the issues of travel, registration etc. Sadly we do not
have a budget.

3. Make data available (this was briefly mentioned in the meeting). These
may be use cases, datasets, traces etc.  Research is better if it is driven
by real world data (and more likely to get published).

Yes! Data from real world sets and librairies I would say. Or at least
real-world use cases.

4. List collaboration opportunities, internships etc that fall within
COINRG domain.

Of course!

mjm

Kind Regards,
Noa

On Tue, Oct 8, 2019 at 4:55 PM Marie-Jose Montpetit <[email-masked]>
wrote:

> --
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin
>

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 9 Oct 2019 07:28:55 +0000

Hi,

In NMRG, we're facing similar challenges wrt. involvement of academics.
Here are few of the things we have done / are trying to do:

- Co-locate interim meetings at universities/research centers (or local/regional hubs) with active teams in the domain and try to attract close-by teams to participate.
- Bring the RG where the research/academic community meets and provide tutorials, interim meetings there. This is useful also to bring the knowledge of what the RG is, how it works and sometimes the activity of the RG is more focused/advanced on some areas and helps to teach/increase the level of awareness of the community.
- Publish position paper(s) and survey paper(s) on the topic by active members of the RG. This is usually well handled by a mix of industry/academic teams and link the published papers as results/outcome of the RG. This is usually more straightforward and timely than going through the RFC publication cycle (even with efficient processing, by the time of RFC publication, the content may be obsolete / not so relevant anymore).
- Balance theoretical and practical aspects of the research.
- If relevant, create dedicated workshops (co-located with conference on the topic), special issues in journals/magazines.
- Liaise with research projects (EU has regular calls and projects). Such consortia are usually good sources of inputs/resources and are eager to contribute to (pre-)standardization activities.
- We have used virtual meetings as a means to ease participation and involvement. Remote participation at IETF meetings (active or passive) is also useful.

I think you are aware of it, but at most IETF meetings, academics and locals could get access to "discounted" rates.

I also welcome other proposals and feedback, because this is, I think, a common challenge for the IRTF RGs.

At another level, having another "official" and recognized output channel from the IRTF (i.e. not only RFCs) would be much useful. I remember there have been discussions on an IRTF Journal ("ANRJ" 😉). I would much support this project.

HTH, best regards, Laurent.

From: Coin <[email-masked]> On Behalf Of Marie-Jose Montpetit
Sent: Tuesday, October 8, 2019 20:32
To: Noa Zilberman <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Coin] Academic contributions in COIN

Some comments below.

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>

On October 8, 2019 at 2:01:33 PM, Noa Zilberman ([email-masked]<mailto:[email-masked]>) wrote:
Hi,

I would suggest that we need to find ways to incentivize academics to engage with COIN.

Some ideas that I can think of are:
1. Clearly list challenges on the wiki. These may be accompanied by drafts, but not necessarily, and can be something that was discussed on the mailing list,
   a presentation from a meeting etc. Ideally those will be accompanied by one or two lines to describe the challenge (+pointers). This helps not only to identify gaps, but also if there's a graduate student looking for a project in in-network computing, there may be a "go to page" hosted by COINRG with potential research challenges, and potential collaborators.

This is at good idea for the Github - if we phase out the wiki - as it is easier to collaborate. I think challenges could be discussed on the mailing list then uploaded and I would love for people involved (the collaborators) to edit the challenge as things progress - or at least send us the updates As for the “go to page” it’s for me part of the description like you say “the posters”..

2. Invite postdocs and students to talk at the meetings. They are usually the first authors of papers so they know the tech side well, are more likely to have the time to travel, and are eager to discuss their research.

In my mind when we invite someone any member of the team can come :) Of course there are the issues of travel, registration etc. Sadly we do not have a budget.

3. Make data available (this was briefly mentioned in the meeting). These may be use cases, datasets, traces etc.  Research is better if it is driven by real world data (and more likely to get published).

Yes! Data from real world sets and librairies I would say. Or at least real-world use cases.

4. List collaboration opportunities, internships etc that fall within COINRG domain.

Of course!

mjm

Kind Regards,
Noa

On Tue, Oct 8, 2019 at 4:55 PM Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> wrote:
Today at the Interim Noa Zilberman raised the issue on how to help academics contribute to COIN (thanks Noa!).

Obviously drafts are not the right vehicle for most academics and Colin Perkins added that we could have other mechanisms.

Some inputs:
- academic presentations at the meeting with appropriate papers stored in the Github and datatracker (we already have done some of this)
- if a topic could lead to a RFC support academic collaborators in writing a draft
- keeping a list of related conferences and try to have mini-PRG meetings there

The minutes of the meeting will be issued and I have a recording I will upload to the GitHub.

Thanks all!

mjm

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
--
Coin mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/coin

---

From: Noa Zilberman <[email-masked]>
Date: Tue, 8 Oct 2019 19:00:56 +0100

Hi,

Kind Regards,
Noa

---

From: Rute Sofia <[email-masked]>
Date: Wed, 9 Oct 2019 08:38:11 +0000

Hello,

I would also suggest considering organizing tutorials and workshops co-located with relevant scientific events. IMO most students are not directed to standardisation. Therefore, most of them usually do not work towards the IETF/IRTF.

So to attract academia, one of the best intruments are scientific events.

BR
Rute Sofia

From: Coin <[email-masked]> On Behalf Of Noa Zilberman
Sent: 08 October 2019 20:01
To: Marie-Jose Montpetit <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Coin] Academic contributions in COIN

Hi,

Kind Regards,
Noa

Some inputs:

Thanks all!

mjm

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 03:41:45 -0700

But that is the point: IRTF is NOT standardisation.

But OK for tutorials it seems its needed :)

mjm

On October 9, 2019 at 4:38:21 AM, Rute Sofia ([email-masked]) wrote:

Hello,

I would also suggest considering organizing tutorials and workshops
co-located with relevant scientific events. IMO most students are not
directed to standardisation. Therefore, most of them usually do not work
towards the IETF/IRTF.

BR

Rute Sofia

*From:* Coin <[email-masked]> *On Behalf Of *Noa Zilberman
*Sent:* 08 October 2019 20:01
*To:* Marie-Jose Montpetit <[email-masked]>
*Cc:* [email-masked]; [email-masked]
*Subject:* Re: [Coin] Academic contributions in COIN

Hi,

Kind Regards,

Noa

Some inputs:

Thanks all!

mjm

[email-masked]

---

From: Rute Sofia <[email-masked]>
Date: Wed, 9 Oct 2019 11:01:49 +0000

Well,

it is for students. I am in both worlds (academia and research towards industry) so… ☺
Rute

From: Marie-Jose Montpetit <[email-masked]>
Sent: 09 October 2019 12:42
To: Rute Sofia <[email-masked]>; Noa Zilberman <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: [Coin] Academic contributions in COIN

mjm

On October 9, 2019 at 4:38:21 AM, Rute Sofia ([email-masked]<mailto:[email-masked]>) wrote:
Hello,

BR
Rute Sofia

From: Coin <[email-masked]<mailto:[email-masked]>> On Behalf Of Noa Zilberman
Sent: 08 October 2019 20:01
To: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Coin] Academic contributions in COIN

Hi,

Kind Regards,
Noa

Some inputs:

Thanks all!

mjm

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 04:09:48 -0700

I also did both and still do. But if professors are not interested students
will not either. So we have to work all angles.

On October 9, 2019 at 7:02:00 AM, Rute Sofia ([email-masked]) wrote:

Well,

it is for students. I am in both worlds (academia and research towards
industry) so… J

Rute

*From:* Marie-Jose Montpetit <[email-masked]>
*Sent:* 09 October 2019 12:42
*To:* Rute Sofia <[email-masked]>; Noa Zilberman <
[email-masked]>
*Cc:* [email-masked]; [email-masked]
*Subject:* RE: [Coin] Academic contributions in COIN

mjm

[email-masked]

Hello,

BR

Rute Sofia

Hi,

Kind Regards,

Noa

Some inputs:

Thanks all!

mjm

[email-masked]

---

From: Frank Fitzek <[email-masked]>
Date: Wed, 9 Oct 2019 14:08:10 +0200

Dear all,

I find the discussion about academic involvement very interesting and 
from our side we are interested in

- research topics wrt COIN

- teaching activities around COIN

- implementation discussion wrt complexity and more

For the teaching activity we made our own emulator with several examples 
of machine learning (congestion control/routing/object detection), 
coding and compression etc. So if anybody is interested in these topics, 
I will be in Singapore and hopefully have a lot of interesting discussions.

Frank

On 09.10.2019 13:09, Marie-Jose Montpetit wrote:
> I also did both and still do. But if professors are not interested 
> students will not either. So we have to work all angles.
>
> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
>
> On October 9, 2019 at 7:02:00 AM, Rute Sofia ([email-masked] 
> <mailto:[email-masked]>) wrote:
>
>> Well,
>>
>> it is for students. I am in both worlds (academia and research 
>> towards industry) so… J
>>
>> Rute
>>
>> *From:*Marie-Jose Montpetit <[email-masked] 
>> <mailto:[email-masked]>>
>> *To:* Rute Sofia <[email-masked] <mailto:[email-masked]>>; Noa 
>> Zilberman <[email-masked] 
>> <mailto:[email-masked]>>
>> *Cc:* [email-masked] <mailto:[email-masked]>; 
>> [email-masked] <mailto:[email-masked]>
>> But that is the point: IRTF is NOT standardisation..
>>
>> [email-masked] <mailto:[email-masked]>
>>
>> [email-masked] <mailto:[email-masked]>
>>
>>     I would also suggest considering organizing tutorials and
>>     workshops co-located with relevant scientific events. IMO most
>>     students are not directed to standardisation. Therefore, most of
>>     them usually do not work towards the IETF/IRTF.
>>
>>     *From:*Coin <[email-masked]
>>     <mailto:[email-masked]>> *On Behalf Of *Noa Zilberman
>>     *To:* Marie-Jose Montpetit <[email-masked]
>>     <mailto:[email-masked]>>
>>     *Cc:* [email-masked] <mailto:[email-masked]>;
>>     [email-masked] <mailto:[email-masked]>
>>     1. Clearly list challenges on the wiki. These may be accompanied
>>     by drafts, but not necessarily, and can be something that was
>>     discussed on the mailing list,
>>
>>      a presentation from a meeting etc. Ideally those will be
>>     accompanied by one or two lines to describe the challenge
>>     (+pointers). This helps not only to identify gaps, but also if
>>     there's a graduate student looking for a project in in-network
>>     computing, there may be a "go to page" hosted by COINRG with
>>     potential research challenges, and potential collaborators.
>>
>>     2. Invite postdocs and students to talk at the meetings. They are
>>     usually the first authors of papers so they know the tech side
>>     well, are more likely to have the time to travel, and are eager
>>     to discuss their research.
>>
>>     3. Make data available (this was briefly mentioned in the
>>     meeting). These may be use cases, datasets, traces etc. Research
>>     is better if it is driven by real world data (and more likely to
>>     get published).
>>
>>     On Tue, Oct 8, 2019 at 4:55 PM Marie-Jose Montpetit
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>         Today at the Interim Noa Zilberman raised the issue on how to
>>         help academics contribute to COIN (thanks Noa!).
>>
>>         Obviously drafts are not the right vehicle for most academics
>>         and Colin Perkins added that we could have other mechanisms.
>>
>>         Some inputs:
>>
>>         - academic presentations at the meeting with appropriate
>>         papers stored in the Github and datatracker (we already have
>>         done some of this)
>>
>>         [email-masked] <mailto:[email-masked]>
>>
>>         mariejo@mit..edu <mailto:[email-masked]>
>>
>>         -- 
>>         Coin mailing list
>>         [email-masked] <mailto:[email-masked]>
-- 

Frank H.P. Fitzek
Professor
Deutsche Telekom Chair of Communication Networks
Institute of Communication Technology
Technische Universität Dresden

mobile: +49 151 160 00003
phone:  +49 351 463 33945
fax:    +49 351 463 37163

web:	cn.ifn.et.tu-dresden.de

5G Lab Germany - Coordinator - 5Glab.de
CeTI - Speaker - ceti.tu-dresden.de
Smart System Hub - Speaker - smart-systems-hub.de

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 05:21:17 -0700

Thanks Frank!

Do you have a link to your emulator we could add to the list or a GitHub
link; can it be accessed remotely with all licensing aspects if licenses
are needed as a principle especially for students I would favor Open Source
implementations. And what is the goal of your emulator and how does it
relate to the topics currently being investigated by the PRG? Maybe
presenting your emulator could be part of your presentation in Singapore.

On teaching we could make a list of classes related to data plane
programmability (like P4), architectures using COIN (I will give one of
those before Singapore and could make the material available), technology
classes using COIN or COIN-like principles etc.  I will create a special
area in Github.

On October 9, 2019 at 8:08:24 AM, Frank Fitzek ([email-masked])
wrote:

Dear all,

I find the discussion about academic involvement very interesting and from
our side we are interested in

For the teaching activity we made our own emulator with several examples of
machine learning (congestion control/routing/object detection), coding and
compression etc. So if anybody is interested in these topics, I will be in
Singapore and hopefully have a lot of interesting discussions.

Frank

Well,

Rute

mjm

[email-masked]

Hello,

BR

Rute Sofia

Hi,

Kind Regards,

Noa

Some inputs:

Thanks all!

mjm

mariejo@mit..edu <[email-masked]>

-- 

Frank H.P. Fitzek
Professor

---

From: Frank Fitzek <[email-masked]>
Date: Wed, 9 Oct 2019 14:30:03 +0200

We are currently finalizing everything, but will be online in two weeks. 
All materials and teaching content will be here ...

https://cn.ifn.et.tu-dresden.de/teaching/lectures/comnets_3/

On 09.10.2019 14:21, Marie-Jose Montpetit wrote:
> Thanks Frank!
>
> Do you have a link to your emulator we could add to the list or a 
> GitHub link; can it be accessed remotely with all licensing aspects if 
> licenses are needed as a principle especially for students I would 
> favor Open Source implementations. And what is the goal of your 
> emulator and how does it relate to the topics currently being 
> investigated by the PRG? Maybe presenting your emulator could be part 
> of your presentation in Singapore.
>
> programmability (like P4), architectures using COIN (I will give one 
> of those before Singapore and could make the material available), 
> technology classes using COIN or COIN-like principles etc.  I will 
> create a special area in Github.
>
>
> On October 9, 2019 at 8:08:24 AM, Frank Fitzek 
> ([email-masked] <mailto:[email-masked]>) wrote:
>
>> Dear all,
>>
>> For the teaching activity we made our own emulator with several 
>> examples of machine learning (congestion control/routing/object 
>> detection), coding and compression etc. So if anybody is interested 
>> in these topics, I will be in Singapore and hopefully have a lot of 
>> interesting discussions.
>>
>> Frank
>>
>>>> *To:* Rute Sofia <[email-masked] <mailto:[email-masked]>>; 
>>>> Noa Zilberman <[email-masked] 
>>>>     students are not directed to standardisation. Therefore, most
>>>>     of them usually do not work towards the IETF/IRTF.
>>>>
>>>>     1. Clearly list challenges on the wiki. These may be
>>>>     accompanied by drafts, but not necessarily, and can be
>>>>     something that was discussed on the mailing list,
>>>>
>>>>     2. Invite postdocs and students to talk at the meetings. They
>>>>     are usually the first authors of papers so they know the tech
>>>>     side well, are more likely to have the time to travel, and are
>>>>     eager to discuss their research.
>>>>
>>>>     meeting). These may be use cases, datasets, traces etc.
>>>>     Research is better if it is driven by real world data (and more
>>>>     likely to get published).
>>>>
>>>>         Today at the Interim Noa Zilberman raised the issue on how
>>>>         to help academics contribute to COIN (thanks Noa!).
>>>>
>>>>         Obviously drafts are not the right vehicle for most
>>>>         academics and Colin Perkins added that we could have other
>>>>         mechanisms.
>>>>
>>>>         Some inputs:
>>>>
>>>>         papers stored in the Github and datatracker (we already
>>>>         have done some of this)
>>>>
>> web:	cn.ifn.et.tu-dresden.de  <http://cn.ifn.et.tu-dresden.de>
>>
>>
>>
>> CeTI - Speaker -ceti.tu-dresden.de  <http://ceti.tu-dresden.de>
>> Smart System Hub - Speaker -smart-systems-hub.de  <http://smart-systems-hub.de>
>> -- 
>> Coin mailing list
-- 

Frank H.P. Fitzek
Professor

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 05:30:54 -0700

Thanks!

On October 9, 2019 at 8:30:06 AM, Frank Fitzek ([email-masked])
wrote:

Thanks Frank!

Dear all,

Frank

Well,

Rute

mjm

[email-masked]

Hello,

BR

Rute Sofia

Hi,

Kind Regards,

Noa

Some inputs:

Thanks all!

mjm

-- 

Frank H.P. Fitzek
Professor

-- 

Frank H.P. Fitzek
Professor

---

From: Rute Sofia <[email-masked]>
Date: Wed, 9 Oct 2019 13:12:27 +0000

Dear Marie-Jose Montpetit,

there is a reason for that. Standards are not usually, at least in Europe, considered valid success indicators from an academic/scientific perspective. Classes on research methodologies do not usually approach standardisation, even if oriented towards research. That is why a lot of students (IMO, from my own academic experience in several countries) don’t follow the IRTF/IETF.

Additionally, participation in the IRTF/IETF requires travelling, which is costly. Academic institutions and projects do not (usually ) foresee this. In fact, in European projects the standardisation is actually left to the industry partners. No funding, no reason to participate ☺

This is slowly changing.

Tutorials, and organization of workshops co-located to scientific events, is a fast way to attract students. After all, most conferences today have a PhD forum…I agree also with the other measures being proposed…

BR
Rute

Sent: 09 October 2019 13:10

I also did both and still do. But if professors are not interested students will not either. So we have to work all angles.

On October 9, 2019 at 7:02:00 AM, Rute Sofia ([email-masked]<mailto:[email-masked]>) wrote:
Well,

From: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>
Sent: 09 October 2019 12:42
To: Rute Sofia <[email-masked]<mailto:[email-masked]>>; Noa Zilberman <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Coin] Academic contributions in COIN

mjm

BR
Rute Sofia

Hi,

Kind Regards,
Noa

Some inputs:

Thanks all!

mjm

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 06:20:32 -0700

This is why we have to make sure we do not put IRTF and IETF in the same
sentence…

Again, IRTF is not standardisation more like a forum to share research on
common networking topics. The fact we meet at the IETF locations is for
convenience and it was mentioned earlier this month on a chairs mailing
list that it is not mandatory.

And you can participate remotely for free and we had a number of
contributions that way in the past years.

On October 9, 2019 at 9:12:30 AM, Rute Sofia ([email-masked]) wrote:

there is a reason for that. Standards are not usually, at least in Europe,
considered valid success indicators from an academic/scientific
perspective. Classes on research methodologies do not usually approach
standardisation, even if oriented towards research. That is why a lot of
students (IMO, from my own academic experience in several countries) don’t
follow the IRTF/IETF.

Additionally, participation in the IRTF/IETF requires travelling, which is
costly. Academic institutions and projects do not (usually ) foresee this.
In fact, in European projects the standardisation is actually left to the
industry partners. No funding, no reason to participate J

This is slowly changing.

Tutorials, and organization of workshops co-located to scientific events,
is a fast way to attract students. After all, most conferences today have a
PhD forum…I agree also with the other measures being proposed…

BR

Rute

*Sent:* 09 October 2019 13:10

[email-masked]

Well,

Rute

mjm

[email-masked]

Hello,

BR

Rute Sofia

Hi,

Kind Regards,

Noa

Some inputs:

Thanks all!

mjm

[email-masked]

---

From: Rute Sofia <[email-masked]>
Date: Wed, 9 Oct 2019 13:22:07 +0000

Well,
indeed that has to be made clearer to students and to teachers…

BR
Rute

Sent: 09 October 2019 15:21

This is why we have to make sure we do not put IRTF and IETF in the same sentence…

Again, IRTF is not standardisation more like a forum to share research on common networking topics. The fact we meet at the IETF locations is for convenience and it was mentioned earlier this month on a chairs mailing list that it is not mandatory.

And you can participate remotely for free and we had a number of contributions that way in the past years.

On October 9, 2019 at 9:12:30 AM, Rute Sofia ([email-masked]<mailto:[email-masked]>) wrote:
Dear Marie-Jose Montpetit,

This is slowly changing.

BR
Rute

mjm

BR
Rute Sofia

Hi,

Kind Regards,
Noa

Some inputs:

Thanks all!

mjm

mariejo@mit..edu<mailto:[email-masked]>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 06:23:27 -0700

And we should all help!

On October 9, 2019 at 9:22:11 AM, Rute Sofia ([email-masked]) wrote:

Well,

BR

Rute

*From:* Coin <[email-masked]> *On Behalf Of *Marie-Jose Montpetit
*Sent:* 09 October 2019 15:21
*To:* Rute Sofia <[email-masked]>; Noa Zilberman <
[email-masked]>
*Cc:* [email-masked]; [email-masked]
*Subject:* Re: [Coin] Academic contributions in COIN

[email-masked]

This is slowly changing.

BR

Rute

[email-masked]

Well,

Rute

mjm

[email-masked]

Hello,

BR

Rute Sofia

Hi,

Kind Regards,

Noa

Some inputs:

Thanks all!

mjm

---

From: Frank Fitzek <[email-masked]>
Date: Wed, 9 Oct 2019 15:28:55 +0200

Regarding the emulator, my colleague Hani will subscribe to the list and 
share the link with more details. The emulator comes with examples and 
can be used for tutorials if needed.

FF

On 09.10.2019 15:23, Marie-Jose Montpetit wrote:
> On October 9, 2019 at 9:22:11 AM, Rute Sofia ([email-masked] 
>> *From:*Coin <[email-masked] <mailto:[email-masked]>> 
>> *On Behalf Of *Marie-Jose Montpetit
>> Again, IRTF is not standardisation more like a forum to share 
>> research on common networking topics. The fact we meet at the IETF 
>> locations is for convenience and it was mentioned earlier this month 
>> on a chairs mailing list that it is not mandatory.
>>
>>     there is a reason for that. Standards are not usually, at least
>>     in Europe, considered valid success indicators from an
>>     academic/scientific perspective. Classes on research
>>     methodologies do not usually approach standardisation, even if
>>     oriented towards research. That is why a lot of students (IMO,
>>     from my own academic experience in several countries) don’t
>>     follow the IRTF/IETF.
>>
>>     Additionally, participation in the IRTF/IETF requires travelling,
>>     which is costly. Academic institutions and projects do not
>>     (usually ) foresee this. In fact, in European projects the
>>     standardisation is actually left to the industry partners.. No
>>     funding, no reason to participate J
>>
>>     This is slowly changing.
>>
>>     Tutorials, and organization of workshops co-located to scientific
>>     events, is a fast way to attract students. After all, most
>>     conferences today have a PhD forum…I agree also with the other
>>     measures being proposed…
>>
>>     BR
>>
>>     Rute
>>
>>     I also did both and still do. But if professors are not
>>     interested students will not either. So we have to work all angles.
>>
>>         it is for students. I am in both worlds (academia and
>>         research towards industry) so… J
>>
>>         Rute
>>
>>         *To:* Rute Sofia <[email-masked]
>>         <mailto:[email-masked]>>; Noa Zilberman
>>         <[email-masked] <mailto:[email-masked]>>
>>         On October 9, 2019 at 4:38:21 AM, Rute Sofia
>>         ([email-masked] <mailto:[email-masked]>) wrote:
>>
>>             Hello,
>>
>>             workshops co-located with relevant scientific events. IMO
>>             most students are not directed to standardisation.
>>             Therefore, most of them usually do not work towards the
>>             IETF/IRTF.
>>
>>             *Cc:* [email-masked]
>>             <mailto:[email-masked]>; [email-masked]
>>             <mailto:[email-masked]>
>>             (+pointers). This helps not only to identify gaps, but
>>             also if there's a graduate student looking for a project
>>             in in-network computing, there may be a "go to page"
>>             hosted by COINRG with potential research challenges, and
>>             potential collaborators.
>>
>>             2. Invite postdocs and students to talk at the meetings.
>>             They are usually the first authors of papers so they know
>>             the tech side well, are more likely to have the time to
>>             travel, and are eager to discuss their research.
>>
>>             Research is better if it is driven by real world data
>>             (and more likely to get published).
>>
>>                 Today at the Interim Noa Zilberman raised the issue
>>                 on how to help academics contribute to COIN (thanks
>>                 Noa!).
>>
>>                 academics and Colin Perkins added that we could have
>>                 other mechanisms.
>>
>>                 Some inputs:
>>
>>                 - academic presentations at the meeting with
>>                 appropriate papers stored in the Github and
>>                 datatracker (we already have done some of this)
>>
>>                 <mailto:[email-masked]>
>>
>>                 mariejo@mit...edu <mailto:[email-masked]>
>>
>>                 -- 
>>                 Coin mailing list
-- 

Frank H.P. Fitzek
Professor

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 06:33:31 -0700

I will also point out the Note Well for contribution to the PRG if its
needed.

mjm

On October 9, 2019 at 9:29:11 AM, Frank Fitzek ([email-masked])
wrote:

Regarding the emulator, my colleague Hani will subscribe to the list and
share the link with more details. The emulator comes with examples and can
be used for tutorials if needed.

FF

And we should all help!

Well,

BR

Rute

[email-masked]

Additionally, participation in the IRTF/IETF requires travelling, which is
costly. Academic institutions and projects do not (usually ) foresee this.
In fact, in European projects the standardisation is actually left to the
industry partners.. No funding, no reason to participate J

This is slowly changing.

BR

Rute

[email-masked]

Well,

Rute

mjm

[email-masked]

Hello,

BR

Rute Sofia

Hi,

Kind Regards,

Noa

Some inputs:

Thanks all!

mjm

mariejo@mit...edu <[email-masked]>

-- 

Frank H.P. Fitzek
Professor

---

From: Aaron Ding <[email-masked]>
Date: Wed, 9 Oct 2019 13:33:33 +0000

Hi Rute,

assumingly, some points below have been made for both communities, especially for the European academic side:
http://www.sigcomm.org/sites/default/files/ccr/papers/2014/January/2567561-2567572.pdf

The funding part has always been a concern, not just for academia..

Cheers,
Aaron
--
Assistant Professor, TU Delft
Head of Cyber-Physical Intelligence (CPI) Lab
http://homepage.tudelft.nl/8e79t/

From: Coin <[email-masked]> on behalf of Rute Sofia <[email-masked]>
Date: Wednesday, 9 October 2019 at 15:12
To: Marie-Jose Montpetit <[email-masked]>, Noa Zilberman <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Coin] Academic contributions in COIN

This is slowly changing.

BR
Rute

mjm

BR
Rute Sofia

Hi,

Kind Regards,
Noa

Some inputs:

Thanks all!

mjm

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 06:36:26 -0700

I think I can talk for the 3 chairs here.

This is why we should encourage remote participation. Sure f2f is fun for
the side meetings but for exchanging ideas and creating discussions on the
list remote is fine. So if you want to participate we will find a way to
accommodate you!

mjm

On October 9, 2019 at 9:33:47 AM, Aaron Ding ([email-masked]) wrote:

Hi Rute,

assumingly, some points below have been made for both communities,
especially for the European academic side:

*http://www.sigcomm.org/sites/default/files/ccr/papers/2014/January/2567561-2567572.pdf
<http://www.sigcomm.org/sites/default/files/ccr/papers/2014/January/2567561-2567572.pdf>*

Cheers,

Aaron

--

*From: *Coin <[email-masked]> on behalf of Rute Sofia <
[email-masked]>
*Date: *Wednesday, 9 October 2019 at 15:12
*To: *Marie-Jose Montpetit <[email-masked]>, Noa Zilberman <
[email-masked]>
*Cc: *"[email-masked]" <[email-masked]>, "[email-masked]" <
[email-masked]>
*Subject: *Re: [Coin] Academic contributions in COIN

This is slowly changing.

BR

Rute

[email-masked]

Well,

Rute

mjm

[email-masked]

Hello,

BR

Rute Sofia

Hi,

Kind Regards,

Noa

Some inputs:

Thanks all!

mjm

[email-masked]

---

From: Rute Sofia <[email-masked]>
Date: Wed, 9 Oct 2019 13:50:25 +0000

Hi Aaron,

right. This is a good paper and  5.2 summarises the main issues both for the IETF and IRTF ☺ (before Marie-Jose again tries to explain the differences between the IRTF and IETF :)

The fact is that there is the need to do more long-run work to change the acceptance of standards in the academic/scientific committee. I have had colleagues in juris of PhDs which surprisingly think drafts are not relevant. In terms of academic CV, I had actually such comments also about both IETF and IRTF contributions to standards ☺

Yes, we all have to contribute so on my side, all MSc and PhD students are involved to at least monitor working groups. Some of them end-up in contributing. As the paper provided by Aaron shows, this is time consuming, and unfortunately there is no funding to support a direct involvement from the students. Not even mine, for the last decade.

Remote participation is therefore a good measure; however,  without broad dissemination, the acceptance may be reduced.

I second all of the proposals by Laurent…they are effective measures.
Rute

From: Coin <[email-masked]> On Behalf Of Aaron Ding
Sent: 09 October 2019 15:34
To: Rute Sofia <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Coin] Academic contributions in COIN

Hi Rute,

Cheers,
Aaron

From: Coin <[email-masked]<mailto:[email-masked]>> on behalf of Rute Sofia <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 9 October 2019 at 15:12
To: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>, Noa Zilberman <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Coin] Academic contributions in COIN

This is slowly changing.

BR
Rute

mjm

BR
Rute Sofia

Hi,

Kind Regards,
Noa

Some inputs:

Thanks all!

mjm

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 07:05:57 -0700

Ok so we all agree that we should have more academic involvement. And money
may or may not be needed and recognition of IRTF contribution promoted and
tutorials and online documentation be provided.

Anything else?

On October 9, 2019 at 9:50:38 AM, Rute Sofia ([email-masked]) wrote:

Hi Aaron,

right. This is a good paper and  5.2 summarises the main issues both for
the IETF and IRTF J (before Marie-Jose again tries to explain the
differences between the IRTF and IETF :)

The fact is that there is the need to do more long-run work to change the
acceptance of standards in the academic/scientific committee. I have had
colleagues in juris of PhDs which surprisingly think drafts are not
relevant. In terms of academic CV, I had actually such comments also about
both IETF and IRTF contributions to standards J

Yes, we all have to contribute so on my side, all MSc and PhD students are
involved to at least monitor working groups. Some of them end-up in
contributing. As the paper provided by Aaron shows, this is time consuming,
and unfortunately there is no funding to support a direct involvement from
the students. Not even mine, for the last decade.

Remote participation is therefore a good measure; however,  without broad
dissemination, the acceptance may be reduced.

Rute

*From:* Coin <[email-masked]> *On Behalf Of *Aaron Ding
*Sent:* 09 October 2019 15:34
*To:* Rute Sofia <[email-masked]>
*Cc:* [email-masked]; [email-masked]; [email-masked]
*Subject:* Re: [Coin] Academic contributions in COIN

Hi Rute,

Cheers,

Aaron

--

This is slowly changing.

BR

Rute

[email-masked]

Well,

Rute

mjm

[email-masked]

Hello,

BR

Rute Sofia

Hi,

Kind Regards,

Noa

Some inputs:

Thanks all!

mjm

[email-masked]

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 07:23:19 -0700

BTW yesterday we did mention drafts were not mandatory. Send us your papers!

And this discussion goes beyond COIN. What specifically can we do?

On October 9, 2019 at 9:50:25 AM, Rute Sofia ([email-masked]) wrote:

> 1. Clearly list challenges on the wiki. These may be accompanied by
> drafts, but not necessarily, and can be something that was discussed on the
> mailing list,
>

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 9 Oct 2019 15:29:18 +0000

😉

-> Bring this discussion to IRTF discuss mailing list? (or even to some relevant blog sites?)

I think IRTF has been doing some useful stuff/initiatives such as the Applied Networking Research Prize (ANRP) and Workshop (ANRW) and corresponding funding to support academic participation to the work in IRTF in general.
I will repeat that an IRTF Journal (ANRJ) could be also an interesting project (but maybe I don't see well enough the challenges/difficulties).

Wrt. valuation of scientific papers vs. (IRTF) RFCs: the publication process of an RFCs is equal if not more stringent than reviews being made in (some/most?) conferences or journals (the process and purpose are different but for the sake of the comparison I put them on the same level). So, I would encourage RFCs to be more recognized as valuable metric even in the academic world.
The time scales are radically different (several months vs. several years), but at the time of evaluation an Internet Drafts goes through the review of the RG, the RG adoption also need consensus, then another review before submission to IRSG for review, IRSG review in itself, and IESG review. This makes at least 3 bodies of subject-matter experts reviewing and analyzing the document before it gets a chance to go on the RFC editor desk 😉
But again, changing the perception is a long-term effort.

Best regards, Laurent.

From: Coin <[email-masked]> On Behalf Of Marie-Jose Montpetit
Sent: Wednesday, October 9, 2019 16:23
To: Aaron Ding <[email-masked]>; Rute Sofia <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Coin] Academic contributions in COIN

On October 9, 2019 at 9:50:25 AM, Rute Sofia ([email-masked]<mailto:[email-masked]>) wrote:
Hi Aaron,

From: Coin <[email-masked]<mailto:[email-masked]>> On Behalf Of Aaron Ding
Sent: 09 October 2019 15:34
To: Rute Sofia <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]..uk<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Coin] Academic contributions in COIN

Hi Rute,

assumingly, some points below have been made for both communities, especially for the European academic side:
http://www..sigcomm.org/sites/default/files/ccr/papers/2014/January/2567561-2567572.pdf<http://www.sigcomm.org/sites/default/files/ccr/papers/2014/January/2567561-2567572.pdf>

Cheers,
Aaron

Additionally, participation in the IRTF/IETF requires travelling, which is costly. Academic institutions and projects do not (usually ) foresee this. In fact, in European projects the standardisation is actually left to the industry partners.. No funding, no reason to participate ☺

This is slowly changing.

BR
Rute

mjm

BR
Rute Sofia

Hi,

Kind Regards,
Noa

Some inputs:

Thanks all!

mjm

https://www.irtf..org/mailman/listinfo/coin<https://www.irtf.org/mailman/listinfo/coin>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 9 Oct 2019 09:14:55 -0700

Wrt. valuation of scientific papers vs. (IRTF) RFCs: the publication
process of an RFCs is equal if not more stringent than reviews being made
in (some/most?) conferences or journals (the process and purpose are
different but for the sake of the comparison I put them on the same level).
So, I would encourage RFCs to be more recognized as valuable metric even in
the academic world.

I agree.

mjm

On October 9, 2019 at 11:29:19 AM, Ciavaglia, Laurent (Nokia -
FR/Paris-Saclay) ([email-masked]) wrote:

😉

-> Bring this discussion to IRTF discuss mailing list? (or even to some
relevant blog sites?)

I think IRTF has been doing some useful stuff/initiatives such as the
Applied Networking Research Prize (ANRP) and Workshop (ANRW) and
corresponding funding to support academic participation to the work in IRTF
in general.

I will repeat that an IRTF Journal (ANRJ) could be also an interesting
project (but maybe I don't see well enough the challenges/difficulties).

Wrt. valuation of scientific papers vs. (IRTF) RFCs: the publication
process of an RFCs is equal if not more stringent than reviews being made
in (some/most?) conferences or journals (the process and purpose are
different but for the sake of the comparison I put them on the same level).
So, I would encourage RFCs to be more recognized as valuable metric even in
the academic world.

The time scales are radically different (several months vs. several years),
but at the time of evaluation an Internet Drafts goes through the review of
the RG, the RG adoption also need consensus, then another review before
submission to IRSG for review, IRSG review in itself, and IESG review. This
makes at least 3 bodies of subject-matter experts reviewing and analyzing
the document before it gets a chance to go on the RFC editor desk 😉

Best regards, Laurent.

*From:* Coin <[email-masked]> *On Behalf Of *Marie-Jose Montpetit
*Sent:* Wednesday, October 9, 2019 16:23
*To:* Aaron Ding <[email-masked]>; Rute Sofia <[email-masked]>
*Cc:* [email-masked]; [email-masked]; [email-masked]
*Subject:* Re: [Coin] Academic contributions in COIN

[email-masked]

Hi Aaron,

Rute

*From:* Coin <[email-masked]> *On Behalf Of *Aaron Ding
*Sent:* 09 October 2019 15:34
*To:* Rute Sofia <[email-masked]>
*Cc:* [email-masked]; [email-masked]..uk
<[email-masked]>; [email-masked]
*Subject:* Re: [Coin] Academic contributions in COIN

Hi Rute,

http://www..sigcomm.org/sites/default/files/ccr/papers/2014/January/2567561-2567572.pdf
<http://www.sigcomm.org/sites/default/files/ccr/papers/2014/January/2567561-2567572.pdf>

Cheers,

Aaron

--

This is slowly changing.

BR

Rute

[email-masked]

Well,

Rute

mjm

[email-masked]

Hello,

BR

Rute Sofia

Hi,

Kind Regards,

Noa

Some inputs:

Thanks all!

mjm

[email-masked]

-- 
Coin mailing list
[email-masked]
https://www.irtf..org/mailman/listinfo/coin
<https://www.irtf.org/mailman/listinfo/coin>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 9 Oct 2019 16:22:19 +0000

On 09/10/2019, 18:15, "Coin on behalf of Marie-Jose Montpetit" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

I agree.

mjm

I have been pushing for this recognition for ages, with not very much success so far. But I don’t think that means we should surrender…

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Colin Perkins <[email-masked]>
Date: Wed, 9 Oct 2019 23:34:43 +0100

Hi Rute,

I agree to some extent, but this certainly depends on the European country and funding source. EU projects can, and do, fund academic partners to do standards work in the IETF, and to disseminate research and engage with industry researchers via IRTF. 

There are also activities like StandICT that directly fund such engagement.

Some national research funders also fund such work. In the UK, there’s a strong push for research impact that makes it possible to fund some IRTF and standards work via research council grants, for example. It varies for different countries, of course.

That said, I agree that tutorials and workshops certainly help engagement. IRTF groups have organised workshops that co-locate with conferences in the past (I remember the IRTF Reliable Multicast Research Group meeting on the beach in Cannes, adjacent to ACM SIGCOMM 1997…), and used this as a way to directly publish research in more academically visible venues. And, as Laurent notes, there are activities like ANRW and ANRP.

Cheers,
Colin

> On 9 Oct 2019, at 14:12, Rute Sofia <[email-masked]> wrote:
> 
> Additionally, participation in the IRTF/IETF requires travelling, which is costly. Academic institutions and projects do not (usually ) foresee this. In fact, in European projects the standardisation is actually left to the industry partners. No funding, no reason to participate J
>  
> This is slowly changing.
>  
> From: Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>> 
> To: Rute Sofia <[email-masked] <mailto:[email-masked]>>; Noa Zilberman <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> On October 9, 2019 at 7:02:00 AM, Rute Sofia ([email-masked] <mailto:[email-masked]>) wrote:
> 
> Well,
>  
> it is for students. I am in both worlds (academia and research towards industry) so… J
> Rute
>  
> From: Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>> 
> To: Rute Sofia <[email-masked] <mailto:[email-masked]>>; Noa Zilberman <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> On October 9, 2019 at 4:38:21 AM, Rute Sofia ([email-masked] <mailto:[email-masked]>) wrote:
> 
> Hello,
>  
> From: Coin <[email-masked] <mailto:[email-masked]>> On Behalf Of Noa Zilberman
> To: Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> On Tue, Oct 8, 2019 at 4:55 PM Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>> wrote:
> https://www.irtf.org/mailman/listinfo/coin <https://www.irtf.org/mailman/listinfo/coin>-- 
> Coin mailing list
> https://www.irtf.org/mailman/listinfo/coin <https://www.irtf.org/mailman/listinfo/coin>

-- 
Colin Perkins
https://csperkins.org/